Jump to content

Rocrail und das 3D-Modellbahn Studio


Recommended Posts

Hallo @V300 Danke für Deine Antwort.
Jetzt funktioniert das Plug-in wieder es hat  zwar eine Ewigkeit gedauert bis es gestartet ist (gefühlte 2 Minuten) warum auch immer. Egal jetzt geht es. 
Mal zu Deiner einfachen Anlage: Du hast zwar im Rocstudio Blöcke eingetragen aber in Deiner Anlage hast Du keine. Du mußt doch die Rückmelder jedem Block zuordnen, dann sollte es funktionieren.
Gruß Steffen

Link to post
Share on other sites
  • Replies 99
  • Created
  • Last Reply

Top Posters In This Topic

Top Posters In This Topic

Popular Posts

Hallo Thomas, ich habe RocStudio jetzt auf Version 1.0.6.0 aktualisiert. Damit werden nun auch korrekt Signale mit integrierten Gleiskontakten unterstützt, also zwei getrennte Objekte in Rocrail,

Hallo Brummer, auch wenn's Dir im ersten Moment unlogisch erscheint: Lass die Weiche als Rechtsweiche, gehe in den Gleisseditor und mach aller genau verkehrt herum. Also das was in der unteren Spalte

Hallo Allaix und Willkommen im Forum, RocStudio ist am Ende nur ein kleines Plugin für das 3D-Modellbahn Studio, was die Zustände zwischen Rocrail und dem Studio synchronisiert. Wird also im Stud

Posted Images

Hallo Steffen,

in MBS gibt es keine Blöcke. Rocstudio wertet lediglich das Überfahren der markierten Gleise aus und übergibt den Parameter an rocrail, welches dann das Ereignis dem gleichnamigen Rückmelder zu ordnet. Das funktioniert leider nicht immer synchron. Der Abstand zwischen den Rückmeldern in MBS muss auf jeden Fall so groß sein wie der längste Zug. Den Rest macht rocrail.  Rocrail ist das Steuerungsprogramm. MBS V5 soll neuartige Melder haben. Wie die mit rocstdio bzw. rocrail zusammen arbeiten, habe ich noch nicht probiert. Zu meinem Problem: Ich habe in den Einstellungen von rocstudio die Geschwindigkeit auf den Faktor 1,2 gesetzt. Jetzt gibt es weniger Probleme.

Gruß Alfredo

PS: gelegentlich bleiben die Züge mitten im oder deutlich hinter dem  Block stehen. Es "kracht" dann oder rocrail findet keinen freien Block, da die Rückmeldung fehlt.

Edited by V300
Link to post
Share on other sites
  • 1 year later...

Hallo,

ich habe die neue Version V6 dazu genutzt, RocStudio etwas anzupassen:

  • Gleiskontakte werden jetzt auch als Rückmelder interpretiert
  • In den RocStudio-Einstellungen kann wahlweise auch die Zielgeschwindigkeit gesetzt werden (Standard), um Züge sanft anfahren und bremsen zu lassen
  • Beim Rückmelder wird der Name der Lok als Identifier an Rocrail gesendet

Viele Grüße,

Neo

Link to post
Share on other sites

Hallo,

vor 29 Minuten schrieb HaNNoveraNer:

Dieser Gleiskontakt müsste neben dem Signal als Signal auch als Rückmelder von Rocrail erkannt werden.

in wie weit ist das ein Problem, Gleiskontakte von Signalen werden doch auch jetzt schon an RocStudio/Rocrail gesendet?

Viele Grüße,

Neo

Link to post
Share on other sites

Hallo Thomas,

ich habe deine Beiträge zum RocStudio-Thema verschoben, da es nichts mit der neuen Erweiterung zu tun hat.

vor 2 Stunden schrieb HaNNoveraNer:

Der Signalkontakt sendet nichts an Rocrail, wenn ich dem RM in Rocrail den Namen des Signals gebe.

Gibt es in Rocrail zeitgleich auch ein Signal mit gleichem Namen? Ich könnte mir vorstellen, dass Rocrail Probleme hat, wenn zwei Objekte den gleichen Namen besitzen. Probier es bitte einmal aus, erstelle eine Anlage in Rocrail nur mit Rückmeldern, ohne Signale.

Viele Grüße,

Neo

Link to post
Share on other sites

Hallo,

vor 5 Minuten schrieb HaNNoveraNer:

Naja, das Problem wird es aber immer geben, da wir ja ein SIgnal da einsetzen, wo wir ein Signal brauchen.

das ist klar, es geht mir zunächst darum, die Ursache für das Problem eindeutig zu finden. Wenn es an Rocrail liegt, weil dieses keine doppelten Namen unterstützt, kann ich in RocStudio eine Erweiterung einbauen, um z.B. Gleiskontakten von Signalen einen individuellen Namen zu verpassen.

Viele Grüße,

Neo

Link to post
Share on other sites

Ok, gleichnamiges Signal in RR gelöscht -> immer noch keine Reaktion, wenn die Lok das Signal im MBS befährt.
Andersrum reagiert das Signal aber, wenn es im MBS betätigt wird und der Kontakt genau so heißt.
Ich vermute, RR unterscheidet Objekte wie Signale und RM und die können gleich heißen.

Edited by HaNNoveraNer
Link to post
Share on other sites

Hallo Thomas,

ich habe RocStudio jetzt auf Version 1.0.6.0 aktualisiert. Damit werden nun auch korrekt Signale mit integrierten Gleiskontakten unterstützt, also zwei getrennte Objekte in Rocrail, die den gleichen Namen besitzen.

Viele Grüße,

Neo

Link to post
Share on other sites

@Neo

Mir ist noch was aufgefallen:
Manche Loks haben spezielle Namen im MBS.
RocRail akzeptiert aber scheinbar nicht alle Namen mit Sonderzeichen.
Da Du die Namen jetzt überträgst, gibt es Fehlermeldung.
Ich würde einfach Namen mit Sonderzeichen NICHT übertragen. (Gibt es ja sicher nicht so oft)
Dann mu8 jeder selber für passende Namen sorgen.

aaa.jpg.f8a18c56d7f9ed5d3168e61319836e1e.jpg

Link to post
Share on other sites

@Neo

Und noch ein kleiner Hinweis.
Auch die eingestellte Wirkrichtung eines Gleiskontakts beeinflußt das Melden an Rocrail.
Ich weiß nicht, ob das so sinnvoll ist?
Bei meinen bisherigen Anwendungen habe ich das Problem, daß Gleiskontakte von beiden Seiten befahren werden müssen, aber nur in einer Richtung bremsen dürfen.
Nun muß ich bei jedem Gleiskontakt, der nicht bremsen soll mit einem weiteren Gleiskontakt irgendwo davor das Bremsen für diese Richtung abschalten und später für die
Gegenrichtung wieder einschalten.
Für meine bisherigen Anwendungen wäre es also besser, wenn die Rückmeldung an Rocrail IMMER käme, egal für welche Richtung der GK eingestellt ist.
Das ist ja auch bei der realen Moba so.

Gruß
Thomas

Link to post
Share on other sites

Hallo Thomas,

vor 26 Minuten schrieb HaNNoveraNer:

Für meine bisherigen Anwendungen wäre es also besser, wenn die Rückmeldung an Rocrail IMMER käme, egal für welche Richtung der GK eingestellt ist.

RocStudio verarbeitet nur die Ereignisse, die vom Studio gesendet werden. Ist eine Seite eines Gleiskontakts im Studio deaktiviert, wird kein Ereignis beim Betreten gesendet. Es ist daher nicht möglich, auf beide Seiten in Rocrail zu reagieren, wenn du im Studio eine Seite deaktiviert hast.

Viele Grüße,

Neo

Link to post
Share on other sites

Hallo,

Am 21.10.2020 um 12:01 schrieb HaNNoveraNer:

Ich würde einfach Namen mit Sonderzeichen NICHT übertragen. (Gibt es ja sicher nicht so oft)

ich habe RocStudio aktualisiert, sodass nun auch Namen mit Sonderzeichen unterstützt werden. Tatsächlich war das kein Problem der Zeichenkodierung, sondern ein Problem der Anführungszeichen im Namen.

Viele Grüße,

Neo

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
×
×
  • Create New...