Jump to content
EASY

Definitionsproblem beim Kranbau...

Empfohlene Beiträge

Hallo @Neo,

in der wiki steht unter "Grundlagen zum Modellbau (ab Version V4)" -> "Kräne"

Zitat

Anschließend folgt der Bewegungstyp, _Tra, _Rot, _Ori oder _Siz_X_Y für Translation (Bewegung entlang einer Achse), Rotation (Drehung um eine Achse zu einem Zielpunkt = Drehkran), Orientation (Drehung zur Orientierung am Zielobjekt = Drehung des Hakens) und Size (Anpassung der Hakengröße auf das Transportgut, wobei X die Mindestgröße und Y die Maximalgröße in ganzzahligen Millimeter angibt)

... nun bin ich etwas am raten, was in V4 "Size in mm" eigentlich ist?

Ich baue gerne in 1:1 (in m) in Blender. Da eine Blendereinheit im MBS 10 Einheiten sind, stelle ich es dann in den Katalog mit dem Maßstab "1:0,1" in m.
Nun soll der Kran beispielsweise Container von 10m bis 20m Länge aufnehmen können (im MBS-Maßstab 1:1)....
... wie muß nun der Eintrag in der .anim Datei für "Size" lauten?
... was wenn ich in einem anderen Maßstab baue / in den Katalog einstelle?
... oder anders gefragt, was ist die Referenz für "Size"?

Gruß
EASY

Bearbeitet von EASY

Diesen Beitrag teilen


Link zum Beitrag
Auf anderen Seiten teilen

Hallo @Neo,

... ich beantworte mal einen Teil selbst9_9...

Ich habe mir einen Testkran gebaut, der nur aus 2 Spitzen besteht, die auseinander gefahren werden können.
Definition in Blender:
5b7b255a3bd57_Bild001.jpg.3ae0b52833ffc4f7de21df7053001be9.jpg
5b7b25b8eabb3_Bild002.thumb.jpg.c904a24c5fe9de9d2c8e710efd4faf21.jpg

... Da eine Blendereinheit im MBS 10 Einheiten sind, ergibt sich folgender Eintrag in die .anim Datei:
_Crane_3_Siz_40_120;241;300

Ich habe das Modell im MBS 1:1 in den Katalog übernommen... (Maßstab im MBS ist auch 1:1 eingestellt)
... ohne daß der Quader aufgenommen wurde, stimmt das Mass...
5b7b255d58b0d_Bild003.jpg.088b45596547c04ed6fd1ff7bb58ad61.jpg

... wird nun der Quader aufgenommen, gehen die Spitzen etwas weiter auseinander...
5b7b255de1298_Bild004.jpg.993fbb7c9b3deb0b6e440be9b901999c.jpg

... um den Faktor 1,15...
5b7b255e968f3_Bild005.jpg.e428af66627a707ab01ae3fc8e1ce4b5.jpg

... das selbe bei 10 Meter...
5b7b255f249a2_Bild006.jpg.d972341e85c01f80fec37678a564d22a.jpg

5b7b255fbf8d5_Bild007.jpg.b4bc67a1560dfbd994d80a11b59026a7.jpg

... der Faktor 1,15 ist 1/0,87

Wenn ich nun den Eintrag in der . anim um diesen Faktor "korrigiere"...
_Crane_3_Siz_46_138;241;300

... dann stimmt die Definition wieder mit meinem Modell (bezogen auf das Maß in der Animation) überein...
5b7b2560513cf_Bild008.jpg.9c72b15cb5cee7a7c48fe7b886f012a6.jpg
5b7b2560d8a3b_Bild009.jpg.075b1fa989e41bbd414cbd6667770c99.jpg

... wie es dann aussieht, wenn ich das Modell in einem anderen Maßstab in den Katalog bringe... werde ich wohl auch noch erforschen.B|

... nur die Korrektur im Programm überlasse ich dann Dir;)

Gruß
EASY

Diesen Beitrag teilen


Link zum Beitrag
Auf anderen Seiten teilen

Hallo Easy,

was meinst Du mit "Einheiten" ?  Hat dies irgendwas mit Kränen zu tun, oder mit Animationen ?

Wenn ich etwas von Blender ins Studio importiere, das in Blender 1,20 m x 0,80 m ist, habe ich im Studio die selbe Grösse.

Schöne Grüsse

Andreas (astt)

Diesen Beitrag teilen


Link zum Beitrag
Auf anderen Seiten teilen

Hallo Andreas,

... als ich in Blender angefangen habe, wußte ich nicht, daß man ein Einheitensystem einstellen kann (in Blender "Einheiten" -> "Keine")... so ist für mich die Rastergröße eine "Blendereinheit". In Blender baue ich im Maßstab 1:1 nur beim .x Export kommt noch der Faktor 10 dazu (keine Ahnung warum), so daß ich im MBS 1:0,1 (oder 10:1) importieren muß. Ich habe mich so daran gewöhnt, daß ich es einfach so lasse...

In dem Kranbeispiel habe ich ausnahmsweise 1:1 importiert (deshalb der Faktor 10), da es mir darum ging, wie der Eintrag "Size" in der .anim Datei vom MBS gewertet wird.

... sorry, wenn ich Dich damit etwas verwirrt habe... meine Überlegungen folgen manchmal den Gehirnwindungen, und die sind auch nicht gerade...

Gruß
EASY

Diesen Beitrag teilen


Link zum Beitrag
Auf anderen Seiten teilen

Hallo @Neo,

... Teil2:

... wenn ich das Modell im MBS im Maßstab 1:0,1 einstelle (MBS Maßsatb nach wie vor 1:1), müßte ich eigentlich in der . anim Datei folgenden Eintrag machen:
_Crane_3_Siz_4.6_13.8;241;300

... wie es aussieht stimmt meine Überlegung, daß ich den Maßstab selbst in der .anim Datei berücksichtigen muß...
... nur habe ich das Problen, daß Nachkommastellen bei "Size" anscheinend nicht vorgesehen sind... und ich so die Ungenauigkeit nicht so gut kompensieren kann...

_Crane_3_Siz_5_14;241;300 liefert zwar Ergebnisse aber eben nur fast...

Gruß
EASY

Diesen Beitrag teilen


Link zum Beitrag
Auf anderen Seiten teilen

Hallo EASY,

ich weiß nicht ob ich richtig verstanden habe oder ich Dir damit helfen kann, aber:   

------

Auszug aus der WIKI:

_Scale_1_100_mm - Gibt den Maßstab und die Einheit an, in dem das Modell im 3D-Programm konstruiert wurde. Statt 1_100 kann jeder beliebige andere Maßstab gewählt werden (die erste Zahl gibt den Zähler, die zweite Zahl den Nenner an). Statt mm ist auch eine Angabe in cm oder m möglich. Ein _Scale-Objekt wird nicht dargestellt, es zählt nur der Name. Ohne ein _Scale-Objekt erscheint beim Import des 3D-Modells ein Abfragedialog, um den Maßstab anzugeben.

-----

Ich mach das so, daß ich in JEDER Blender Scene einen kleinen Würfel einbau mit der Objektbezeichnung: _Scale_1_1_m, damit ist der Maßstab überall gleich

und 3DMBS fragt dann auch nicht nach dem Maßstab.

mfg Max

PS: der Würfel ist mit dieser Bezeichnung auch nicht sichtbar

Diesen Beitrag teilen


Link zum Beitrag
Auf anderen Seiten teilen

Hallo @Neo,

Teil3: ... interessant wird es, wenn ich im MBS dann auch noch einen anderen Maßstab einstelle:

... wie hier beschrieben kann ich mit dieser Definition _Crane_3_Siz_46_138;241;300 ein Objekt aufnehmen, das zwischen 4m und 12m ist (Modell 1:1 in den Katalog in m; MBS 1:1 in m))

... hier ist beschrieben, welchen Einfluß auf den Eintrag in der .anim der Maßstab hat mit dem ich das Modell in den Katalog stelle:
_Crane_3_Siz_4.6_13.8;241;300 [ideal, geht aber nicht wegen Nachkommastellen] kann ein Objekt aufnehmen, das zuischen 0,4m und 1,2m ist (Modell 1:0,1 in den Katalog in m ; MBS 1:1 in m). 

... und wenn ich dann noch den Maßstab im MBS ändere z.B. im MBS 1:32 in mm:
_Crane_3_Siz_46_138;241;300 kann ein Objekt aufnehmen, das zwischen 128mm und 375mm ist (Modell 1:1 in den Katalog in m; MBS 1:32 in mm)
[128 = 4000/32 ; 375 = 12000/32]

... nun, ich gebe zu, daß es etwas zugespitzt dargestellt ist... aber ich hoffe, daß Du mir eingestehst, daß der Umgang mit diesem Krantyp doch zu einer kleinen Herausforderung werden kann...

Gruß
EASY

Diesen Beitrag teilen


Link zum Beitrag
Auf anderen Seiten teilen

Hallo EASY,

danke für den Hinweis, du hast mal wieder durch eigene Untersuchungen praktisch die Lösung selber erkannt. Bei der Size-Angabe handelt es sich noch um ein "Relikt" aus Pre-V4-Zeiten, in denen es noch nicht die flexible Maßstabslogik gab. Im Moment werden die Angaben wie von dir erkannt noch in H0 interpretiert, ohne den eigentlichen Modellmaßstab zu berücksichtigen.

Das Problem kann ich nur im Studio lösen, als Zwischenlösung könntest du dein Modell in Blender schon in H0 konvertieren (z.B. durch ein übergeordnetes Dummy-Objekt mit entsprechender Skalierung). Eine manuelle Konvertierung der Größen im Animationsnamen empfehle ich im Moment noch nicht, je nachdem wie der Fix im Studio aussieht könnten danach wieder Anpassungen an solchen Modellen nötig werden.

Am 21.8.2018 um 08:26 schrieb EASY:

In Blender baue ich im Maßstab 1:1 nur beim .x Export kommt noch der Faktor 10 dazu (keine Ahnung warum)

Das klingt etwas merkwürdig, mir ist nicht bekannt, dass der Exporter noch eine Konvertierung durchführt. Hast du das Verhalten mal etwas genauer untersucht?

Viele Grüße,

Neo

Diesen Beitrag teilen


Link zum Beitrag
Auf anderen Seiten teilen

Hallo @Neo,

vor 5 Stunden schrieb Neo:

Hast du das Verhalten mal etwas genauer untersucht?

... Fehler liegt beim Anwender:$

Ich habe die Einstellungen in Blender von Version zu Version "auf die harte Tour" immer nur kopiert... dabei muß ich wohl etwas durcheinander gebracht haben.
Woran es nun genau gelegen hat, weiß ich (noch) nicht... aber mit Blender neu aufsetzen ist nun alles gut... und ich habe 1:1.

Gruß
EASY

Diesen Beitrag teilen


Link zum Beitrag
Auf anderen Seiten teilen

Erstelle ein Benutzerkonto oder melde dich an, um zu kommentieren

Du musst ein Benutzerkonto besitzen, um einen Kommentar verfassen zu können

Benutzerkonto erstellen

Neues Benutzerkonto für unsere Community erstellen.

Neues Benutzerkonto erstellen

Anmelden

Du hast bereits ein Benutzerkonto? Melde dich hier an.

Jetzt anmelden

×