Jump to content
raf.sonneville

Spline street piece

Recommended Posts

Hi

I have a problem when making a street that has to be a spline in TS4 that can be flexible bend.

I made the piece in Sketchup Pro 2018, but when I make it into an X file and bring it in TS4 then it seems of lot of the faces can't be seen anymore.

You see two pieces. On the left what it should look like, and the one on the right is the spline version.

I can bend the piece as you can see in the third picture.

Can you help me please?

See the pictures.

THX

testpic1.gif

testpic2.gif

testpic3.gif

Share this post


Link to post
Share on other sites

Hello Raf,

your model contains 6 materials (including 5 textures). But a spline model must contain only one single material (see here in the Wiki):

Spline - Das 3D-Modell wird entlang der Spur gebogen. Unterstützt werden dabei nur 3D-Modelle, die aus maximal einem Material bestehen und nicht animiert sind. 3D-Modelle für Splines werden entlang +Y gebogen.

Spline - The 3D model is bent along the track. Only 3D models are supported that consist of a maximum of one material and are not animated. 3D models for splines are bent along +Y.

Many greetings
BahnLand

Share this post


Link to post
Share on other sites

Thx for the help. Worked. I used more than one material. That was the problem.

I only have one problem left. What kind of _CP contact points do I use on the spline so it connects to existing non-spline road pieces I made myself?

Cos now it seems to each time rotate 90 degrees when I connect to the existing one. See the picture. If I add a contact point or not, it has the same effect.

Thx

testpic4.gif

Share this post


Link to post
Share on other sites

Hello Raf,

I have seen in your 1st picture that the spline direction of your model is not equal to the y-axis.

testpic1.gif

But this is necessary for spline models so that thay will by correctly aligned along the spline track. So, you must rotate your sketchup model by 90°, so that it especially can correctly connect with other street elements.

Many greetings
BahnLand

 

Share this post


Link to post
Share on other sites

Hi Raf,

you don't need a _CP for splines, the studio automatically creates such points for each spline start and end. _CPs are only needed for models without any routes.

Kind regards,

Neo

Share this post


Link to post
Share on other sites

Hi guys

Thanks for the help so far. Its all better now, however I still have a problem.

In the first pic you see 3 pieces. The left and right are the same static piece. The middle one is the spline.

In the second pic you see I can connect the spline perfect to the left piece.

In the third pic you can see I can bend the spline perfectly also.

BUT …. In the fourth pic you can see that when I bend the spline I cannot connect to the right piece.

What is the problem here now ? 

Thx in advance and sorry for asking all the time.

greetz

spline1.gif

spline2.gif

spline3.gif

spline4.gif

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×