Jump to content
norbert_janssen

Meine erste EV funzt nicht - Aufenthalt fuer bestimmte Zeit am Ende einer Strecke, dann Rueckfahrt

Recommended Posts

26.11.18;05:30h
Erste EV - Aufenthalt TR9 im HBf links

'TR9b' betritt 'TR-Gerade-30m-HBfl' - Zeit warten - Rueckfahrt

Extras-Ereignisverwaltung-'TransRapid'-Neues Ereignis 'HBfl'
- Ereignis - Zug/Fahrzeug betritt ein Gleis/eine Strasse - TR-Triebwagen 9b - TR-Gerade-30m-HBfl
- Bedingung - Fahrzeug steht auf einem Gleis/einer Strasse-TR-Triebwagen 9b-TR-Gerade-30m-HBfl
- Aktion - Fahrzeuggeschwindigkeit setzen-TR-Triebwagen 9b-TR-Gerade-30m-HBfl-0km/h
             - Countdown starten-Warten bis Ende-60Sekunden
             - Fahrzeuggeschwindigkeit setzen-TR-Triebwagen 9b-TR-Gerade-30m-HBfl-Ist-Geschwindigkeit setzen

 

Share this post


Link to post
Share on other sites

Hallo Norbert,

Du hast in Deiner Ereignisdefinition 3 Aktionen definiert, die unmittelbar hintereinander ausgeführt werden:

  1. Triebwagen anhalten
  2. Countdown mit Wartezeit aufziehen
  3. Triebwagen eine Geschwindigkeit zuweisen.

Dies bedeutet, dass der Triebwagen sofort in die Richtung weiterfährt, die über das Vorzeichen der Geschwindigkeit spezifiziert ist. Der zwischen den beiden Geschwindigleitszuordnungen (0 und verschieden von 0) gestartete Countdown, der nach 60 Sekunden ausgelöst wird, verpufft ohne Aktion. Die Bedingung ist übrigens überflüssig, das diese automatisch erfüllt ist, wenn der Zug das besagte Gleis "betritt".

Korrekt hätte Deine Ereignissteuerung wie folgt aussehen müssen:

1. Ereignis:
- Ereignis - Zug/Fahrzeug betritt ein Gleis/eine Strasse - TR-Triebwagen 9b - TR-Gerade-30m-HBfl
- Bedingung - keine
- Aktion - Fahrzeuggeschwindigkeit setzen-TR-Triebwagen 9b-TR-Gerade-30m-HBfl-0km/h
             - Countdown starten-Warten bis Ende-60Sekunden

2. Ereignis:
- Ereignis - Countdown läuft ab
- Bedingung - keine
- Aktion - Fahrzeuggeschwindigkeit setzen-TR-Triebwagen 9b-TR-Gerade-30m-HBfl-Ist-Geschwindigkeit setzen

Mit dieser Definition hälte der Zug an, bleibt 60 Sekunden stehen und setzt dann seine Fahrt in die vorgegebene Richtung fort.

Merke:
Die Ereignissteuerung im Modellbahn-Studio funktioniert wie bei Windows auch: Tritt ein Ereignis auf, werden die damit verbundenen Aktionen sofort ausgeführt. Soll eine Aktion zeitgesteuert verzögert werden. Muss ein neues Ereignis nach Ablauf der Wartezeit generiert werden (hier ist es der Countdown, mit dem das Ereignis generiert wird), welches dann weitere Folge-Aktionen anstößt (hier im Deinem Beispiel die dritte Aktion, welche den Triebwagen wieder startet).

Auch das Betriebssystem Windows ist komplett Ereignis-gesteuert. Typische Ereignisse, auf die Windows reagiert, sind der Mausklick oder der Tastendruck - insbesondere das Drücken der Enter-Taste, mit der dann bestimmte Aktionen verknüpft sind (z.B. eine Programmausführung).

Viele Grüße
BahnLand

Share this post


Link to post
Share on other sites

Hi BahnLand

habe deine Angaben umgesetzt und erster Erfolg: TRANS RAPID bleibt im 'Bahnhof'stehen - faehrt aber NICHT nach eingetragener Zeit zurueck ! ?

Ich musste diesen Bahnhof einrichten wegen der winzigen Luecke, die ich nicht geschlossen bekomme -ueber eine Woche schon daran versucht-

Dann kann er da zur Ansicht auch etwas warten ! Tut er jetzt - und schlaeft ein !
Bild 2 zeigt den 5gleisigen Endhaltepunkt fuer fuenf unterschiedlich lange TR -die ich dann auch irgendwann abwechselnd fahren lassen moechte.

Dafuer braucht es wohl ein STUDIUM der EV ! Aber ich hab ja Zeit !
 

https://www.facebook.com/norbert.janssen.90

TransRapid Hbf.jpg

Trans-Rapid & ICE III.jpg

2018-11-22-1805h - Trans-Rapid im neuen 'Bahnhof'.jpg

Share this post


Link to post
Share on other sites

hallo Norbert,

das Häkchen bei der IST Geschwindigkeit löschen(entfernen). Die Ist Geschwindigkeit wäre in deinem Falle -0-. Nun müßte der weitere Ablauf funktionieren.

Gruß Karl

Share this post


Link to post
Share on other sites

Hallo Norbert,

kannst Du Deine Anlage mal als mbp-Datei exportieren (statt "Speichern" oder "Speichern unter ..." auf "Exportieren" klicken und dann als mbp-Datei abspeichern) und dann diese Datei hier im Forum als Anlage anhängen? So alleine aus Deinen wenigen Angaben eine vernünftige Diagnose und eine Lösung zu erstellen ist etwas schwierig bis unmöglich.

Viele Grüße
BahnLand

Share this post


Link to post
Share on other sites

Hallo Norbert,

ich habe mir eine Teststrecke erstellt mit einen Haltegleis, dass von li. wie auch von re. angefahren wird. Danach habe ich in der EV für jeden Triebwagen separate countdowns erstellt ( z.B. wartezeit1 für TR1, für Tr2 wartezeit2). Unter Aktionen: Fahrgeschwindigkeit setzen --- Gleis einmal stop und einmal - alle Gleise- benannt. Der Ablauf funktioniert auch bei unterschiedlicher Ankunft auf dem Haltegleis. Inwiefern dieses in den Gesamtablauf deiner Anlage passt, kann ich dir allerdings nicht sagen.

Gruß Karl

Share this post


Link to post
Share on other sites

Hallo @norbert_janssen,

der Fehler liegt im Auslöser, hier hast Du Zeitpunkt erreicht ausgewählt es müsste aber Coundown abgelaufen ausgewählt werden.

Wenn Du den Auslöser des entsprechenden EV eintrages von Zeitpunkt erreicht; 00:00 auf Coundown läuft ab; Warten bis Ende änderst läuft das ganze.

Der von Dir gewählte Auslöser bezieht sich auf die Uhrzeit (entweder virituelle oder Echtzeit je nach Einstellung). Da Deine Anlage aber auf Fixzeit 12:00 Uhr (Standarteinstellung) eingestellt ist wird dieser Zeitpunkt nie erreicht, daher bekommt der Zug auch keinen Abfahrbefehl.

HG

Wüstenfuchs

Share this post


Link to post
Share on other sites

An alle meine Ratgeber/Helfer
habe alle Euere Tips befolgt und in unterschiedlichen Arrangements getestet:
Der Zug wartet weiter auf meinen manuellen Befehl !
Habe die Anlage hochgeladen, s.o. 3860EE32-3BB6-426A-BF4A-75B77953F60D
Vielleicht findet einer ja den Fehler beim 'Spielen' !

 

Share this post


Link to post
Share on other sites

Hallo @norbert_janssen,

wenn Du folgenden EV eintrag wie angegeben änderst funzt es.

Ereignis: TR-Wende2

Auslöser: Zeitpunkt erreicht Coundown läuft ab

Uhrzeit='00:00' Name='Warten bis Ende'

Aktion: Countdown stoppen

Aktion: Fahrzeuggeschwindigkeit setzen

Fahrzeug='TR-Triebwagen 9b' Gleis/Straße='TR-Gerade-30m-HBfl'

Geschwindigkeit='-230' Ist-Geschwindigkeit setzen='0'

Einfach die rotgeschriebenen Einträge von Dir löschen oder gegen die grünen austauschen.

Wenn dieses bei anderen Zügen auch vorkommt einfach genauso verfahren.

HG

Wüstenfuchs

Share this post


Link to post
Share on other sites

Hallo @norbert_janssen,

psst, Tata schläft. Mein alter Herr war gestern Abend, als er vom Wintermarkt nach Hause kam, so aufgedreht weil ssein Lauflichtgerät am Karussel gesponnen hat, dass er wohl die halbe Nacht am PC gesessen hat.:o Naja eigendlich sitzt er immer noch da auf seinen Sofa, allerdings Schnarcht er, als ob er den Amazonasregenwald zu Brennholz verarbeiten will.:P

Wird ihn garantiert freuen, dass er Dir helfen konnte.

Jetzt werde ich aber erstmal Frühstück machen, und mir überlegen wie ich das "Sägewerk" neben mir dazu überede aufzustehen, er muss ja hier spätestens um acht losfahren um Pünktlich zu öffnen.

HG

C.Fuchs

(die Tochter von Wüstenfuchs)

Share this post


Link to post
Share on other sites

:D:D:D Das ist eindeutig ein Kandidat für den Post des Jahres!
Sag' ihm, der Andy hat gemeint, er hätte da noch ein paar Leuchtwürfel übrig. Dann geht er richtig ab (der Arme).

viele Grüße und einen schönen Tag
  Andy

Share this post


Link to post
Share on other sites

Danke für's Angebot Andy, habe den Fehler allerdings inzwichen gefunden. Im Mittelbau war eine Steckverbindung (die wohl seit ihren Einbau nicht mehr gelöst wurde) korrodiert. Darauf dort nachzusehen kommt man natürlich immer erst zum Schluss. 

HG

Wüstenfuchs

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×