Jump to content

Recommended Posts

Hallo @Andy,

vor 20 Minuten schrieb Andy:

Wirklich mit dem Plane-Symbol ein Mesh mit vier Punkten erzeugt und dann da eine Textur draufgemacht. Länge und Breite skaliert, Höhe kommt Original mit Null

Ohne dass mir jetzt eines der Programme vorliegt (mein PC hat gestern den Total-Crash hingelegt und ist nun beim Doctor),

scheint mir das Problem, welches du beschreibst ein anderes zu sein - auch unabhängig von Blender-Version 2.79 oder 2.8.

Beispielsweise bsetehen die Außenwände - die "Gehäuse" meiner Eisenbahnen/Triebfahrzeuge - auch aus nichts anderem, als aus einer in der Dicke bei 0 skaliertem Objekt. (Eine mögliche Innenwand ist auch nichts anderes, nur eben die Normalen nach innen gedreht).

Ein wesentlicher Punkt ist aber folgender: Eine Plane erscheint ja in Blender zunächst auf der xy-Achse, liegt alos sozusagen auf dem Boden. Um daraus eine Hauswand zu machen, muss man sie aufrichten, also in x oder y um 90° drehen. Dabei ist natürlich darauf zu achten, ob die Flächen-Normalen in die gewünschte Richtung zeigen (und nicht z.B. zur Gebäude-Innenseite).

ganz wichtig bei diesem Drehen in x oder y ist aber die Frage, ob du das im Objekt- oder Editier-Modus machst. Drehst du die Plane im Editiermodus, aändert sich an der Ausrichtung der Normalen des gesamten Objektes gar nix, was im 3D-MBS durchaus zu Problemen führen kann (z.B. zu den früher beschriebenen furchtbaren Schattierungsproblemen).

Wenn du nicht sicher bist, in welchem Modus du die Plane gedreht hast, oder wie oft, dann hilft hier folgendes: klicke das Objekt an (mach es zum aktiven Objekt) und drücke die Tastenkombination <Strg>+<A> und hier dann Apply (anwenden) Rotation und ggf. auch Skalierung.

Vielleicht hilft das bei deinem Problem weiter.

Gruß
Reinhard

Edited by Reinhard

Share this post


Link to post
Share on other sites
vor 5 Minuten schrieb Reinhard:

(mein PC hat gestern den Total-Crash hingelegt und ist nun beim Doctor)

Hallo Reinhard, schon wieder?:(

Hoffe auf baldige Genesung desselben, lg max

Share this post


Link to post
Share on other sites
vor 18 Minuten schrieb Reinhard:

Drehst du die Plane im Editiermodus

Genau das! Ich habe Lothar's Daten direkt eingegeben und die Plane gar nicht angerührt. Dann ist ja alles klar. Trotzdem interessant, dass das Problem durch die 'Scheindicke' dann gelöst wird und das der 2.8er den Wert gerade wieder nullt. Okay, dann ist das ja alles schon bekannt. Mir fehlt da halt noch etliches an Know-How. Danke Euch!

Gruß
  Andy

Share this post


Link to post
Share on other sites

Hallo @maxwei,

vor 28 Minuten schrieb maxwei:

allo Reinhard, schon wieder?:(

Hoffe auf baldige Genesung desselben

Danke für dein Mitgefühl! Ja vorgestern Abend ging er einfach unter der Maus aus, einfach so und nicht wieder an, kein Zucken (außer ein Lüfter, der noch Geräusche macht). Ich hoffe, es ist "nur" das Netzteil und nicht z.B. das Motherboard!

Scheaun wir mal, ich hoffe auf baldige Meldung vom Onkel Doc.

Gruß
Reinhard

Share this post


Link to post
Share on other sites

Hallo Andy,

vor einer Stunde schrieb Andy:

Wirklich mit dem Plane-Symbol ein Mesh mit vier Punkten erzeugt und dann da eine Textur draufgemacht. Länge und Breite skaliert, Höhe kommt Original mit Null.

... das ist mal wieder mal das Problem der Sprache was "skalieren" bedeutet. Ich dachte Du hast bei "skalieren in z" die Null eingetragen... (nicht bei Dimension in z)

vor 47 Minuten schrieb Reinhard:

Wenn du nicht sicher bist, in welchem Modus du die Plane gedreht hast, oder wie oft, dann hilft hier folgendes: klicke das Objekt an (mach es zum aktiven Objekt) und drücke die Tastenkombination <Strg>+<A> und hier dann Apply (anwenden) Rotation und ggf. auch Skalierung.

... dabei wird die Rotation wieder auf (x=0, y=0, z=0) bzw. die Skalierung auf (x=1, y=1, z=1) gesetzt.
Ohne daß in der Modellgeometrie etwas geändert wird. Es werden also nur die Bezüge zurückgesetzt.

Ich mache das fast schon automatisch, da ich in der Vergangenheit öfter Probleme im MBS mit der Darstellung hatte und nicht so recht wußte warum... aber  es hat (meist) geholfen... so mache ich es lieber einmal mehr (wenn eigentlich nicht nötig) als hinterher zu suchen...

P.S. Rotation auf diese Art "zurückzusetzen" hilft auch ganz gut beim Erstellen von Animationen (besonders wenn die Startwerte ziemlich krumm sind...)

Gruß
EASY

Edited by EASY

Share this post


Link to post
Share on other sites

Hallo Neo,

davon abgesehen, daß man auch beim Modellbau Komponenten sinnvolle Namen geben sollte, ist mir (angenehm) aufgefallen,
daß der Importer für glTF-Dateien "Flächen" und "Würfel" nicht mehr mit einer Fehlermeldung belegt (im Gegensatz zum .x Importer)

Sollte man da (aus irgendeinem Grund) "trotzdem" etwas auf  ä ö ü  bei der Namensgebung von Modellkomponenten in Blender achten?

Gruß
EASY

Edited by EASY

Share this post


Link to post
Share on other sites

Hallo EASY,

mir sind aktuell keine Probleme bei der Verwendung von Umlauten bekannt, die Einschränkung auf ASCII bezieht sich allein auf das alte X-Format.

Viele Grüße,

Neo

Share this post


Link to post
Share on other sites

Hallo zusammen, ich stehe momentan vor einem Problem das ich beim *.X Export einfach nicht hatte, weil ich, so denke ich, das zwar gut funktionierte nach meiner Methode, aber trotzdem (durch lesen in verschiedenen Freds) falsch angegangen bin, folgendes Problem: VARLIST

Blender 2.79:
In dieser Version exportierte ich ganz normal(*.x Dateien sind ja reine Textdateien), und änderte direkt in der Datei im Texteditor den Bezug(Name) zur texturdatei, funktionierte bestens, hatte mit den _Custom.png bis jetzt nichts am Hut.

Aufgrund dessen habe ich mich mal mit dem _Custom.png beschäftigt, bringe das aber nicht hin, da der Bezug in Blender beim UR-File ja dann _Custom.png heißen muß, damit ändert sich auch durch die Varlist nichts; oder versteh ich hier was grundsätzlich komplett falsch?

Blender 2.80:
Da funktioniert das nicht mehr, da das keine reine Textdatei (*.glb) ist und Änderungen nicht funktionsfähig zulässt.
also muß ich gezwungenermaßen auf die _Custom.png zurückgreifen, das ich aber nicht hinbringe, weil das nirgendwo wirklich erklärt wird.

Mit der Bitte auf Nachhilfe in Form eines Beispiels.

lg max

Edited by maxwei

Share this post


Link to post
Share on other sites

Ich nochmal, ach du Riesenkacke(n), jetzt hab ich's geschnallt, hatte immer falsche Einträge in der Varlist.
Hab das grad in 2.79 getestet, jetzt versteh ich's erst, aber muß das auch in 2.8 testen.

 lg max

Share this post


Link to post
Share on other sites

ok, kleines Update, um eine funktionierende Varlist bewerkstellen zu können muss wie folgt exportiert werden:

for.jpg.b0f33e7142b413434b71d96a8dc7adb0.jpg

so funktionierts, lg max

Share this post


Link to post
Share on other sites

Hallo Jungs,
in diesem Thread sind hier schon viele wichtige Informationen für das Arbeiten mit Blender 2.8 für MBS enthalten.
Ich möchte die Betonung auf 'für MBS' legen und ein wenig darauf eingehen, was ich für meine (im Verhältnis zu Lokmodellen) doch recht minimalistischen Anforderungen beim Faller Hochhaus gebraucht habe, speziell im Hinblick darauf, wie ein Bordmittelbauer wie Lothar doch den Weg in den Blender finden kann. Er hat noch die gleichen Berührungsängste, wie ich sie hatte.
  Zum Ersten ein Wort im Vergleich zum alten 2.79er: durch die Kamerasymbole im Viewport und dem neuen Verhalten der linken Maustaste finde ich 2.8 dem 2.79 schon mal sehr überlegen. Damit gehen die allerersten Klicks bedeutend einfacher.
  Ein Wort zu Einsteigervideos:  mal grundlegend was zum Interface ansehen, lernt man was. Wenn's an bunte Lichtquellen und den Eevee-Renderer geht, bringt das nichts für MBS. Oder wenn als erstes Modell ein Geschützturm gebaut wird, kriege ich 'nen sauren Magen.

Also:
1. Objekte habe ich eigentlich nur zwei Typen gebraucht. Würfel (Cubes) und Ebenen (Planes).
2. die Positionierung der Objekte habe ich direkt aus den herausgezogenen MBS-Daten des Hochhauses gewonnen und so eingegeben:

1901131269_Anmerkung2019-09-22073806.jpg.e0ffc0c32e8a28b49a20a33e201dac0e.jpg
 

3. Ich habe drei PNG-Grafiken mit GIMP angelegt. Für 'normale' Texturen, für 'leuchtende' LS-Texturen und für transparente Texturen. Hierfür wird man sich drei Materiale anlegen. Für jede Grafik eins. Dazu geht man auf das Materialsymbol, erzeugt ein neues Material und selektiert bei BaseColor Image (Neo hat das weiter oben beschrieben), gibt den Dateinamen an und lädt die Datei über das Ordnersymbol. Die ist nun als Textur bekannt.

757655022_Anmerkung2019-09-22074559.jpg.f0c7dcf9b2645d09fb8c5e87f36a2410.jpg

4. Jetzt ist das Objekt mit einer Textur verknüpft und die würde man jetzt in folgender Einstellung schon sehen können, wenn sie schon die richtige Ausrichtung hätte. Dazu gleich. Erstmal die Einstellung: wichtig: Objektmodus, und das Textursymbol. Oben ist unser Objekt angewählt.

662668669_Anmerkung2019-09-22075048.thumb.jpg.ae495928cc47a33929ac509d9086ca6f.jpg

5. Jetzt schaltet man in den Editmodus um und holt sich in der Mitte den UV-Editor.
Unter Menüpunkt UV wählt man Unwrap, was die Eckpunkte (Vertices), Kanten (Edges) und Flächen (Faces) nun in den UV-Editor bringt. Die zieht man nun (mit der rechten Maus) an die entsprechenden Stellen, wobei die Funktion View Center (in View), bzw. die Taste Numpad . sehr wichtig für genaues Positionieren ist. Ggf. muß man über die Menüpunkte Select noch auswählen, was man will. Oder man klickt mit rechts die Stellen an, mit gehaltenem Shift kann man noch eins dazu selektieren. Die beiden blauen Kästchen unten sagen, was angewählt ist: im Viewport links sind es die Flächen, im UV-Editor rechts stehe ich auf Vertices (hätten sie links und rechts auch gleiche Symbole nehmen können...)

737751083_Anmerkung2019-09-22080116.thumb.jpg.41f087af63c279c73f9d624a2310006e.jpg

Für die einfache Wand habe ich alle Punkte einfach ins Grau gezogen:

1312720260_Anmerkung2019-09-22081053.jpg.b9848cacd20d5fe5ea97e83fb7deb868.jpg

So. Der ganze Prozess wiederholt sich nun für alle Objekte, wobei die leuchtenden Objekte im Namen mit _LS beginnen und als Material auf das zweite PNG eingestellt sind:

1391081024_Anmerkung2019-09-22081930.thumb.jpg.6c3f8a66a912cded651025e96fcbd348.jpg

Am Ende muß es nur noch exportiert werden:

957829418_Anmerkung2019-09-22082207.jpg.d2918546a024baabe555ee09fec439d5.jpg

Also, soviel zu den absolut notwendigen Basics für MBS. Ich kann praktisch noch nichts, aber wenn ich das hingekriegt habe, schafft ihr das auch!
Brummi hat an anderer Stelle noch einen Thread, wie man mit den Texturen auch anders umgehen kann - mithilfe eines sogenannten Texturatlas. Wie ich das gelesen habe, war's für mich schon zu spät mich darauf umzustellen.
Bin mal gespannt, was die 'Profis' dazu und dem Post an sich anmerken. Texturen kann man sich zur Not auch ganz einfach machen, indem man mit MBS was auf den Boden sprüht und 'abfotografiert'. Da gibt's bestimmt kein Copyright-Problem.
Jeder Modellbauer zählt (jeder Programmierer auch ;)).

Grüße
  Andy

Edited by Andy

Share this post


Link to post
Share on other sites
Am ‎20‎.‎08‎.‎2019 um 09:40 schrieb Neo:

Da jedoch nicht absehbar ist, wann der glTF-Exporter dieses Zusammenfügen aller Animationen unterstützen wird, werde ich das Zusammenfügen im Studio implementieren.

Hallo @Neo, gibt es da schon etwas hinsichtlich o.a. Zusammenfügen im Studio??

lg max

Share this post


Link to post
Share on other sites

Hallo max,

das Zusammenfügen ist bereits in der aktuellen Version V5 implementiert.

Viele Grüße,

Neo

Share this post


Link to post
Share on other sites

Hallo NEO, dann muß ich was falsch machen, ich kann in die *.anim schreiben was ich will, MBS nimmt ausschließlich nur den 1. Eintrag, keine weiteren Animationen möglich.

lg max

PS: letzte Version ist installiert

Share this post


Link to post
Share on other sites

Komisch, bei mir geht's:

Treppenhauslicht;1;2;NoAutoPlay;NoLoop;
Fensterlichter;3;4;NoAutoPlay;NoLoop;

 

Share this post


Link to post
Share on other sites

Ich habe noch eine Frage an andere 2.8-Nutzer.
In meinem ersten Bild im letzten Post sieht man's: er zeigt bei Transform das Y nicht, X und Z sind da. Ist das bei euch auch so?

Share this post


Link to post
Share on other sites

Hallo,

vor 1 Stunde schrieb maxwei:

Hallo NEO, dann muß ich was falsch machen

wenn du die Modelldaten zur Verfügung stellst, kann ich mal nachschauen.

vor 11 Minuten schrieb Andy:

In meinem ersten Bild im letzten Post sieht man's: er zeigt bei Transform das Y nicht, X und Z sind da. Ist das bei euch auch so?

Bei mir ist das nicht so, aber ich kann auf deinen Bildern erkennen, das deine UI aus 2.79 importiert wurde, eventuell liegt dort die Ursache. Ich empfehle dir, beim Öffnen der Blender-Datei die Option "Load UI" zu deaktivieren, um die Standard-2.8-UI zu verwenden:

UI.jpg.f926ed1fb4948130ee3c2c99cb383e7e.jpg

Viele Grüße,

Neo

Share this post


Link to post
Share on other sites

Nutzt nix, Neo. Er baut etwas anders auf, hat kein 'default' mehr oben drin und geht stattdessen auf 'layout', und geht erstmal in den Solid Mode (und ich kann das Knöpfchen für die Textur wieder suchen). Ich meine, fehlen tut's mir nicht.
Aber er ist schon zweimal kommentarlos abgeschmiert, wenn er die Texturen am Anfang reinbringt und gelegentlich mag er halt nicht exportieren. Das ist schon noch 'ne Beta!
Ich werde mal beide Versionen rauswerfen und dann nur noch den 2.8 wieder draufmachen. Mal sehen, was passiert.

(was'n Ärger - dann nutzen meine Bildchen von oben ja auch wieder nix, wenn da andere Leute was anderes auf den Schirm kriegen. Wer ahnt denn sowas 9_9)

Gruß
  Andy

Share this post


Link to post
Share on other sites

Hallo @Neo, ich habe mal ein ganz einfaches Beispiel erstellt, egal was ich mache, es kommt immer nur ein Eintrag, in diesem Falle eigenartigerweise nur der Zweite.

for.jpg.c0d93a9163a1976f4fb9e6dbfa3ef530.jpg

animation_test.zip

lg max

Share this post


Link to post
Share on other sites

Hallo max,

du musst in Blender die FPS auf 24 setzen (Blender-Default) und dein Modell neu exportieren, dann funktioniert es:

FPS.jpg.851082d77be0a3999e46921376b570a8.jpg

Der Hintergrund ist der: Das glTF-Format speichert Animationen nicht in Keyframes ab, sondern in Zeiten, ohne eine FPS-Angabe (wird bei Zeitangaben auch nicht mehr benötigt). Damit aber die Anim-Dateien im Studio weiterhin funktionieren, muss das Studio die Zeiten wieder zurück in Keyframes umrechnen, wofür die Standard-FPS von 24 angenommen werden. Stimmen die FPS nicht, kommen natürlich alle Keyframe-Angaben durcheinander.

Ich werde das mit im Wiki erwähnen.

Viele Grüße,

Neo

Share this post


Link to post
Share on other sites

@Neo, ach du kacke, wie kommt man denn auf sowas, da hätte ich mir den Wolf gesucht, 
Habs grad ausprobiert, funktioniert jetzt tadellos.

Vielen Dank, jetzt geht's weiter

lg max

Share this post


Link to post
Share on other sites

Hallo Neo,

vor 4 Stunden schrieb Neo:

Der Hintergrund ist der: Das glTF-Format speichert Animationen nicht in Keyframes ab, sondern in Zeiten, ohne eine FPS-Angabe (wird bei Zeitangaben auch nicht mehr benötigt). Damit aber die Anim-Dateien im Studio weiterhin funktionieren, muss das Studio die Zeiten wieder zurück in Keyframes umrechnen, wofür die Standard-FPS von 24 angenommen werden. Stimmen die FPS nicht, kommen natürlich alle Keyframe-Angaben durcheinander.

im .x Format konnte man ja bisher eine Animation mit wenig Frames [zeitlich] "strecken" indem man die FPS Angabe in Blender heruntergesetzt hat...
... bedeutet das nun, um den gleichen Effekt zu erhalten, muß man im .glTF Format die Animation "länger" machen (mehr Frames) ?

Gruß
EASY

Share this post


Link to post
Share on other sites

Zwischendurch noch eine Statusmeldung: Blender 2.79 und 2.80 deinstalliert. Blender 2.80 wieder installiert. Hochhausdatei geladen. Y ist da. Gehe auf Texturansicht. Er schmiert ab. Gleiches ohne Load UI. Lade erneut und lade in den Materialien die drei Texturen erneut ein. Jetzt bleibt er mit Texturansicht stabil. Ich sichere und exportiere erneut. Die glb-Datei ist von 1.5 MB runter auf 1.2 MB. Soweit scheint alles gut. Aber mache ich bei frischem Blender einen Import der glb-Dateien, schmiert er grundsätzlich ab, wenn ich wieder in die Textur-Ansicht gehe. MBS mag die glb-Datei aber. Das ist alles sehr mysteriös und wackelig.

Gruß
  Andy

Share this post


Link to post
Share on other sites

Hallo,

vor 1 Stunde schrieb EASY:

bedeutet das nun, um den gleichen Effekt zu erhalten, muß man im .glTF Format die Animation "länger" machen (mehr Frames) ?

nein, du kannst auch bei glTF in Blender die FPS herabsetzen und erhältst eine verlangsamte Animation, muss dann aber in der Anim-Datei diese Verlangsamung bei den Frame-Zahlen einrechnen. Wenn du also von 24 auf 12 FPS herunter gehst, musst die die Frames in den Anim-Dateien verdoppeln.

Viele Grüße,

Neo

Share this post


Link to post
Share on other sites

weitere Versuche:
  glb-Datei importiert. Texturansicht an, Peng! Absturz ohne Meldung, einfach weg.
Nochmal: importiert. Um die Fehlerquelle zu suchen alle 'Augen' in der Objektliste ausgeschaltet. Nun wieder in Texturansicht geschaltet, gut. 'Augen' in einem Rutsch einschalten (bei gedrückter Maustaste über die 'Augen' runterziehen). Nach den ersten paar schmiert er wieder ab.
Wieder rein. Augen aus, Texturansicht. Gleiche Aktion jetzt Auge für Auge gemacht, dabei immer gewartet bis das Objekt texturiert angezeigt wird, dann erst das Nächste.
Er kommt heil durch!!!
Wenn da nicht noch Beta draufstehen würde, würde das Programm bei mir jetzt normalerweise in den Mülleimer wandern.
Okay, ich habe ja ein Save, bei dem er stabil bleibt und andere Programme (auch der 3D-Viewer) kommen offensichtlich mit der glb-Datei zurecht.
Ich habe das jetzt nur gepostet, damit derzeitige 2.8-Nutzer erkennen, wie wichtig es hier ist, sehr oft und vielleicht mit aufsteigender Dateinummerierung zu sichern!

Grüße
  Andy

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×