Jump to content

Recommended Posts

vor 5 Stunden schrieb ralf3:

Wieder etwas schlauer geworden...die Richtungen der Gleiskontakte ist nicht wie bei den Weichenstellungen 0 und 1 oder abweichend 1 und 2 sondern 1 und -1

schlauere Grüße, Ralf

 

Tja Ralf

Das ist spezialwissen das man  nur hier im forum, zwischen irgendwelchen zeilen findet oda so wie du durch probieren und studieren herausfinden kann.

Man kann das in den bedingungen ausnutzen.......ist auch bei der dampf an/ab schaltung ausgenutzt.

 

Cheers

Tom

Share this post


Link to post
Share on other sites
vor 36 Minuten schrieb metallix:

Das ist spezialwissen das man  nur hier im forum, zwischen irgendwelchen zeilen findet oda so wie du durch probieren und studieren herausfinden kann.

Der einfachste Weg, die Parameter für die Richtung der Gleiskontakte herauszufinden, ist die Beobachtung des Ereignisprotokolls, denn da wird es angezeigt. ;)

beispiel.jpg.6236709239adeefaebaed4391c0771db.jpg

Share this post


Link to post
Share on other sites

Sicher...........wenn man eine weile mit V5 gearbeitet hat achtet man auch auf solche feinheiten, sofern man nicht gerade an anderen raetseln knobelt.

Share this post


Link to post
Share on other sites
vor 4 Stunden schrieb Timba:

Der einfachste Weg, die Parameter für die Richtung der Gleiskontakte herauszufinden, ist die Beobachtung des Ereignisprotokolls, denn da wird es angezeigt. ;)

beispiel.jpg.6236709239adeefaebaed4391c0771db.jpg

Genau so hab ich es herausgefundwn Timba..

Und auch das kleine Manko an Toms Vorschlag für die Rauchsteuerung. Um die EV so klein wie nur möglich zu halten hatte er ja die Geschwindigkeitseinstellung unter die Bedingungszeile in die trifft zu und trifft nicht zu Zeilen gesetzt. Mit einer Lok und für sich allein betrachtet haut das auch prima hin. Was passiert aber nun , wenn der Dampfzug mit dem Dummy davor irgendwo hält und ein anderer Zug fährt über den "Rauchen"-Kontakt? Ganz einfach der Kontakt löst über die "Trifft nicht zu"-Option der Bedingung die dort hinterlegten Aktionen aus und der Dampfzug fährt los. Die Variante "Mch einfach gar nichts wenn die Bedingungen nicht zutreffen" erreicht man also nur, wenn man entweder einen zweiten Befehl einbaut oder wenn man die Steuerung füs Rauchen für die Zeit, in der andere Züge auf der gleichen Strecke unterwegs sind, deaktiviert. Manchmal führt Verschlankung auch zu neuen Problemen, sieht man ja auch bei manchen Supermodels. :o

dicke Grüße, Ralf

Share this post


Link to post
Share on other sites
vor 6 Minuten schrieb ralf3:

Was passiert aber nun , wenn der Dampfzug mit dem Dummy davor irgendwo hält und ein anderer Zug fährt über den "Rauchen"-Kontakt?

Hi Ralf

 

......das hatte ich dir hier schon aufgezeigt, was zu tun ist um das zu vermeiden.

Cheers

Tom

 

Share this post


Link to post
Share on other sites

Hi Tom, die Dampflok und den Dummy in die Bedingungen mit Namen einzuschließen funktioniert eben nicht. Wenn ein anderer Zug über den Gleiskontakt fährt, dann sind die Bedingungen ja eben nicht erfüllt und es kommen die dafür eingetragenen Aktionen zum Tragen. Da darf in diesem Fall wirklich nichts drinstehen und für die Ausführung dieser Aktionen ist dann tatsächlich ein zweiter Auslöser von Nöten. Icvh hab es letztlich mit der Deaktivierung gelöst, haut ja auch hin.

zufriedene Grüße, Ralf

 

Share this post


Link to post
Share on other sites
vor 4 Stunden schrieb ralf3:

Manchmal führt Verschlankung auch zu neuen Problemen, sieht man ja auch bei manchen Supermodels.

Guter Spruch, muss ich mir merken! (y)

Share this post


Link to post
Share on other sites

Hab die EV mal umgebaut, nach Deinem Vorbild Tom. Das aktivieren/deaktivieren  ist somit für die Rauchgeschichte entfallen. Bei anderen Ereignissen macht es aber absolut Sinn, da die nur schwierig über Parameter zu handhaben sind. Zum Beispiel Drehscheibe. Da laufen mit ein und derselben Lok ganz unterschiedliche Bewegungen ab je nachdem was zuvor passiert ist. Bei der Erstellung der EV sind mir aber noch andere Selbstverständlichkeiten aufgestoßen. Selbstverständlich für alte Hasen, Stolpersteine für Neulinge. Bei den diversen Rangiermanövern hielt der Zug manchmal nicht, dann Gleiskontakt um 1 mm verschoben und Lok hielt.Erklärung war ganz einfach, daher auch die differenzierte Begriffswahl. Der 1 mm machte den Unterschied zwischen Lok und Zug. Entweder schon angekoppelt oder nicht. so wird aus der Lok ein Zug mit nahezu doppelter Länge, der natürlich schon auf dem Kontakt steht und ihn somit nicht mehr betreten kann.

Nun laufen aber schon ca 11 Minuten EV auf der Micro-Anlage mit wechselnden Ereignissen. O.K. die Zeit kommt auch durch die beiden Standardgeschwindigkeiten zusammen. 15 km/h auf der Strecke und 5 km/h beim Rangieren. Bei der Anlagengröße, dem Thema und dem Profil in meinen Augen schnell genug. Nach 11 Minuten ist der derzeitige Endpunkt erreicht und ich muß Einiges umsetzen um die Startposition wieder herzustellen. Wenn die 2. Hälfte der EV fertig ist, ist das ja nicht mehr nötig sondern es ergibt sich eine Endlosschleife die dann aber fast eine halbe Stunde läuft.

Als nächster Schritt wird der Güterzug dann seine Fahrt ins Tal antreten um dort den wartenden Waggon aufzunehmen und den angekuppelten abzustellen.

Beim gedeckten Güterwagen wird vor Abfahrt schon mal schön die Tür geschlossen. Weiter kann man natürlich vor Ausfahrt der Diesellok die Schuppentore öffnen (derzeit ist permanent Tag der offenen Tür) und nach dem Abstellen wieder schließen und vielleicht noch ein paar weitere Animationen integrieren.

Hier nochmal die Content-ID: 6E265B38-F40B-43D2-8558-F7B240502B93

(Nach Goetz Ermahnung lieber einmal zuviel als zu wenig) Ich müßte die Startposition hergestellt habe, so dass ein Starten der Animation genügt.

unsichere Grüße, Ralf

Share this post


Link to post
Share on other sites

Aehm.....Drehscheibe hatte ich auch gleich mit umgebaut..... Ich fand es etwas ulkig das die leere scheibe irgendwann zurueck in die ursprungslage geht, ohne das da einer der 8 bewohner an einer schubstange zu sehen war. ;)

Share this post


Link to post
Share on other sites

Hallo Ralf,

Deine Anlage "Ganzklein" ist wirklich sehenswert. Sie gefällt mir sehr gut - sowohl von der Ausstattung her als auch bezüglich des automatischen Betriebsablaufs. (y)
Allerdings sind mir noch 2 Dinge aufgefallen, denen eventuell noch nachgegangen werden sollte:

1450449620_01Wagentr.thumb.jpg.a80e9b56f1250dbc15dc2f2abbd53c63.jpg
533834697_02Wagentr.thumb.jpg.9cd15bfb9b5b2b961f73855da38f50ba.jpg

Der Güterwagen in der Bildmitte wird je nach Kameraposition mit geschlossener oder geöffneter (oder eher "verschwundener") Tür angezeigt. Zur Aufnahme der beiden Bilder habe ich die Entfernung der Kamera nur minimal verändert. Ich vermute mal, dass dies ein Problem des Wagenmodells ist, und dass sich deshalb Frank (@fmkberlin) diesen Wagen nochmal anschauen sollte (könnte eventuell mit einem LoD-Stufen-Wechsel zusammenhängen - vielleicht fehlt in LOD1 die Tür oder wird nicht animiert).

341921765_03Unfall.thumb.jpg.a8a5fc04337f0a2c05395dd7485504c5.jpg

Am Ende des zweiten "Ausflugs" des kleinen Triebwagens gab es bei mir bei der Einfahrt einen Auffahrunfall, weil die Einfahrweiche zum mittleren Bahnhofsgleis falsch gestellt war. Dieses Verhalten trat bei mir allerdings nur einmal im Schnellgang (4-fache Geschwindigkeit) auf. Ich habe dann nochmal mit 1-facher Geschwindigkeit und auch mit 4-facher Geschwindigkeit versucht, das Verhalten nachzustellen, was mit jedoch nicht mehr gelang. Es scheint also irgend eine "Zufallskonstellation gewesen zu sein, aufgrund derer die Weiche bei dem einen Schnelldurchlauf nicht korrekt gestellt worden war. Ich würde daher vorschlagen, dieses Verhalten zuerst einmal zu ignorieren. Vielleicht tritt es ja überhaupt nicht mehr auf. Wenn doch, sollte dem allerdings nachgegangen werden.

Im Schnellgang hatte ich dann noch ein anderes Probelm, das zweimal auftrat: Der Triebwagen wendete nach dem Start aus dem Stumpfgleis bereits vor dem Bahnübergang, um - ohne seine volle Runde gedreht zu haben - in den Bahnhof einzufahren, über die Drehscheibe zu wenden, und dann in das Stumpfgleis zurückzukehren. Ich habe den Verdacht, dass die Ereignisverwaltung im Schnellgang ab und zu ein Ereignis "verschluckt".

Ich hätte mir vorstellen können, dass im Schnellgang bei sehr großen Anlagen mit vielen parallelen Abläufen eventuell ein Ereignis (oder zumindest dessen Ausführung) verschluckt werden könnte, aber nicht bei einer solch kleinen Anlage mit einer aus nur wenigen Ereignisdefinitionen bestehenden Ereignissteuerung, wobei die einzelnen Ablaufe sogar noch im Wesentlichen getrennt sind (nur die Rundfahrt des Dampfzugs auf der unteren Ebene überschneidet sich zeitlich mit der Ankunft des Triebwagens im Bergbahnhof). Vielleicht hat @Neo dazu eine Erklärung.

Viele Grüße
BahnLand

Share this post


Link to post
Share on other sites

Hallo,

vor 7 Minuten schrieb BahnLand:

Ich hätte mir vorstellen können, dass im Schnellgang bei sehr großen Anlagen mit vielen parallelen Abläufen eventuell ein Ereignis (oder zumindest dessen Ausführung) verschluckt werden könnte

mir ist nicht bekannt, dass Ereignisse verschluckt werden, das erscheint mir auch sehr unwahrscheinlich. In Kombination mit sehr sehr kurzen Gleisen und einer hohen Fahrzeug/Abspielgeschwindigkeiten kann es jedoch dazu kommen, dass Gleise beim Fahren übersprungen werden, weil der (alte) Fahrzeug-Code immer nur das alte und das neue Gleis nach einer Fortbewegung berücksichtigt und Gleise dazwischen ignoriert. Ob dieser Fall hier eine Rolle spielt habe ich aber nicht geprüft.

(Die Gleiskontakte besitzen diese Problematik nicht, diese werden auch dann ausgelöst, wenn ein Fahrzeug einen großen Sprung macht)

Viele Grüße,

Neo

Share this post


Link to post
Share on other sites

Lach,,, nee BahnLand nee Neo, da warst Du zu schnell ich war gerade am Schreiben, alles gut...keine Halunkinationen... war ein Fehler in der noch unfertigen EV den ich mittlerweile behoben hatte und Anlage neu hochgeladen. Also ganz einfache Erklärung.

Share this post


Link to post
Share on other sites
vor 51 Minuten schrieb metallix:

Aehm.....Drehscheibe hatte ich auch gleich mit umgebaut..... Ich fand es etwas ulkig das die leere scheibe irgendwann zurueck in die ursprungslage geht, ohne das da einer der 8 bewohner an einer schubstange zu sehen war. ;)

Den Umbau hatte ich nicht mit übernommen. Ich komm besser zurecht, wenn Die Scheibe in ihrer definiertern Nulllage ist. Die Schubstangen sind eh nie besetzt und die EV für die Aktion möchte ich mir gar nicht vorstellen. Lokschuppentür geht auf, Bahnmitarbeiter geht vom Schuppen zur Scheibe, verändert sich vom gehenden Arbeiter zum schiebenden Arbeiter, schiebt  parallel zur Scheibe mit angepasster Geschwindigkeit verwandelt sich wieder in gehenden Menschen und verschwindet wieder im Lokschuppen. Dabei muß er dann auch noch die Schubstange entsprechende der Position der Scheibe ansteuern bevor er sicvh in einen schiebenden Menschen verwandelt...nee, lass mal.

Als die kleine Bahnstation "ans Elektrische" angeschlossen wurde hat die vielen Krankschreibungen wegen "Rücken" zum Anlaß genommen die Drehscheibe mit einem modernen elektrischen Antrieb auszustatten. Der wurde in ein belüftetes Gehäuse direkt neben der Scheibe eingebaut. Die Kettenzüge laufen aus Berufsgenossenschaftlichen Gründen natürlich verdeckt.

rückenschonende Grüße, Ralf

Share this post


Link to post
Share on other sites
vor 39 Minuten schrieb BahnLand:

Der Güterwagen in der Bildmitte wird je nach Kameraposition mit geschlossener oder geöffneter (oder eher "verschwundener") Tür angezeigt. Zur Aufnahme der beiden Bilder habe ich die Entfernung der Kamera nur minimal verändert. Ich vermute mal, dass dies ein Problem des Wagenmodells ist, und dass sich deshalb Frank (fmkberlin) diesen Wagen nochmal anschauen sollte (könnte eventuell mit einem LoD-Stufen-Wechsel zusammenhängen - vielleicht fehlt in LOD1 die Tür oder wird nicht animiert).

Das ist mir beim Ablauf auch schon aufgefallen. In der Totalen stand der Waggon immer hinter dem Schuppen, so dass es nier auffiel. Erst im Zusammenhang mit der EV dachte ich erst das Ereignis Tür schließen wäre gar nicht ausgeführt worden. Nach dreimaligem Überprüfen der EV hab ich dann mal zufällig näher rangezoomt und siehe da, die Tür war zu. Meine Vermutung geht in die gleiche Richtung wie Deine..irgend etwas mit den LOD.

geschlossene Grüße, Ralf

p.s. Solange ich die EV noch nicht fertig hab muß ich mich dran gewöhnen Veränderungen der Anlage nur in der Ausgangsstellung durchzuführen. Ich hab heute schon zum 4. Mal, diesmal nach dem Einbau des Drehscheibenantriebs, das ganze Geraffel wieder in die Grundstellung gesetzt. >:(. Kommt davon wenn man nicht aufpasst und in Etappen arbeitet.

Share this post


Link to post
Share on other sites

Hallo Ralf, Bahnland und Gemeinde,

werde mich um das Problem kümmern, sowie ich zu Hause bin!

Viele Grüße aus Kaufbeuren

Frank

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×