Jump to content

Recommended Posts

Hallo
Ich habe leider noch ein Problem mit dem Bagger.
Ich möchte gerne den Blender Mittelpunkt genau zwischen den Rädern haben.
Aber egal, was ich in Blender so probiere, er wird vom MBS immer in die Mitte des Modells samt Ausleger gelegt.
Das sieht dann bei Kurvenfahrt unschön aus.
Wie kann ich das hinbekommen, daß der Mittelpunkt stimmt?
Beim Kran funktioniert es übrigens, weil dort wohl der Kranbereich die Modellgrenzen definiert.

aaa.thumb.jpg.daf110891f66687660950dcbe4ccd704.jpg

bbb.thumb.jpg.a6244cdad75beba2ffef692ced6ea3f0.jpg

 

Edited by HaNNoveraNer
Link to post
Share on other sites

Hallo @HaNNoveraNer,

wie sich das bei Kränen verhält, weiß ich nicht genau, weil ich Kräne noch nicht gebaut habe (ob z.B. die Kran-/Bagger-Funktion bestimmte Objekt-Mittelpunkte haben).

Bei "meinen" Modellen mache ich das so:

Bild96.thumb.jpg.0c9449d089f9f5763fd5ac33702d4abd.jpg

Sämtliche einzelnen Objekte haben denselben Koordinaten-Ursprung. Wo der ist, legst du in Blender selbst fest. Am einfachsten geht das, wenn wie bei meinen Modellen, der 3D-Cursor als Koordinaten-Ursprung verwendet werden soll. Wo sich dieser 3D-Cursor befindet, kannst du (wie den 2D-Cursor oben im UV-Editor) selbst bestimmen.

Mit der Tastenkombination <Umschalt>+<C> springt der Cursor immer auf die Position 0-0-0 (und das gesamte Modell wird eingeblendet. Nun wird jedem einzelnen Körper des Modells diese Position mit <Set Origin> (Menü Objekt wie im Bild) --> Origin to 3D Cursor zugewiesen. (Dass in meinem Bild an der Stelle eine 1 sichtbar ist, liegt daran, dass ich diese Funktion der Taste 1 zugewiesen habe - weil ich sie so oft benötige)

Einzige Ausnahme von dieser Koordinaten-Zuweisung bilden die animierten Objekte:

- Räder (_Wheels) müssen ihren Ursprung im Achs-Zentrum haben - in diesem Beitrag beschrieben
- auch Drehgestelle müssen einen eigenen Ursprung haben - in demselben Artikel beschrieben
- weitere animierte Objekte können leuchtende Objekte sein (Lampen). Da diese meist skaliert werden (damit sie unsichtbar werden), liegt deren Ursprung üblicherweise an einer im Modell versteckten Stelle - zu der sie hin verkleinert werden.

Gruß
Reinhard

Edited by Reinhard
Link to post
Share on other sites

Hallo @HaNNoveraNer,

vor 1 Stunde schrieb HaNNoveraNer:

Ja, so hab ich es auch gemacht

Dann entschuldige bitte meinen Beitrag, wollte nicht als Klugscheißer auftreten, nur bei Problemen helfen.

Es gibt - aus meiner Sicht - noch eine Möglichkeit, dein Problem anzugehen: In diesem Beitrag habe ich beschrieben, was passiert, wenn man ein Modell aus Blender exportiert und die Animationen gerade nicht "auf 0" gesetzt sind. Vielleicht hast du ja beim Export deines Modells  gerade auch die Animation irgendwo mittendrin oder sogar am Ende stehen. Dann sollten diese auf 0 gesetzt werden und das Modell erneut exportiert werden.

Gruß
Reinhard

Link to post
Share on other sites

Hallo @HaNNoveraNer,

versuche mal die beiden Achsen als _WheelSet zu definieren in der Mitte der Achsen, brauchst aber auch noch ein "virtuelles" _WheelSet1 außerhalb ohne Child's.

Oder pro Achse ein _WheelSet, hab's so noch nicht ausprobiert, müsste aber funktionieren.

Der Ursprung ändert sich dadurch zwar nicht, aber die Räder bleiben auf der Strasse.

lg max

Edited by maxwei
Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
×
×
  • Create New...