Jump to content

Pfad folgen => Übernahme des manuell eingegeben Abstandes nicht erst mit ENTER


Recommended Posts

Wenn ich bei "Pfad folgen" den Abstand direkt manuell eingebe, wird er erst übernommen, wenn ich ihn mit ENTER bestätige.

Hilfreich wäre es, wenn der eingegebene Wert auch ohne ENTER wirken würde. (bei Abstandeingabe über den Schieberegler muss man ja auch nicht nochmal auf ENTER gehen)

Bin nämlich -als Anfänger- darauf reingefallen:

Habe "Pfad folgen" angeklickt, den gewünschten Wert manuell eingegeben und dann gleich das Gleis angeklickt, dessen Pfad ich folgen wollte.

Da MBS da dann als Abstand allerdings noch 0 "im Hinterkopf hatte", wurde mein Gleis direkt auf das "Gleis-dessen-Pfad-ich-folge" gelegt.

Erst beim Schreiben eines Threads unter "Technischer Support" ist mir das mit dem "ENTER" aufgefallen.

Danke schon mal für die wohlwollende Prüfung (-;

Link to post
Share on other sites

Hallo,

aktuell sehe ich hier keinen Änderungsbedarf, da sich alle Eingabefelder im Studio gleich verhalten: Eingaben werden erst beim Drücken von Enter oder beim Verlassen des Feldes übernommen. Wenn einzelne Felder anders reagieren würden, würde das zu mehr Verwirrung führen.

Viele Grüße,

Neo

Link to post
Share on other sites

Hi Neo,

erstmal vielen Dank für die schnelle Antwort.

Nach meinen Beobachtungen wird der Wert aber beim reinen Verlassen des Feldes nicht übernommen.

Wenn ich einen Wert reinschreibe, dann ist der Cursor  (senkrechter Strich hinter dem eingegebenen Wert) noch im Feld und blinkt da (wenn ich mich meiner VisualBasic-Kenntnisse erinnere, heißt das "Das Feld hat den Fokus"

Wenn ich dann das Gleis, dessen Pfad ich folgen will, anklicke, ist der Cursor nicht mehr im Feld (=> das Feld hat den Fokus nicht mehr, es wurde somit verlassen), dennoch wird der Wert nicht übernommen.

 

ich hab's grad mal mit dem Feld "Rotation x" ausprobiert

Da funktioniert es meiner Meinung nach korrekt:

Ich schreibe einen Wert für das Objekt "Gleis 1" rein. Dann klicke ich irgendein anderes Objekt an => die Rotation wird auf das Objekt "Gleis 1" übernommen.

 

LG Uwe

 

Link to post
Share on other sites

Hallo Uwe,

vor 32 Minuten schrieb mcbeth1307:

Nach meinen Beobachtungen wird der Wert aber beim reinen Verlassen des Feldes nicht übernommen.

hier scheint es noch ein Problem zu geben, danke für den Hinweis. Nach der Korrektur sollte sich dein Wunsch damit eigentlich auch erledigen, weil durch das Verlassen der Wert sofort übernommen wird.

Viele Grüße,

Neo

Link to post
Share on other sites
vor einer Stunde schrieb Neo:

hier scheint es noch ein Problem zu geben, danke für den Hinweis. Nach der Korrektur sollte sich dein Wunsch damit eigentlich auch erledigen, weil durch das Verlassen der Wert sofort übernommen wird.

Sehe ich auch so...wann wird denn der nächste Patch kommen ?

Link to post
Share on other sites

Hallo Uwe,

ein konkretes Datum kann ich aktuell nicht nennen, ich denke in den nächsten Wochen werden genug Punkte angelaufen sein, sodass sich ein Update lohnt.

Viele Grüße,

Neo

Link to post
Share on other sites
16 hours ago, Neo said:

... Inputs are only accepted when you press Enter or when you leave the field...

I have (too...) often been fooled by this with the Engine 'Set Speed' field. If the focus changes, the value is not updated. One has to use the 'Enter' key to validate. Is this a 'special case', or should it work like all the other data entry fields..? :/

Ich habe mich (auch ...) oft mit dem Feld "Set Speed" des Motors täuschen lassen. Wenn sich der Fokus ändert, wird der Wert nicht aktualisiert. Zur Validierung muss die Eingabetaste verwendet werden. Ist dies ein Sonderfall oder sollte es wie alle anderen Dateneingabefelder funktionieren? :/

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
×
×
  • Create New...