Jump to content

Recommended Posts

vor 6 Stunden schrieb Klartexter:

Wie funktioniert das, dass man die Textur in Sketchup bearbeiten kann? Wenn ich auf Texturbild bearbeiten gehe, dann öffnet sich das mit dem Standardprogramm, was mir aber für Sketchup nichts nützt. Im Video ist die Textur offensichtlich dauerhaft auf der Arbeitsfläche, wie geht das?

Ich kann nicht kritisieren, was andere tun....
Aber ich sage; Vergiss das. Keine Texturbearbeitung in SKP selbst.
Wenn du Farben meinst usw.
Die Größe der benötigten Textur selbst; indem Sie das gewünschte Stück aus Ihrer importierten Textur kopieren, gruppieren und dann auf die zu bemalende Oberfläche skalieren.
Auch hier schlage ich vor, dass wir eine schnelle Teambesprechung durchführen. Ihr Problem ist sehr einfach zu lösen und es gibt noch so viele Worte, die ich für eine Aktion schreiben muss, die mit einer kleinen Anzahl von Tasten auf der Maus gelöst werden kann.
Was für den einen verständlicher Text ist, kann es für andere nicht sein. Ich selbst hatte das in der Vergangenheit SO VIEL. Und sicherlich, weil Deutsch nicht meine Muttersprache ist und ich mich manchmal noch sehr auf Google verlassen muss. Es war nie die Schuld der Leute, die es mir erklärt haben. So ist es nun mal.

Schick mir eine PN mit deiner E-Mail-Adresse und wir klären das morgen, wenn du Zeit hast. Wohlgemerkt, ich glaube, ich habe einen Unterschied von 5 Stunden zu Deutschland.


Viele Grüße

Link to post
Share on other sites
  • Replies 88
  • Created
  • Last Reply

Top Posters In This Topic

Top Posters In This Topic

Popular Posts

Hallo Walter, ich habe ein kleines Prinzip-Modell mit den Aufriss-Maßen des GT6N gebastelt, an dem ich erklären möchte, wo die Coupler-Objekte zu platzieren sind, und was es mit den eingebauten W

Man glaubt es kaum, aber dank euerer Hilfen habe ich es jetzt tatsächlich geschafft, zumindest mehrere Farben mit der Multitextur aufzubringen. Jetzt mache ich mich mal schlau, wie das mit den Holzstr

Hallo @Klartexter, Am einfachsten ist es in Sketchup, eine Modellfläche mit einer einzelnen Farbe oder einem einzelnen Motivbild (Einzeltextur) zu belegen. Dann wird jedoch jede verwendete Farb

Posted Images

Zuerst möchte ich hier Hubert mal Dank sagen für seine Bemühungen, mir zu helfen. Aber nach vier Stunden Beschäftigung mit seiner Hilfedatei bin ich eher noch mehr verunsichert, zumal ich ein weiteres Problem habe, das auf YouTube angesehen werden kann: https://youtu.be/UxRc44aKDjo Das Problem ist kurz beschrieben: Ich gehe wie in Bahnlands Beispiel vor, lege Hilfslinien an, zeichne ein Rechteck und fülle es mit der Textur. Dann positioniere ich die Stelle in der Multitextur, mit der ich texturieren will. Danach wähle ich auch projezieren, skaliere den Bereich und wähle danach den Farbtopf und drücke die Alt-Taste, um die gewählte Farbe - im Beispiel Metall - auf die Räder zu texturieren. Doch statt Metall bekomme ich eine Holztextur!  Ich kann es drehen wie ich will, ich bekomme nicht das gewählte Element!

Nun zu den Fragen bezüglich Sketchup. Wenn ich ein Modell baue, dann geschieht das immer entlang der roten Linie. In Bahnlands Hilfsvideo habe ich aber gesehen, dass sein Modell mittig über der roten Linie steht. Hubert hat mir ein Plugin empfohlen, welches Gruppen mittig über die Linie setzt, allerdings auch mittig entlang der blauen Linie. Wenn ich das Projekt dann speichere und später wieder aufrufe, dann ist es aber wieder entlang der roten Linie. Ich bin jetzt doch etwas verunsichert, wozu da Plugin da ist, denn bei mehreren Gruppen werden die alle mittig verschachtelt.

Tja, und dann mein Problem mit den unterschiedlichen Versionen im Aussehen von Sketchup, ich verwende Windws 10 und Sketchup 2017. Bild 1 zeigt meine Arbeitsfläche, Bild 2 die Arbeitsfläche von Hubert. Inzwischen weiß ich zwar, dass ich das rechte Menuefeld ausschalten kann und das linke Menuefeld ausblenden, aber es ist mir bisher nicht gelungen, nur einzelne Menues aufzuzeigen. Sicher kein weltbewegendes Problem, aber eine leichte Verunsicherung ist gegeben. Bild 1 zeigt übrigens die Räder, die partout nich mit einer Metalltextur versehen werden wollen.

Nun denn, es war ein langer und arbeitsreicher Tag, meine Kunden sorgen mit ihren Bestellungen auch morgen dafür, dass mir nicht langweilig wird. Aber vielleicht kann mir ja jemand sagen, was da falsch läuft mit der Textur, bisher hat das ganz gut geklappt, warum plötzlich nicht mehr? Ich wünsche allen hier eine gute Nacht.

bild1.jpg

bild2.jpg

Link to post
Share on other sites

Hallo Walter,

so sieht mein Arbeitsplatz in Sketch Up 2017 aus:2017er.thumb.jpg.63584720bdcd0a4a3a047222c3dc6349.jpg

zur Texturieren: wenn alle Stricke reißen sollten, nimm deine Multitextur und trage diese komplett auf die Nabenseite auf. Die Textur befindet sich nun auf der Nabenseite. Rechtsklick und über positionieren  die gewünschte Textur so verschieben, daß  diese sich an der gewünschten Position befindet. Die Reiszwecken benutzt du jetzt zum Rahmen stecken, indem du nach Linksklick auf eine Reiszwecke diese mit der Maus in eine Ecke deiner Einzeltextur platzierst. Ebenso verfährst du mit den anderen Zwecken, dabei  zu beachten ( als Beispiel)  Reiszwecke unten re. ist an der Einzeltextur auch unten rechts. Beim neuplatzieren der Zwecken erscheinen blaue Hilfs-(Kontroll)linien, die dir die richtige Position zum Zwecken - Nachbar anzeigen.  Danach auf die benötigte Größe ziehen/ drücken und fertigstellen. Jetzt kannst du auch mit der Pipetten Funktion weiterarbeiten.

würde mich freuen das du damit weiterkommst

Gruß Karl

  

 

Link to post
Share on other sites
vor 10 Stunden schrieb Klartexter:

Zuerst möchte ich hier Hubert mal Dank sagen für seine Bemühungen, mir zu helfen. Aber nach vier Stunden Beschäftigung mit seiner Hilfedatei bin ich eher noch mehr verunsichert, zumal ich ein weiteres Problem habe, das auf YouTube angesehen werden kann: https://youtu.be/UxRc44aKDjo Das Problem ist kurz beschrieben: Ich gehe wie in Bahnlands Beispiel vor, lege Hilfslinien an, zeichne ein Rechteck und fülle es mit der Textur. Dann positioniere ich die Stelle in der Multitextur, mit der ich texturieren will. Danach wähle ich auch projezieren, skaliere den Bereich und wähle danach den Farbtopf und drücke die Alt-Taste, um die gewählte Farbe - im Beispiel Metall - auf die Räder zu texturieren. Doch statt Metall bekomme ich eine Holztextur!  Ich kann es drehen wie ich will, ich bekomme nicht das gewählte Element!

Man sollte nach einem langen Arbeitstag vielleicht auch mal die Finger von Sketchup lassen, jetzt ist mir klar geworden, warum das nicht funktionieren konnte. Ich hatte den Radsatz als Gruppe gespeichert, das aber beim Versuch zu texturieren nicht beachtet. Nachdem ich die Gruppe auf bearbeiten gestellt habe war das Texturieren auch kein Problem mehr. Das nur als Information, der Fehler lag wie so oft nicht am Programm sondern auf meiner Seite. Die Lösung fiel mir beim verpacken meiner Pakete ein, da ich bei einer Gruppierung ja quasi auch etwas verpacke. Also gleich die Arbeit unterbrochen und getestet, ob dem so ist, und es war so. Und jetzt bekommt DHL dann etwas zu tun. Schönen Tag noch.

Walter

Link to post
Share on other sites
vor 6 Stunden schrieb Klartexter:

Man sollte nach einem langen Arbeitstag vielleicht auch mal die Finger von Sketchup lassen, jetzt ist mir klar geworden, warum das nicht funktionieren konnte. Ich hatte den Radsatz als Gruppe gespeichert, das aber beim Versuch zu texturieren nicht beachtet

One remark i didnt add in the PPT... 

Link to post
Share on other sites
vor 17 Stunden schrieb Klartexter:

das auf YouTube angesehen werden kann:

Weird way of painting... my opinion. Id import the texture on a face first and set it to projected. As of from slide 6 in the PPT

Then start cutting out copies of that texture as shown in the slides afterwards. Can also be seen in the videos of Bahnland.

Edited by hubert.visschedijk
Link to post
Share on other sites

Hallo Hubert,
ich habe noch nicht die Zeit gefunden, mich mit Deiner PPT näher zu befassen, daher habe ich es so gemacht, wie es Bahnland in seinem Video zeigt. Denn das Texturbild bekomme ich zwar auf die Arbeitsfläche, aber ich kann es nicht auf projeziert stellen. Ebenso kann ich nicht eine Fläche markieren oder gar ausschneiden oder kopieren. Denn da finde ich nichts in Sketchup, was mir das ermöglicht. Ich weiß, dass es bei Dir funktioniert, aber ich bin noch nicht dahinter gekommen, wie es funktioniert. Im Moment fehlt es mir auch etwas an der Zeit, mich länger mit dem Thema zu befassen, Deine PPT ist auf jeden Fall eine Hilfe. Die wird eben jetzt Stück für Stück geistig verarbeitet, dauert dann eben etwas länger. Aber ein alter Mann ist auch kein Schnellzug ;-)
Schönen Abend noch

Walter

Hello Hubert,
I haven't yet found the time to look at your PPT in more detail, so I did it the way Bahnland shows it in his video. Because I do get the texture image on the work surface, but I can't set it to projected. Similarly, I can't select a surface or even cut or copy it. Because I can't find anything in Sketchup that allows me to do that. I know it works for you, but I haven't figured out how it works yet. At the moment I don't have enough time to deal with the subject for a longer time, but your PPT is definitely a help. It is now being mentally processed piece by piece, which takes a little longer. But an old man is not an express train either ;-)
Have a nice evening

Walter

textur.jpg

Link to post
Share on other sites
vor 14 Stunden schrieb Klartexter:

Texturbild bekomme ich zwar auf die Arbeitsfläche, aber ich kann es nicht auf projeziert stellen

Wegen des Popup-Fensters gehe ich davon aus, dass das Gesicht eine Gruppe ist. Machen Sie dies rückgängig und versuchen Sie es erneut, indem Sie mit der rechten Maustaste klicken und "projiziert" auswählen.

Seien Sie nur sicher;
Zuerst haben Sie ein einfaches fläche mit den gleichen Abmessungen wie die Textur entworfen. NICHT Größe.
Dann "importieren" Sie die Textur als Textur auf diese Fläche. Nicht als Bild.

viele grusse

 

Link to post
Share on other sites
Posted (edited)

Immer wieder Sonntags kommen Fragen, für die ich - noch - keine Antworten gefunden habe. Ich habe mein erstes Straßenbahnmodell ziemlich weit voran gebracht, und zum testen dann ins Programm geladen. Beim ersten Versuch kam die Meldung (sinngemäß), dass eine Textur das hochladen verhindere, da sie nicht das richtige Format habe. Der Text war irgendwie noch anders, aber ihr kennt die Meldun sicher. Da ich nur zwei Texturen verwendet hatte, eine mit 32x32 und eine Multitextur mit 1024x1024 habe ich nicht so recht glauben können, dass die Textur schuld sein kann. Ich habe im Modell komponenten und Gruppen gehabt, ich habe dann mal die Komponenten in Gruppen geändert, und dann hat der Upload funktioniert. Gibt es da Einschränkungen, dass zum Beispiel Komponenten keine Gruppen enthalten dürfen?

Beim Test im MBS habe ich dann bei Betreten des Cockpit den Nummernschildkasten vor Augen, so macht das aber keinen Spass. Gibt es in Sketchup eine Möglichkeit, eine Kamera an einer anderen Position zu platzieren? In Sketchup gibt es ja einen Menuepunkt Kamera, nur bin ich noch nicht ganz schlau aus den Funktionen geworden. Denn im MBS kann man ja leider nicht die Position der Kamera bestimmen, oder sehe ich das falsch?

Ich wünsche noch einen schönen Restsonntag

Walter

Edited by Klartexter
Link to post
Share on other sites

Hallo KLartexter

vor 36 Minuten schrieb Klartexter:

Denn im MBS kann man ja leider nicht die Position der Kamera bestimmen, oder sehe ich das falsch?

Wie in der WIKI so schön steht kannst du ein Objekt namens _CCP in deinem Modell positionieren welches dann die Kameraposition angibt.

lg max

 

Link to post
Share on other sites
Am 15.8.2021 um 14:37 schrieb Klartexter:

Beim Test im MBS habe ich dann bei Betreten des Cockpit den Nummernschildkasten vor Augen, so macht das aber keinen Spass. Gibt es in Sketchup eine Möglichkeit, eine Kamera an einer anderen Position zu platzieren? In Sketchup gibt es ja einen Menuepunkt Kamera, nur bin ich noch nicht ganz schlau aus den Funktionen geworden. Denn im MBS kann man ja leider nicht die Position der Kamera bestimmen, oder sehe ich das falsch?

Walter, 

Das ist immer ein bisschen Testen. In SKP können Sie die Kamera an einem Punkt im Modell platzieren, aber in MBS scheint sie zu hoch oder zu weit / nahe platziert zu sein.
Es gibt keine andere Möglichkeit, als die Kamera in SKP neu zu positionieren und in MBS erneut zu testen. Aus diesem Grund speichere ich diesen Abschnitt immer zum Schluss zusammen mit allen anderen Animationen, falls vorhanden.

und um das Modell schnell zu laden, ohne Rauhigkeit, emittierende oder metallische Textur.

Viele Grüße.

Link to post
Share on other sites
  • 3 weeks later...

Guten Abend,

so langsam verzweifle ich am MBS. Denn nachdem ich jetzt den Dreh mit den Texturen verstanden habe, lassen sich in Sketchup auch die entsprechenden Teile texturieren. Aber wenn ich das Modellteil dann zum testen in den lokalen Katalog lade, dann erhalte ich ein Ergebnis wie auf dem beigefügten Bild. Es sind zwar "nur" die Texturen der Sitze, die hier unterschlagen werden, aber das kann es ja nicht sein. Warum also werden diese Texturen im MBS nicht angezeigt?

gt6.jpg

Link to post
Share on other sites

Überprüfen Sie den Sitz in SKP, um sicherzustellen, dass Sie die "blau/graue" Oberfläche nicht gestrichen haben. Wenn ja, ist diese Oberfläche in MBs unsichtbar.

ehrlich gesagt kann ich es auf dem Foto nicht ganz erkennen, aber dies ist mein erster Gedanke, dass die Textur nicht sichtbar ist.

Schick mal die SKP wieder. Dan kann ich es ansehen wenn sie wollen.

Edited by hubert.visschedijk
Link to post
Share on other sites

Eine Frage an die Experten hier: Wie ich durch einen freundlichen Hinweis von BahnLand erfahren durfte, färbt Sketchup immer beide Seiten ein, was zu einer hohen Polygonzahl führt, die nicht gewollt ist. Ich weiß, dass ich in Sketchup unter Elementinformationen die Flächen ändern kann, aber das ist sehr aufwendig und zeitintensiv. Daher meine Frage: Kann man bei Sketchup irgendwo in den Einstellungen festlegen, dass immer nur die Vorderseite texturiert werden soll? Danke für eventuelle Tipps.

Walter

info.jpg

Link to post
Share on other sites

Walter,

Nein. Aber ich glaube mit JPG passiert das nicht. Nur mit PNG.

Aber um al die flache wieder auf "grau" zu haben....

Alle flache in de gruppe auswahlen, flache umdrehen (rechter mousetaste), und dan wiederum diese flache malen mit die basistextuur von SKP.

Alle flache wiederum umdrehen so das die wirklich gemalte flache wiederum sichtbar sein.

Ein weiterer Trick, damit Sie nicht jedes Mal alles drehen müssen, was Sie malen, besteht darin, ein sehr kleines Stück Ihrer Textur mit einer leuchtend rosa oder lila Farbe zu bemalen.
Dann malen Sie alles rosa.
Dann dreht man alles um und malt die grauen Stellen wieder mit der Grundtextur von SKP, so dass sie wieder grau sind.
Alles zurückdrehen, damit die Farbe Pink wieder sichtbar wird.
Jetzt malen Sie alles mit den echten Farben. Das hat einen Vorteil..
Sie können kein einziges Stück verpassen, denn was Sie vielleicht vergessen, ist knalliges Pink..
Und alles, was Sie neu lackieren, wird nicht mehr automatisch auf die graue Seite gemalt.

1000659081_basistextuur.jpg.86794fcdc35a420e1017ec761eafcae5.jpg

Viele grusse

Edited by hubert.visschedijk
Link to post
Share on other sites

Hallo Walter,

vor einer Stunde schrieb Klartexter:

... färbt Sketchup immer beide Seiten ein ...

das stimmt so nicht!
Nur wenn man Sketchup-Gruppen mit dem Farbeimer anmalt, ohne sie vorher aufzulösen oder die Gruppe zu öffnen, werden alle Flächen in der Gruppe sowohl auf der Vorderseite als auch auf der Rückseite eingefärbt. Wenn man direkt eine Fläche auswählt (egal ob nicht gruppiert oder nach Öffnen der Gruppe(nhierarchie), bis man die Fläche direkt anklicken kann), wird diese immer alleine (also jene Flächenseite, die angeklickt wurde) angemalt.

Eine Fläche kann Teil einer Gruppe und diese Gruppe Teil einer weiteren übergeordneten Gruppe sein. Um hier die einzelne Fläche allein bemalen zu können, muss man sukzessive alle übergeordneten Gruppen durch Doppelklick öffnen, bis man an der Fläche selbst angekommen ist. Letzteres kann man daran erkennen, dass auf der Fläche selbst ein Markierungsraster angezeigt wird, aber kein umhüllender Rahmen mehr sichtbar ist, der eine angeklickte Gruppe kennzeichnet.

Statt in eine Gruppe(nhierarchie) hinein zu klicken, um an die zu texturierende Fläche zu gelangen,  kann man die Gruppe(nhierarchie) auch auflösen, wobei man dann aber nach der Einfärbung möglicherweise die übergeordnete(n) Gruppe(n wiederherstellen muss.

Klickt man eine nicht gruppierte Fläche oder eine Fläche innerhalb der direkt übergeordneten Gruppe mit einfachem Klick an, wird genau diese Fläche durch ein Punktraster gekennzeichnet. Klickt man anschließend mit dem Farbeimer auf diese Fläche, wird genau diese Seite der Fläche eingefärbt, aber nicht deren Rückseite (oder umgekehrt). Wählt man diese Fläche mit Doppelklick aus, wird die Umrandung dieser Fläche mit markiert. Wählt man diese Fläche mit einem 3-fach-Klick aus, werden auf höchster Ebene alle Einzelflächen des Modells oder innerhalb einer Gruppe alle Einzelflächen dieser Gruppe (außer jeweils vorhandenen (Unter-)Gruppen) einschließlich der zugehörigen Kanten ausgewählt (erkennbar an dem über alle ausgewählten Flächen reichenden Markierungsraster). Wenn man danach mit dem Farbeimer auf diese eine Fläche klickt, werden alle anderen markierten Flächen mit dieser zusammen texturiert - aber ebenfalls nur auf einer Seite: Texturiert man von der 3-fach angeklickten Fläche die Vorderseite, werden auch von allen anderen markierten Flächen (unabhängig von ihrer Ausrichtung) nur die Vorderseiten texturiert. Handelt es sich bei der angeklickten Fläche um eine Rückseite, wirkt sich die Texturierung auch bei den anderen markierten Flächen nur auf deren Rückseiten aus.

Man kann also immer - solange man nicht eine "Gruppe" auswählt - die Vorder- und Rückseite einer Fläche oder einer ausgewählten Ansammlung von Flächen getrennt texturieren.

Abschließend noch eine Bemerkung zur inzwischen eingegangenen Antwort von Hubert:
Hat man versehentlich eine "Gruppe" (Vorder- und Rückseiten) texturiert, lassen sich die Rückseiten einzeln oft nicht zurücksetzen. Man muss dann auch das "Entfärben" der Rückseiten wieder auf die ganze Gruppe anwenden, was dann aber dazu führen kann, dass dann alle Vorderseiten der Gruppe wieder entfärbt sind. In diesem Fall muss man die Vorderseiten innerhalb der Gruppe wie oben beschrieben neu einfärben.

Viele Grüße
BahnLand

P.S.:
Eine Sketchup-Einstellung, bei der mit der Texturierung einer Seite immer die andere Seite mit texturiert wird, kenne ich nicht.

Edited by BahnLand
Link to post
Share on other sites
vor 32 Minuten schrieb BahnLand:

Nur wenn man Sketchup-Gruppen mit dem Farbeimer anmalt, ohne sie vorher aufzulösen oder die Gruppe zu öffnen, werden alle Flächen in der Gruppe sowohl auf der Vorderseite als auch auf der Rückseite eingefärbt. Wenn man direkt eine Fläche auswählt (egal ob nicht gruppiert oder nach Öffnen der Gruppe(nhierarchie), bis man die Fläche direkt anklicken kann), wird diese immer alleine (also jene Flächenseite, die angeklickt wurde) angemalt.

möglicherweise abhängig von der SKP-Version ? Denn bei mir werde beide Seiten lackiert.

vor 32 Minuten schrieb BahnLand:

Hat man versehentlich eine "Gruppe" (Vorder- und Rückseiten) texturiert, lassen sich die Rückseiten einzeln oft nicht zurücksetzen. Man muss dann auch das "Entfärben" der Rückseiten wieder auf die ganze Gruppe anwenden, was dann aber dazu führen kann, dass dann alle Vorderseiten der Gruppe wieder entfärbt sind. In diesem Fall muss man die Vorderseiten innerhalb der Gruppe wie oben beschrieben neu einfärben.

Aber das meinte ich nicht. Ich meinte die Oberflächen. Gruppen sollten niemals bemalt werden, da Sie in diesem Fall tatsächlich die gesamte Gruppe mit der Basistextur bemalen müssen. (Nicht jede Oberfläche innerhalb der Gruppe) Oder lösen Sie die Gruppe auf und treten Sie sofort als Gruppe wieder bei. (endlich sind alle Flächen ausgewählt) So lässt es sich auch lösen.

viele grusse

Edited by hubert.visschedijk
Link to post
Share on other sites
vor 8 Stunden schrieb BahnLand:

Klickt man eine nicht gruppierte Fläche oder eine Fläche innerhalb der direkt übergeordneten Gruppe mit einfachem Klick an, wird genau diese Fläche durch ein Punktraster gekennzeichnet. Klickt man anschließend mit dem Farbeimer auf diese Fläche, wird genau diese Seite der Fläche eingefärbt, aber nicht deren Rückseite (oder umgekehrt). Wählt man diese Fläche mit Doppelklick aus, wird die Umrandung dieser Fläche mit markiert. Wählt man diese Fläche mit einem 3-fach-Klick aus, werden auf höchster Ebene alle Einzelflächen des Modells oder innerhalb einer Gruppe alle Einzelflächen dieser Gruppe (außer jeweils vorhandenen (Unter-)Gruppen) einschließlich der zugehörigen Kanten ausgewählt (erkennbar an dem über alle ausgewählten Flächen reichenden Markierungsraster). Wenn man danach mit dem Farbeimer auf diese eine Fläche klickt, werden alle anderen markierten Flächen mit dieser zusammen texturiert - aber ebenfalls nur auf einer Seite: Texturiert man von der 3-fach angeklickten Fläche die Vorderseite, werden auch von allen anderen markierten Flächen (unabhängig von ihrer Ausrichtung) nur die Vorderseiten texturiert. Handelt es sich bei der angeklickten Fläche um eine Rückseite, wirkt sich die Texturierung auch bei den anderen markierten Flächen nur auf deren Rückseiten aus.

Man kann also immer - solange man nicht eine "Gruppe" auswählt - die Vorder- und Rückseite einer Fläche oder einer ausgewählten Ansammlung von Flächen getrennt texturieren.

Abschließend noch eine Bemerkung zur inzwischen eingegangenen Antwort von Hubert:
Hat man versehentlich eine "Gruppe" (Vorder- und Rückseiten) texturiert, lassen sich die Rückseiten einzeln oft nicht zurücksetzen. Man muss dann auch das "Entfärben" der Rückseiten wieder auf die ganze Gruppe anwenden, was dann aber dazu führen kann, dass dann alle Vorderseiten der Gruppe wieder entfärbt sind. In diesem Fall muss man die Vorderseiten innerhalb der Gruppe wie oben beschrieben neu einfärben.

Viele Grüße
BahnLand

P.S.:
Eine Sketchup-Einstellung, bei der mit der Texturierung einer Seite immer die andere Seite mit texturiert wird, kenne ich nicht.

Hallo BahnLand, hallo Hubert,

erst einmal vielen Dank für Euere Antworten. Ich bin ja, wie bekannt ist, ein absoluter Neuling auf dem Gebiet, daher erlebe ich auch immer neue Überraschungen. Als Du mir mitgeteilt hattest, dass im Modell auch die Innenflächen texturiert sind, war ich mal wieder überrascht. Denn damit hatte ich überhaupt nicht gerechnet. Also habe ich das Modell nochmals völlig neu aufgesetzt, als erstes habe ich nur das Cockpit gebaut, das nach der Fertigstellung als Gruppe gepackt werden soll. Nachdem alles rundherum in der Grundfarbe weiß von Sketchup erstellt war, habe ich begonnen, wie in Deinem Video gezeigt die Flächen zu texturieren. Also eine Farbe gewählt und mit Farbkübel auf die Fläche gebracht. Dann habe ich mich an Deinen Hinweis erinnert und habe mich mal nach "innen" gescrollt, und da war alles in der Farbe von außen. Ich hatte auch in Erinnerung, dass es in Sketchup eine Funktion gibt, die das anzeigt. Es hat dann noch eine Zeit gebraucht, bis ich auf den Dreh mit der Markierung der Fläche gekommen bin, danach habe ich dann festgestellt, dass alle Flächen beidseitig texturiert waren! Dabei hatte ich noch gar keine Gruppen oder Komponenten erstellt, ich habe dann Fläche für Fläche entsprechend abgeändert, was ziemlich zeitaufwendig war und daher zu meiner Frage geführt hat.

Inzwischen habe ich noch etwas festgestellt, BahnLand. Wenn ich mit einer Texturfarbe aus Sketchup - also die dort gespeicherten Angebote - eine Fläche bemale, dann wird auch nur die Fläche bemalt, nicht aber die Rückseite. Bei einer eigenen Textur macht aber Sketchup genau das! Ich hänge hier mal die entsprechenden Bilder mit an, auf denen das zu sehen ist. Warum das so ist weiß ich allerdings nicht. Das nur zur Info, danke auch für den Tipp mit der Wechselfarbe, der spart mir viel Zeit.

B0a.jpg

B0b.jpg

B1.jpg

B2.jpg

B3.jpg

B4.jpg

B7.jpg

Link to post
Share on other sites

Ich denke jetzt darüber nach, weil du gerade erst angefangen hast.
Ändern Sie Ihre Textur in eine JPG-Datei. Beginnen Sie dann mit dem Malen und sehen Sie, ob beide Seiten fleckig werden. Nun, schön.
Ändern Sie dann testweise dieselbe Textur in eine PNG-Datei und sehen Sie, ob die Rückseite plötzlich gefärbt ist.
Wenn nicht, dann ist die Lösung da. Beginnen Sie mit JPG und wenn Sie fertig sind, ändern Sie die gesamte Textur in PNG.

Dann stellt sich natürlich die Frage, warum nicht einfach alles in JPG behalten?
Nun, ich persönlich denke, PNG hat eine bessere Qualität und verwendet auch Texturen, die teilweise transparent sein sollten. Ich kann also kein JPG verwenden.

Viele Grüße.

 

Link to post
Share on other sites

Hallo Walter,

besitzt die png-Datei, die Du zur Texturierung verwendest, einen Alphakanal?

Dann stellt sich das vor Dir beschriebene Verhalten ein. Das ist dann der Effekt, den ich für "halbtransparente" Texturen (mit geschwächter Deckkraft) beschrieben habe. Denselben Effekt konnte ich nun auch mit "teiltransparenten" Texturen nachstellen (Texturen bei denen Teilbereiche vollständig durchsichtig sind, also 0% Deckkraft besitzen). Bei beiden Transparenzformen wird ein Alphakanal benötigt, der innerhalb der png-Datei spezifiziert, welche Bereiche mit welcher Deckkraft auf eine Fläche aufgetragen werden sollen.

Da ich meine Texturen meistens mit dem in Windows vorhandenen Paint erstelle, welches keine Alphakanäle unterstützt, werden hier die png-Dateien  immer ohne Alphakanal abgespeichert, was bedeutet, dass man mit diesen Dateien auch keine Transparenzen erzeugen kann. Wenn ich in einer png-Datei eine Halbtransparenz (zu einem gewissen Grad durchsichtig) oder eine Teiltransparenz (Teilbereich der Textur unsichtbar) benötige, öffne ich die bereits vorbereitete png-Datei in Gimp und stelle dort für die betroffenen Texturbereiche die gewünschte Transparenz her. Beim anschließenden Abspeichern erhält die Datei in Gimp automatisch enen entsprechend präparierten Alphakanal.

Wenn ich nun eine Fläche eines Sketchup-Modells mit der Textur aus einer png-Datei ohne Alphakanal bemale, verhält sich die Textur genauso, wie wenn sie aus einer bmp-Datei oder einer jpg-Daei eingelesen worden wäre: Es werden wie oben beschrieben nur jene Seiten der Flächen bemalt, die mit dem Farbkännchen angeklickt wurden.  Bemale ich eine Flächenseite dagegen mit einer Textur, die aus einer Datei (z.B. png-Datei) mit enthaltenem Alphakanal stammt, wird nicht nur die angeklickte Seite der Fläche, sondern auch die andere Seite automatisch mit angemalt. Es ist also keine Voreinstellung von Sketchup, sondern der vorhandene oder fehlende Alphakanal der png-Datei, der bewirkt, dass bei der Texturierung einer Flächenseite die andere unangetastet bleibt oder das Spiegelbild der auf der ursprünglichen Seite aufgetragenen Textur verpasst bekommt.

Glücklicherweise lässt sich die Bemalung der auf diese Weise unbeabsichtigt mit texturierten Fläche mit der von Hubert beschriebenen Methode wieder entfernen, ohne dass die beabsichtigte Bemalung ebenfalls verschwindet. Dies gilt für beide Seiten der Fläche: Ist die Fläche doppelseitig mit einer Alphakanal-Textur bemalt, kann man diese sowohl nur auf der Rückseite als auch nur auf der Vorderseite entfernen.

Wenn man dagegen versehentlich durch Bemalung einer "gruppierten" Fläche die gesamte Gruppe beidseitig texturiert hat, ist die Entfärbung einer einzelnen Fläche innerhalb der Gruppe nicht möglich. Man muss die Entfärbung dann wieder auf die Gruppe selbst anwenden, wodurch dann allerdings bei allen Flächen der Gruppe jeweils beide Seiten entfärbt werden.

Schlussfolgerung:
Wenn Deine Textur von Dir bewusst mit Alphakanal verwendet wird, bleibt Dir nichts anderes übrig, als die zu viel bemalten Rückseiten nachträglich wieder zu entfärben. Wenn Du darauf geachtet hast, dass die Sketchup-Vorderseiten bei Deinen Bauteilen stets nach außen zeigen, kannst Du alle Rückseiten der ungruppierten Flächen auf höchster Ebene oder innerhalb einer Gruppe auf einen Schlag zusammen entfärben. Hierbei gehst Du wie folgt vor:

643213781_01Untexturiert.thumb.jpg.edb39e58c3a15be20243cfb765dd0d52.jpg

Als Beispiel habe ich einen geöffneten Quader gewählt, der noch vollständig unbemalt ist. Alle Vorderseiten (weiß) zeigen nach außen und alle Rückseiten (grau) nach innen. Ich habe den Würfel schon einmal vollständig ausgewählt, weshalb seine Flächen (unabhängig von der Vorder- und Rückseite) ein Punktraster zeigen. Als Textur habe ich eine halbtransparente png-Datei (mit Alphakanal) eingelesen, deren Deckkraft durchgängig 50% beträgt.

1920331154_02Texturierungbeidseitig.thumb.jpg.24ed5182b20ef8cbe882f0576240e72b.jpg

Wählt man nun die Textur aus und klickt mit dem Farbeimer auf eine der markierten Würfelflächen, werden alle markierten Flächen mit der Textur beidseitig bemalt.

1636081638_03AuswahlFlchenmitgleicherTextur.thumb.jpg.45599a9b780d370e86bdceb353ee849b.jpg

Ohne im Würfel (hier in der höchsten Ebene ohne Gruppen - man könnte sich aber bei einem anderen Modell auch innerhalb einer (geöffneten) Gruppe befinden) irgendwelche Flächen ausgewählt zu haben klickt man zum Entfernen eine bestimmten Textur von allen Vorder- oder Rückseiten zunächst die Textur mit der rechten Maustaste in der Auswahl aller verwendeten Texturen (im obigen Bild eingerahmt) und anschließend im sich öffnenden Popup-Menü "normal" (mit der linken Maustaste) den Punkt "Auswählen" an.

489804624_04TexturfrVorder-undRckseiten.thumb.jpg.1069d19191025fb8ffc5218b7e4c4725.jpg

Hierdurch werden im Modell alle Flächen, die mit dieser Textur bemalt sind, als ausgewählt gekennzeichnet (Punktraster), und bei den Elementinformationen wird angezeigt, ob es sich bei den ausgewählten Flächen mit dieser Textur um Vorderseiten (links) und/oder Rückseiten (rechts) handelt.

1038853467_05AuswahldereinzuwechselndenTextur.thumb.jpg.8353e93877829bc0d27c932998ef3ebe.jpg

Zum Entfernen der Textur von allen Rückseiten wird das rechte Bildchen angeklickt. Hierdurch öffnet sich ein kleines Fenster, indem alle im Modell momentan verfügbaren Texturen und Farben aufgelistet werden. Hierunter befindet sich im obigen Beispiel auch das Ikon für die Standard-Farben (zur Kennzeichnung ungefärbter Flächen), da ich neben dem Würfel ein kleines ungefärbtes Viereck platziert habe. Wenn es innerhalb des Würfels eine ungefärbte Fläche gegeben hätte, hätte ich dieses Viereck nicht benötigt. Gibt es im Modell keine ungefärbte Fläche, wird auch dieses Standardfarben-Ikon nicht im obigen Auswahlfenster für die Füllungen angezeigt. Klickt man nun auf die mit dem roten Pfeil gekennzeichnete "leere" Füllung, ...

1339610748_06Ergebnis.thumb.jpg.ae8baaa6b83c8f6feedd1652a960a9db.jpg

... wird die Textur von den markierten Rückseiten entfernt. Dies wird nun auch in den Elementinformationen so wiedergespiegelt.

Für die Flächen Deines Modells, die keinen Alphakanal benötigen (die also 100% Deckkraft besitzen sollen), kannst Du Texturen ohne Alphakanal verwenden. Wegen der verlustfreien Kompression empfiehlt sich hierbei ebenfalls das png-Format (das jpg-Format hat zwar eine höhere Kompressionsrate,  komprimiert aber nicht verlustfrei und erzeugt Farb-Artefakte, die sich nicht mehr heraus korrigieren lassen). Soll aus einer png-Datei der (möglicherweise vorhandene) Alphakanal entfernt werden, bietet sich als einfachste Methode das Einlesen der png-Datei in Paint und das anschließende Zurückschreiben an. Mit dieser Datei können dann Sketchup-Flächen wie von mir im letzten Beitrag beschrieben auf Vorder- und Rückseiten getrennt aufgetragen werden.

Viele Grüße
BahnLand

Edited by BahnLand
Link to post
Share on other sites
vor 1 Stunde schrieb BahnLand:

Hallo Walter,

besitzt die png-Datei, die Du zur Texturierung verwendest, einen Alphakanal?

Hallo BahnLand,

erst einmal wieder danke für Deine Hilfestellung, danke auch an Hubert. Die PNG-Dateien werden von mir mit paint.net erstellt, offenbar wird da dann ein Alphakanal beigefügt. Die Farben sollen ja decken, für die Fenster verwende ich dann ein anderes Material (die von Dir zur Verfügung gestellte Fenster.png). Ich habe jetzt mal Deinen Tipp mit Paint befolgt, und tatsächlich wird nur noch eine Seite bemalt. Das bedeutet, dass ich künftig Änderungen zwar mit Paint.net vornehme, aber dann mit Paint die Datei zurücksetze.

Nur gut, dass ich am Anfang nicht gewusst habe, auf was man alles beim erstellen eines Modells achten muss, ich glaube, ich hätte da erst gar keinen Versuch unternommen. Es war ja schon eine Herausforderung, sich mit einer gänzlich unbekannten Software vertraut machen zu müssen, obwohl ich schon fast 30 Jahre mit dem PC arbeite. Immer, wenn ich dann geglaubt hatte, dass ich es jetzt gecheckt hätte, wie es funktioniert, tauchte wieder ein neues Problem auf. Aber dank euerer Hilfestellung war bisher alles lösbar, aber der nächste Lernprozess steht schon an. Denn LOD1 und LOD2 sind derzeit noch die großen Unbekannten, aber damit beschäftige ich mich erst dann, wenn ich meinen A-Teil des GT6 fertig gebaut habe. Einstweilen nochmals herzlichen Dank für die Teilhabe an eueren Erfahrungen.

Walter

Link to post
Share on other sites

Hallo0 Walter,

vor 3 Stunden schrieb Klartexter:

Nur gut, dass ich am Anfang nicht gewusst habe, auf was man alles beim erstellen eines Modells achten muss, ich glaube, ich hätte da erst gar keinen Versuch unternommen.

Umso besser weißt du nun zu schätzen, was andere Modellbauer hier leisten.  :)
Und ich habe das Gefühl, dass da bei dir etwas Gutes entsteht, was den ganzen Aufwand rechtfertigt.

Viele Grüße
Götz

Link to post
Share on other sites
  • 2 weeks later...
Am 8.9.2021 um 19:47 schrieb Goetz:

Hallo0 Walter,

Umso besser weißt du nun zu schätzen, was andere Modellbauer hier leisten.  :)
Und ich habe das Gefühl, dass da bei dir etwas Gutes entsteht, was den ganzen Aufwand rechtfertigt.

Viele Grüße
Götz

Hallo Götz,

das habe ich auch schon vorher geschätzt, nur war mir nicht bewusst, wie viel Arbeit tatsächlich dahinter steckt. Und wie viele Probleme auftauchen, die man so gar nicht erkennen kann. Ich doktere schon eine ganze Zeit an einem Problem herum, bei dem mir BahnLand schon gute Tipps gegeben hat. Aber trotz der Tipps mag es mir noch nicht gelingen, eine Lösung zu finden. Ich möchte gerne den Augsburger GT6 bauen, der aus 3 Modulen besteht. Das Problem ist der Faltenbalg, der die Teile verbindet, BahnLand gab mir den Hinweis mit den Objekten _Coupler0 und _Coupler1, womit ein Teil des Faltenbalgs dann in das andere Fahrzeugteil ragen würde. Denn bei der Kurvenfahrt gibt es bisher eine Lücke, die es in der Realität eben nicht gibt.

Ich habe die Objekte schon mal tiefer ins Fahrzeug gelegt, und im geraden Streckenverlauf ist damit schon eine direkte Verbindung gegeben. Aber in der Kurve, wie das Bild zeigt, eben nicht. Der B-Teil ist zwar nur für Testzwecke erstellt, da wird der Wagenkasten erst gebaut, wenn es mit dem Faltenbalg funktioniert, das nur als Info. Aber zum testen genügt mir das ja schon, dann kann ich eben sehen, ob etwas so funktioniert, wie es soll.

Deshalb meine heutige Frage an die Community: Wo sollte ich etwas ändern, die Bilder zeigen die Coupler-Objekte im A- und im B-Teil, damit keine Lücke in der Kurvenfahrt mehr entsteht? Ich habe es schon mit konischen Verbindungen versucht, aber das war nicht erfolgreich. Sollten die Coupler noch weiter ins Fahrzeuginnere gesetzt werden? Über Tipps würde ich mich freuen, jetzt geht es aber erst mal nach München zum Arztbesuch.

Walter

coupler.jpg

coupler2.jpg

coupler3.jpg

D-A-607-2-1-4-JS13171k.jpg

Link to post
Share on other sites
Am 8.9.2021 um 11:12 schrieb Klartexter:

Die PNG-Dateien werden von mir mit paint.net erstell

Ich brauche auch paint.net

vor 4 Stunden schrieb Klartexter:

womit ein Teil des Faltenbalgs dann in das andere Fahrzeugteil ragen würde. Denn bei der Kurvenfahrt gibt es bisher eine Lücke, die es in der Realität eben nicht gibt.

Ja, das wird ein bisschen rätselhaft, um das gut und glaubwürdig zu machen, ohne dass der faltenbalg im Modell herausragt.
Sie müssen den Faltenbalg jedoch etwas verlängern, damit er im Modell selbst verschwindet, ohne wieder aufzutauchen, wenn das Modell der Biegung folgt.
Das bedeutet, dass sich die Kupplung mehr nach innen bewegen muss. Es besteht keine Verpflichtung, die Kupplung exakt am Rand des Modells zu platzieren.
Im Folgenden habe ich versucht, es in einer SKP-Zeichnung zu erklären.

Sie können den Faltenbalg als eigenständiges Modell bauen, was hilft, das Modell "natürlich" zu drehen. Und dort, wo die Kupplung im faltenbalg Modell platziert ist, baut man dann auch noch ein unsichtbares Drehgestell.

Viele Grüße

balg.thumb.jpg.fba3f096e46622fb08d7d962f50b8d3e.jpg

 

Example.jpg

ein guten beispiel, der doppelstockwagen von @Reinhard

8098044C-9F56-4BF4-AD36-1FC5D47C0F00 (das model)

EE8E8DE9-3694-4B6D-99B0-B0AE190417FD (faltenbalg)

Viele grusse

EDITED

Oder geben Sie jedem Modell ein Stück Balg, bei dem ein Balg etwa einen Millimeter schmaler und niedriger ist als der andere (damit sich die Texturen in MBS nicht überlappen und daher beim Rotieren nicht auffallen) und platzieren Sie die _kuppler auch dort ein bisschen nach drinnen.
ISeh mal die Schwebebahn von @maxwei (es gibt auch andere)

3AD71840-BC5C-411F-A085-076C8E435691

5C13318A-9A17-45E9-A6DD-85B5C51EDE53

4A3C7E38-757F-4F5D-A5AF-7054FD32B9EF

 

Edited by hubert.visschedijk
Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
×
×
  • Create New...