Jump to content

Polygone und LOD -Stufen


Recommended Posts

Hallo an alle,

ich beobachte nicht selten unsere Benutzerstatistik und muß immer wieder feststellen, die Zahl der Benutzer steigt stetig(y). Vielleicht der eine oder andere "Neuer" möchte sich auch aktiv am Modelle- bauen beteiligen. Ich möchte hier nicht auf 3D Max, Blender, oder Sketch Up, usw. eingehen,  sondern was ist zu tun wenn der Modellstudio -Editor mir sagt: reduzieren sie die Anzahl der Polygone, fügen sie eine Detailstufe (LOD) hinzu mit max. 3 Materialien und max. 5000 Polygonen. Hier als Beispiel 2 screenshots: Demo1.thumb.jpg.ad6394ec986435ff4f783eb7dd587508.jpg

Im ersten Bild: das fertige Modell, so wird es jedem Benutzer später im Online Katalog bereitgestellt.

Demo2.thumb.jpg.363c98535e6dd6e9a1ad3d80bd19bd32.jpg

...... und so könnte eine LOD-Stufe zu seinem "Originalmodell" aussehen. Die Anzahl der Polygone sind, in unserem Falle, weit unter der vorgeschriebenen Höchstgrenze. Und wenn dann im Editor das grüne Häkchen, statt dem gelben Dreieck erscheint, hat man nichts falsch gemacht.

Keine Bange : auch wenn beide *x-Dateien gemeinsam 'hochgeladen' werden, wird die LOD_Stufe erst später sichtbar je weiter wir uns von dem Modell entfernen (rauszoomen). 

Dieses als kleiner Crash-Kurs in Sachen Polygone/ LOD-Stufen.

Gruß Karl

 

Link to post
Share on other sites

Hallo Karl,

ein interessantes und wohl auch nicht ganz einfaches Thema für angehende Modellbauer, was du da eröffnet hast.

Den Einfluss der LOD-Stufen kann man sehr deutlich am Beispiel des ICE4 -Mittelwagens erkennen. 

 434005205_Screenshot2021-08-15072244.jpg.d9a6a465e9c1d42ea61484f27a14b163.jpg

Dieser wechselt ab einem gewissen Abstand die Farbe anders als die übrigen Fahrzeuge im Zug. Aus meiner Sicht leider auch viel zu früh. Das liegt wohl an der Textur der LOD-Stufe 3, die nur noch 1 Material zulässt. 

511210450_Screenshot2021-08-15072315.jpg.12a33a8192460dd9936dbfd57ae0c7c6.jpg

Ein nicht allzu schöner Effekt für den tollen Zug, auf den die Modellbauer bei der Erstellung der LOD-Stufen vielleicht auch mehr achten sollten.

1428430751_Screenshot2021-08-15074551.jpg.c27602040fbeb16d73d5e6fc2bf28497.jpg

Auch kann man bei den Informationen zum Modell nicht ablesen, welche LOD-Stufe gerade aktiv ist.  

Nur mal so als kleinen Hinweis. 

VG

Hawkeye   

Link to post
Share on other sites

Hallo Hawkeye,

vor 15 Minuten schrieb Hawkeye:

Auch kann man bei den Informationen zum Modell nicht ablesen, welche LOD-Stufe gerade aktiv ist.  

Ich sehe in den Eigenschaften rechts in der Spalte "3D-Modell" an oberster Stelle "Detailstufe: 1 von 3"
Bedeutet das nicht, dass man aktuell die erste der drei enthaltenen Detailstufen sieht?

Du hast recht. 

Viele Grüße
Götz

Edited by Goetz
Ergänzungen
Link to post
Share on other sites

Hallo,

vor 2 Stunden schrieb Hawkeye:

Dieser wechselt ab einem gewissen Abstand die Farbe anders als die übrigen Fahrzeuge im Zug.

@Reinhard
Kannst du bitte einmal prüfen, ob du das korrigiert bekommst?

vor 2 Stunden schrieb Hawkeye:

Auch kann man bei den Informationen zum Modell nicht ablesen, welche LOD-Stufe gerade aktiv ist. 

Das geht konzeptionell nicht, da spätestens bei mehreren Ansichten unterschiedliche LOD-Stufen gleichzeitig angezeigt werden. Ich werde allerdings den Modell-Editor dahingehend anpassen, dass die entsprechend ausgewählte LOD-Stufe in der Vorschau auch angezeigt wird. Das sollte zumindest dem Modellbauer helfen, einfacher seine Modelle zu prüfen.

Viele Grüße,

Neo

Link to post
Share on other sites

Hallo und guten Abend an alle,

Menschen machen Fehler, ich glaube, daß dies Reinhard nicht mit Absicht so erstellt hat. Der Fehler ist nun mal passiert. Er wird hier sicherlich für Abhilfe sorgen. Auch scheinen mir ein Paar Gleisstücke, im 3. Bild ersichtlich, nicht in Ordnung zu sein. Vielleicht ist die Darstellung nur bei mir so?. 

bleibt gesund

Gruß Karl

 

Link to post
Share on other sites

Hallo Karl,

vor 7 Stunden schrieb brk.schatz:

...,  ich glaube, daß dies Reinhard nicht mit Absicht so erstellt hat.

natürlich hat Reinhard das nicht mit Absicht gemacht, das habe ich ihm ja auch gar nicht  unterstellen wollen. Ich bin ein riesiger Fan von seinen detailgetreuen Modellen.

Hier geht’s ja auch gar nicht um diesen kleinen Fehler in diesem Modell an sich, sondern wie Neo es schon richtig erkannt hat darum, das es für einen Modellbauer wohl doch nicht so einfach ist, die 3 geforderten LOD-Detailstufen unter den von ihm gesetzten Bedingungen zu konstruieren und zu überprüfen. Siehe das von dir erstellte Thema in dem wir uns hier befinden. Neo schafft durch seinen Vorschlag hierfür eine Verbesserung und 10 Modellbauer finden das toll und sinnvoll.  Das war das Ziel meines Beitrages.

Die Teststrecke in der mir das aufgefallen ist, ist auch nicht gerade klein, sonst würde das Programm bei der Darstellung von den Modellen auch gar nicht auf die LOD Stufe 3 umschalten.

Auch sind die Schienen völlig in Ordnung, es fehlt an den von dir erkannten Gleisstücken nur das Schotterbett. Das ist für diese Teststrecke vorläufig auch so beabsichtigt.  

1879675929_Screenshot2021-08-16071258.thumb.jpg.38582c3f9d3179ce519728e9399b5015.jpg

Ich finde es schon merkwürdig, das man sich hier für gut gemeinte positive Kritik, die doch nur zur Verbesserung des Gesamteindrucks des MBS führen soll, noch rechtfertigen muss.

Viele Grüße

Hawkeye

 

Link to post
Share on other sites

Guten Abend,

Am 15.8.2021 um 07:50 schrieb Hawkeye:

Dieser wechselt ab einem gewissen Abstand die Farbe anders als die übrigen Fahrzeuge im Zug.

 

Am 15.8.2021 um 09:55 schrieb Neo:

Kannst du bitte einmal prüfen, ob du das korrigiert bekommst?

 

Am 16.8.2021 um 07:46 schrieb Hawkeye:

natürlich hat Reinhard das nicht mit Absicht gemacht

Hier liegt ein mittelschwerer Fehler in der LOD1 vor, auf den mich auch @BahnLand schon in "meinem" Thread hingewiesen hat. Der Fehler ist nicht so wirklich groß, er liegt lediglich in der fehlerhaften Materialzuweisung.

Das eigentliche Problem bin wohl in diesen Monaten ich. Aus unterschiedlich schweren Gründen komme ich seit Mai so gar nicht mehr zum 3D-MBS und zu Blender. Dieser Zustand wird wohl auch noch eine Weile andauern. Ich hoffe, dass ich etwa zum Jahresende wieder besser einsteigen kann - an meinem Willen dazu fehlt es jedenfalls nicht.

Speziell beim ICE 4 ist es derzeit so, dass ich ihn (nach dem tollen Erfolg des ICE 1) auf die neue Material-Struktur umstelle (Glanz der Außenhaut, Metallic an den Drehgestellen, nur noch 2 Materialien anstatt 3 oder 4) Das mache ich derzeit tatsächlich im Hintergrund. Aber eben sehr sehr langsam, da mir die Zeit komplett fehlt. Im Zuge dieser Material-Umstellung werden auch die Fehler in den LOD behoben.

Alle Freunde des 3D-MBS und speziell meiner Modelle bitte ich also um Entschuldigung für die vorhandenen Fehler - sie werden behoben. Aber hierzu bitte ich euch auch noch um einige Geduld. Ich werde zurückkommen, niemand wünscht sich das wohl mehr, als ich. Aber das "wirkliche Leben" vergönnt mir das eben jetzt noch nicht.

Vielen Dank für euer Verständnis.

Gruß
Reinhard

P.S.:

 

Edited by Reinhard
Link to post
Share on other sites
Am 16.8.2021 um 07:46 schrieb Hawkeye:

Ich finde es schon merkwürdig, das man sich hier für gut gemeinte positive Kritik, die doch nur zur Verbesserung des Gesamteindrucks des MBS führen soll, noch rechtfertigen muss.

Hallo @Hawkeye, du musst dich dafür nicht rechtfertigen. Ganz im Gegenteil! Zumindest ich - und ich denke auch alle anderen Modellbauer - sind dir und euch für Kritik, also für Verbesserungsvorschläge oder für das aufzeigen von Fehlern sehr dankbar. Denn es ist nicht - wie oben angedeutet - schwer für die Modellbauer, die Neuerungen umzusetzen, die wir allesamt auch toll finden. Bei mir (und hier spreche ich erstmal nur für mich) sind diese Fehler (wie oben beschieben am ICE 4) reine Schusseligkeitsfehler. Im Überschwang, ein Modell endlich fertigzustellen, um es euch hier präsentieren zu können, übersieht man dann einfach den einen oder anderen notwendigen Arbeitsschritt.

Da zumindest ich das wohl nie abstellen kann, bin ich den Freunden hier sehr dankbar, die solche Fehler finden und darauf aufmerksam machen. Denn ein gemeinsames Ziel haben wir wohl alle: 3D-MBS soll immer besser werden...

Gruß
Reinhard

Link to post
Share on other sites

Hallo Reinhard,

vor 14 Stunden schrieb Reinhard:

Der Fehler ist nicht so wirklich groß, er liegt lediglich in der fehlerhaften Materialzuweisung.

ich habe die Materialzuweisung korrigiert, sodass die letzte Detailstufe die korrekte Textur verwendet. Damit ist der Fehler behoben und du musst dir keinen Stress bei der Überarbeitung des ICE 4 machen.

Viele Grüße,

Neo

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
×
×
  • Create New...