Jump to content

Neue Beta-Version V7


Recommended Posts

Hallo @Sintbert, hallo @HaNNoveraNer

die richtige Lösung habt ihr von @prinz bekommen. Ich möchte noch ein wenig Aufklärung beisteuern.

Über "Verbindung" bekommt ihr das Element, welches mit dem Objekt verkettet ist.
Das ist beim Signal das Gleis. Haltet den Mauszeiger über das Kettensymbol, um zu sehen, mit welchem Objekt etwas verkettet ist.

1566558522_objectlink.jpg.07dc2e113309d5eac9392f0938b226d0.jpg

Viele Grüße
Götz

Link to post
Share on other sites
  • Replies 444
  • Created
  • Last Reply

Top Posters In This Topic

Top Posters In This Topic

Popular Posts

Hallo, los geht es! Heute ist es endlich soweit und die neue Version V7 steht zum öffentlichen Testen und Ausprobieren bereit. Auf den folgenden Seiten findet ihr einen Schnelleinstieg:

Hallo, ich habe heute wieder ein Update für euch, siehe erster Beitrag für eine Liste der Änderungen. @michellombart Auch wenn es nicht explizit empfohlen wird, Objekte mit der Bodenplatte

Hallo, ich mache heute schon etwas eher Mittag, weshalb es jetzt schon das neue Update gibt . Die Änderungen könnt ihr wie gehabt im ersten Beitrag einsehen. Weiterhin viel Spaß mit V7, es m

Posted Images

Aber ich habe einen Gleiskontakt mit einem Signal verkettet.
Nun möchte ich über den Gleiskontakt und die Verbindung das Signal ansprechen.
Und zwar nicht direkt wie bei Prinz, sondern über die Connection.
Was hat das mit euren beiden Lösungen zu tun?

Edited by HaNNoveraNer
Link to post
Share on other sites

Hallo Thomas,

vor 7 Minuten schrieb HaNNoveraNer:

Aber ich habe einen Gleiskontakt mit einem Signal verkettet.

Nein, du hast ihn nicht verkettet (= Kettensymbol), sondern verlinkt (=Schaltverbindung).
Das ist nicht dasselbe.

Viele Grüße
Götz

Link to post
Share on other sites

Ja, das habe ich auch gerade festgestellt.
Verketten = Connection in Lua = Verbindung in EV ?
Verbinden mit = ?
Die über die Schaltverbindung verbundenen Objekte (hier Signal) kann man dann scheinbar nicht über die EV ansprechen?
Dann bliebe hier nur die Lösung, das Signal in eine Variable im GK einzutragen.

Gruß
Thomas

Edited by HaNNoveraNer
Link to post
Share on other sites

Hallo Thomas,

vor 16 Minuten schrieb HaNNoveraNer:

Verketten = Connection in Lua

Ne, das verkettete Objekt ist über "link" ansprechbar.

Die Schaltverbindung wäre (wie von dir schon richtig vermutet) über "connection" ansprechbar. Aber das läuft bei mir auch ins Leere. Entweder fehlt mir da noch der richtige Durchblick oder es hakt da tatsächlich.   @Neo?

Alternativ kannst du die zugehörige Ampel in einer Objektvariablen im Kontakt hinterlegen. Das weißt du aber sicher. Und ich verstehe, warum du gerne direkt den verschalteten "Partner" identifizieren würdest.

Viele Grüße
Götz

Link to post
Share on other sites
vor 1 Stunde schrieb streit_ross:

wenn der Zug nach dem Passieren des Signals dieses auf 0-Halt stellt.

Hallo zusammen,

Ich löse das so:
jedes gewünschte Signal erhält das Schlagwort "Signal", der zugehörige Gleiskontakt gehört zum Signal und kann deshalb auch geschaltet werden.

In diesem Falle schaltet sich der Gleiskontakt (und damit sein Signal) selbst:
3DMBS_2021_N00862.thumb.jpg.17b5517b4c19221f34c2fc803b1dc121.jpg

Jedes Signal schaltet nach Passieren des Gleiskontaktes auf "Halt". Gut für Blockstrecken und sonstige Fahrstraßen. Man hat auch immer eine definierte Ausgangsstellung für die Signale. Damit hat man einen "Großteil der EV" schon erledigt,

meint Henry

Link to post
Share on other sites

Hallo Henry.

Ja, das funktioniert aber nur bei Signalen mit eigenem Gleiskontakt. Ist aber dafür eine gute Lösung.
Übrigens: Verwendet man Fahrstraßen, werden die Startsignale automatisch bei Zugmitte ohne EV auf Halt zurückgestellt.
Gehört der Gleiskontakt aber nicht zum Signal, wird aber mit diesem verbunden über "Verbinden mit", dann funktioniert diese Lösung nicht.

Edited by HaNNoveraNer
Link to post
Share on other sites

Hallo,

der Unterschied "Verknüpfung" und "Verbindung" wurde ja schon geklärt, hier geht es also um die Verbindungseigenschaften. Tatsächlich gibt es aktuell noch gar keine Möglichkeit, per EV auf die Verbindung eines Gleiskontakts zuzugreifen. Die gab es bisher auch noch nicht einmal für normale Signale. Die Verbindung/Connection-Eigenschaft gibt es nur bei Schaltern (deswegen ist diese Eigenschaft auch nur in der Schalter-Kategorie aufgelistet). Da ein auslösender Gleiskontakt technisch auch ein Schalter sein könnte, wird diese Eigenschaft in der grafischen EV angezeigt.

Ich werde im nächsten Update den Zugriff auf die Verbindung von Gleiskontakten und von Signalen hinzufügen.

Viele Grüße,

Neo

Link to post
Share on other sites

Hallo @Neo,

hier gibt es eine Abweichung,

vergleicht man die Meldungen für Block 2 und Block 3 auf dem Gleisbild, wird die Geschwindigkeit der ausgelesenen Lok unterschiedlich formatiert angezeigt:

3DMBS_2021_N00863.thumb.jpg.684b18e6c8cec5d18bdfc2356d9ef6d5.jpg

meldet Henry

Link to post
Share on other sites

Hallo Henry,

an der Ausgabe von Zahlen in Beschriftungsfeldern hat sich gegenüber alten Versionen nichts geändert, die Formatierung wird von der "Lua-Engine" übernommen, die Zahlen in Strings umwandelt. Das Ergebnis hängt dabei von der tatsächlichen Zahl ab.

Wenn du eine ganz bestimmte Formatierung wünschst, müsstest du mit der Lua-Funktion string.format arbeiten. Alternativ kann ich auch gern eine Formatierungsanweisung in die Aktion einbauen, gleich mit ein paar Vorlagen.

Viele Grüße,

Neo

Link to post
Share on other sites

@Henry

Die Genauigkeit des Ist-Wertes kann bei Berechnungen in der EV erforderlich sein.
Wenn du den Wert für die Textdarstellung "glätten" möchtest, kannst du ihn per Lua umformatieren.

In dieser alten Versuchsanlage findest du ein praktisches Beispiel:  FEF1FE2A-0C15-4263-B0E8-1146C69EC770

Das Prinzip ist:

local Zahl = vehicle.currentSpeedAbs
local Textmuster1 = "%d" -- Dezimalzahl ohne Nachkomma Stellen
local Textmuster2 = "%f.2" -- Dezimalzahl mit Nachkomma Stellen

local Ausgabetext = string.format(Textmuster1, Zahl)

$("Beschriftung").text = Ausgabetext


local bewirkt, dass die einzelnen Bausteine nur temporär innerhalb dieser Funktion erzeugt und beim Verlassen gelöscht werden.
Es ist nicht erforderlich, aber ratsam. 

Die Aufteilung in viele Variablen soll nur dazu dienen, die einzelnen Bausteine lesbar zu machen.

Es funktioniert auch als Einzeiler. Aber der ist nicht so leicht durchschaubar

$("Beschriftung").text = string.format("%d", vehicle.currentSpeedAbs)

 

Eigentlich glaube ich, du weißt das alles.
Aber ich kann dich gerade gut als Projektionsfläche nutzen, um es allgemein zu erklären.

Viele Grüße
Götz

Link to post
Share on other sites
vor 42 Minuten schrieb Neo:

Alternativ kann ich auch gern eine Formatierungsanweisung in die Aktion einbauen, gleich mit ein paar Vorlagen.

Hallo @Neo

ich halte das für sinnvoll, meint

Henry

vor 28 Minuten schrieb Goetz:

Eigentlich glaube ich, du weißt das alles.

:) im Prinzip ja, aber am Detail hakt es sehr oft :/, man kämpft sich voran - aber manchmal klickt es schon im Hinterstübchen -

will sagen - weist du nix - fragen!

Danke !

Link to post
Share on other sites

Hallo @Neo,

beim Starten einer Animation über einen Gleiskontakt wird als mögliches Animations-Objekt(Auslöser) nur der Gleiskontakt angeboten (was natürlich keinen Sinn macht), aber nicht das auslösende Fahrzeug. So bleibt nur der umständliche Weg über eine z.B. im Gleiskontakt hinterlegte Objektvariable. Dies war auch schon einmal in einem früheren Thread erwähnt worden und ich hatte gehofft, dass V7 hier eine Änderung bringt. Vielleicht lässt sich das ja noch in das Update einbauen?

PS: Im übrigen vielen Dank und großes Lob für die V7. Fahrstraßen, Landschaftsbearbeitung, Portale und Depots, super und wirkliche Neuerungen und Verbesserungen.

Viele Grüße

Walter

Edited by walterKY
Korrektur
Link to post
Share on other sites

Hallo @Neo

wenn ich die Cockpit Ansicht über das Eigenschaftsfenster anwähle sehe ich auch die grüne Leitlinie für das Ziel des Kfz.

222.thumb.jpg.09625e967194b511998c64449e59b6c4.jpg

Kann du das bitte noch Ändern ? In der Cockpit Ansicht möchte ich nur die Aussicht geniessen.

Gruß Axel

Link to post
Share on other sites

Hallo @Neo, 

ich habe bei Fahrstraßen 2 Probleme. Ich habe meine Bahnhofsteuerung von V6 mit den Fahrstraßen von V7 ergänzt. Bei der Steuerung V6 wird bei jedem Zug der "Stoppt" der Antrieb ausgeschaltet.

1. Schaltet ein Signal einer Fahrstraße jetzt auf 1-Hp1 oder 2 Hp-2, dann wird der Antrieb nicht automatisch wieder aktiviert.   

158500178_Screenshot2021-09-18133045.thumb.jpg.7c7d743bf24c2ecf808d5c87b5a3b08e.jpg

Ich hatte das so verstanden, das bei Aktivierung einer Fahrstraße auch automatisch der Antrieb eingeschaltet wird, ist das nicht so?  

 

2. Das Signal für die Einfahrt in den Kopfbahnhof ist mit einen Zs3 Geschwindigkeitsanzeiger verbunden, der je nach aktivierter Fahrstraße andere Anzeigen schalten soll.

Anzeige "13" ist zur Kontrolle die Fehlermeldung.  Hier die EV.

 1142343377_Screenshot2021-09-18132846.thumb.jpg.1ae0cbbd58db69ebd3e8d5c0bc317163.jpg

Mir wird aber bei allen Fahrstraßen die Fehlermeldung "13 " angezeigt".955038780_Screenshot2021-09-18132740.thumb.jpg.95ae2a3b3853b96ce3fac41135e75669.jpg

Nur bei Stellung 0-Hp0 wird Zs3 Stellung "aus" richtig angezeigt.

101978430_Screenshot2021-09-18132708.thumb.jpg.46d4553cb8e2f200148e38172b4abacc.jpg 

 

Ich finde nur die Fehler nicht.

Viele Grüße

Hawkeye

Link to post
Share on other sites

Hallo,

vor 2 Stunden schrieb Hawkeye:

Ich hatte das so verstanden, das bei Aktivierung einer Fahrstraße auch automatisch der Antrieb eingeschaltet wird, ist das nicht so?  

nein, der Antrieb wird nicht automatisch eingeschaltet. Generell haben Fahrstraßen keinen direkten Einfluss auf Fahrzeuge. Fahrstraßen schalten nur Weichen und Signale. Die Signale selbst entscheiden dann, ob ein Fahrzeug auf dem Signalkontakt beschleunigt wird. Ein deaktiviertes Fahrzeug wird dadurch aber nicht einfach aktiviert, das müsstest du selber tun. Warum aber deaktivierst du den Antrieb vor einem Signal?

vor 2 Stunden schrieb Hawkeye:

der je nach aktivierter Fahrstraße andere Anzeigen schalten soll.

Anhand der Bilder ist nur schwer einzuschätzen, was bei dir falsch läuft. Du solltest aber bedenken, dass eine Fahrstraße erst dann als aktiv gilt, wenn alle enthaltenen Signale und Weichen in der Zielstellung angekommen sind. Das Ereignis "Signal schaltet" ist daher nicht geeignet, um auf die Aktivierung einer Fahrstraße zu prüfen. Nutze hierfür besser direkt "Fahrstraße wird aktiviert/deaktiviert".

Viele Grüße,

Neo

Link to post
Share on other sites

Hallo @Neo,

danke für Aufklärung. Das trägt doch schon zum Verständnis bei.

vor 7 Minuten schrieb Neo:

Warum aber deaktivierst du den Antrieb vor einem Signal?

Das hat einen (für mich) entscheidenden Grund. 

Ich habe im Bahnhof Gleise, die in beide Richtung Signale haben. Also das Züge auch in der Richtung aus der sie gekommen sind, wieder ausfahren können. Dazu wird der Antrieb bei „Zug stoppt“ deaktiviert und je nach Ausfahrrichtung wird bei Triebzügen das erste Fahrzeug in der entsprechenden Fahrtrichtung automatisch aktiviert. Das hat den Vorteil, das auch bei gekoppelten Triebzügen, diese durch entkoppeln getrennt werden können und nacheinander das Gleis in die gleiche oder verschiedene Richtungen verlassen können, z.B gekoppelte ICE oder S-Bahn Züge.
Werde die EV dann also so anpassen, das nur noch die Antriebe von Zügen auf entsprechend mit Schlagwort definierten Gleisen abgeschaltet werden, dann dürfte das Problem nicht mehr auftreten.

vor 14 Minuten schrieb Neo:

Nutze hierfür besser direkt "Fahrstraße wird aktiviert/deaktiviert".

Danke für den Tip.

Ist dann wohl ein Logik Fehler von mir.

Vielen Dank für die schnelle Antwort,

viele Grüße

Hawkeye

Link to post
Share on other sites

Hallo liebe Leute, folgende Dinge sind mir noch aufgefallen:

-bei dem neuen Strassensystem docken die Straßen beim verlängern nicht an Kreuzungen an. Beim verschieben und untereinander schon.

-temp.thumb.JPG.5c541acccb2c1d1d708951e609b321cb.JPG

-wenn ein Fahrzeug sein Ziel erreicht hat, wird das Ziel ja nicht gelöscht, aber ein 2. Mal findet das Fahrzeug das Ziel nicht. Es muss erneut zugewiesen werden.

temp2.thumb.JPG.0132563e955c6af31b2110b0c146ebfb.JPG

 

-Kann es ausserdem sein, dass ein neues Ziel nicht übernommen wird, wenn es nicht weit genug vom momentanem Standort entfernt ist? Es ist so, ich wollte beim verlassen eines Zielkontakts denselben wieder als neues Ziel einstellen. Das Ziel wird in dem Fall nicht übernommen.

LG Ronald

Edited by RoniHB
Ergänzung
Link to post
Share on other sites

Hallo @Neo, 

zu den Fahrstraßen ist mir noch aufgefallen, das Vorsignale in der Fahrstraße ebenfalls berücksichtigt werden, wenn die Fahrstraße aktualisiert wird! Das hat aber zur Folge, das nach mittigem passieren des Vorsignals durch den Zug, das mit dem Vorsignal verknüpfte Signal auf 0-Hp0 schaltet und der Zug vor dem Hauptsignal anhält.

Hier sollte die Möglichkeit bestehen, das Vorsignal aus der Fahrstraße zu löschen. Geht aber momentan nicht. man muss die Vorsignale vom Gleis trennen, dann die Fahrstraße aktualisieren und danach die Vorsignale wieder an das Gleis setzen. Damit sie nicht in der Fahrstraße auftauchen.

Beabsichtigt sind folgende Wegpunkte: 

1056118702_Screenshot2021-09-19104942.thumb.jpg.006275001c1dfc5099daeb13aa524fe7.jpg

Wird die Fahrstraße danach nochmal aktualisiert, werden die Vorsignale in die Fahrstraße aufgenommen und lassen sich nicht mehr entfernen.

424228354_Screenshot2021-09-19105010.thumb.jpg.702d0739c8c4fa5f5b1b806584cefc73.jpg

Hier sollten die Vorsignale einzeln aus der Fahrstraße gelöscht werden können.319036167_Screenshot2021-09-19105115.thumb.jpg.4ea275e32bb7999bb52d392a7c8d5467.jpg 

Die Folge ist, das bei Überfahren eines Vorsignals das Vorsignal auf "0" schaltet und dadurch auch das verbundene Hauptsignal wieder auf "0-Hp0" geht, bevor der Zug das Hauptsignal verlassen hat.

Viele Grüße

Hawkeye  

Link to post
Share on other sites

ergänzend:

nachdem du die Liste der Wegpunkte übernommen hat, kannst du im folgenden eine Auflistung aller enthaltenen Signale sehen.
Dort kannst du individuell für jedes Signal vorgeben, was im Falle der Aktivierung sowie der Deaktivierung passieren soll:

894417723_VorsignaleinFS.jpg.01072b142d845fc32dcdb5878c7a0d58.jpg

 

Viele Grüße
Götz

Edited by Goetz
Schreibfehler korrigiert
Link to post
Share on other sites

Halo @Roter Brummer, hallo @Goetz,

danke für die schnellen Antworten.

Jetzt hab ich es auch gesehen.

Man steht nur wie ein Ochse vor dem Berg, wenn ein Zug auf ein „grünes“ Signal zufährt und das das Signal plötzlich ohne ersichtlichen Grund auf „rot“ schaltet. Das durch eine Aktualisierung einer Fahrstraße, die durch Einbau einer zusätzlichen Weiche, erforderlich war, auch nachträglich eingebaute Vorsignale in der Fahrstraße dann mit berücksichtigt werden, hatte ich nicht auf dem Schirm. 
Schon gar nicht, das beim Vorbeifahren an einem Vorsignal eine voreingestellte Aktion in der Fahrstraße stattfindet. Das ist neu. Und muß man wissen.

Viele Grüße

Hawkeye

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
×
×
  • Create New...