Jump to content

Neue Beta-Version V7


Recommended Posts

Hallo alle zusammen

@NeoEine frage
Sollte der Straßenabschnitt in diesem Experiment nicht sichtbar sein?
Alles besteht aus unabhängigen Straßenstücken, (spur 0, spur 1, spure 2 usw) von denen jedes seine eigene Position, Höhe und Drehwinkel hat, um schließlich ein Ganzes zu bilden.
Die zentrale Spur, der alte Spline, ist das 3D-Modell.
Das rechte und linke Gleis ist die Straße, die alte virtuelle Fahrspur.
Mache ich hier etwas falsch, sodass nur der erste Teil sichtbar ist?

Hier ist die ID-Nummer. Die Gruppe muss aufgelöst werden, um den bearbeiteten Straßenabschnitt anzuzeigen.

E8B121BF-0A48-4C98-852F-543FBBCB323C

Viele grusse

straat1.thumb.jpg.fe0ae68854f99d631286b38c57460901.jpg

straat2.thumb.jpg.bb5c871075473ddeb4fd94af7b5844d2.jpg

straat3.thumb.jpg.9c441bcd7d66244141821cc6e8d7093b.jpg

straat4.thumb.jpg.1e095b87ece6486071efa7fbddd6ae80.jpg

 

Edited by hubert.visschedijk
Link to post
Share on other sites
  • Replies 444
  • Created
  • Last Reply

Top Posters In This Topic

Top Posters In This Topic

Popular Posts

Hallo, los geht es! Heute ist es endlich soweit und die neue Version V7 steht zum öffentlichen Testen und Ausprobieren bereit. Auf den folgenden Seiten findet ihr einen Schnelleinstieg:

Hallo, ich habe heute wieder ein Update für euch, siehe erster Beitrag für eine Liste der Änderungen. @michellombart Auch wenn es nicht explizit empfohlen wird, Objekte mit der Bodenplatte

Hallo, ich mache heute schon etwas eher Mittag, weshalb es jetzt schon das neue Update gibt . Die Änderungen könnt ihr wie gehabt im ersten Beitrag einsehen. Weiterhin viel Spaß mit V7, es m

Posted Images

Hallo Modellbahnfreunde

Hallo Götz

Ist es ratsam über jedes Gleiskontakt ( nicht Gleiskontakt vom Signal ) über Schlagwort " Signal auf Halt " zusetzen .

Screenshot_11.jpg.1a679fa460b2f47df09b1fcb0934f0f2.jpg

 

Screenshot_7.thumb.jpg.7e22d2f10e9766d91b48744292500080.jpg

Die Gleiskontakte setzen so alle Signale auf Halt , wenn eines der Gleiskontakte " Fahrzeugmitte "betreten wird .

Vielleicht ist hier dann eine Liste/Tabelle wohl ratsam für die Signale in den Bereiche .

 

Die F-Sh ( Formsperrsignale ) ist bis zum F-Hp ( Formhauptsignal ) mit FS ( Fs ) = Fahrstraße ( oder auch Fahrweg ) eingesetzt .

Eine Erleichterung der FS einrichten ohne EV ist wirklich einfacher geworden . Prima für diese Lösung !

Screenshot_8.thumb.jpg.2af00d14be1776780ef303556c420dec.jpg

usw. ......

In der ersten Zeile ist meine Einstellung verloren gegangen , woran es gelegen hat weis ich leider nicht .

Sollte es nochmal passieren , muss ich den Arbeitsschritt mir merken !

 

Hier ein Beispielanlage zum Testen ( Einsatz sind Portale , Depots und Signale ) .

Ich hab die Portale genutzt wegen Aufteilung der Bereiche " Strecke - Vorfeld Weichen zu den Abstellbahnhof - Abstellbahnhof für jedes Gleis zum Depot-Gleis .

 

Vielen Dank für den Rat der Signale " Fahrzeugmitte betreten " Signal auf Halt setzen .

Screenshot_9.thumb.jpg.e2fb7bc096d0247b445c0253cdfb8ae5.jpg

 

Screenshot_10.thumb.jpg.ad02b7a719a21b94b117c74233d72bf7.jpg

Hier sind Formsignale genommen worden ( auch Lichtsignale sind möglich ) .

Screenshot_12.thumb.jpg.6321df45087d8e3ee456e21535268b8b.jpg

 

Viele Grüße 

H:xnS

 

 

Link to post
Share on other sites
Am 14.9.2021 um 18:13 schrieb Goetz:

Du kannst dem Fahrzeug per EV eine negative Geschwindigkeit geben.
Anschließend weist du ihm (in derselben EV) den Platz an der Laderampe als neues Ziel zu:

Hallo Götz, das funktioniert bei mir so nicht. Das FW-Fahrzeug soll rückwärts in die Halle fahren.

LG Ronald

temp.JPG

Link to post
Share on other sites

Hallo,

ich habe die Anlage gerade geladen und einen Effekt den ich mir nicht erklären kann. Wenn ich bei laufender Anlage in der Menüleiste auf Ansicht gehe wird das Menü ständig aus- und eingeblendet (es flackert), aber nur dieses Menü und der Autoverkehr ruckelt. Die anderen Menüs wie Bearbeiten, Katalog usw. werden richtig eingeblendet. Es ist die Version 7.0.2.0.

Link to post
Share on other sites

Hallo @RoniHB

sieht aus, als hätte ich es mir bei meinem Test zu einfach gemacht.
Mein Aufbau war so simpel (nur ein T), dass es vom Umkehrpunkt aus keine Route vorwärts zum Ziel gab.

Ich muss mich morgen mal mehr darin vertiefen.

Viele Grüße und danke für den Hinweis
Götz

Link to post
Share on other sites
vor 16 Minuten schrieb Goetz:

Ich muss mich morgen mal mehr darin vertiefen.

Ja, alles Gut, allerdings konnte ich dein einfaches Beispiel auch nicht nachstellen.

Gute Nacht, bis morgen.
LG Ronald

Link to post
Share on other sites
vor 11 Stunden schrieb RoniHB:

allerdings konnte ich dein einfaches Beispiel auch nicht nachstellen.

Das ist kein Wunder, Roni.

Denn wie ich gerade feststellen muss, hatte ich mich da gepflegt selbst reingelegt.
Es funktioniert nicht. Und ich habe auch noch keine Idee, wie man es nun hinkriegen kann.

Viele Grüße
Götz

Link to post
Share on other sites

Yes.
Rückwärts funktioniert das leider nicht. Schade.
Dann muß man das z.B. so lösen:

Demo Rückwärtsfahren.mbp

Ansonsten müßte @Neo den Anwender bei jedem Ziel die Richtung mit eingeben lassen, die das Fahrzeug
nach Erreichen des Ziels nehmen soll.
Wäre vielleicht auch möglich.

In der Ereignis-Protokollierung für die EV fehlt übrigens noch eine Fehlermeldung oder Warnung, wenn ein Ziel
nicht gesetzt werden kann, weil keine Route gefunden wird!

Edited by HaNNoveraNer
Link to post
Share on other sites

Hallo Roni und wen du einen zweiten Kontakt auf den umkerkontagt legst und den für die andere Richtung 

Und in der Ev bei ersten nur minus wert und beim zweiten den Fahrweg machst 

Da aber kein Fahrzeug oder fast nie von der Straße aus an die Rampe fährt würde ich um das Lager. fahren und dann an die Rampe 

Habe leider nur ein Tablet und man nicht testen😭

 

 

 

 

 

 

 

Edited by aloys63
Link to post
Share on other sites

Hallo Modellbahnfreunde

Hallo Götz

Screenshot_15.thumb.jpg.8484a09d21e4223e6599779519e69437.jpg

 

Warum wiederholt sich die Verzögerung dauerhaft ? 

Wollte bewirken , dass der Taster ( GBS-Baustein-Taster ) einmal schaltet und zwar , wenn der den Durchlauf abgearbeitet hat  .

Es sind z.Zt nur 2 Taster so belegt - siehe Bild !

 

Verlieren der FS ( Fahrstraßen ) Einstellungen , setzt man nach der FS ein weiteren GK ( Gleiskontakt ) ,  nimmt er irgendwann den Punkt des neuen GK. an .

Warum ? 

Muss man die FS noch irgendwie abspeichern ? 

Vorher war alles ok und dann kommt FS muss neu eingestellt werden - keine Fehlermeldung vorher gekommen , wenn Fehler sein sollte .

Was ich auch bemerkt habe , stehen die Weichen nicht richtig der FS , ist eine Herstellung der FS nicht möglich ( Signal zu Signal ) .

 

Vielen Dank für die Hilfe !

Viele Grüße

H:xnS

 

Link to post
Share on other sites

Hallo Hans,

vor einer Stunde schrieb h.w.stein-info:

Warum wiederholt sich die Verzögerung dauerhaft ? 

  • Deine Bedingung ist, dass der Taster aus sein muss.
  • Wenn diese Bedingung nicht erfüllt ist, schaltest du ihn eine Sekunde später an.
  • Das hat zur Folge, dass dieser Schalter nach dem ersten Einschalten im Abstand von einer Sekunde wieder eingeschaltet wird.
    Und wieder (weil die Bedingung erneut nicht erfüllt ist.)
    Und wieder ...

Viele Grüße
Götz

Edited by Goetz
Formatierung
Link to post
Share on other sites

Hallo zusammen,

schade, dass das mit dem rückwärts Ziel anfahren nicht funktioniert, vor allem, weil die Straßenkreuzungen keine Weichenstellungen mehr haben. Man kann also nicht mehr rückwärts in eine Abzweigung fahren (muss man ja auch vielleicht nicht).

Solch eine Lösung, rückwärts irgendwo hineinfahren, in eine Halle oder so, muss, wie bisher, mit virtuellen Spuren und Weichen stellen realisiert werden.

@HaNNoveraNer und @aloys63, vielen Dank für eure Vorschläge, aber in diesem Fall ging es mir explizit um die neue Zielführung bei Straßenfahrzeugen.

vor 8 Stunden schrieb Goetz:

Denn wie ich gerade feststellen muss, hatte ich mich da gepflegt selbst reingelegt.

ja, macht ja nix, es geht schon mal was unter. ;)

 

LG Ronald

Link to post
Share on other sites

Hallo Götz

vor 2 Stunden schrieb Goetz:

Hallo Hans,

  • Deine Bedingung ist, dass der Taster aus sein muss.
  • Wenn diese Bedingung nicht erfüllt ist, schaltest du ihn eine Sekunde später an.
  • Das hat zur Folge, dass dieser Schalter nach dem ersten Einschalten im Abstand von einer Sekunde wieder eingeschaltet wird.
    Und wieder (weil die Bedingung erneut nicht erfüllt ist.)
    Und wieder ...

Viele Grüße
Götz

Soll heißen , falscher Arbeitsschritt - Bedingung wird nie erfüllt !

Ok .

Mit den FS muss ich  nochmal genauer studieren , muss dein Video  ansehen ! (y)

Viele Grüße

H:xnS

Link to post
Share on other sites

Hallo,

Am 18.9.2021 um 19:29 schrieb RoniHB:

bei dem neuen Strassensystem docken die Straßen beim verlängern nicht an Kreuzungen an. Beim verschieben und untereinander schon.

danke für den Hinweis, ich kümmere mich darum.

Am 18.9.2021 um 19:29 schrieb RoniHB:

wenn ein Fahrzeug sein Ziel erreicht hat, wird das Ziel ja nicht gelöscht, aber ein 2. Mal findet das Fahrzeug das Ziel nicht. Es muss erneut zugewiesen werden.

Ein Fahrzeug fährt immer nur auf der vorher festgelegten Route. Sobald es die Route verlässt, verhält sich das Fahrzeug zufällig und findet nicht automatisch zur Route zurück.

Am 18.9.2021 um 19:29 schrieb RoniHB:

Kann es ausserdem sein, dass ein neues Ziel nicht übernommen wird, wenn es nicht weit genug vom momentanem Standort entfernt ist? Es ist so, ich wollte beim verlassen eines Zielkontakts denselben wieder als neues Ziel einstellen. Das Ziel wird in dem Fall nicht übernommen.

Das funktioniert schon, allerdings muss es auch einen Pfad geben, ausgehend von der Blickrichtung des Fahrzeugs, bis zum Ziel (bedenke die maximalen 7 Abzweigungen zwischen zwei Wegpunkten).

Am 19.9.2021 um 14:43 schrieb hubert.visschedijk:

Sollte der Straßenabschnitt in diesem Experiment nicht sichtbar sein?

Es handelt sich hier noch um einen Fehler, der mit dem nächsten Update behoben wird.

@h.w.stein-info
Falls du generelle Fragen zur Planung und Steuerung hast, dann empfiehlt sich ein neues Thema, damit hier die Übersicht nicht verloren geht.

vor 2 Stunden schrieb RoniHB:

schade, dass das mit dem rückwärts Ziel anfahren nicht funktioniert

Das liegt aber nur daran, dass ich diesen Fall bisher nicht berücksichtigt habe :). Auf eine explizite Richtungsangabe würde ich zunächst noch verzichten wollen, in einem ersten Schritt würde ich die letzte Fahrtrichtung für die Wegfindung heran nehmen. Somit hat der Nutzer indirekt Einfluss auf die Richtung.

Viele Grüße,

Neo

Link to post
Share on other sites

Hallo @Neo,

hier noch ein Wunsch zu Fahrstraßen.

In der EV können Fahrstraßen beliebig oder individuell selektiert werden. 1997397617_Screenshot2021-09-21075417.thumb.jpg.3d5146e5367e3ce79ff8bd093e3e7548.jpg

 

Da die Fahrstraßen aber in Kategorien zusammengefasst werden können, wäre es doch schön, wenn hier auch Kategorien ausgewählt werden könnten.

Also in diesem Beispiel nicht nur die einzelne Fahrstraße "Einfahrt Kopfbahnhof Gleis (1)",  sondern die ganze Kategorie "Kopfbahnhof Einfahrt". 

Dann könnte die folgende Meldung in der EV vermieden werden.  

343882702_Screenshot2021-09-21080207.thumb.jpg.eacb36a3b0b4422bd6237e4eee4cb027.jpg

Ist das machbar? 

Viele Grüße

Hawkeye

 

Link to post
Share on other sites

Hallo,

machbar ist das, wird eventuell aber womöglich gar nicht benötigt, da Fahrstraßen noch mit Variablen/Schlagwörter ausgestattet werden, und du so Fahrstraßen auch kategorieübergreifend adressieren kannst.

Viele Grüße,

Neo

Link to post
Share on other sites

Hallo,

vor 2 Minuten schrieb JimKnopf:

kann es sein das in V7 die LOD2 Stufe etwas eher in Kraft tritt als in den Versionen davor

in diesen Bereichen gab es keine Änderungen. Verwendest du die gleichen Grafikeinstellungen wie früher, speziell den Detailgrad?

Viele Grüße,

Neo

Link to post
Share on other sites

Hallo @Neo,

ich bin gerade dabei, einen "wiederverwendbaren" Bahnhofsbaustein zu entwerfen, mit dem "auf einfache" Weise Anlangen mit mehreren Bahnhöfen, die untereinander durch Strecken verbunden sind, aufgebaut werden können sollen. Der Bahnhofsbaustein soll bezüglich der Fahrstraßen und der Ereignissteuerung  soweit wie möglich vorkonfiguriert sein, sodass vom Anwender nur noch die "Verbindungen" zwischen den einzelnen Bausteinen "geschlossen" und konfiguriert werden müssen.

Hierbei sehe ich bei den Fahrstraßen noch folgenden Verbesserungsbedarf:

  1. Wenn ich das Bahnhofsmodul mit fertig eingerichteten Fahrstraßen als Anlage abgespeichert habe und anschließend als Baugruppe in eine andere Anlage einfüge ("Einfügen aus -> Anlage ..."), sind sämtliche Fahrstraßen des eingefügten Bausteins nicht mehr gültig und müssen alle einzeln wieder "neu aufgebaut" werden. Hier würde ich mir wünschen, dass die Fahrstraßen nach dem Einfügen des Bausteins alle gültig sind.
     
  2. Wenn ich anschließend den auf der Anlage eingefügten Baustein komplett kopiere (vervielfältige), besitzt die Kopie keine Fahrstraßen mehr. Diese müssen alle von Hand neu aufgebaut werden. Eine Vervielfältigung "mit Fahrstraßen" ist also nur durch erneutes Einfügen des Bausteins "als Anlage" möglich mit der Konsequenz, dass auch die dazugehörige Ereignissteuerung dupliziert wird und daher nachträglich wieder gelöscht werden muss (diese soll ja nur einmal vorhanden sein und von allen Baustein-Kopien gleichermaßen genutzt werden können). Ich würde mir wünschen, dass dann, wenn eine Gleiskonfiguration mit Fahrstraßen-Kontakten (Signale oder Gleiskontakte) auf der Anlage zum Duplizieren (Copy&Paste) ausgewählt wird, alle "betrofenen" Fahrstraßen automatisch mit dupliziert werden und daher dann ebenfalls in der Liste der Fahrstraßen zusätzlich erscheinen (und gültig sind).
     
  3. Analog zum Punkt 2 würde ich mir dann auch wünschen, dass dann, wenn eine komplette Gleis-Signal-Gleiskontakt-Konfiguration aus der Anlage entfernt wird, betroffene Fahrstraßen automatisch mit gelöscht werden. Denn es gibt ja dann keinen Bezug dieser Fahrstraßen zu irgendwelchen Objekten auf der Anlage mehr.
     
  4. Wird eine komplette Fahrstraßen-Kategorie nicht mehr benötigt, muss man alle darin enthaltenen Fahrstraßen einzeln löschen. Es wäre schön, wenn man hier auch eine komplette Kategorie einschließlich aller enthaltenen Fahrstraßen auf einmal löschen könnte.
     
  5. Dieser Punkt könnte möglicherweise in dieser Beitragsfolge schon genannt worden sein:
    Es wäre schön, wenn man Fahrstraßen auch über die EV dynamisch komplett neu einrichten und wieder entfernen könnte.

Viele Grüße
BahnLand

 

Edited by BahnLand
Link to post
Share on other sites

Hallo BahnLand,

vor 22 Minuten schrieb BahnLand:

sind sämtliche Fahrstraßen des eingefügten Bausteins nicht mehr gültig und müssen alle einzeln wieder "neu aufgebaut" werden.

hast du hierfür ein Beispiel? Bei einem kurzen Test musste eine importierte Fahrstraße nicht neu aufgebaut werden.

vor 31 Minuten schrieb BahnLand:

Ich würde mir wünschen, dass dann, wenn eine Gleiskonfiguration mit Fahrstraßen-Kontakten (Signale oder Gleiskontakte) auf der Anlage zum Duplizieren (Copy&Paste) ausgewählt wird, alle "betrofenen" Fahrstraßen automatisch mit dupliziert werden

Auf ein automatisches Duplizieren und Löschen von Fahrstraßen würde ich zunächst verzichten, das ist schwierig zu konzeptionieren. Das Studio kennt den Begriff einer "Gleiskonfiguration" nicht und man müsste sehr genau aufpassen, wann der Nutzer tatsächlich die gesamte Gruppe dupliziert oder einfach nur Teile davon für andere Zwecke kopiert. Einfacher erscheint mir in diesem Fall das manuelle Löschen der importieren Ereignisse.

vor 32 Minuten schrieb BahnLand:

wenn eine komplette Gleis-Signal-Gleiskontakt-Konfiguration aus der Anlage entfernt wird, betroffene Fahrstraßen automatisch mit gelöscht werden

Selbes Problem wie Punkt 2. Solange es keine explizite Definition einer "Gleis-Signal-Gleiskontakt-Konfiguration" mit expliziter Verknüpfung einer Fahrstraße mit dieser Konfiguration gibt, sehe ich ein automatisches Löschen problematisch. Der User könnte ja Teile der Gleiskonfiguration erneuern wollen, ohne die dazugehörige Fahrstraße löschen zu wollen. Ich denke einfacher ist dafür dein Punkt 4, in dem mit einem Klick alle Fahrstraße einer Kategorie gelöscht werden können.

vor 41 Minuten schrieb BahnLand:

Es wäre schön, wenn man Fahrstraßen auch über die EV dynamisch komplett neu einrichten und wieder entfernen könnte.

Hier gab es von mir die Rückfrage, ob es solche dynamischen Fahrstraßen auch im realen Bahnbetrieb gibt, da ich Bedenken habe, Fahrstraßen per EV zu erzeugen (mit allen Konfigurationsoptionen, die es gibt). Eventuell müssen hier eher andere Mechanismen greifen.

Viele Grüße,

Neo

Link to post
Share on other sites

Hallo @Neo,

vor 41 Minuten schrieb Neo:

hast du hierfür ein Beispiel? Bei einem kurzen Test musste eine importierte Fahrstraße nicht neu aufgebaut werden.

ich habe zur Demonstration folgenden Beispielbaustein als Entwurf veröffentlicht:

1453197171_01Beispielbausten.thumb.jpg.014f394edacb020034731ae31578babb.jpg

3BDB048B-C00D-4D2D-A0DA-348AD71BC8FB

 

1498362880_02leereBodenplatte.thumb.jpg.e7914ece150eb26a87ee9567233aa17f.jpg

Ausgangspunkt für die Demonstration ist eine leere Bodenplatte.

563216028_03Bausteinimportiert.thumb.jpg.be3dd04b60ae192188682c0f9f22cae1.jpg

Hier füge ich nun den Baustein ein. Du hast Recht: Die Fahrstraßen des Bausteins sind hier alle gültig.

879028478_04Bausteinverschoben.thumb.jpg.b9425273cdfba4aba9bf01aae199681c.jpg

Nun verschiebe ich den kompletten Baustein auf der Anlage an einen anderen Ort. Und schwupp: Alle Fahrstraßen sind nun ungültig.

Dieser Vorgang lässt sich beliebig wiederholen:

667789980_052.Bausteineingefgt.thumb.jpg.3ee89016eaf77fb1fbc7c4c5244b8546.jpg

Wird der Baustein ein zweites Mal eingefügt, sind dessen Fahrstraßen zunächst (noch) gültig.

1064866542_062.Bausteinverschoben.thumb.jpg.0cfc586738596fd47978727f7b95004a.jpg

Sobald man aber auch diesen Baustein verschiebt, werden auch diese Fahrstraßen auf ungültig gesetzt.

Es ist schon sehr mühsam, bei jedem Baustein, der auf die Anlage gezogen wird, jede einzelne Fahrstraße von Hand wieder aufbauen zu müssen - zumal es sich hier im ein sehr einfaches Beispiel handelt. Betrachtete man stattdessen beispielsweise einen Bahnhof mit 5 Bahnhofsgleisen und auf jeder Seite zwei Ausfahrten zu verschiedenen Zielbahnhöfen, sind dies in Summe bereits 40 Fahrstraßen die hier von Hand nachjustiert werden müssen: Aus 5 Bahnhofsgleisen jeweils 2 Ausfahrten und 2 Einfahrten auf die beiden Streckenäste, auf beiden Seiten des Bahnhofs (= 20 Ausfahrstraßen und 20 Einfahrstraßen). Ich glaube nicht, dass ein Baustein mit fertig konfigurierten Fahrstraßen von den Anwendern akzeptiert wird, wenn diese nach dem Verschieben des Bausteins alle neu rekonfiguriert werden müssen.

Übrigens:
Verschiebe ich den Baustein, nachdem ich die ungültig gewordenen Fahrstraßen repariert habe, auf der Anlage nochmals an einen anderen Ort, passiert das Gleiche: Alle Fahrstraßen der verschobenen Gleiskonfiguration sind wieder ungültig. Möglicherweise ist nach der Verschiebung der Gleiskonfiguration und Loslassen der Maustaste eine weitere Mausbewegung - eventuell auch über die Fahrstraßen-Anzeige - notwendig, damit dieser Effekt zutage tritt.

Viele Grüße
BahnLand

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
×
×
  • Create New...