Jump to content
Sign in to follow this  
zecke

Da fehlt doch etwas...

Recommended Posts

Hallo zusamen,
 

Ich habe einen Rundbahnhof gebaut, darin  einen BR 101 mit mehreren IT EF09 FS Az 2000 XMPR IC und änlichen als anhänger benutzt.

Blick_auf_den_rundbahnhof.jpg

Im_rundbahnhof.jpg

 

Da gibt es nur ein kleines PROBLEM!

 

Vor_dem_rundbahnhof.jpg

Ich hab euch noch die Anlage in der .zip zur verfügung gestellt.

 

Hoffe auf baldige Antworten,

zecke

 


 

Anlage.zip

Share this post


Link to post
Share on other sites

Das Problem kenne ich. Ich hatte einen ähnlichen Effekt als ich ein Glashaus baute. Die vordere Fensterfläche war sichtbar, die hintere fehlte. Ich kann Dir nicht genau sagen warum das so ist. So seltsam es klingt... Der Effekt entstand immer dann wenn ich meine TGA's die ich für die Fenster benutzte mit Gimp bearbeitete. Ich bekam das Problem in den Griff indem ich die TGA'S in Photoshop lud und, ohne irgend eine Änderung zu machen wieder als TGA speicherte. Scheint so als würde Gimp Bilddateien anders ablegen als Photoshop.

HG
Franz

 

 

Share this post


Link to post
Share on other sites

Hallo Zecke,

es handelt sich hier um ein Darstellungsproblem bei transparenten Objekten. Diese müssen vom 3D-Modellbahn Studio immer "von hinten nach vorne" gezeichnet werden, also die Objekte, die am weitesten von der Kamera entfernt sind zuerst. Die Entfernung wird anhand des Objektmittelpunktes berechnet, und hier entsteht das Problem, wenn das transparente Objekte so groß ist, dass der Mittelpunkt sehr weit weg ist, das Objekte aber trotzdem bis an die Kamera heranragt. Deine einzige Chance ist es, deinen Bahnhof in kleinere Teile zu unterteilen (z.B. Dach und Seitenwände), sodass das Studio die Objekte besser sortieren kann.

Viele Grüße,

Neo

Share this post


Link to post
Share on other sites

Hallo Zecke und Neo,

nach meiner Erfahrung sieht das so aus, als ob dies das "bekannte" PNG-Problem ist:
Wenn ein Objekt, das sich hinter einer halb-transparenten Ebene befindet, eine Textur im PNG-Fornat besitzt, ist die Fläche nicht mehr schtbar (erscheint selbst als durchsichtig). Wenn man für die Textur anstelle der PNG-Datei eine JPG-Datei verwendet, existiert dieses Problrem nicht - die Fläche wird auch hinter einer "Glasscheibe" ordentlich angezeigt. Allerdings muss man bei JPG-Bildern die im Allgemeinen sehr gute Komprimierung (Speicheroptimierung) durch einen starken Qualitätsverlust erkaufen, der vor allem dann entsteht, wenn man im Bild schräge Trennkanten oder gar Schrift darstellen will. Diese werden bei der JPG-Komprimierung "ausgefranst". Da ich dies bei meinen Eurofima-Wagen vermeiden wollte (die Seitenflächen zeigen teilweise ziemlich viele Details), habe ich mich entschlossen, die Außenseiten der Wagen mit PNG-Texturen zu versehen, die zwar (meist) nicht so stark wie JPG-Bilder komprimiert werden, aber dafür die Bildqualität unangetastet lassen. Die Inneneinrichtungen der Eurofima-Wagen musste ich dagegen mit JPG-Texturen versehen, da ich den von Dir gezeigten Effekt auch bei den Fensterglasscheiben der Wagen hatte (siehe hierzu meine ausführliche Beschreibung des Problems hier).

Ich sehe eigentlich für die Behebung des Problems nur 3 Lösungsmöglichkeiten:

  1. Man "lebt mit dem Verschwinden der Wagen-Außenseiten, sobald sie hinter Fensterglas gelangen (nicht so schön für den Anwender),
  2. Ich stelle die Außen-Texturen alle auf das JPG-Format um (würde ich sehr ungern tun, da hierdurch wie oben beschrieben viele Details verloren gehen - vom Arbeitsaufwand bei 66 umzustellenden Fahrzeugen ganz zu schweigen),
  3. Neo versucht den "Verschwinde-Effekt", der ja nur bei Texturen im PNG-Format, aber nicht bei Texturen im JPG-Format auftritt, zu beheben.

Mir ist völlig schleierhaft, wieso JPG-Texturen und PNG-Texturen bei der Wiedergabe hinter (halb-)transparenten Flächen zu unterschiedlichen Ergebnissen führen (Fehler nur beim PNG-Format, nicht aber beim JPG-Format wirksam). Dies kann doch dann eigentlich nichts mit der Überschneidung von transparenten und wiederzugebenden Flächen dahinter zu tun haben. Ich vermute, dass das zweierlei "Baustellen" sind. Oder irre ich mich da?

Viele Grüße
BahnLand

 

Share this post


Link to post
Share on other sites

Hallo BahnLand,

der Unterschied zwischen JPEG und PNG ist der, dass ersteres Format keine Transparenzinformationen enthält, und das Studio die nicht-transparenten Objekte IMMER vor den transparenten Objekten zeichnet. Daher tritt das Problem bei JPEG nicht auf. Du musst deswegen aber nicht auf PNGs verzichten. Versuch diese, solltest du keine Transparenzinformationen nutzen, als 24-Bit abzuspeichern, um den "Transparenzmodus" zu deaktivieren. Auch kannst du JPEGs mit 100% Qualität nutzen. Alternativ nutzt du gleich DDS-Texturen im DXT-1-Format. Eine große Rolle spielt das nicht, denn das Studio konvertiert intern eh alle Texturen nach DXT-1 oder DXT-5, je nachdem ob das Quellformat Transparenzinformationen unterstützt oder nicht.

Viele Grüße,

Neo

Share this post


Link to post
Share on other sites

Hallo Neo,

Danke für die Information. Ich werde es (bei nächster Gelegenheit) ausprobieren.

Viele Grüße
BahnLand

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×