Jump to content

Animated bridges and routes


 Share

Recommended Posts

Hi guys

I have a layout that I built at V6 that never worked properly. I have imported it, stripped all the signals and evens out, and replaced them with routes. The trains now seem to do as expected.

But I have the Bascule Bridge over a ship canal that is supposed to lift  when a ship comes along, but only if there is no train on the bridge (obviously!)... I will sorry about making it lift as and when I get this next bit to work:

The routes across the bridge seem to think it is a vehicle. I cannot get them to clear. I even tried deleting the bridge and putting it back in. Replacing it with track works, so it's not the ships going under. (I've put them on routes too, but that's another problem for another day.)

I'm wondering if there's something I've missed, or if I have to exclude the bridge from the routes and handle trains on it the old fashioned way?

Cheers

Simon

==============

Hallo Leute

Ich habe ein Layout, das ich bei V6 gebaut habe, das nie richtig funktioniert hat. Ich habe es importiert, alle Signale abgezogen und ausgeglichen und durch Routen ersetzt. Die Züge scheinen jetzt wie erwartet zu funktionieren.

Aber ich habe die Klappbrücke über einem Schiffskanal, die sich heben soll, wenn ein Schiff vorbeikommt, aber nur, wenn kein Zug auf der Brücke fährt (offensichtlich!)... das nächste Stück zum Arbeiten:

Die Wege über die Brücke scheinen zu denken, dass es sich um ein Fahrzeug handelt. Ich kann sie nicht zum Löschen bringen. Ich habe sogar versucht, die Brücke zu löschen und wieder einzubauen. Das Ersetzen durch Gleis funktioniert, also gehen die Schiffe nicht unter. (Ich habe sie auch auf Routen gesetzt, aber das ist ein anderes Problem für einen anderen Tag.)

Ich frage mich, ob ich etwas übersehen habe oder ob ich die Brücke von den Strecken ausschließen und Züge auf ihr auf die altmodische Weise abwickeln muss?

Danke schön

Simon

Link to comment
Share on other sites

Pending any information to the contrary, I have assumed that routes simply won't work across this sort of bridge.

So the preceding route still ends at the signal before the bridge, but now the next route starts at a track contact on the other side. A simple event for when the route activates/deactivated changed the signal accordingly.

It works, but it's not particularly elegant.

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...