Jump to content

Metasequoia


HWB
 Share

Recommended Posts

Hallo Hermann,

ich vermute mal, dass es in Deiner x-Datei - sofern sie in "lesbarer" Form erzeugt wurde - eine globale Frame-Definition mit globaler FrameTransformMatrix gibt. Die Datei müsste ziemlich am Anfang etwa so wie nachfolgend gezeigt aussehen (ohne die rote Zeile):

Frame _Global_ {
 FrameTransformMatrix {
  1.000000, 0.000000, 0.000000, 0.000000,
  0.000000, 1.000000, 0.000000, 0.000000,
  0.000000, 0.000000, 1.000000, 0.000000,
  0.000000, 0.000000, 0.000000, 1.000000,
 }    # <frametransformmatrix>
 
 Frame _Scale_1_87 { }    # leerer Frame - nur der Name ist wichtig !!!
 
 Frame Radsatz1 {
            :
            :
            :

Füge dort die rote Zeile ein und schreibe anstelle "1_87" jenen Maßstab hin, in dem Du Dein Modell in der x-Datei erzeugt hast.

Beim obigen Beispiel wurde das Modell in der x-Datei im H0-Maßstab erzeugt. Hast Du Dein Modell im Maßstab 1:1 gezeichnet und so auch in der x-Datei erzeugt, muss der Frame-Name "_Scale_1_1" heßen. Wenn Du das Modell in der x-Datei im Maßstab 1:100 hinterlegt hast, benennst Du denn roten Frame-Namen in "_Scale_1_100" um usw.

Wenn das Modellbahn-Studio diese Zeile in der x-Datei vorfindet, "weiß" das Modellbahn-Studio, in welchem Mastab das Modell übergeben wurde, und wandelt das Modell dann automatisch in den für das Modellbahn-Studio benötigten Maßstab um. Wenn Du dann nach dem Hochladen das Modell auf die Anlage ziehst, sollte das Größenverhältnis passen - unabhängig davon, in welchem Maßstab Du die Anlage baust.

Viele Grüße
BahnLand

 

Edited by BahnLand
_Scale-Syntax korrigiert
Link to comment
Share on other sites

Hallo Hermann,

ich kenne das von Dir verwendete Konstruktionsprogramm nicht. Deshalb kann ich auch nichts über dessen Eigenarten aussagen.

Das (händische) Einfügen der von mir oben dargestellten roten Zeile in die x-Datei sollte aber immer möglich sein, da ich den Programm-Einstellungen in Deinem Screenshot entnehmen konnte, dass eine lesbare x-Datei erzeugt wird. Notfalls musst Du eben mit dem Verkleinerungsfaktor "_Scale_x_y" (Verkleinerung im Maßstab x:y, x und y ganze Zahlen) etwas herumspielen, bis die Größe im Modellbahn-Studio passt.

Ich hatte mich übrigens oben in meinem ersten Beitrag verschrieben: statt "_Scale_1:100" muss es "_Scale_1_100" heißen (Sorry!).

Viele Grüße
BahnLand

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...