Jump to content

MBS Kills Mouse Performance Of On-Top Windows


trevor
 Share

Recommended Posts

Hi Neo...

frabzfunny_43d95b6ce09a51180a7c3c84f8deb96c.jpg

This has irritated me since day 1, so I thought I'd take some time to play with it, and bring it up again as a fairly serious issue since you're working on V4.

With MBS loaded, simulation running or not, if you try to work in another window on the same monitor as MBS, MBS will kill the mouse performance in that window.

Kill the mouse =  mouse is sluggish, hesitates, jumps, and is basically irritatingly unusable..

This is true when the covering window completely obscures the MBS layout graphics panel...
Leave ONE graphic line visible and it seems ok.
Actually if you cover it with 2 windows and leave one pixel in the corner visible it is still ok.

I noticed the following which may be unrelated, but it may also be a clue...

With MBS in 2D mode, set the covering window position so you can still see the margin rulers in MBS.
Now move the mouse around the covering window....
Notice the ruler cursors still move in the MBS window...
Actually.. they still move even when the mouse it out in the clear on the desktop.
(Even as I move it around on THIS window, which is two monitors away ....)
It seems you are monitoring and acting on system mouse movements and not window mouse movements.....
 

Note, It is not a performance issue...
MBS has no apparent effect, or a much much less significant effect, on windows that are on other monitors or that do not obscure the MBS graphics panel.
Similarly, working on the other windows that do NOT cover MBS do not appear to affect the MBS simulation or frame rate.

So I.. literally.. work around it.
But I'm certain most users do not have that luxury.

Best regards

T

 

Edited by trevor
Link to comment
Share on other sites

Hi Trevor,

vor 23 Minuten schrieb trevor:

mouse is sluggish, hesitates, jumps, and is basically irritatingly unusable..

I'm afraid that this behavior is special to your computer, it is the first time that I read about mouse problems. The mouse cursor is managed by the operation system only, and if it starts to jump, than your graphics driver seems to have problems updating the cursor. Try to minimize the MBS window when working in other applications, MBS is throttled down when minimized, this might resolve the problems on your computer.

Kind regards,

Neo

Link to comment
Share on other sites

10 minutes ago, Neo said:

I'm afraid that this behavior is special to your computer

Hmm... that is ALWAYS a possibility I guess.

Mind you.. I do NOT have this issue with other graphics applications.

It would be interesting to hear from other users to see how many folks have the issue but have never noticed / reported it.

Edited by trevor
Link to comment
Share on other sites

Hi Trevor,

vor 7 Minuten schrieb trevor:

Hmm... that is ALWAYS a possibility I guess.

I know that everything which can go wrong will go wrong in an application, but the smoothness of the mouse cursor is nothing an application can control. It is the same with non-privileged applications, which cannot access ressources only an admin can access. So when your mouse acts up because of a heavy load due to a demanding layout loaded in MBS, then something is wrong with your computer/drivers. Especially when the behavior depends on other windows of foreign applications. The only way to affect the mouse cursor is by using very high thread priorities, so that Windows has not enough power to update the mouse, but MBS does not change the default settings.

vor 5 Minuten schrieb trevor:

I do NOT have this issue with other graphics applications.

What kind of graphics applications are they? Do they draw 3D graphics in realtime in a window? Try to enable the compatibility mode in the graphics settings of MBS to see if this has an effect. And make sure that you have enabled vertical synchronisation to not waste too much power.

Kind regards,

Neo

Link to comment
Share on other sites

3 minutes ago, Neo said:

What kind of graphics applications are they? Do they draw 3D graphics in realtime in a window? Try to enable the compatibility mode in the graphics settings of MBS to see if this has an effect. And make sure that you have enabled vertical synchronisation to not waste too much power.

EEP 12.. for instance

As I said it is NOT performance related... it only happens when the MBS graphic panel is obscured

8 minutes ago, trevor said:

to enable the compatibility mode in the graphics settings of MBS to see if this has an effect

None whatsoever

Edited by trevor
Link to comment
Share on other sites

Hi Trevor,

on Windows 7, Aero is enabled when your windows have these transparent glass frames.

I can only give you some general tips. Update all of your drivers, keep Windows up to date (Windows update) and try to temporarily disable other software which might affect the mouse behavior. If this doesn't help, than there is not much I can do for you, in that case MBS is not fully compatible to your computer. This might change with V4 because of heavy optimizations, although mouse and window processing are not touched. Such kind of problems are typically the case of incompatibilities between software and drivers, so there is a good chance that the problem gets resolved just by keeping all software and drivers up to date.

Kind regards,

Neo

Link to comment
Share on other sites

7 minutes ago, Neo said:

so there is a good chance that the problem gets resolved just by keeping all software and drivers up to date.

hmm.. well I am pretty anal about keeping both up-to date.. In fact they are both set to auto-update...

BTW... EEP may NOT be a great example since it stops updating when their window loses focus. Something that you can't do with MBS due to the multi-window setup and the plug-in interface. Though you COULD stop intercepting mouse events at that time.....

But I do have other heavy graphics apps that do not have this issue.

 

Link to comment
Share on other sites

Hi Trevor,

mouse events are only continuously captured in 2D mode because of the rulers, but if I understand you, the problem also occurs in 3D mode, which only processes mouse events when Windows sends them to the application, which cannot be disabled.

vor 28 Minuten schrieb trevor:

But I do have other heavy graphics apps that do not have this issue.

The problem is that each application behaves differently, especially when it comes to 3D rendering, why they are not really comparable (just look at the graphic driver updates when new AAA games are released). Your problems might be solved by just re-ording some graphics code in MBS, but this is based on assumptions and there is no guarantee that this has no negative impact on other users.

I'm sorry that I can't give you a solution, your problem is too special (for now). Perhaps other users have the same problem so that a regularity can be determined.

Kind regards,

Neo

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...