Jump to content

Skriptfehler


Recommended Posts

Hallo zusammen,

ich hab eine kleine Demo-Anlage veröffentlicht:

1A833A78-60F6-4D6F-BB61-235A4C021BAA

Kurzbeschreibung:

Zug stoppt abhängig von Geschwindigkeit und Länge mittig auf dem Gleis. Wenn der Zug stoppt (hier soll später eine Verzögerung eingebaut werden), schaltet das Asig auf Fahrt und der Zug startet wieder. Bei Kontakt vom Zug mit dem Asig, werden die ausgelesenen Daten der Zugeigenschaften wieder gelöscht, damit nach Erweiterung der Anlage nicht durch Zufall ein falscher Zug, dessen Name noch hinterlegt ist, zum Irrläufer wird. Dieser Ablauf scheint zu funktionieren, aber wenn ich die Ereignisprotokollierung aufrufe, wird die Animation durch einen Skriptfehler angehalten, wenn der Zug am Asig ankommt. Die EV mag womöglich nicht, dass die Variable Lokname gelöscht wird, obwohl die Zug seine Zielgeschwindigkeit noch nicht erreicht hat, oder irre ich mich.

Eigentlich wollte ich mit dem Ereignisauslöser Zug/Fahrzeug stoppt arbeiten, aber ich hab leider keinen Bezug zur Variable Lokname herstellen können.

Über Ideen und Anregungen würde ich mich sehr freuen.

Viele Grüße, Berlioz

Link to comment
Share on other sites

Hi Thomas,

o ja, danke. Ich hatte das ganze aus einer anderen Anlage kopiert und das Signal anders benannt ... und weg waren die Einträge. Ist mir gestern leider nicht aufgefallen.

Viele Grüße, Berlioz

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...