Jump to content

Problem nach Update


 Share

Recommended Posts

Hallo Modellbahner,

habe seit dem letzten Update ein Problem. Bei Ereignisse Aktivieren/Deaktivieren werden alle Ereignisse einer Gruppe in der EV Deaktiviert, beim Aktivieren aber nur das Explizit angegebe. Vor dem Update lief die Anlage einwandfrei.

Beispiel:
Lok1 betritt stop1, Deaktiviere Gl1-ICE1
Lok2 betritt stop2, Deaktiviere Gl2-ICE3
Lok3 betritt stop3, Deaktivere GL3-BR99

Lok1, 2 oder 3 betritt das zugehörige Gleis und löst die Aktion aus. Aber leider alle drei. Bei der zugehörigen Aktivierung wird die richtige Aktion ausgeführt.
Auch nach neuem Aufbau der EV das gleiche Ergebniss.

Gruß Fred

Link to comment
Share on other sites

Hallo Fred,

bei einem ersten Test konnte ich dein geschildertes Verhalten nicht reproduzieren. Kannst du mir deine exportierte Anlage, bei der das Problem auftritt, per Mail zuschicken?

Vielen Dank,

Neo

Link to comment
Share on other sites

Hallo Fred,

bist du sicher, dass das Problem erst durch das Update entstand? Ich kann das Verhalten nämlich auch mit der alten Version reproduzieren, und so wie die Ereignisverwaltung aufgebaut ist, handelt es sich hier auch nicht um einen Fehler, sondern um ein gewolltes Verhalten. Die Ereignisgruppen "Entkuppeln-1", "Entkuppeln-3" und "Entkuppeln-4" enthalten im Unterordner "Umlenken/ankoppeln" alle ein Ereignis "Lok zurück", was die jeweilige Gruppe deaktiviert. Nur werden alle 3 Ereignisse immer gleichzeitig ausgelöst, da alle 3 Ereignisse den gleichen Auslöser verwenden, nämlich das Verlassen des Gleises "Lok zurück".

Habe ich etwas übersehen?

Viele Grüße,

Neo

Link to comment
Share on other sites

Hallo Neo,

Aua, da ist mir doch ein dicker fehler unterlaufen. Ich hatte in der alten Version nur mit Gleis1 getestet und direkt nach update auf gleis 3 und 4 kopiert und nur noch angepasst und dann vor lauter Wald die Bäume nicht mehr gesehen. Entschuldige bitte, dass ich versucht habe dir einen Fehler zu unterstellen. Mea culpa...

Aber wie du auch gesehen hast, hatte ich meinen eigenen Fehler bereits abgefangen.

Gruß aus der Sonne, Fred.

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...