Jump to content

Berechnungsfehler oder Rundungsfehler ?


Recommended Posts

Hallo @Neo, 

ich bin gerade dabei zu versuchen eine Oberleitung in einer geneigten Kurve durch Anpassung des durch die Neigung entstehenden seitlichen Versatzes am Pantographen 

auszugleichen. Dabei ist mir etwas Merkwürdiges aufgefallen.

Ausgangssituation: Schienen Radius = 1000 mm Winkel = 180°, also einen Halbbogen

Neigung der Schiene 6,5° => Ein Versatz an der Oberleitung zur Senkrechten von 7,66mm, also ca. 8mm. 

1636203944_OberleitungBild1.jpg.e82fa3167f45bfbe16c1edbde8777601.jpg

Bild 1: Die blaue Linie zeigt den Versatz, den ich gegenüber der Senkrechten ausgleichen möchte.

Bei der Erstellung der Polygone (12 Stück) für den Halbbogen schleicht sich jedoch immer ein Fehler ein.

Bei der Fehlersuche habe ich die Anzahl der Polygone immer weiter bis auf 2 Stück reduziert, 

dabei erstmal auf die Berücksichtigung des geplanten Versatzes verzichtet,

und bei diesen 2 Polygonen (Sehnenlänge also bei 90 ° = 1414,214mm) folgendes festgestellt.

1391503028_OberleitungBild2.thumb.jpg.8b9630be97f5e4411d15212d83e13e03.jpg

Bild 2: Sehne 1 angefügt, trifft den Schnittpunkt am Fluchtstab, passt.

496239263_OberleitungBild3.thumb.jpg.0a8f8d43a7c65c629b22fffcf8db2786.jpg

Bild 3: Winkel der Sehne mit z =-90° ist o.k.

567182025_OberleitungBild4.thumb.jpg.fb276946bcce064ca2b1391d4a06d5a6.jpg

 

Bild 4: Die gleiche Sehne an die andere Seite angefügt, ergibt einen Versatz am Fluchtstab.

 

1367332186_OberleitungBild5.thumb.jpg.188a7efc027e697156c13ef9b61ceb2b.jpg

Bild 5: Versatz am Schnittpunkt, dieser resultiert aus einer nicht beabsichtigten Verdrehung um die z-Achse, siehe Bild 6. 


1093449119_OberleitungBild6.thumb.jpg.f8ae1691a9b4ffb9c5394437105fb00e.jpg

Bild 6. Zeigt eine Verdrehung von 0,41° um die z-Achse, die ich mir nicht erklären kann.

Wenn ich jetzt das "Automatische Einrasten" deaktiviere, den ungewünschten Winkel auf 0° korrigiere und die Sehne "händisch" verschiebe, passt es wieder.  

1994914830_OberleitungBild7.thumb.jpg.518002d7834848128e837fcabd387075.jpg

Bild 7: Versatz bei 2 Polygonen korrigiert 

Bei 12 Polygonen ist das allerdings eine unmögliche Aufgabe diese Korrektur "händisch" durchzuführen.

Woher kommt diese Verdrehung von 0,41° ???

Ist das ein Berechnungsfehler im Programm oder ein Rundungsfehler ?   

Ich finde keine Erklärung. 

Viele Grüße

Hawkeye

 

 

 

Edited by Hawkeye
Vorzeichen korrigiert
Link to post
Share on other sites

Hallo @Neo,

habe gerade hierzu noch festgestellt, das es mit den Längen zusammenhängt.

1716921441_Bild9.thumb.jpg.cfadf5a9ff4b22d6083547582cf142f3.jpg

 

Durch die Winkel 45° bei L =0,01 an den Enden muss sich ein Rechteck ergeben.

geht auch bei Kantenlänge 500, 1000, 1200 mm

Aber ab ca. 1300mm taucht der Winkel 0,41° auf und verhindert, das Schließen des Quadrates.

Viele Grüße 

Hawkeye

Link to post
Share on other sites
vor 1 Stunde schrieb Neo:

hast du eine Beispielanlage für mich?

Hallo @Neo,

sicher, hier die Testanlage.

Die Sehnen der roten Spur betreffen das Gleis.

Die Oberleitung hat den etwas vergrößerten Radius 1000,032 mm mit 12 Sehnen á 259,733 mm Länge und 2 Winkel á 7,4616°

(entspricht für die Oberleitung einer Segmenthöhe von 8mm weniger als dem Kurvenradius der Gleise als Ausgleich der Gleisneigung von 6,5°

für den Pantographen in der Höhe 67,25mm über Gleis]. 

Macht bei 12 Stück einen Winkel von 179,08°, dabei sollte die Sehnenlänge von 2000m = Durchmesser erhalten bleiben. 

Die komplette Oberleitung müsste zum Schluss gruppiert und die Gruppe um einen kleinen Winkel von ca. 0,46° gedreht werden,

um an die Anschlüsse der geraden Oberleitung anzuschließen.

Es passt aber schon bei den roten Spuren als Ersatz für die Gleise mit Sehnenlänge 1414,214 mm nicht.

Viele Grüße

Hawkeye

 

Test Oberleitung in Kurve.mbp

Link to post
Share on other sites

Hallo Hawkeye,

danke für die Beispielanlage. Es handelt sich in diesem Fall um Gleitkomma-Ungenauigkeiten, verursacht durch deine spezielle Spline-Konfiguration. Bei jeder Oberleitung hast du vor und nach dem eigentlichen Spline ein 45°-Stück mit der Länge von 0,01 mm (= 10 Mikrometer) eingefügt.

Solche hohen Genauigkeiten unterstützt das Studio nicht, bei H0 liegt die Genauigkeit eher im Bereich von 0,1 mm. Durch die extrem kurze Länge in Kombination mit dem extrem langen Spline (1414 mm ist um Faktor 140.000 größer) kommt es an den Spline-Grenzen zu Ungenauigkeiten, wodurch die Winkeldifferenzen entstehen.

Du musst auf die kurzen Spline-Stücke leider verzichten.

Viele Grüße,

Neo

Link to post
Share on other sites

Hallo @Neo,

danke für die schnelle Antwort. Ich habe sowas schon vermutet, war mir aber nicht sicher.

Dann muss ich wohl einen anderen Weg finden, um die Oberleitung passend zum Pantographen hinzukriegen.

Viele Grüße,

Hawkeye

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
×
×
  • Create New...