Jump to content

Austausch eines Zuges ( Beispiel ) Schwebebahn Typ


Recommended Posts

Hallo Modellbahnfreunde

Meine Vorstellung ist ein austauscht beim einfahren in das Depot von gleichen Wagennummer ( Beispiel hier die Schwebebahn ) .

Screenshot_3.thumb.jpg.ebdcd3f32368569ae79784d204ef637c.jpg

 

Zur Auswahl finde ich aber NICHT die richtige Lösung , die hier vorgeschlagen wird .

Möglich ist hier .....

1. Erster Zug fährt aus

2. Letzter Zug fährt aus

3. Zufälliger Zug fährt aus

..... all diese Möglichkeiten kann ich so nicht gebrauchen .

 

Vorhaben : Auswechseln ( Austausch ) eines Zuges ( Schwebebahn) mit gleichen Wagennummer .

Zug Typ 15 mit Wagennummer 39 fährt ins Depot gleichzeitig soll der Zug Typ 72 mit Wagennummer 39 aus dem Depot ausfahren ,

Umgekehrt sollte es dann auch so werden ... .

Diese Ausführung will ich im Bereich des Betriebswerks "Abstellung" vornehmen . Eine Weiche sorgt für die Auswechslung zum Depot ( Modell ) oder zur Abstellung ( Selbstbau ) .

 

Beispiel : Betriebswerk " Vohwinkel " 

Screenshot_4.thumb.jpg.5d51994e8ebbe76fe0f244bedc4b5e54.jpg

Grüner Bereich überschneidet sich , so dass es aussieht es wäre eine Verbindung . In Wirklichkeit sind die Enden der Schienen nicht verbunden .

Screenshot_5.thumb.jpg.beb93f88bfce0fa5cd6b959fbb5280f9.jpg

Grüne Pfeile : Einfahrt ins Depot

Rote Pfeile : Ausfahrt aus dem Depot

Blaue Pfeile die offenen Stellen des Gleisende ( Schienenende ) 

 

Jetzt zur meiner Frage :

Wie kann man es mit der EV oder Lua lösen , um das auswechseln des Wagentyps vorzu nehmen .

Beispiel kann hier gern mit Gleisen ausgeführt werden ( Testanlage ) .

 

Das Beispiel könnte man bei Zugverband nutzt bei der Bahn mit anderen Wagen-Nummern.

Probiere immer noch aus , wie ich mit der Steuerung der EV es hinbekomme .

Bei den Typ 72 gab es maximal 28 Wagen und ein Kaiserwagen ( zweiter Kaiserwagen als Ersatzteil ) , bei den Typ 15 sollen es später 40 oder bis 48 Wagen geben .

 

Ein weiteres Vorhaben ist eine Ergänzung als Schablone der Front / Heck des Typs 15 .

Beispiel hier

Screenshot_8.thumb.jpg.42519c8c63b79f142469d8b9a6d505d5.jpg

Front des Typs 15 kopiert ( Screenshot )

 

Screenshot_6.thumb.jpg.1672fc6d0d3c870513d66db50320e88a.jpg

Bearbeitung mit Paint Net neuster Version , die Bereich ( Kariert ) sind mit RAdierung behandelt .

Zusätzlich sind graue Flächen hinzugefügt ( für die Beschritung ) .

 

Screenshot_7.thumb.jpg.f54369e637ed32f4d4e181f55f210e2a.jpg

Diese Vorlage " Schablone " wird auf eine Ebene des 3D-Modellbahn Studio aufgebraucht .

Anschließend wird die Ebene vor den Wagen angepasst und verbunden .

 

Warum ?

Bei den Typ 15 ist keine Tauschtextur vorgesehen , sodass man neue Ziele oder Wagennummer vornehmen kann .

Ein kleiner Nachteil gibt es ....

Wenn der Wagen in Bewegung ist natürlich diese Schablone ohne Einwirkung des Licht der Anlage ( Schattenreflekturen ) .

Durch Leuchten der Ebene ist die Schablone ein festgelegter Bereich ( Nacht müsste die Ebene  Leuchten deaktiviert werden ) !!!!!!

 

Vielleicht kann " maxwei " dieses noch ändern , wenn er wieder ganz Fit ist ( kann lange Dauern - wegen seiner Gesundheit ) .

Wünsche mir , dass er wieder der Alte ist mit neuer Kraft :D(y)

 

Ok ! 

Vielen Dank , wenn einer hier eine Lösung bringen kann .

Viele Grüße 

H:xnS

Meine Gesundheit macht Fortschritte , aber öfters Pausen erstmals .

 

Link to comment
Share on other sites

vor 1 Stunde schrieb h.w.stein-info:

Wie kann man es mit der EV oder Lua lösen , um das auswechseln des Wagentyps vorzu nehmen .

Das siehst du in dieser Beispielanlage:

2030502506_ZugaufKnopfdruck.jpg.20b2592080be8d4a7dc3c451d577ae3e.jpg

Content-ID: A197B196-0219-4B99-A9E5-064A6B285503

Und wenn deine Namen ungeeignet sind, um den Zug Typ 72 mit Wagennummer 39 im Depot zu identifizieren, dann kannst du alternativ auch ein Schlagwort nutzen.

Lua ist notwendig, da du mit der grafischen EV alleine den Einschränkungen unterliegst, die du schon festgestellt hast.

Viele Grüße
Götz

Link to comment
Share on other sites

Hallo Götz

Aha , gut das wir mit Lua arbeiten können .

Gut , mit der Namensgebung kann ich auch Änderungen vornehmen .

 

Ich werde mir die Content-ID ....... ansehen , wie man weiter kommt .

Herzlichen Dank erstmal Görz

Viele Grüße

H:xnS

Link to comment
Share on other sites

Hallo Götz

Ich habe auf meine Anlage dem Beispiel nachgebaut .

Feststellung : Die Taster habe ein Schlagwort " Depot Abruf " .

Den Schienenfahrzeuge sind keine Schlagwörter oder Textfelder eingegeben ( nach Untersuchung ) deines Beispiel .

Mein Aufbau ....

Screenshot_13.thumb.jpg.e06f0423bd9700dd7b404bb267a56a91.jpg

 

Screenshot_14.thumb.jpg.643d19867a2c5c8d217bf6af1a1b30bf.jpg

 

Screenshot_15.thumb.jpg.143dab5037e8b9661285ad0b81bd855e.jpg

 

Hier habe ich natürlich die Schwebebahnfahrzeuge verwendet .- Die Wagen haben die gleiche Bezeichnung wie das Beschriftung .

Taster haben das Schlagwort " Depot Abruf " erhalten ( alle ) .

 

Ich gehe mal davon aus , dass die Bezeichnung des Fahrzeug genutzt wird .

 

Screenshot_16.thumb.jpg.cfac529364df42b974d0826f6c426093.jpg

 

Meine Fahrzeuge habe als Variable "Text" so bekommen , die wird in das Programm ja nicht angesprochen ..... oder ? .

 

Screenshot_17.thumb.jpg.76601a0c79cd8ca4503e9c298dfd858a.jpg

 

In der Programmierung EV mit Lua .... 

 

Screenshot_18.jpg.dda40b7c5f0c8ad1d865e109f14d1b51.jpg

Hier habe ich es nachgeschrieben , wie das Vorbild war - habe aber ein Hindernis gehabt sobald ich auf das $ - Zeichen getippt habe .

Es gab drei Vorschläge , davon habe ich das Objekt gewählt und bestätigt .

 

Hier verstehe  ich nicht , was die eckige Klammer mit 1 aussagt - oder ist das ein L ?

 

Meine Fehlermeldung lautet so :   attempt to index a nil value (field"link")

Screenshot_19.jpg.8c6ba13d0ae0098ff1b21801f7588c1d.jpg

 

Habe auch versucht Lücken (  Abstände ) hinein gebraucht , daran liegt es auch nicht ( Siehe Bild oben ) .

Denke -- das es keine Lücken bzw. Abstände geben darf . 

 

Wer Link fehlt hier in der Bezeichnung (field"link")

 

Der Fehler tritt auf , wenn einer der Taster gedrückt wird , Programm stoppt - Fehler finde ich nicht .

Englisch kann ich kaum noch und nachlesen gibt viele teils andere Ergebnisse ( Übersetzer ) .

 

Hätte das so geklappt , hätte ich über ein Gleiskontakt den entsprechenden Taster ausgeführt oder sogar ohne Taster .

 

Bitte nochmals um Hilfe zur Erklärung !

Viele Grüße

H:xnS

 

Link to comment
Share on other sites

vor 9 Stunden schrieb h.w.stein-info:

Die Taster habe ein Schlagwort " Depot Abruf " ...

und sie haben eine Verknüpfung zu ihrem Beschriftungsfeld:

1037674211_VerknpfungTasterundBeschriftung.thumb.jpg.7747e82553df2e6c0549de1004f9245e.jpg

 

Über diese Verknüpfung findet meine EV den Text zum jeweiligen Taster.
Das passiert in der ersten Zeile meines Skripts.

Weil diese Verknüpfung bei dir fehlt, gibt es kein Feld "link" in deinem Taster. Deshalb ist der Wert des Feldes "link" bei dir "nil" (= nichts)

Du kannst ebenso gut die Zugnamen in einer Variablen hinterlegen und musst dann anstelle der Verknüpfung diese Variable benutzen.

Eine Zahl in eckigen Klammern hinter dem Namen einer Tabelle ist ein Index.
Das ist die Platznummer eines Elements in der Liste.

In der Klammer steht bei mir eine Eins, weil ich das erste Element aus der Liste haben möchte.

Viele Grüße
Götz

 

 

Link to comment
Share on other sites

Hallo Götz

Neuer Versuch !

Test Anlage neu aufgebaut und auch die EV / Lua Programmierung .

Screenshot_20.thumb.jpg.d5e07500435fb3cf8b0de057d3c273a4.jpg

Da Du mir ein Hinweis gabst zu den Taster ( Verknüpfung mit Beschriftungfeld ) hatte es bei der alten Testanlage immer noch nicht geklappt .

Ok , gelöscht !

Neuer Versuch - und jetzt , ja jetzt klappt es wirklich gut , sowie es bei deiner Vorlage-Anlage auch ist .

Eine Taste drücken und es kommt der Zug aus dem Depot heraus gefahren . Sowie die Beschriftung ist , ist der Zug ( in dem Fall der Triebwagen ) mit der gleicher Bezeichnung .

Hatte da nicht geachtet , weil sonst der Wagen ( Zug ) nicht gefundet wird - logisch :o .

 

Jetzt muss ich versuchen , sodass nicht die gleichen Wagen-Nummern auf der Strecke sind .

Gedanke !

Taster sperren durch Bedingung/en ...... Taster kann nicht bedient werden .

 

In deinem Beispiel waren zwei Depots ( als Ein- und Ausfahrt mit Antrieb vorne ) .

So konnte ich es nicht gebrauchen .

Bei der Einfahrt habe ich ein Gleiskontakt verwendet , der den Zug ins Depot ( GRÜN )sendet .

Wird nun einer der Taster gedrückt , wird der entsprechende Zug aus dem Depot ( GRÜN ) heraus .

Die Spitze des Zug ist immer der Antriebwagen , das ist hier sehr wichtig . Im Prinzip ist es immer eine Rundfahrt der Strecke .

Die Weichen in diesem Test dienen als Verbindung zur Strecke und Depot .

 

Ergänzung ; noch nicht ausgeführt :

Mit einen weiteren Gleiskontakt sollen die Runden gezählt werden und dann soll der Zug ins Depot fahren .

Gleiche Wagen-Nr. müssen vermieden werden ( das soll die Bedingung regeln ) .

Von der Strecke ins Werk ( Abstellung ) werden die Wagen geparkt , hat der Zug eine gewisse Parkstellung ausgeführt - erst dann soll er ausgetauscht werden .

Typ 15 gegen Typ 72        oder      Typ 72 gegen Typ 15     ( beide Wagen haben die gleiche Wagen - Nummer ) 

Also hier wird der Typ des Modell ausgewechselt .

 

Meine Versuchsanlage kann ich hier später hochladen - komme noch einige Dinge hinzu !

 

Für Mitleser und Neulinge 

Auch ein Video der Gesamtanlage Strecke Wuppertal mit allen Fahrzeugen ( Schwebebahn ) , ab Version 7 nutzbar !

 

Vielen lieben Dank Götz für dein Beispiel der Testanlage .

Viele Grüße

H:xnS

 

 

 

 

 

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...