Jump to content

Verknüpfte Textfelder nach Neustart verschoben


Recommended Posts

Einen schönen Gruß an alle Forum-Kollegen,

ich habe da ein kleines Problem. Ich habe mir ein paar Straßenbahnen aus dem Online-Katalog geholt und sie dann mit präzise platzierten Textfeldern (Linien Nr. und die Richtungstafel) etwas geändert. Die Textfelder habe dann mit dem jeweiligen Wagen verknüpft. Vor kurzem bemerkte ich, dass nach einem PC-Neustart (auch vom Ruhezustand) sind die Textfelder leicht verschoben. Auf dem Bild sieht man das genau. Man sieht den Wagen von vorne. Von hinten sieht man den Textfeld gar nicht, weil es in dem Wagen "drinnen" verschwunden ist. Anders gesagt, es sieht so aus als ob sich die Straßenbahn leicht nach hinten verschoben hat. Ich hätte gerne gewusst ob man dagegen etwas tun kann, bzw. ob ich vielleicht selber etwas falsch mache.1957044325_Bild2.thumb.jpg.5c07c20897c14ce2ffda88d487b29805.jpg

Ich habe in Forum einen ähnlichen Beitrag vom Februar 2021 gelesen, da waren aber die ganze Züge, bzw. Gleise verschoben.

Ich bin sicher, dass Ihr mir einen guten Tipp gebt und bedanke mich schon bei Euch im Voraus.

Schöne Grüße. Eddie.

 

Bild 1.jpg

Link to post
Share on other sites

Hallo Eddie,

Du verwendest doch die Stuttgarter Straßenbahnen auf Deiner Anlage. Diese unterstützen Tauschtexturen. Lade doch einfach die Textur des originalen Modells als Vorlage herunter, überschreibe dort die Zugzielanzeige (Liniennummer und Zielhaltestelle) und weise dann die so veränderte Textur als Tauschtextur zu. Dann benötigst Du die "angeklebten" Textfelder nicht mehr, und es kommt dann auch nicht mehr zu den von Dir genannten "Verschiebungen".

Viele Grüße
BahnLand

Link to post
Share on other sites

Hallo @BahnLand,

danke Dir für die schnelle Antwort. Ich konnte leider nicht früher antworten. Ich bin gerade dabei es so zu machen wie Du es erklärst hast, aber arbeiten mit Paint ist für mich ein Neuland und ich muss mich damit zuerst vertraut machen. Zuerst habe ich mir Paint.net installiert um vom .dds auf .png zu kommen (hast Du auch mal jemandem empfohlen). Jetzt versuche ich auf normalem Paint die Linien Nr. zu verändern, aber so auf Anhieb klappt es nicht so, wie ich das möchte (die richtige Schriftart, Größe, Hintergrundfarbe, zentrieren...)

Üben, üben und nochmal üben und ich freue mich schon auf meine erste veränderte Straßenbahn. 

So nebenbei gefragt, warum verschieben sich eigentlich die verknüpften Objekte, ein kleiner Systemfehler?

Gruß. Eddie 

Link to post
Share on other sites

Hallo Eddie,

vor 8 Stunden schrieb SY-DU:

So nebenbei gefragt, warum verschieben sich eigentlich die verknüpften Objekte, ein kleiner Systemfehler?

das kann wahrscheinlich nur @Neo beantworten.

Viele Grüße
BahnLand

Link to post
Share on other sites

Hallo @BahnLand

ich möchte mich für Dein Tipp mit den Tauschtexturen bedanken. Das sind meine ersten Versionen:

848588375_33rot.thumb.jpg.5668027b475acf8377f3abd258e903ef.jpg428731166_38rot.thumb.jpg.a2e9ad5c1c3f641b19945ae5e7f924e7.jpg

Ich bin 100% zufrieden und glücklich. Nach kurzem Ausprobieren mit dem dds-png-dds-konvertieren blieb ich dann direkt beim Paint.net und .dds-format.

Es ist zwar eine ziemlich mühsame Angelegenheit, aber man freut sich am Ende um so mehr.

So nebenbei erwähnt, es ist mir auch mit einen Trick gelungen die Weichen der gesamten Strecken so zu programmieren, dass ich die Straßenbahn nur mit der Linien Nr. versehe (ohne die Richtung Angabe) und sie fährt dann die gesamte Strecke hin und zurück ohne jegliche "Weichenkonflikte". Erreicht habe ich das mit den Gleiskontakten und einem zusätzlichen Triebwagen, den ich "Weiche-Trick-Wagen" genannt habe und der mir die Weichenprogrammierung sehr erleichtert hat.

Jetzt ran an die Arbeit, weil ich so in der ersten Etappe ca. 40 Straßenbahnzüge verändern möchte.

Schöne Grüße. Eddie.

Link to post
Share on other sites

Hallo @BahnLand,

ich wende mich nochmal an Dich in der Hoffnung, Du wüsstest wieder die Antwort.

Ich war dabei auch das ältere Modell (BF050E03-9E36-4A18-BCD2-C5AC1251C82E) anders zu beschreiben, da stellte sich heraus, dass von den Feldern für Linien Nr. und Richtungstafel jeweils nur ein aktiv war und das andere ohne Funktion. Auf dem Bild habe ich sie beschrieben:1750477101_Vorlage-Fehlerodersogewollt.thumb.jpg.f017c0e3c1ffb53545cbb0181321fc2c.jpg

Später, wo ich auch die Seiten neu färben wollte sah der Wagen auch nicht so richtig aus. Hier die entsprechenden Bilder:1856106574_Vorlage3.thumb.jpg.89d9d47f4f262fbcd7e12902f1c36ac6.jpg660977121_Vorlage2.thumb.jpg.d6cac1cadd678721f73505334959c4e8.jpg789618821_Vorlage1.thumb.jpg.98ceb9ea006254bce54ca50b060c2f7c.jpg955934772_Vorlage4.thumb.jpg.49fce9ab11a47991cf602dd4b9e3ffd6.jpg

Ich hoffe, dass Du mir weiterhelfen kannst.

Schöne Grüße. Eddie.

 

Link to post
Share on other sites

Hallo Eddie,

Du hast Recht: Bei dem Oldtimer wird für die Zugzielanzeige und die Liniennummer an beiden Enden immer das gleiche Feld aus der Multitextur hergenommen: Für die Zugzielanzeige das obere Feld und für die Liniennummer das linke Feld. Das entsprechende untere bzw. rechte Feld wird tatsächlich nicht verwendet. Ich kann jetzt nicht mehr sagen, ob ich das damals "aus Versehen" so gemacht habe, oder - nachdem das Layout für die Mulitextur bereits festgelegt war - doch bewusst nur jeweils ein Feld verwendet habe. Denn logisch ist dies allemal, weil ja an allen vorgesehenen Stellen immer das aktuelle Ziel und die aktuelle Liniennummer angezeigt werden soll. Trotzdem war ich inkonsequent. Denn beim moderneren T2-Triebwagen (dem mit den runden Fronten) habe ich tatsächlich für die hintere Anzeige jeweils "die anderen" Felder auf der Multitextur verwendet.

Bei den Seitenwänden muss man zwischen dem oberen Teil (direkt unterhalb der Fenster ) und dem Streifen ganz unten unterhalb der Schrammleiste unterscheiden. Der obere Teil wurde meistens für Werbung verwendet, wobei auf beiden Seiten unterschiedliche Werbemotive aufgebracht sein konnten. Deshalb werden hierfür verschiedene Bereiche aus der Multitextur benutzt. Der untere Seitenstreifen ist jedoch entweder einfarbig oder enthält das Logo oder die Bezeichnung der Bahngesellschaft und bestenfalls noch die Fahrzeugnummern. Dies sind jedoch Bezeichnungen, die dann auf beiden Seiten identisch sind. Deshalb habe ich auch hier denselben Bereich aus der Multitextur (den unteren Teil der unteren Seitenwand) hergenommen.

Hier das Ganze noch an an einem Bildbeispiel verdeutlicht:

956196845_Demo-Textur.thumb.jpg.22c07ae3267c7a930fcf3d3ebd2a5101.jpg

Die Textur enthält 2 verschiedene Zugzielanzeigen "Eningen" und "Pfullingen" sowie 2 verschiedene Liniennummern "1" und "2". Ferner gibt es je 2 Motive für die Dachwerbung ("Fschbach" und "Henkel"), die Seitenwerbung ("Doornkaat" und "Martini") und die Gesellschaftsbezeichnung ("WEG" und "Reutlinger Straßenbahnen"). Für die Eckwerbungen habe ich in der Multitextur 4 verschiedene Motive aufgebracht.

Oldtimer-Triebwagen.thumb.jpg.6992cefbf57da74807dcf23aa2ad470f.jpg

Tatsächlich verwendet werden bei der Linien- und Zielanzeige nur die "1" und "Eningen". Genauso steht im unteren Seitenstreifen auf beiden Seiten nur "Reutlinger Straßenbahnen". Die Motive "2", "Pfullingen" und "WEG" werden ignoriert. Dagegen kommen bei der Seitenwerbung, der Dachwerbung und der Eckwerbung alle auf der Multitextur hinterlegten Motive zum Einsatz.

Wenn Du Deine individuellen Texturmotive nach dem hier gezeigten Schema auf der Multitextur platzierst, solltest Du eigentlich "zufriedenstellende Ergebnisse erzielen können.

Viele Grüße
BahnLand

 

Link to post
Share on other sites

Danke Dir sehr.

Ich wollte gerade ins Bett, aber die Antwort schaffe ich noch 🙂.

Mit dem Seitenfärben habe ich doch geschafft, weil ich's erst später das kleine Fenster "Grundfarbe" entdeckt habe und auf einmal war der Rest auch "neu gestrichen".

Ich wusste gar nicht, dass Du die Straßenbahnen erschaffen hast - aller Achtung. 

Wird Du das mit dem "Oldtimer" verbessern können, oder bleibt es so. Auch wenn nicht, ich komme damit gut aus und bin sehr zufrieden. 

Nochmal danke und schöne Grüße. Eddie. 

Link to post
Share on other sites

Hallo Eddie,

momentan möchte ich da nichts ändern, weil sich die Realisierung der "beleuchteten" Teile von V5 nach V6 inkompatibel geändert hat. Um die Straßenbahn mit denselben Beleuchtungseffekten in V6 neu übergeben zu können, müsste ich die Textur modifizieren (separate Texturbereiche für beleuchtete und unbeleuchtete Bauteile) und das Modell entsprechend neu texturieren. Und dafür fehlt mir momentan die Zeit. Ich möchte Dich daher bitten, die genannten "Einschränkungen"  (an beiden Enden identische Zielanzeige und Liniennummer sowie gleiche Bezeichnung der Bahngesellschaft auf beiden Längsseiten unten) in Kauf zu nehmen.

Bitte beachte noch, dass es sich bei diesen Fahrzeugen um Meterspurfahrzeuge handelt. Du solltest für deren Einsatz daher die die Meterspur-Tramgleise verwenden (Kategorie "Schmalspur 1000 mm (Tramgleis)" unter "Vorbild-orientiert"). Du kannst übrigens mit der Ersetzen-Funktion Dein komplettes Normalspur-Gleisset in die Schmalspur umwandeln, ohne dass sich dadurch die vorhandene Gleisgeometrie verändert. Normalspur- und Schmalspur-Straßenbahnen solltest Du nicht gemischt einsetzen. Sonst musst Du die Dreischienengleise verwenden, die Du im selben Verzeichnis wie die Schmalspurgleise findest (bitte rechts- und links-ausgerichtete Varianten unterscheiden!).

Viele Grüße
BahnLand

Link to post
Share on other sites

Hallo @BahnLand,

danke für Deine ausführliche Erklärung. Du hast Recht, es ist schon richtig, dass alle Anzeigetafel die aktuelle Richtung zeigen. Ich wollte es nur für mich so beschreiben, dass zumindest die hintere Anzeige am Triebwagen die andere Richtung zeigt.

Wenn es um die Straßenbahnen geht, ich werde nur Deine 1-Meter Spur verwenden, weil ich sie verändern kann. Alle anderen werde ich löschen. Das die Gleise dabei normalspurig  sind stört mich nicht, weil ich zuerst alle Straßenbahnen erstellen, und die Strecken (Weichen) programmieren will. Ich werde es aber auf jeden Fall tun. Dazu habe ich eine Frage: Ich habe schon sehr viele Gleiskontakte programmiert. Bleibt die Programmierung bei der Umspurung erhalten, oder müsste ich dann alles nochmal neu programmieren?

Schöne Grüße. Eddie. 

Link to post
Share on other sites

Hallo Eddie,

wenn Du die Gleise nicht austauschst, sondern mit der Ersetzen-Funktion umwandelst, bleiben sie als auf der Anlage bereits platzierte Objekt erhalten. Damit hat die Ereignisverwaltung auch nach der Umwandlung weiterhin Zugriff auf die Gleise und Gleiskontakte. Sie funktioniert also weiterhin. Prüfe jedoch nach der Umwandlung, ob alle Gleiskontakte auch tatsächlich noch "Kontakt" haben. Notfalls musst Du sie mit der Maus wieder in die richtige Lage rücken - was der Ereignissteuerung jedoch keinen Abbruch tut. Nur wenn Du die alten Gleise löschst und durch neue Gleise aus dem Online-Katalog ersetzt, funktioniert die Ereignissteuerung nicht mehr, da dann die Verknüpfungen mit den (nun gelöschten) Objekten nicht mehr existiert. Es ist also in diesem Fall zwingend notwendig, dass Du die alten Objekte beibehältst, aber eben mit der Ersetzen-Funktion modifizierst.

Viele Grüße
BahnLand

Link to post
Share on other sites
  • 3 weeks later...

Hallo Eddie,

ich würde gern die Ursache für dein Problem finden, kann das Verhalten allerdings nicht reproduzieren. Hast du eine Beispielanlage für mich, die das Problem zeigt?

Viele Grüße,

Neo

Link to post
Share on other sites

Hallo @Neo,

danke für Deine Interesse. Ich habe zwar meine Anlage auf Anraten von @BahnLand angepasst und nur mit Straßenbahnen bestückt, die ich selber mit Tauschtexturen verändern kann, aber, um Dir das Problem zu zeigen, habe ich nochmal zwei Gothawägen mit den verknüpften Beschriftungen installiert. Das Phänomen kennst Du schon, ein paar Beiträge vorher habe ich es mit den dazugehörigen Bildern mit @BahnLand besprochen.

Meine Anlage habe ich gerade aktualisiert und veröffentlicht. ID - 01E1E744-07B3-4243-BE2B-D7390C23260F.

Schöne Grüße. Eddie.

Link to post
Share on other sites

Hallo Eddi,

danke für die Beispielanlage. Ich sehe zwar die Abstände, wenn ich die Textfelder aber zurückschiebe, die Anlage speichere und wieder neu öffne, befinden sie sich weiterhin am korrigierten Platz. Das ist bei dir anders?

Viele Grüße,

Neo

Link to post
Share on other sites

Hallo @Neo,

also vorher war das so, dass sich die Beschilderungen etwa bei der Hälfte von den Bahnen beim Neustart verschoben haben.

Aber wie gesagt, die Sache hat sich bei mir erledigt, weil ich es jetzt anders mache. Aber vielen Dank nochmal. 

Schöne Grüße. Eddie. 

Link to post
Share on other sites

Hallo @BahnLand,

ich wollte mich für Deinen guten Rat bedanken und Dir zeigen, welche Farben ich für mein System ausgewählt habe:

1.1.thumb.jpg.3e1c2a017fa798646aa96afc746a738a.jpg2.2.thumb.jpg.9073438cb7f6e170ad9df2447b179849.jpg12.1.thumb.jpg.aa27c971e1967cd13fb063408f27d328.jpg16.thumb.jpg.fb01026c2247540d68e63862da016de1.jpg17.thumb.jpg.87f4f4e43b729e04555ed253d292ddfc.jpg18.thumb.jpg.f565e3b0e0db913b8873679cdaeab352.jpg21.2.thumb.jpg.954fedb0845c36208d6e15db72001f43.jpg22.1.thumb.jpg.2abf0b0c819ffc8575b71802cf15c262.jpg

Wenn ich alle Straßenbahnzüge erstelle, komme ich zu der Umspurung, dann programmiere ich die restlichen Weichen. Auf die Logos und verschiedenen Beschreibungen habe ich zuerst bewusst verzichtet, weil ich einfach keine Zeit habe

Schöne Grüße. Eddie.

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
×
×
  • Create New...