Jump to content

Assigning wagons to a locomotive // Waggons einer Lokomotive zuordnen


Recommended Posts

Hi folks.

A fairly straight forward question, I hope, but I would love an answer, please.

I'm using the following event to load all the wagons in a consist into a table list on the loco that's pulling them. Everything works just fine, but on one particular consist I noticed it loaded backwards. (With rather strange results when it came to loading the wagons!)

I think it was because the wagons were the wrong way around, the loco attached to the back of the train and the iteration went the wrong way. So I have flipped the direction of those wagons. What I want to know is, am I correct, or is there some other reason? If the latter, what can I do about it?

Cheers

Simon

Hey Leute.

Eine ziemlich einfache Frage, hoffe ich, aber ich würde mich über eine Antwort freuen, bitte.

Ich verwende das folgende Ereignis, um alle Waggons in einem Verband in eine Tabellenliste auf der Lok zu laden, die sie zieht. Alles funktioniert einwandfrei, aber bei einem bestimmten Zug ist mir aufgefallen, dass er rückwärts geladen wurde. (Mit ziemlich seltsamen Ergebnissen bei der Beladung der Waggons!)

Ich denke, es lag daran, dass die Waggons falsch herum waren, die Lok am Ende des Zuges befestigt war und die Iteration in die falsche Richtung fuhr. Also habe ich die Richtung dieser Wagen umgedreht. Was ich wissen möchte ist, liege ich richtig oder gibt es einen anderen Grund? Wenn letzteres, was kann ich dagegen tun?

Beifall

Simon

Übersetzung über Google Übersetzer

Capture.JPG.9e2f6f7f4523c162770c6cf487d12e02.JPG

 

 

Link to comment
Share on other sites

Hello Simon, 

vor einer Stunde schrieb simonjackson1964:

Everything works just fine, but on one particular consist I noticed it loaded backwards. (With rather strange results when it came to loading the wagons!)

I think it was because the wagons were the wrong way around, the loco attached to the back of the train and the iteration went the wrong way.

it depends on the directions of the first and last vehicle of the train.  There are 4 combinations possible.   V = front view 

1373457721_Screenshot2022-05-03172057.thumb.jpg.841fc9f088bddb612e6833cfd570d89a.jpg

The correct list loading works fine with directions 1. 2. and 3, only 4. gives you a wrong list. 

For more information, and solving the Problem you can look here.  

 

And here.

Regards, 

Hawkeye

Link to comment
Share on other sites

Hi Hawkeye

I had a feeling it was something like that. The wagons should all be pointing the right way from now on, so hopefully I won't have the problem again. I made sure to swap all the wagons to point the right way.

Odd that if I hadn't wanted the shunt loco to be facing the consist. it wouldn't have happened. Also it's good to know thatbI only have to check the wagon at the rear.

Thanks for the assist.

Simon

Link to comment
Share on other sites

Posted (edited)
vor 37 Minuten schrieb simonjackson1964:

The wagons should all be pointing the right way from now on

Hi Simon,
When you read Hawkeye's post once more, you'll find that it's the engines which matter and not the wagons.

Sorry, my mistake. I mistook the wagon at the end for a second engine.

My apologies
Goetz

Edited by Goetz
Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...