Jump to content

Wie steuere ich die automatische Beschleunigung via EV?


Recommended Posts

Hallo, liebe Steuerungs-Experten

Ich habe folgende Situation (vgl. Anhänge): Auf der Strasse verkehren verschiedene Autos, darunter Bus 1. Zu einem früheren Zeitpunkt hat der Bus vor einer Bahnschranke angehalten und das folgende Auto 2 ist dann aufgeschlossen. Nach Oeffnen der Schranke ist der Bus weitergefahren und zieht nun Auto 1 immer nach. Am Kontakt "Bus-Halt" hält der Bus für 3 sec, während andere Autos hier unbeeinflusst mit 50 kmh weiterfahren. Nach dem Bus-Halt fährt dieser mit 80 kmh bis zum Bremskontakt 50, um hier wieder auf die Soll-Geschwindigkeit von 50 kmh abgebremst zu werden. Leider folgt dem Bus aber bis hierhin Auto 2 ebenfalls mit 80 kmh, statt nur mit 50 kmh. Somit bleibt der zu kurze Abstand Bus 1/Auto 2 nach wie vor ungewollt bestehen.

Mir ist bewusst, dass dieses "Nachziehen" von Auto 2 nur unterbrochen werden kann, wenn am Bus-Halt die automatische Beschleunigung kurzzeitig ausgeschaltet und dann später wieder eingeschaltet wird. Aber wie löse ich das mit der EV - ich finde keine entsprechende Aktion/Befehl?

Und was, wenn später Auto 3 auch den Bus 1 über den Bus-Halt ziehen würde?

Kann mir jemand einen Weg aufzeigen, um dieses Problem zu lösen - oder muss ich von Zeit zu Zeit die Fahrzeuge manuell mit grösseren Abständen nachjustieren? Danke für Eure Hilfe

@frenkyboy

Steuerung Beschleunigung.jpg

Beschleunigung steuern.mbp

Link to comment
Share on other sites

Guten Abend, @Phrontistes

Besten Dank für Deinen Tipp - ich habe die EV entsprechend angepasst. Leider nach wie vor kein befriedigendes Ergebnis - der Bus zieht das nächste Fahrzeug immer noch nach; letzteres foutiert sich um die EV-Befehle.

Kannst Du meine EV einmal detailliert anschauen - vielleicht entdeckst Du den Fehler, den ich im Programm mache. Ich füge hier die korrigierte Test-Anlage bei.

Besten Dank im voraus und freundliche Grüsse
@frenkyboy

Steuerung Beschleunigung.jpg

Beschleunigung steuern.mbp

Link to comment
Share on other sites

Versuche es mal mit einem zweiten Kontakt etwa da wo der Buss wieder auf 50km/h ist und aktiviere die Automatische Beschleunigung erst dort wieder.

So wie du es jetzt hast, wird die Automatische Beschleunigung deaktiviert und im gleichen moment wieder aktiviert.

Link to comment
Share on other sites

Hallo @frenkyboy,

vor 1 Stunde schrieb frenkyboy:

Guten Abend, Phrontistes

Nachdem Du den zielführenden Tipp schon von @Sintbert hast und nachdem sich @Hawkeye das schon angeschaut hat, hast Du bestimmt schon die gewünschte Lösung. @Hawkeye ist der Auto-Experte hier.

Bis Du Bündner (RhB im Profilbild) oder jedenfalls Schweizer ("sich foutieren"; viele Nachbarn aus dem großen Kanton werden nicht wissen, was das ist)?

Beste Grüße

Phrontistes

Link to comment
Share on other sites

Guten Tag @Sintbert, @Hawkeye und @Phrontistes

Besten Dank, liebe Freunde , für Eure nützlichen Lösungsvorschläge. Ich kann mich nun beruhigt dem weiteren Ausbau der Anlage widmen, aus welcher ich dieses Teilproblem hier zur Diskussion gestellt habe. Ich schliesse damit das Thema.

Hier noch eine Erklärung: "Foutieren" = "Sich um etwas nicht kümmern" (schweizerisches Hochdeutsch, aus dem Französischen übernommen).

Freundliche Grüsse und Dank

Frenkyboy

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
×
×
  • Create New...