Jump to content

Verknüpfte unsichtbare Objekte


MarkoP
 Share

Recommended Posts

Hallo Neo,

hat man unsichtbare und verknüpfte Objekte auf seiner Anlage und verschiebt das Objekt mit dem das unsichtbare Objekt verknüpft ist wird das unsichtbare Objekt wie ein Rollmaterial mit Antrieb über die Platte bewegt. Diese Bewegung erfolgt in Verschieberichtung soweit ich das beurteilen kann.

Ich habe die Anlage wo es mir aufgefallen ist bereits aufgelöst, werde aber versuchen das Problem noch einem zu rekonstruzieren. Vielleicht kannst du aber auch mal danach schauen.

Gruß
MarkoP

Link to comment
Share on other sites

Hallo MarkoP,

Zitat

Diese Bewegung erfolgt in Verschieberichtung soweit ich das beurteilen kann.

... ja... das ist Sinn und Zweck der Verknüpfung... und ein ausgeblendetes Objekt ist nach wie vor vorhanden.. nur eben nicht sichbar.

... offen gestanden, kann ich nicht ganz verstehen worin Dein Problem liegt... hättest Du gerne, daß mit der "Unsichtbarkeit" die Verknüpfung unwirksam wird?

Gruß

EASY 

Link to comment
Share on other sites

Hallo Easy,

ich denke du hast nicht richtig verstanden was ich meine.
Wenn ich das sichtbare Element verschiebe, verschiebt sich das unsichtbare, verknüpfte Element nicht nur mit, sondern von alleine immer weiter.
Es entfernt sich also von seinem Mutterobjekt und die Verknüpfung verändert den Abstand.

Den gleichen Effekt habe ich bei verknüpftem Rollmaterial. Ich habe den Helikopter aus dem Katalog mal versucht zum Fliegen zu bringen und für diesen horizontele und vertikale Bewegungsstrecken sowie Neigungs- und Drehungsstrecken angelegt. Doch wenn ich den Helikopter (der ja aus verschiedenen animierten und verknüpften Einzelelementen besteht) verschiebe, machen diese verknüpften Elemente sich selbstständig und verändern ihre Position im Verhältnis zum Mutterobjekt. Ich dachte es läge an den Rollmaterialeigenschaften und den Schienen, doch ist es das gleiche Verhalten wie bei den ausgeblendeten Objekten.

Gruß
MarkoP

Link to comment
Share on other sites

Hallo MarkoP

... sorry... war in Deinem ersten Beitrag nicht so ersichtlich, was Du meinst... um einmal beim Beispiel vom Heli zu bleiben...

Du hast eine Strecke (Geise) für den Heli angelegt und wenn Du den Heli (auf dem Gleis?) verschiebst, beginnt er sich zu "zerlegen"?

Wenn ja, ist dies dann, wenn Du den Heli als ganzes (Gruppe) verschiebst, oder wenn Du das Teil verschiebst, das als Rollmaterial definiert ist (ohne die Gruppe aufzulösen) ?

Gruß

EASY

Link to comment
Share on other sites

Hallo Easy,

genau das meine ich. Wenn ich das Rollmaterial als Einzelobjekt verschiebe (also die Gruppe aufgelöst ist) zerlegt sich der Heli.
Bei meinem Schaltpult hat es den gleichen Effekt wenn ich z.B. den Untergrund des Pultes anpacke und verschiebe; einige Objekte (soweit ich sehen konnte die unsichtbar geschalteten) trennen sich vom Untergrund und bewegen sich selbstständig. Interessant dabei, dass sie sich weiterbewegen auch wenn die manuelle Verschiebung abgeschlossen ist. Es sieht fast so aus, als wenn es sich um beschleunigtes Rollmaterial handelt, doch es sind Schalter und Kontrolllampen.

@Neo

Ich werde schauen, dass ich das Schaltpult noch mal so aufgebaut bekomme und dann exportieren. Wäre das ok?

Gruß
MarkoP

Link to comment
Share on other sites

hallo MarkoP,

ich habe mir das mal angeschaut, das problem liegt an den schwarzen tasten die mit den rot/grünen kontrolllampen verknüpft sind und zusätzlich auch noch umgekehrt!

da die rot/grünen kontrolllampen zusätzlich noch in der gruppe des schaltpultes sind, kommt es beim verschieben des schaltpultes zu dem sonderbaren verhalten.

ausprobieren kannst du das in dem du einen schwarzen taster bewegst - dann folgt die kontrollleuchte. solltest du aber eine der kontrollleuchten bewegen kommt es zu dem effekt.

vg quackster

Link to comment
Share on other sites

Hallo Quackster,

danke für die Analyse. Genau das ist die Ursache, doch es löst nicht das Problem. Das Verhalten sollte so ja nicht auftreten. Sobald die Verknüpfung vorhanden ist, benehmen sich die verknüpften Objekte beim Verschieben des Mutterobjektes 'eigensinnig' und halten sich nicht an die Verknüpfung, sondern verselbstständigen sich.

Die Gruppe fasst alle nicht bedienbaren Elemente zusammen. Damit die bedienbaren Elemente beim Verschieben des Schaltpultes mitgenommen werden, ist die Verknüpfung notwendig. Soweit mir aufgefallen ist, passiert dieses Verhalten auch nur wenn mindestens ein verknüpftes Objekt unsichtbar ist. Wenn man vorher alles wieder einblendet, funktioniert es wie es soll - aber das will ich heute Nachmittag/Abend noch mal gegenprüfen. Frage ist auch ob es etwas mit der Gruppierung zu tun hat.

Gruß
MarkoP

P.S. der Kippschalter ist an die Hand/Auto-Lampe verknüpft und die schwarze Anforderungstaste an die grün/rot-Kontrollleuchte.
Wenn die Verknüpfung also richtig funktioniert, müsste es genau umgekehrt als von dir beschrieben sein funktionieren.
Wenn man die grün/rot-Kontrolleuchte oder den Kippschalter bewegt, dürfte sich nichts anderes mitbewegen; wenn man jedoch die Hand/Auto-Lampe bewegt müsste der Kippschalter sich mitbewegen bzw. bei der grün/rot-Kontrolleuchte die schwarze Anforderungstaste.

Link to comment
Share on other sites

hallo MarkoP,

das problem liegt an den schwarzen tasten die mit den rot/grünen kontrolllampen verknüpft sind und zusätzlich auch noch umgekehrt!

z.b.

Schaltpult SBf01_Gl01_Freigabe verknüpft mit Schaltpult SBf01_Gl01_Signalanzeige
Schaltpult SBf01_Gl01_Signalanzeige verknüpft mit Schaltpult SBf01_Gl01_Freigabe

alleine diese kreiselverknüpfung  bewirkt das seltsame verhalten!

ausprobieren kannst du das, in dem du einen schwarzen taster bewegst - dann folgt die kontrollleuchte. solltest du aber oder eine der kontrollleuchten bewegs, dann kommt es auch zu dem effekt. (das hatte ich in meinem ersten beitrag falsch dagestellt, da durch probieren meiner seits änderungen vorgenommen wurden)

weil die rot/grünen kontrolllampen zusätzlich noch in der gruppe des schaltpultes sind, kommt es beim verschieben des schaltpultes ebenfalls zu dem sonderbaren verhalten, da die signalanzeige ebenfalls bewegt wird.

diese effekt ist sehr einfach aufzubauen: zwei objekte wechselseitig verknüpfen, eines davon bewegen und schon geht die fahrt los.

 

vg quackster

Link to comment
Share on other sites

Hallo,

quackster hat das Problem korrekt erkannt, gegenseitige Verknüpfungen sind nicht möglich. Ich werde hier eine Überprüfung einbauen und dafür sorgen, dass es nicht mehr zu solchen automatischen Bewegungen kommt. Einen Zusammenhang mit unsichtbaren Objekten kann ich im Moment nicht erkennen. Das Problem tritt auch bei sichtbaren Objekten auf.

@Marko
Die Frage bleibt aber, warum du die Signalanzeiger mit den entsprechenden Freigabe-Tasten und umgekehrt verknüpft hast? Eine Verknüpfung würde hier ja ausreichen, um die Objekte alle beieinander zu halten.

Viele Grüße,

Neo

Link to comment
Share on other sites

Hallo Neo,

Zitat

Eine Verknüpfung würde hier ja ausreichen, um die Objekte alle beieinander zu halten...

... mein Erfahrungswert ist schon etwas älter, aber als ich (noch im alten EP) erstmalig mit Verknüpfungen gearbeitet habe, habe ich auch erst einmal diesen "Fehler" gemacht... 

... ich wollte 2 Objekte "zusammenhalten"... nur bei der Verknüpfung folgt A zwar B aber B folgt nicht A... da kommt man schon mal auf den Gedanken die Verknüpfung "doppelt" zu setzen, wenn man die Objekte einzeln bewegt...

Gruß

EASY

Link to comment
Share on other sites

@Quackster, NEO, Easy

irgendwie hat sich da ein Fehler eingeschlichen, ich habe keine rekursive Verknüpfung erstellt.
Keine Ahnung wie das zustande kommt, ist jedenfalls nicht bewusst gemacht.

Wie schon mal geschrieben habe ich lediglich die Kippschalter an die Hand/Auto-Lampe verknüpft und die schwarze Anforderungstaste an die grün/rot-Kontrollleuchte verknüpft. Anschließend alles mit einem Rahmen markiert, zusätzlich die schwarze Bodenplatte angeklickt damit sie ebenfalls markiert ist und abschließend alle Kippschalter und Anforderungstasten aus der Markierung rausgenommen und dann eine Gruppe davon erstellt. Dadurch sind die Kippschalter und Anforderungstasten mit Elementen innerhalb der Gruppe "Schaltpult SBf01" verknüpft, gehören aber nicht zur Gruppe und sind bedienbar.

Ich wollte sie bewusst nicht mit der Gruppe selbst verknüpfen, da sie dann nicht bedienbar wären und diese Verknüpfung sich bei Auflösen der Gruppe ja auch auflösen würde. Ich habe also definitiv keine rekursive Verknüpfung erstellt. Kann mir aktuell nur vorstellen, dass es mit der Erstellung der Gruppe zu igrentwelchen Problemen gekommen ist.

Mal sehen ob ich das irgendwie reproduzieren kann.

Link to comment
Share on other sites

Ich habe gerade mal testweise die rekursiven Verknüpfungen gelöscht. War auch nur bei den Anforderungstasten und den Signalanzeigern so. Die Automatikschalter und Automatikanzeiger waren nur einfach verknüpft so wie sie sollten.

Der Effekt trat nicht mehr auf. Bleibt also zu klären wie es zu dieser Doppel-Verknüpfung gekommen ist.

Gruß
MarkoP

Link to comment
Share on other sites

Hallo Marko,

Zitat

Bleibt also zu klären wie es zu dieser Doppel-Verknüpfung gekommen ist.

das lässt sich wahrscheinlich im Nachhinein nicht mehr klären, aber ich werde wie gesagt einen Hinweis einbauen, der bei gegenseitigen Verknüpfungen angezeigt wird.

Viele Grüße,

Neo

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...