Jump to content

Problem Modellbau / Sketchup / Multitextur


Recommended Posts

Guten Abend,
anscheinend bin ich mal wieder zu dumm.
Ich versuche mich gerade mal mit Multitexturen. In Sketchup sieht alles ganz gut (für mich, bestimmt nicht für den innovativen Modellbauer).
In MBS sind Teile des Modells korrekt dargestellt, manche Teile fehlen, (ein paar habe ich gefunden, da waren die Vorder- und Rückseite vertauscht).
Wieder andere sind von der Textur vollkommen verzerrt.In Sketschup  sind fast alles Komponenten.

So sieht es in Sketchup aus.                                                   So in MBS

 

In MBS der hintere Teil ist mit Komponenten bearbeitet. Da fehlen dann auch Teile obwohl m.E. die Textur richtig aufgebracht wurde.
Im vorderen Bild sind alle Komponenten, Gruppen in Einzelteile aufgelöst.
Da sind dann zwar alle Teile da, aber die Verzerrung ist geblieben.

Wenn ich dann in Sketchup bei den Einzelelementen die Textur neu aufbringe dann sieht es in MBS wieder korrekt aus.
Würde mir nicht gefallen, wenn ich alles auf Einzelelemente aufbringen müßte, denn dann wäre ich wahrscheinlich Weihnachten 2020 noch nicht fertig.

Ich würde Euch ja gerne auch die Sketchup Datei bereitstellen, aber das Teil überschreitet leider (auch gezippt) die 4MB Grenze.
Ich benutze Sketchup 2017 und DirectX-Exporter V3.
 

Ich hoffe jemand hat eine Idee wo ich da Mist gemacht habe.

Viele Grüße
Jochen

Hm, irgenwie hat es mit den Bildern nicht geklappt.
Hier als Datei

 

Dom_Fehler.jpg

Dom_Sketchup.jpg

Edited by Jochen
Bilder nachgeladen
Link to comment
Share on other sites

Hallo Jochen,

die nicht angezeigten Flächen können von einem kopierten oder gespiegelten Bauteil stammen, deren Koordinaten nach dem Exportieren vom MBS V4 etwas seltsam interpretiert werden. Hier hilft nur Einzelkopierung und Umbenennung. Die Richtung der Normalen(sichtbare Seiten) müssen in jedem Fall vor dem Export alle überprüft werden. Etwas Arbeit, aber ein Muss.

Die Verzerrungen können von nicht verwendeten Scheitelpunkten stammen, tippe aber im obigen Fall eher auf ein Flächenmap, dass du bei nicht rechteckigen Flächen nicht verwenden kannst. Hier sollte ein Vertex-UV-Mapping Abhilfe schaffen.

vor 14 Stunden schrieb Jochen:

Wenn ich dann in Sketchup bei den Einzelelementen die Textur neu aufbringe dann sieht es in MBS wieder korrekt aus.Würde mir nicht gefallen, wenn ich alles auf Einzelelemente aufbringen müßte, denn dann wäre ich wahrscheinlich Weihnachten 2020 noch nicht fertig.

Gut Ding will eben Weile haben, ich baue an einer Lok so zwischen 4-6 Wochen. Alles aus einzelnen Flächen zusammengesetzt, immer wieder ins MBS exportiert und geprüft, um dann erst weiter zu machen. Und trotzdem tauchen am Ende immer noch kleine Fehler auf, denn bei einem Modell mit über 50.000 Polys sieht man manchmal den Wald vor lauter Bäumen nicht.

Gruß Seehund

Link to comment
Share on other sites

Hallo @seehund

vielen Dank das war's. Die fehlenden Teile waren von mir gespiegelt wurden und dann habe ich teilweise mit den Gespiegelten weitergearbeitet.
Die Verzerrungen waren wohl fehlende Kanten, die auf einem anderen (ausgeblendeten) Layer lagen.

Und das mit der Zeit ist nicht so tragisch. Der Kölner Dom hat ja auch ein paar Jahrhunderte zur Fertigstellung gebraucht.
 und so lange möchte ich nicht daran basteln. :-) Aber ich war so froh dass  ich zum ersten Mal was halbwegs Ansehbares mit einer Multitextur in Sketchup hinbekommen habe, das mir meine wenigen verbliebenden Haare zu Berge standen, als ich das Ergebnis in MBS sah. :-) Dann kann ich ja jetzt mich mal an die Türme wagen.
Übrigens meine Hochachtung für Euch Modellbauer. Manchmal starte ich MBS und sehe mir einfach nur Modelle an und staune und erfreue mich daran.

Viele Grüße
Jochen

Edited by Jochen
Link to comment
Share on other sites

vor 21 Stunden schrieb schlagerfuzzi1:

hallo jochen,

ich kann dir zwar leider nicht behilflich sein, :(aber mir gefällt dein Modell(y)... extra gefällt mir... gruß schlagerfuzzi

Hallo @Schlagerfuzzi

vielen Dank, das hilft es weiter zu versuchen

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...