Jump to content

Konflikt zwischen Anlagen "Ablaufberg" und "Ablaufberg V4"


BahnLand
 Share

Recommended Posts

Hallo Neo,

mit ist heute etwas "Seltsames" passiert, aufgrunddessen nun meine ursprüngliche (noch aus V3 stammende) Veröffentlichung der Anlage "Ablaufberg" im Online-Katalog V4 verschwunden ist:

Da die Anlage "Ablaufberg" aufgrund der nicht mehr möglichen Fahrweg-Sperrung bei Kreuzungen nicht mehr funktioniert, wollte ich sie nun an die V4-Gegebenheiten anpassen. Dazu habe ich sie unter dem abweichenden Namen "Ablaufberg V4" in "meinem" (Benutzer-)Katalog als Duplikat abgespeichert. Etwas später sah ich in dem zughörigen Katalogeintrag das gelbe Warndreireck, das besagt, dass die damit markierte Anlage gegenüber der bisherigen Veröffentlichung modifiziert sei. Dabei hatte ich sie nur abgespeichert, aber nie veröffentlicht. Ich wollte nun den "vermeintlichen" öffentlichen Inhalt der Anlage wiederherstellen, indem ich die Anlage vom Online-Katalog "neu herunterladen" wollte. Dies wurde mit der Meldung, dass die Anlage bereits in einer anderen Kategorie vorhanden sei, abgelehnt. Da ich die Anlage also weder aus dem Online-Katalog (in vermeintlich dort vorhandener Form) wiederherstellen konnte, noch sie explizit im Online-Katalog veröffentlichen wollte, woilte ich die vermeintliche Veröffentlichung zurückziehen, wobei ich die Warnung erhielt, dass damit auch alle dazugehörenden "Statistik-Angaben" (wie z.B. die Anzahl der vorhandenen "Gefällt-mir"-Klicks) gelöscht würden. Nach der Bestätigung für die "Rücknahme" der Veröffentlichung war zwar wie erwartet das gelbe Warndreieck weg (die Anlage wurde nicht mehr als "veröffentlcht" angezeigt). Aber auch meine Original-Anlage "Ablaufberg"  ist jetzt nicht mehr "veröffentlicht", obwohl sie es zuvor definitiv noch war!

Da ich es nicht glauben wollte, dass meine orginale Anlage "Ablaufberg" im öffentlichen Online-Katalog nicht mehr vorhanden sein sollte, habe ich versucht, die Anlage mit verschiedenen Sucheinstellungen im öffentlichen Katalog wiederzufinden, allerdings vergeblich. Dafür habe ich tatsächlich eine Anlage "Ablaufberg V4" gefunden, die nicht von mir stammt (veröffentlicht von "JmiKnopf" am 8.1.2018). Was wäre nun passiert, wenn ich meine "vermeintlich veränderte" Anlage "Ablaufberg V4"  tatsächlich "wieder"veröffentlicht hätte? Hätte ich dann unwissentlich die Anlage von "JmiKnopf" überschrieben?

Dass durch die "Zurücknahme" der Veröffentlichung "meiner" Anlage "Ablaufberg V4" die Anlage mit demselben Namen von "JmiKnopf" nicht betroffen wurde, finde ich ja vollkommen in Ordnung. Aber warum wurde dann stattdessen die Veröffentlichung meiner Anlage "Ablaufberg" (ohne den Zusatz " V4") anulliert? Das hätte nicht passieren dürfen!
 

Grundsätzlich würde ich in der Katalogverwaltung des Modellbahn-Studios folgende Verhaltensweisen vorschlagen:

  1. Beim Abspeichern einer Anlage im lokalen Benutzerkatalog könnte das Modellbahn-Studio im Online-Modus zwar automatisch prüfen, ob dieser Name bereits eine im Online-Katalog veröffentlichte Anlage identifiziert, und an den Benutzer eine entsprechende Warnmeldung ausgeben. Dies kann aber nicht verhindern, dass möglicherweise Anlagen mit demselben Namen auf anderen (privaten) Benutzerkatalogen abeglegt sind, die nicht überprüft werden können. Die Überprüfung wäre also unvollständig.
     
  2. Beim Veröffentlichen einer Anlage sollte nicht nur überprüft werden, ob diese im Online-Katalog bereits existiert, und dann der Benutzer gefragt werden, ob er diese Anlage überschreiben möchte. Es sollte zusätzlich überprüft werden, ob es sich bei der gleichnamigen Anlage im Online-Katalog um eine Anlage des Benutzers oder um die Anlage eines anderen Anlagenbauers halndelt. Trifft letzteres zu, sollte anstelle der Abfrage, ob die existierende öffentliche Anlage überschrieben werden soll, eine Ablehnung erfolgen, in der auf die Existenz einer gleichnamigen veröffentlichten Anlage eines anderen Anöagenbauers hingewiesen und der Benutzer aufgefordert wird, für die Anlage einen anderen Namen zu verwenden.
     
  3. Wird vom Benutzer eine Anlage geändert, von der es im Online-Katalog eine gleichnamige veröffentlichte Ausführung gibt, sollte vom Modellbahn-Studio zunächst geprüft werden, ob die im Online-Katalog veröffentlichte Anlage vom Benutzer oder einem anderen Anlagenbauer stammt. Nur wenn ersteres zutrifft, sollte der "Globus" zur Anzeige der vom Benutzer bereits veröffentlichten Anlage durch das gelbe Warndreieck als "Änderungskennzeichen" ersetzt werden. Die Existenz einer gleichnamigen Anlage eines anderen Anlagenbauers im öffentlichen Bereich sollte sich auf die lokale Anlage des Benutzers nicht auswirken (bleibt wie vorher als "unveröffentlicht" gekennzeichnet).


Viele Grüße
BahnLand

Edited by BahnLand
Link to comment
Share on other sites

Hallo BahnLand,

wenn du eine eigene Anlage öffnest, die zwar Teil des Online-Katalogs, nicht aber Teil deines Benutzerkatalogs ist, dann speichert das Studio die Anlage unter der gleichen Content-ID in deinem Benutzerkatalog ab, unabhängig des Namens. Das ist wichtig, damit es nicht zu Duplikaten kommt, wenn man eine Online-Anlage weiter baut, die zuvor nicht im eigenen Benutzerkatalog existierte. Eine neue Content-ID wird beim Speichern einer fremden Anlage generiert.

Wenn du eine Kopie einer Anlage anlegen möchtest, dann stelle zunächst sicher, dass du mit "Online-Version herunterladen" die Originalanlage in deinen Benutzerkatalog lädst. Anschließend kannst du eine Kopie mit "Anlage speichern unter" erstellen, wobei dann eine neue Content-ID generiert wird.

Anlagen anderer Nutzern können grundsätzlich nicht durch eigene Anlagen überschrieben werden, unabhängig ob sie den gleichen Namen besitzen (es zählt immer nur die Content-ID). Beim Upload einer Anlage erfolgt ein Hinweis, falls es bereits eine Anlage mit gleichem Namen gibt.

Viele Grüße,

Neo

Link to comment
Share on other sites

Hallo BahnLand,

 

entschuldige ich wollte dir deinen Anlagennamen nicht wegnehmen.

 

Ich finde Anlagen die sich auf möglichen Lösungen von Anlagenabläufe beziehen sollten einen aussagekräftigen Namen haben. Da ich gerade an einen Ablaufberg unter V4 mit möglichst kurzer EV arbeite, ist nur der Name „Ablaufberg V4“ wirklich Aussagekräftig.

 

Mit freundlichem Gruß JimKnopf

Edited by JmiKnopf
Name nicht ganz richtig
Link to comment
Share on other sites

Hallo,

@JmiKnopf
Ich mache Dir keinen Vorwurf. Schließlich hast Du den Namen "Ablaufberg V4" zuerst verwendet, und ich habe ja auf "Ablaufberg ..." kein Copyright (:)). Trotzdem ist im Modellbahn-Studio etwas schiefgelaufen.

@Neo
Wenn ich mich recht entsinne (und das ist jetzt etwas schwer, ohne es nochmal nachvollziehen zu können), war es tatsächlich so, dass ich "meine eigene" Anlage "Ablaufberg" unter der Kategorie "Meine Anlagen" (also im lokalen Benutzerkatalog) nicht gefunden habe, sie dann im offiziellen Online-Katalog gefunden und deshalb direkt von dort geöffnet habe. Ich nehme an, dass sie dabei implizit wieder im lokalen Benutzerkatalog angelegt wurde - genauso, wie Du in es in Deiner Antwort beschreibst. Denn seither kann ich sie auch wieder unter "Meine Anlagen" finden.

Diese geöffnete Anlage habe ich dann mittels "Speichern unter" mit dem neuen Namen "Ablaufberg V4"  abgespeichert und damit in meinem Benutzerkatalog eine Kopie der originalen Anlage "Ablaufberg" angelegt. Hierbei scheine ich aber nicht eine neue Content-ID bekommen zu haben, sondern es wurde (leider jetzt nicht mehr nachvollziehbar) stattdessen anscheinend die Content-ID der im offiziellen Online-Katalog vorhandenen Anlage "Ablaufberg V4" von @JmiKnopf  (von der ich nichts wusste) herangezogen, was die Existenz des gelben Warndreiecks in "meiner" frisch abgespeicherten Anlage "Ablaufberg V4" erklären würde.

Wenn das Verhalten im Modellbahn-Studio tatsächlich so ist, wie ich es hier beschrieben habe, halte ich dies für einen Fehler. Wenn dies aber definitiv nicht das Verhalten des Modellbahn-Studios ist, kann ich mir nicht erklären, wieso ich das "Geändert-Zeichen für veröffentlichte Anlagen" für meine Anlage "Ablaufberg V4" bekommen habe, die ich definitiv nie im offiziellen Online-Katalog veröffentlicht und auch nicht von dort heruntergeladen habe (zumindest nicht bewusst, da ich ja von deren Existenz nichts wusste). Ich habe ja auf dem Bildschirm auch "meine" Anlage, und nicht die von @JmiKnopf gesehen).

vor 1 Stunde schrieb Neo:

Wenn du eine Kopie einer Anlage anlegen möchtest, dann stelle zunächst sicher, dass du mit "Online-Version herunterladen" die Originalanlage in deinen Benutzerkatalog lädst. Anschließend kannst du eine Kopie mit "Anlage speichern unter" erstellen, wobei dann eine neue Content-ID generiert wird.

Kann es vorkommen, dass eine von mir im Online-Katalog veröffentlichte Anlage, die ich aus dem Benutzerkatalog heraus öffnen möchte, und die dort kein Änderungskennzeichen (gelbes Warndreieck) aufweist, sich von der Online-Version unterscheidet? Wie kann es zu einer solchen Situation kommen? Ich bin bei der (impliziten) Status-Anzeige "Keine Änderung" bisher immer davon ausgegangen, dass ich unabhängig davon, ob ich die Anlage aus dem lokalen Benutzerkatalog oder aus dem offiziellen Online-Katalog heraus öffne, dann immer denselben Stand der Anlage geöffnet habe.

Dies alles erklärt aber nicht, warum durch die "Rücknahme" der Veröffentlichung meiner Kopie "Ablaufberg 04" die Veröffentlichung des Originals "Ablaufberg" annulliert wurde.

Viele Grüße
BahnLand

Link to comment
Share on other sites

Hallo BahnLand,

vor 9 Minuten schrieb BahnLand:

Ich nehme an, dass sie dabei implizit wieder im lokalen Benutzerkatalog angelegt wurde

nicht ganz. Beim Öffnen einer Anlage passiert noch nichts, erst wenn du auf "Speichern / Speichern unter" klickst, erfolgt eine Ablage in deinem Benutzerkatalog. Handelt es sich dabei um eine Anlage, die online, aber nicht offline existiert, dann wird die vorhandene Content-ID verwendet. Das erklärt auch, warum du das gelbe Warndreieck siehst. Das hat nichts mit JmiKnopfs Anlage zu tun, sondern deine Anlage "Ablaufberg V4" wurde mit der Content-ID deiner Anlage "Ablaufberg" gespeichert, denn diese hast du ja auch geöffnet gehabt.

Am besten du testet das Verhalten noch einmal mit einer neuen Anlage:

  • Erstelle eine neue Anlage und veröffentliche diese unter dem Namen A. Notiere dir die Content-ID.
  • Lösche die Anlage aus deinem Benutzerkatalog, ohne die Veröffentlichung zurückzuziehen
  • Öffne die Anlage A aus dem Online-Katalog und speichere sie unter dem Namen B ab

-> Anlage B sollte weiterhin die Content-ID von Anlage A haben, inkl. des gelben Warndreiecks, weil du beim Speichern den Namen der Anlage geändert hast.

Viele Grüße,

Neo

Link to comment
Share on other sites

Hallo Neo,

ich habe jetzt Deine Beschreibung mit einem entsprechenden Beispiel nachvollziehen können. Demnach sollte die jetzige Content-ID 91C89FDB-6C42-4627-AC26-3CEEC850A97F meiner lokal gespeicherten Anlage "Ablaufberg V4" jene der ursprünglich veröffentlichten Anlage "Ablaufberg" gewesen sein, deren Veröffentlichung ich ja aus "Unwissenheit" zurückgezogen habe. Ich habe aber seitdem auch die Anlage "Ablaufberg" wieder in meinem lokalen Benutzerkatalog, jedoch mit der Content-ID BF1E3582-32E9-4074-AE25-5F55DED16C28. Wenn diese bei der ganzen Herumprobiererei nur deshalb neu vergeben wurde, weil durch das Abspeichern der aus dem Online-Katalog geladenen Anlage unter einem neuen Namen die Content-ID "mitgenommen" wurde, wundert es mich, dass die nunmehrige Anlage "Ablaufberg" mit der "neuen" Content-ID ein "letztes Änderungsdatum" 13.Okt. 2017 aufweist. Das heißt doch, dass sie die Content-ID schon damals besessen haben muss. Wie kann es dann sein, dass die veröffentlichte Anlage mit gleichem Namen eine andere Content-ID hatte? Das verwirrt mich jetzt total.

Die Situation, die mich zum Erstellen dieses Threads bewogen hat, konnte ich übrigens nicht mehr nachstellen.

Die Anlage "Ablaufberg", deren Veröffentlichung durch meine Herumprobiererei verloren gegangen ist, werde ich erst wieder neu veröffentlichen, wenn ich sie mit V4-Mitteln wieder zum Laufen gebracht habe (ich bin schon ein ganzes Stück vorwärts gekommen).

Viele Grüße
BahnLand

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...