Jump to content

Signal auf Hp0 nach Aktivierung der Fahrstraße


Recommended Posts

Hallo in die Runde,

Ich möchte eine Fahrstraße aktivieren (Bild 01) und nach 3 bzw. 4 Sekunden das Signal wieder auf Hp0 und die Geschwindigkeits- und Richtungsanzeige wieder auf Aus ohne die Fahrstraße zu deaktivieren.

Die Signale schalten nach Aktivierung der Fahrstraße wie in den Bildern 02 bis 04 auf die jeweilige Einstellung.

Die Signale stellen sich aber erst wieder um wenn die Fahrstraße aufgelöst ist. Wie bekomme ich es hin das die Signale nach den paar Sekunden umstellen?

001.thumb.jpg.4b9625e45fcb9e10e2d7f31036d7c53d.jpg002.thumb.jpg.e6e5b3066ce5d015ff4641bf3a00a6df.jpg003.thumb.jpg.667e369daeff4061f753c900123b15af.jpg004.thumb.jpg.d5cd4e29a8c96ce823e871c27a46b4b2.jpg

Gruß Thomas

Link to comment
Share on other sites

Hallo @Thomas_103

Ich glaube nicht, dass du willst dass sie immer nach ein paar Sekunden umstellen, sondern nach vorbeifahrt des Zuges?

Wenn du die Gleiskontakte der Signale bei der Erstellung der Fahrstrasse miteinbeziehst, dann kannst du in der Fahrstrasse einstellen, dass bei Auflösung der Fahrstrasse beim Gleiskontakt das Signal umstellt. Dies geschieht dann automatisch, wenn die Mitte des Zuges den Gleiskontakt überfährt, oder bei Ankunft der Spitze des Zuges am ende der Fahrstrasse. Was auch immer zuerst geschieht.

2024-01-1808_28_43-Thunersee-3D-ModellbahnStudioV8.5.thumb.jpg.884d68d2ca0576d925a2697eafe2b90b.jpg

Gruss
Sintbert

Link to comment
Share on other sites

Deine Ereignisse würde ich so nicht realisieren, da sie sich immer wieder selbst aufrufen.
Für Dich wäre das Ereignis "Fahrstraße wird aktiviert" die beste Wahl, um Zug zu starten und Anzeigen zu schalten.
Alles in dem einen Ereignis.
Und wenn Du nicht, wie Sintbert schreibt, über einen Gleiskontakt zurückschalten möchtest, könntest Du in das obige Ereignis
zusätzlich eine Verzögerung von 4s einbauen, die Deine Anzeigen zurücksetzt.

Gruß
HaNNoveraNer

Edited by HaNNoveraNer
Link to comment
Share on other sites

vor 4 Stunden schrieb Thomas_103:

Die Signale schalten nach Aktivierung der Fahrstraße wie in den Bildern 02 bis 04 auf die jeweilige Einstellung.

Da irrst du dich, Thomas

So, wie du es angelegt hast, schaltet der Geschwindigkeitsanzeiger pausenlos immer wieder

Signalschaltet.jpg.fdae4f3136dfca6639b7d0e8697b2f62.jpg

Wenn das Signal schaltet, dann stellst du dasselbe Signal neu.
Das ist ein Schaltvorgang. Also wird dieses Ereignis erneut aufgerufen. Und du schaltest das Signal noch einmal (auf dieselbe Stellung)
Das ist ein weiterer Schaltvorgang. Wieder wird dieses Ereignis ausgelöst. Und wieder schaltest du das Signal ...

Nach 25 Wiederholungen bricht das Studio diesen Vorgang (und damit auch die Verarbeitung weiterer Ereignisse) ab.
Deshalb passiert bei dir scheinbar (!) gar nichts. Denn diese 25 Wiederholungen laufen blitzschnell ab.

Mit der Taste F12 kannst du das Ereignisprotokoll öffnen. Dort kannst du solches Fehlverhalten gut beobachten und ableiten, was in deiner EV geändert werden muss.

Viele Grüße
Götz

 

Link to comment
Share on other sites

Hallo @Sintbert @HaNNoveraNer und @Goetz,

jetzt hab ich die Gleise, die Signale und eine Lok auf eine leere Platte, dann die EV geschrieben um sie als Entwurf mal hochzuladen.

Kann ich mir sparen. Nun schaltet die Fahrstraße, die Signale gehen an, nach ein paar Sekunden wieder aus und die Fahrstraße bleibt trotzdem aktiv bis zum letzten Punkt der Fahrstraße. So wie ich es wollte.

So sieht die EV jetzt aus. Müsste so sein wie @HaNNoveraNer es vorgeschlagen hatte.

01.thumb.jpg.1450b2271e89b38b8837ac7586bf735f.jpg02.thumb.jpg.401c65e633b954df3e17e405ab8cd25b.jpg

Vielen Dank an euch für die Hilfe.

Viele Grüße aus dem verschneiten Karben

Thomas

 

Die EV habe ich jetzt noch zusammengelegt.

Edited by Thomas_103
Zusammenlegung der EV
Link to comment
Share on other sites

vor 35 Minuten schrieb Thomas_103:

Müsste so sein wie HaNNoveraNer es vorgeschlagen hatte.

 

Leider hast du nur zur Hälfte gelesen, was dir empfohlen wurde.

Dein Signal Ausfahrsignal Bhf N8 ist der Beginn deiner Fahrstraße.
Damit wird es automatisch auf Fahrt gestellt, wenn du die Fahrstraße aktivierst.
Und ebenso wird es automatisch auf Halt zurück gesetzt, sobald die Mitte des Zuges dieses Signal passiert.

Beides ist so in den Einstellungen der Fahrstraße festgelegt.

Deshalb musst du dieses Signal überhaupt nicht per EV schalten.

Und wenn die Eigenschaften des Kontaktpunkts vom Signal Ausfahrsignal Bhf N8 so sind, dass sie den Zug auf dem Kontakt bei Stellung Fahrt auf 80 km/h beschleunigen. dann ist auch der Eintrag für die Beschleunigung des Zuges in der EV überflüssig.

Beide Konfigurationen - die der Fahrstraße und die des Signalkontakts - kannst du ändern. Und je nachdem, was du da änderst wird es eventuell erforderlich, Dinge in der EV zu bewirken. Aber du zeigst weder die Konfiguration deiner Fahrstraße noch die des Signalkontakts. Deshalb vermute ich, dass du von diesen Möglichkeiten nichts weißt. Dann werden beide ihre Standardkonfiguration haben und die ist so, wie oben beschrieben.

Viele Grüße
Götz

Edited by Goetz
Schreibfehler korrigiert
Link to comment
Share on other sites

Hallo @Goetz,

Die Konfiguration des Signals ist bei Hp0 auf Abbremsen auf 0 eingestellt und bei KS1 ist alles aus.

Dies habe ich so eingestellt weil ich von einem Signal mehrere Fahrstraßen schalte mit unterschiedlichen Geschwindigkeiten, die dann per EV geregelt werden.

Das Signal soll aber schon früher auf Halt umspringen und nicht erst in der Mitte des Zuges, deswegen habe ich dies so eingestellt.

Hier auch wieder je nach Geschwindigkeit zwischen 7 und 11 Sekunden.

Das die Signale bei Aktivierung der Fahrstraße auf KS1 gehen weiß ich. Dann muss ich das mal ohne den Eintrag in der EV testen.

Da hast du Recht das kann ich mir dann sparen.

Gruß Thomas

Link to comment
Share on other sites

Hallo Thomas,

vor 4 Minuten schrieb Thomas_103:

Die Konfiguration des Signals ist bei Hp0 auf Abbremsen auf 0 eingestellt und bei KS1 ist alles aus.
Dies habe ich so eingestellt weil ich von einem Signal mehrere Fahrstraßen schalte mit unterschiedlichen Geschwindigkeiten, die dann per EV geregelt werden.
Das Signal soll aber schon früher auf Halt umspringen und nicht erst in der Mitte des Zuges, deswegen habe ich dies so eingestellt.

Das sind alles wichtige Informationen, die du uns vorenthalten hast.
Diese Bedingungen haben Einfluss darauf, mit welcher Taktik man die Sache angeht. Und wenn wir davon nichts wissen, laufen wir Gefahr falsche Ratschläge zu geben.

Link to comment
Share on other sites

vor 2 Stunden schrieb Goetz:

Wenn das Signal schaltet, dann stellst du dasselbe Signal neu.
Das ist ein Schaltvorgang. Also wird dieses Ereignis erneut aufgerufen. Und du schaltest das Signal noch einmal (auf dieselbe Stellung)
Das ist ein weiterer Schaltvorgang. Wieder wird dieses Ereignis ausgelöst. Und wieder schaltest du das Signal ...

Hallo Götz,
ich habe auch mal diesen  Gedankenfehler gemacht. Es ist aber so, dass ein Ereignis "Signal schaltet" nur dann ausgeführt wird, wenn sich der Schaltzustand tatsächlich ändert. Hier ein kleiner Versuchsaufbau:

Strecke mit Signal:

Signalschaltet1.thumb.jpg.22e6fd61624ec2173a601efd7c968be8.jpg

Fahrstraße absichtlich so eingestellt, dass das Signal nicht wieder auf Hp0 gesetzt wird:

Signalschaltet2.jpg.c6edfa6930f8b1373fc589d87f5cbf8d.jpg

Ereignis: Schaltet das Signal, so wird nach einer Verzögerung das Signal wieder auf Hp0 gesetzt:

Signalschaltet3.thumb.jpg.b313a71ec549435db08c085c98e253f1.jpg

Im Ereignisprotokoll ist ersichtlich, das das Ereignis "Signal schaltet" nur zweimal ausgelöst wird: Bei Schalten auf Hp1 (durch Fahrstraße) und nach der Verzögerung wieder auf Hp0. Danach taucht das Ereignis nicht mehr auf, da kein Wechsel des Schaltzustandes auftritt.

Signalschaltet4.thumb.jpg.13d04ddeac7ac0017bd4e728ded2fef2.jpg

Ich habe mal lange gesucht, warum so ein Ereignis nicht ausgeführt wird, bis ich gemerkt habe, dass das Signal schon den gewünschten Status hatte o.O

Viele Grüße,
    Wolfgang

 

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
×
×
  • Create New...