Jump to content

[Erledigt] Straßenampel


Recommended Posts

Hallo,

jetzt war Seehund schneller als ich (irgendwie habe ich dessen Produktionsgeschwindigkeit noch nicht drauf ;)).

Ampeln.jpg

Ich möchte Euch aber trotzdem meine Ampel nicht vorenthalten, weil sie nicht wie Seehund's Ampel (im Bild in der Mitte) mit einem Lampenpfahl fest verbunden ist und daher an jeder Stelle platziert werden kann (die "Befestigungsarme" sind an der Ampel fest fixiert, das Erzeugen der Ampel-Galgen überlasse ich anderen).

Ich habe die Ampel in zwei Varianten produziert. Die erste Variante ("Ampel (Steuerung)") funktioniert genauso wie Seehund's Ampel und benötigt daher als "Schaltkasten" eine Kreuzungsweiche. Die zweite Variante ("Ampel (Signal)") ist als "Signal" realisiert, kann also durch direktes "Anklicken mit der Leertaste" geschaltet werden und damit auch "Einfluss" auf Straßengleise und darauf fahrende Autos nehmen. Die Umschaltung erfolgt über eine Animation, die als Zwischenstufe zwischen der Rot- und der Grünphase das (nur) gelbe Licht enthält. Es lässt sich leider ausschließlich nur "Rot+Gelb" oder "nur Gelb" als Zwischenphase der Animation realisieren, da diese beim Umschalten vorwärts oder rückwärts abgespielt wird und nicht für die jeweils andere Richtung ausgetauscht werden kann. Und da erschien es mir sinnvoller, für beide Umschaltungen das "nur gelbe" Licht anstelle der Rot-Gelb-Kombination herzunehmen.

Beide Varianten sind wegen der bisher noch nicht verfügbaren Darstellung von mehr als zwei Signalzuständen eben "nur Krücken", aber trotzdem besser als "Nichts".

Ich habe beide Ampeln im Katalog-Hauptverzeichnis "Straße" (nicht in Straße --> Straßen) platziert (da, wo auch die Straßenlampen hinterlegt sind). Vielleicht könnte man ja der besseren Übersichtlichkeit wegen genauso wie für die Straßenschilder ein eigenes Unterverzeichnis für alle Arten von "Laternen" (zu denen ich auch die Ampeln zähle) anlegen.

Viele Grüße
BahnLand

 

Link to post
Share on other sites

Hallo,

Danke für die Ampeln.

Für mich kommt nur die Ampel(Signal) in Frage.

Allerdings hätte ich noch ne Bitte, kann ich die Ampel fest am Mast bekommen, da ich sie sonst extra an einen Mast (welchen) heften muss.

Eine Einheit Mast/Ampel wäre mir persönlich lieber.

 

PS:

Bei der Ampel (Steuerung) verändern sich die Farben wenn ich die Boddenplatte markiere, bzw. die Ansicht kippe.

 

Gruß

Rainer

Link to post
Share on other sites

Hallo,

@Rainer,
die Ampel vom Typ Signal gibt es jetzt auch mit Mast. Die Ampel vom Typ Steuerung habe ich nicht zusätzlich mit Mast hinterlegt, da es diese ja von Seehund gibt. Dass bei "meiner" Ampel beim Kippen der Anlage die beleuchteten Laternen wechseln, hat wahrscheinlich etwas mit der anfänglichen "Undefiniertheit" des Zustands zu tun. Sobald man die Ampel mit einer Kreuzungsweiche (als Schaltelement) verknüft, ist dieser Effekt verschwunden. Die Ampel zeigt dann aus jeder Blickrichtung auf die Anlage stets jenen Signalzustand an, der der aktuellen Stellung der Kreuzungsweiche entspricht.

@Neo,
bei meiner Ampel ohne Mast hatte ich zunächst nur ein Sketchup-Modell, das ich zur Unterscheidung zwischen der Steuerungs- und der Signal-Variante mit unterschiedlichen Animations-Definitionen in der DirectX-Datei versah. Da bei der Signal-Variante die "Rot+Gelb"-Anzeige nicht mehr benötigt wird (es gibt nur eine Animation für den Vorwärts- und Rückwärts-Lauf), habe ich die beiden Modelle bereits auf Sketchup-Ebene getrennt. Dadurch besitzen die in das Modellbahn-Studio übernommenen X-Dateien gegenüber den alten Ausprägungen abweichende Namen. Da man bei einer Namens-Änderung der Eingabedatei diese nicht durch eine "Aktualisierung" übernehmen kann (hierbei wird grundsätzlich nach einer Aktualisierung unter dem alten Dateinamen gesucht), habe ich die korrigierten Modelle neu eingespielt, aber unter denselben Objektnamen wie die bereits im Katalog befindlichen Modelle abgespeichert. Ich wurde hierbei gefragt, ob ich die alten (bereits existierenden) Modelle überschreiben wolle, was ich dann auch bestätigt habe.

Ich hätte hierbei erwartet, dass die bereits freigegebenen Modelle auch weiterhin im Online-Katalog sichtbar sind. Dies war aber nicht so: die beiden (korrigierten) Ampel-Modelle waren plötzlich nicht mehr "öffentlich". Ich musste sie also erneut explizit freigeben, woraus ich schließe, dass sie auch wieder eine neue ID verpasst bekommen haben. Das sollte nach meinem Verständnis nicht so sein. Ich bin davon ausgegangen, dass im Online-Katalog bereits veröffentlichten Modelle bei einem Update auch dann, wenn sich der Name der einzulesenden DirectX-Datei geändert hat, das Modell aber unter dem ursprünglichen Modell-Namen abgelegt werden soll (und ja auch tatsächlich "überschrieben" wird), dieses weiter öffentlich bleibt und auch die bereits vergebene ID beibehält.

Viele Grüße
BahnLand

Link to post
Share on other sites

Hallo BahnLand.

Danke für die Erfüllung meines Wunsches.

Der Wechsel via Gelb ist geil.

Die Ampel (Signal) ohne Mast habe ich auch verwendet und sie an gefährlichen Kreuzungen :-) am linken Mast angepappt.

Momentan noch ohne Steuerung in EV, aber nur deshalb da ich noch 20 unterschiedliche Kreuzungen  in die EV eintragen muss und das dauert bis man die Namensänderung in der Steuerung pro Kreuzung vorgenommen hat.

 

PS:

noch als Hinweis, der Gismo steht auf der Ampel und nicht am Mast. Das erschwert etwas die Positionierung.

 

Gruß

Rainer

Link to post
Share on other sites

Hallo Rainer,

normalerweise ist mein DirectX-Exporter so eingestellt, dass bei der Darstellung des Modells im Modellbahn-Studio sich das Gizmo in der Horizontale (x- und y-Richtung) im durch die Außenmaße des Objekts bestimmten Zentrum befindet. Bei der Ampel mit Mast befindet sich dieses Zentrum unter dem Lichtkasten, weil "gegenüber" dem Mast auch noch die Lampenschirme "herausragen".

Ich habe jetzt den "Drehpunkt" so verschoben, dass er mittig unter dem Ampelmast liegt. Dreht man also nun die Ampel, bleibt der Mast an Ort und Stelle, und der Ampel-Ausleger (der Lichtkasten) schwenkt um den Mast herum.

ACHTUNG!
Auf der Anlage bereits platzierte Ampeln müssen "nachjustiert" werden, weil sich die Positionskoordinaten auf der Anlage auf das Gizmo beziehen und sich das Modell diesem gegenüber durch die Korrektur etwas verschoben hat.

Viele Grüße
BahnLand

Link to post
Share on other sites

Hallo,

irgend etwas ist jetzt aber schiefgelaufen.

Habe gerade meine Anlage neu gestartet und alle Ampel(Signal) Masten waren Fragezeichen.

Es sind plötzlich die Masten mit dem versetzten Gismo, also nicht am Mast, wieder aktiv im Katalog.

Gruß

Rainer

Link to post
Share on other sites

Hallo Rainer und Neo,

ich weiß nicht was passiert ist.

@Rainer:
Offenbar konntest Du ja gestern meine korrigierte Ampel noch einlesen. Zwischenzeitlich hatte ich nichts gemacht.

Als ich gerade zur Prüfung das MBS und dort den Katalog öffnete, bekam ich zwei Ampeln mit demselben Namen "Ampel_mit_Mast (Signal)" angezeigt. Ich habe dann eine davon auf eine leere Anlagenplatte gezogen, worauf die andere aus dem Katalog verschwand. Leider war die "übrig gebliebene" die nicht korrigierte (alte) Version.

Ich habe dann diese Ampel über das Kontext-Menü zum Bearbeiten geöffnet und nach dem Anklicken des Buttons "Ampel_mit_Mast (Signal)" die (einzige vorhandene) Detailstufe (über den Refresh-Button) von der Festplatte neu hochgeladen.  Nachdem ich dann die Ampel (mit erneuter Bestätigung der Freigabe) abgespeichert hatte, zeigte der Katalog wieder zwei Ausprägungen der Ampel mit identischem Namen an (die neue korrigierte Ampel wurde also neu hinzugefügt und die alte nicht korrigierte im Katalog beibehalten). Ich habe jetzt die alte Version explizit gelöscht, sodass wieder nur eine Version (nämlich die aktuelle korrigierte) vorhanden ist. Allerdings bekommst Du jetzt möglicherweise wieder Fragezeichen und musst daher diese nochmals über das Bearbeiten-Menü der MBS ersetzen (es genügt die explizite Ersetzung eines Fragezeichens, wobei alle weiteren Fragezeichen mit gleicher Bezeichnung gleich mit ersetzt werden sollen).

@NEO:
Mir ist nicht bewusst, dass ich beim Hochladen (Ersetzen) der alten Ampel durch die neue mit versetztem Gizmo etwas falsch gemacht habe, zumal Rainer die neue Ampel auch vom Katalog herunter laden konnte. Es muss also in der Nacht etwas mit dem Katalog passiert sein, das bewirkte, dass wieder die alte Ampel-Version (und zwar nur diese, und mit anderer ID) anstelle der zuletzt hochgeladenen Ampel vorhanden war. Und dass durch das Aktualisieren  der im Katalog vorhandenen Ampel eine neue angelegt und die alte beibehalten wird, erscheint mir ebenfalls etwas "suspekt".

Ich hoffe, dass jetzt die aktuelle Ampel (ich hab's bei mir geprüft - wobei ich als Bereitsteller der Ampel diese im Katalog ja "etwas anders" sehe) bei allen Hobby-Kollegen wieder korrekt angezeigt wird und erfolgreich herunter geladen werden kann.

Viele Grüße
BahnLand

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
×
×
  • Create New...