Jump to content

Texturen / Blender


Recommended Posts

Hallo,

ich benötiger als "blutiger" Anfänger in Bezug auf 3D-Modelle im MBS Hilfe.

Auf Grund von 3D-Modellen, die ich für meine Anlage in MBS benötige (Epoche IV) und nicht im Katalog sind, habe ich mich entschlossen einfach mal mittels Blender ein einfaches 3D-Modell zu bauen. Nix besonders, ist nur ein Bushaltestellenschild :-D .. man sollte ja klein anfangen :-D

Soweit hat auch alles geklappt, nur bei den Textuten verzweifele ich.

Aber der Reihe nach:

  • Modell mittels Blender 3.0 erstellt .. Textur (png) für das Schild in Blender zugewiesen hat die Auflösung 256x1024 (wegen der Zweierpotenz)
  • Textur dann durch Rotation und Skalierung so lange hin- und hergeschoben bis es im Blender passt (siehe screenshot1)
  • Objekt als dlTF-Datei eyportiert
  • habe es dann in MSB hochgladen .. und da kamm das dann raus :-( (siehe screenshot2)

Ich wäre über ein bissel Hilfe sehr dankbar

 

LG

screenshot1.jpg

screenshot2.jpg

Link to comment
Share on other sites

Good morning...

Could you 'zip' your Blender file, and the Texture, and post it here, please..? I'd have a look to see where it's gone wrong. It can't be much, and I'll admit to having scratched my head with Blender at first, but once it became more clear to me, it all made sense. Stick with it; you're nearly there. B|

Guten Morgen...

Könnten Sie bitte Ihre Blender-Datei und die Textur 'zippen' und hier posten? Ich würde mal schauen wo es schief gelaufen ist. Es kann nicht viel sein, und ich gebe zu, dass ich mich zuerst mit Blender am Kopf gekratzt habe, aber als es mir klarer wurde, ergab alles einen Sinn. Dabei bleiben; Sie haben es fast geschafft. B|

Douglas

Link to comment
Share on other sites

Hallo Torsten

Punkt 1: Auf die Stange wendest du ein CTRL A (Apply all Transforms an, damit bekommst du erstmal die Schattierungen weg (falls gewollt)for.jpg.4fb2a87769995ebe010e13b3faaf0ea2.jpg

Punkt 2: Es scheint als ob die Textur nicht korrekt zugewiesen wurde: (Wie du Texturen erstmal anwendest und in Blender aktivierst weißt du ja)

     Schalte auf den U/V Editor:

for1.thumb.jpg.896502bedb68777cd6dea005e947aff5.jpg

     Selektiere das Schild (rechts), schalte auf exakte Front-View (90° normal auf das Schild um Verzerrungen zu vermeiden. Gehe in den Edit-Modus und selektiere das Face, oder alles, je  nachdem was du willst, jetzt drückst du "U" und gehst auf "Project from View", damit wird die Front-Ansicht in den UV/EDitor übernommen, dort kannst du jetzt den Kreis skalieren und verschieben um die Textur anzupassen, dann sollte das auch passen.

for2.jpg.12fb9c80a666ad46dc87121adc1f13cc.jpg

for3.thumb.jpg.42c534c480fc9827ba4ed9e9b2c02343.jpg

lg max

PS: Ansonsten stelle mal das File zur Verfügung wie Douglas bereits erwähnte

 

Link to comment
Share on other sites

Vielen Dank für die schnellen Antworten, ich glaube ich habe verstanden wo mein Problem liegt. Morgen werde ich mir mal ganz viel Zeit und Ruhe nehmen und mich damit beschäftigen!! .. Sollte ich das immer noch nicht hinbekommen, stelle ich hier die Datei mal zur allgemeinen "Belustigung" rein, damit man sieht wie "doof" man sein kann 9_9

 

LG und Danke!!

Link to comment
Share on other sites

Hallo,

zuerst das Positive ... dank Eurer Hilfe habe ich das jetzt mit den Texturen hinbekommen :D

Wobei sich noch die Frage stellt .. ich habe die Texturen auf 256x1024 gebracht, alles was darunter war hat zu stark gepixelt, beinm hochladen hat MBS rumgemeckert, dass die Gesamtgöß der Textur zu groß wäre (siehe screenshot). :(

und nun leider das Negative ...

  1. siehe screenshot: bei den unverbundenn Objekten sind die Flächen schön "rund" .. ausser oben der Halbkreis beim Schild, da muss ich nochmal schauen. liegt am "Smoothen" .. das habe ich schon im Forum gefunden .. da muss ich nochmal ran
  2. bei den verbundenen Objekten wirkt alles etwas eckig :o
  3. und was mich am meistgen stört, sind die komischen Schatten bei der Textur, komischerweise treten die aber nur bei den "gesmoothen" Objekten auf, das Schild oben ist ein Zylinder der nicht "gesmootht" wurde

Ich weiß, das das Schild kein anspruchvolles Modell ist, aber mir juckt es in den Händen/Maus Dinge für MBS zu erschaffen, und sei es nur für mich :), deshalb macht es mich verrückt, wenn ich den Fehler nicht finde >:(

 

Deshalb nutze ich einfach mal das Angebot und stelle die Blenderdatei mit hier rein.

Wahrscheinlich habe ich nur einen Anfgängerfehler gemacht.

 

LG

 

 

screenshot3.jpg

screenshot4.jpg

Bushaltestellenschild_DDR_Test_1.zip

Link to comment
Share on other sites

Hallo Torsten, wie versprochen...

1. Wie ich oben schon schrieb solltest du immer ein Apply all Transforms (CTRL A) auf jedes einzelne Objekt setzen
     (Durch die Anwendung von Transformationswerten werden im Wesentlichen die Werte für die Position, die Drehung oder die Skalierung des Objekts          zurückgesetzt, während  die Objektdaten visuell an ihrem Platz bleiben).

for1.jpg.5ab81934ed870f7a1fda684e62d2a8c2.jpg

2. Um jetzt die Schattierungen wegzubekommen (das passiert beim Smooth-Modifier) muss genau dieser begrenzt werden und zwar hier:
    Damit sagst du dem Modifier dass nur Kanten unter 30° gesmootht werden sollen, spiele mit den Werten dann siehst du was passiert)

for2.thumb.jpg.0b2bc618bc461f3687ae0ad29ed0cd9c.jpg

3. Du hast für jedes Objekt eine eigene Textur erstellt, das ist unnötig, eine reicht im Normalfall , eine 2. wäre nur bei transparenten Texturen nötig, du            kannst ja x verschiedene mappings aufbringen, ich habe diese auf die Schnelle mit 128*128 gezeichnet.
    Für uni-farbene Objekte reicht sowieso im Bestfall 1 Pixel (wenn man dieses trifft)

for3.jpg.54316498ba0986f36a6053bf8fec6cc3.jpg

4. Bei der Stange (das habe ich nicht mehr gemacht ) ist es nicht nötig diesen aus 3 Teilen zu bauen. Einfacher ist es einen Zylinder (32 Seiten sind auch zu      viel, 12-16 reichen  ebenso, denn den Rest macht dann der Smooth-Modifier, diesen verjüngen und wieder strecken, das spart Polygone.
    oberes Face selektieren im Edit-Mode dann "E"(Extrude) drücken  und "S"(Scale), dann "M" (move), spiele auch damit etwas herum, das erklärt sich              dann von selbst.

for4.jpg.91337d565b6f4b356a3886c379d9b626.jpg

Jetzt weist du ein Material zu, selektierst dann nur die dementsprechenden Faces und positionierst diese im UV Editor wie gewünscht, so kannst du auch an nur einem Objekt für jedes Face eine unterschiedliche Farbe (Textur) zuweisen.
for5.thumb.jpg.c41a486a1ff02c647990cc2c33f1bcdf.jpg

lg max

Edited by maxwei
Link to comment
Share on other sites

Hallo @maxwei,

ich bin Blender Neueinsteiger und komme mit Deinem oben beschriebenen Punkt 2 nicht ganz klar. Ich habe einen Zylinder erstellt und die Einstellungen wie im Screenshot gezeigt eingestellt, aber es erfolgt keine Glättung. Da Du von dem Modifier spricht ist mir nicht ganz klar ob da noch zusätzlich der Modifier zugewiesen werden muss. Ein Versuch brachte auch keinen Erfolg. Muss hier noch etwas beachtet werden? Eine Hilfestellung wäre nett. Vielen Dank.

Siejay

Link to comment
Share on other sites

Hallo Siejay

erst musst du das Objekt selektieren, rechte Maustaste und "Smooth" einschalten, dann kannst du das Limit setzen, ich habe das deswegen nicht erwähnt weil Torsten weiß wie man den "Smooth" aktiviert. (Eins darunter schaltest du das wieder ab)
for6.jpg.14ffaa787fb369d8629a5d481bba8330.jpgfor7.jpg.02e09b3ba2ac133f6c335e3ab1f4dbdf.jpgfor8.jpg.2e09cb4e0ecca5dbff2774fdc89f8ac5.jpg

lg max

Link to comment
Share on other sites

Hallo @maxwei,

vielen Dank für die Beschreibung. Funktioniert. Es kann so einfach sein, wenn man weiß wie es geht. Das Shade Smooth kenne ich. Mich hat der Begriff "Modifikator" verwirrt, da bin ich falsch "abgebogen" und hatte den Modifikator verwendet.

Viele Grüße,

Siejay

Link to comment
Share on other sites

So .. jetzt habe ich etwas Zeit und muss auch Maxwel ganz herzlichen Dank für die schnelle, unkomplizierte und einfach nachvollziehbare Hilfe sagen!!!

Manchmal sind es nur die "Kleinigkeiten" die einen verzweifeln lassen 9_9

Danke nochmal und LG Torsten

 

 

Link to comment
Share on other sites

Posted (edited)

Halt .. was vergessen .. kommt davon wenn man zu schnell auf "senden" klickt ..

Gehört zwar nicht zum Thema aber vieleicht kann mir der ein oder andere die Auskunft geben ..

Habe hier im Forum durch Zufall gefunden, dass es mal ein Modell der DR-Baureihe 106  gab .. bzw. das es in Arbeit war .. scheinbar aber leider nie den Weg in den Katalog gefunden hat.

Da ich gerne nach Epoche IV (DR) baue wäre es schön, wenn irgendwann im MBS die DR-Familie etwas "Zuwachs" bekommen würde .. ja ich weiß der 24.12. ist ein tolles Datum um sich was zu wünschen, aber man kann es ja mal versuchen. :$

Die Großdiesel´s gibt es ja schon :D

 

 

 

 

Edited by torsten.jaeger
Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...