Jump to content

Blender Problem


Recommended Posts

Hallo.

Ich hätte mal eine Frage. Möchte mit Blender einen Zylinder erstellen. Mit ein paar Animationen. Das erstellen klappt und Animationen funktionieren. Wenn Ich das Modell Ins MBS importieren möchte erhalte Ich eine Fehlermeldung egal in welchen Maßstab Ich das Modell Importiere. Wenn Ich aber ein anderes Modell importieren möchte dann Funktioniert es.

Gruß Christian

Fehlermeldung.jpg

Link to comment
Share on other sites

Hallo @Chris06

Die Fehlermeldung kann ja alles mögliche bedeuten und ob ich dir helfen weiß ich nicht. Häng doch mal deine Blender- und die .anim-Datei an. Dann schaue ich, und bestimmt viele Andere auch, mal darauf. Meistens ist es nur eine Kleinigkeit. Kenn ich ja von mir. Ich steh im Wald und sehe die Bäume nicht. 9_9

Beste Grüße

Dirk

Link to comment
Share on other sites

Hallo Christian,

wenn diese Fehlermeldung kommt, beantworte sie bitte mit "Ja".

Es öffnet sich dann im Browser ein Texteingabefenster, in welchem Du @Neo (theoretisch) mitteilen kannst, was vor dem erscheinen des Fehlers passiert ist. Wenn Du dieses Eingabefenster (mit oder ohne eingegebenen Text) absendest, wird @Neo zumindest die vom Program erzeugte Diagnose-Information erhalten. Diese steht nämlich in der URL (in der Adresszeile des Browserfensters).

Du kannst Dir diese Diagnose-Information auch selbst anschauen, indem Du die URL kopierst und in ein Textprogramm (z.B. in Notepad) einliest. Dann kannst Du nämlich den URL-Text umbrechen und damit vollständig lesen. An irgend einer Stelle dieses Textes findest Du dann die eigentliche Fehlerursache im Klartext. Möglicherweise kannst Du damit sogar direkt erkennen, was die Ursache für den Fehler ist, und diese dann beseitigen.

Viele Grüße
BahnLand

Link to comment
Share on other sites

Hallo Christian,

in der zweiten Zeile deiner Anim-Datei hast du statt eines Semikolons einen Doppelpunkt verwendet:

01_Drehen;0;360;NoAutoPlay;NoLoop
02-Volumen;365:385;NoAutoPlay;NoLoop
03-Skalieren;390;410;NoAutoPlay;NoLoop

Viele Grüße,

Neo

Link to comment
Share on other sites

Hallo @Neo, @dirk.z,

Danke für eure schnelle Antwort. Hab denn Fehler in der Anim-Datei behoben. Modell lässt sich nun wieder Importieren. Da Ich gestern angenommen hatte es liegt an Blender hatte Ich den neu installiert. Nun Hab Ich ein anderes Problem. Hab mal ein kurzes Video gemacht. Ist wahrscheinlich besser zum Verständnis. Mit dem Bild wollte Ich nur zeigen das die Endlosschleife aktiviert ist.

https://drive.google.com/file/d/1g9GJSwBi5x_sO3JSx73Lmmh53E8LPtPQ/view?usp=sharing

Gruß Christian

Zylinder 1.jpg

Link to comment
Share on other sites

Was ist denn das Problem, dass die Walze am Anfang/Ende der Anim. langsam beginnt und aufhört?
Dann ist in Blender bestimmt noch die Standard-Einstellung für Anim. eingestellt (Bezier, ease-in/out), 

key-frame mode sollte dann auf linear umgestellt werden (zB im Anim. Layout).

key-mode.thumb.jpg.ed8883b8c9ce839911700fcca83a2739.jpg

Link to comment
Share on other sites

Hallo @Eggu,

Danke das wahr es. Hab das Modell erneut importiert. Nun funktioniert es mit der neuen Einstellung. Muss Ich nun jedes mal diese Einstellung vornehmen. Bei mir sieht es etwas anders aus müsste aber passen da es funktioniert.

Gruß Christian

Blender Einstellung.jpg

Link to comment
Share on other sites

Ja, den Keyframe-Typ kann man an verschiedenen Stellen einstellen.

Den genauen Kurvenverlauf sieht man im Graph-Editor, dort kann man auch die Kurvenverläufe fein-tunen.

Ob man die Default-Werte hierfür verändern kann, weiß ich nicht, müsste man recherchieren.
Gruß Eggu

 

Graph-Editor.jpg.1e08feb4c2a927a18b7fcd93f3ccc6d9.jpg

Link to comment
Share on other sites

vor 3 Minuten schrieb Eggu:

Ob man die Default-Werte hierfür verändern kann, weiß ich nicht, müsste man recherchieren.

Unter Preferences-Animation kann man die Default-Werte verändern.

default-keyframe-type.thumb.jpg.27014096af727d2390271d879a5518d6.jpg

Link to comment
Share on other sites

Hab Ich bei mir geändert. Noch eine andere Frage. Kann man in Blender die Geschwindigkeit der einzelnen Animationen ändern. Oder ist dies nur in den Eigenschaften des Modells möglich?

Blender Einstellung 1.jpg

Link to comment
Share on other sites

vor 11 Minuten schrieb Chris06:

Kann man in Blender die Geschwindigkeit der einzelnen Animationen ändern

Die Anim.-Geschw. ändert man, indem man die Keyframes horizontal verschiebt (also den Zeitpunkt verändert),
oder die Änderung der location/scale/Winkel unterschiedlich ausführt. Beides muss zusammen passen, so dass es auch zur
Wiedergabegeschwindigkeit passt (Frames/second), und so dass es nicht ruckelt, und so, dass man nicht unnötig viele Keyframes erzeugen muss.
Für gleichmäßige Drehungen reichen ein Keyframe alle 90°, oder 120°.  180° könnte problematisch sein, weil dann die Drehrichtung zweideutig ist.
Bei Drehungen um mehrere Achsen kann es unerwartete Ergebnisse geben (siehe "Euler-Drehungen" oder auch "Gimbal-Lock").
Dann könnte man auf Quaternionen-Drehung ausweichen.

Link to comment
Share on other sites

Hallo,

vor 16 Minuten schrieb Chris06:

Kann man in Blender die Geschwindigkeit der einzelnen Animationen ändern.

Die Animationen werden mit einer festen Bildrate (fps [frames per second // Bilder je Sekunde]) exportiert. Der Standardwert ist 24 fps.
Du bestimmst also über die Anzahl der zugewiesenen Bilder die Geschwindigkeit der Animation (Animationslänge 24 Bilder = eine Sekunde)...

Gruß
EASY

Link to comment
Share on other sites

vor 1 Minute schrieb Eggu:

indem man die Keyframes horizontal verschiebt

Komplette Keyframes (auch mehrere)  kann man zB direkt in der Timeline selektieren und verschieben
(wie üblich mit G wie grab)

Keyframe-Pos.jpg.7f4f398a3d7cc7e7268c38703e9f1fa0.jpg

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
×
×
  • Create New...