Jump to content
Neo

Rocrail und das 3D-Modellbahn Studio

Recommended Posts

hey Hansi,

schau mal oben rechts im schwarzen balken dieser mitteilung.

da sollte jetzt #50 stehen. mit #44, #45 sind die nr. der antworten hier gemeint.

gruß quackster

 

 

ups... to late :)

Share this post


Link to post
Share on other sites

So, jetzt habe ich die doppelte Kreuzungsweiche genau so, wie angegeben, geändert. Das Schalten in alle vier Zustände klappt nun. Leider stimmt die Fahrwegsmarkierung in Rocrail nicht mit der Weichenstellung der Kreuzungsweiche überein. Könnt ihr mir schnell noch sagen, wie ich das verändern muss?

Gruß Hansi

Share this post


Link to post
Share on other sites

Hallp Hansi,

versuche mal, die DKW auf der Anlage um 180° zu drehen (also andersherum einzubauen), vielleicht klappts dann,

meint Henry

Share this post


Link to post
Share on other sites

Hallo Henry,

klappt leider auch nicht. Die beiden Stellungen 2 und 3 (also abbiegen) funktionieren richtig. Nur die beiden Stellungen 0 und 1 (also geradeaus) sind seitenverkehrt. Auch bei Drehung der Weiche bleibt das Problem weiter bestehen.

Gruß Hansi

Share this post


Link to post
Share on other sites

Egal, was ich auch in den Einstellungen versuche, das Problem lässt sich nicht lösen. Kann mir jemand helfen?

Gruß Hansi

Share this post


Link to post
Share on other sites

Hansi,

ich benutze Rocrail zwar nicht, sehe aber in #44, zweites Bild, das sich die Ausgänge tauschen lassen- (Haken setzen) schon versucht?

Gruß Lutz

Share this post


Link to post
Share on other sites

Hallo Lutz,

 ja, habe ich auch versucht. Egal, welche Veränderungen ich dort versuche, das Problem bleibt bestehen. Trotzdem danke für deine Antwort.

Gruß Hansi

Share this post


Link to post
Share on other sites

Zwei Symbole? Es gibt da eine DKW links und eine DKW rechts. Ansonsten nur noch einfache Kreuzung ohne Weiche links und rechts. Ins Gleisbild passt jedoch nur die DKW links. Oder hab ich da was übersehen?

Gruß Hansi

Weiche.png

Share this post


Link to post
Share on other sites

Vielleicht sollte Neo nochmal einen Blick in das Rocstudio bezüglich der DKW-Ansteuerung werfen ???

meint Henry

Share this post


Link to post
Share on other sites

Hallo Hansi2009,

habe im Anhang MBS-Datei(DKW) und dazu Datei für Rocrail .

In der Rocrail-Datei kann die DKW mit den Tasten t1 bis t4 geschalten werden und im MBS wird die DKW angezeigt,

man kann auch in RR auf das Symbol klicken.

 

Gruß Gartenbahner

PS. man muss bei RR  Kompromisse  bei der Darstellung des Gleisplanes schließen(man kann nicht immer so korrekt

die Gleise legen wie im MBS, es darf nur funktionell sein, nicht nach Schönheit)

Dkw.zip

Share this post


Link to post
Share on other sites

Hallo Gartenbahner,

danke für deine Hilfe. Ich habe es mir angeschaut. Bei deiner Weiche funktioniert es. Aber ich kann nicht verstehen, dass es bei meiner nicht geht. Trotzdem kein Problem. Um Schönheit geht es mir nicht, will nur so viel Übersichtlichkeit, wie nur möglich. Aus diesem Grunde habe ich jetzt vor, die verlegten Gleise zu verändern. Ich werde die Kreuzungsweiche rausnehmen, den Abzweig doppelgleisig machen, und dabei einfache Kreuzungen ohne Weichenfunktion verwenden.

Aber wie gesagt, ich bin immer dankbar für die Hilfe hier. Vor allem wenn sich jemand so viel Mühe macht (y)

Gruß Hansi

Share this post


Link to post
Share on other sites

Hi Hansi,

nur noch kurz zur DKW, ersetze diese durch zwei Weichen dann klappt es auch mit der Steuerung durch RR.

Ich hatte vor einem Halben Jahr das mit DKW erprobt und bin dabei wie ich mich jetzt erinnere auch abgestürzt

bei der Automatik. Entschuldige dass ich erst jetzt darauf komme, aber ich habe die Versuche zu spät gefunden,

bin dann auf zwei Weichen umgestiegen.

Wie Henry schon bemerkte sollte sich Neo das noch einmal ansehen.

 

Gruß Gartenbahner

Share this post


Link to post
Share on other sites

Hallo Gartenbahner,

das ist natürlich eine gute Idee. Damit funktioniert es erstmal, so werde ich es machen. Danke für den Tipp!

Gruß Hansi

Share this post


Link to post
Share on other sites

Hallo Eisenbahnliebhaber,

ich bin neu hier im Forum des 3D-Modellbahn Studios. Ich habe mir schon viele Anlagen angesehen und bin begeistert über die Möglichkeiten einer realistischen Gestaltung von virtuellen Modellbahnen.
Zur Zeit teste ich die Möglichkeiten, die sich durch die Kopplung mit Rocrail über RocStudio eröffnen. Da ich aus gesundheitlichen Gründen keine reale Modellbahn mehr bauen kann, hoffe ich, dass mir das 3D-Modellbahn Studio im Zusammenspiel mit Rocrail eine entsprechende virtuelle Umgebung zur Verfügung stellen kann.

Das realistische Anhalten von Loks lässt sich zum Beispiel über die Rocrail-Funktionen BBT und SBT sehr schön realisieren. Auch Fahrstraßen mit Weichen- und Signalschaltungen funktionieren bisher prima.

Ich bin jetzt am realistischen Anfahren der Loks gescheitert. Auch viele Einstellungsversuche unter Zuhilfenahme des Artikels (in diesem Thema) v. 7. Mai 2014 von Franz blieben erfolglos.

Ich hoffe, dass es Mitglieder des Forums gibt, die auch virtuelle Umgebungen mit Rocrail aufgebaut haben und Lösungen für die aktuellen Software-Versionen für das langsame Anfahren herausgefunden haben.

Vielen Dank im Voraus
Roger

Share this post


Link to post
Share on other sites

Hallo und Guten Tag, ich bin absolut neu im 3DMBS, weil ich erst jetzt nach meiner Pensionierung richtig Zeit finde, mich mit meinem lange stiefmütterlich behandelten Hobby Modelleisenbahn zu beschäftigen...Ich weiß nicht ob ich hier in diesem Beitrag richtig bin, aber vielleicht nimmt mich ja jemand an die Hand und leitet mich ein wenig  ... (y):D

Habe selbst eine mittlere Anlage von ca. 2,85 x 4,20 (5,40) mtr, die ich in den letzten Monaten erst langsam - jetzt - ordentlich aufbaue und die Gleise und Aufbauten ordentlich (?) verbaue... Ich fahre digital ( noch mit Twincenter und 3 Twinboostern ) und benutze zusätzlich als Steuerung die Multimaus. Ich fahre DCC  auf H0 - Modellgleis. Bin gerade dabei, mich in die Welt der PC-Steuerung einzulesen wobei mir jetzt schon der Kopf raucht ob der Vielfalt....Ich habe mit itrain und Demo-Traincontroller und mit Rocrail erste Gehversuche gestartet und weiß nicht, wo es hingeht...ich tendiere zu Rocrail...muss halt noch viel lesen, viele Videos schauen usw.. Technisch schwanke ich zur Zeit zwischen z21 und Digikeijs DR 5000 als Nachfolger für meine Twincenter.

Ich probiere  auch mit einem Raspberry Pi 3 B und auch hier ist einlesen das A&O und Try and Error mein Alltag. Aber dank meiner Pensionierung habe ich ja Zeit.... übrigens das zweite Hobby ist unser neues Wohnmobil....gerade 1 1/2 Jahre alt....

Ich habe damals vor 14 Jahren mit Wintrack (6.,1 3D) meine erste Planung gemacht und wollte jetzt für unser Patenkind ein Kommunionsgeschenk bauen - eine kleine Anlage (Platte 1,95 cm x 1,10 ist in der Bucht gekauft ...und erstes Gleismaterial) .. als ich mein altes Wintrack 6,1  installieren wollte musste ich feststellen, dass dies gar nicht mehr unter Win 10 läuft...also nach einer neuen Modellbahnsoftware Ausschau gehalten  und auf MBS gestoßen...Ich muss sagen...ich bin begeistert....habe mit dem Programm in zwei Tagen intuitiv ohne großes Einlesen diese kleine Anlage (1. Entwurf) lennartfastfertig mit loks.mbp erstellt....(erster Versuch - bin wie gesagt kein Eisenbahner und kenne mich mit diesbezüglichen Regeln nicht aus - bin aber ehrlich gesagt auch kein Regelfreak...Hauptsache es macht Spaß...) - noch arbeite ich im Demomodus dieses Programms - ich denke ich kaufe mir 3D MBS - weil auch der Preis ist bei diesem Leistungsumfang - schon in der Demoversion - absolut fair...

Jetzt nach längerer Einleitung meine erste eigentliche Frage:

Ich lese viel über RocStudio und MBS und ROCRAIL - habe aber immer noch nicht durchgeblickt....Kann ich neben der Steuerung einer virtuellen MBS Anlage  auch die tatsächliche Anlage in der Kombination Rocrail - RocStudio - 3D MBS steuern....

 

Vielleicht habe ich mich unfachmännisch ausgedrückt, dies bitte ich zu entschuldigen...ich lerne noch....  

 

Für Rückmeldungen wäre ich richtig dankbar...

 

LG Allaix

 

 

Share this post


Link to post
Share on other sites

Hallo Allaix und Willkommen im Forum,

RocStudio ist am Ende nur ein kleines Plugin für das 3D-Modellbahn Studio, was die Zustände zwischen Rocrail und dem Studio synchronisiert. Wird also im Studio eine Lok gestartet, so wird die gleiche Lok auch in Rocrail gestartet. Hast du die Lok in Rocrail mit deiner realen Modellbahn verknüpft, setzt sie sich auch dort in Bewegung. Rocstudio ermöglicht also eine Steuerung von Rocrail und somit indirekt auch eine Steuerung deiner realen Modellbahn, bzw. erlaubt umgekehrt eine Echtzeitvisualisierung deiner Modellbahn in 3D.

Schau dir mal folgende YouTube-Videos an, die geben einen ersten Einblick:

  1. https://youtu.be/zmh_X42NN5k
  2. https://youtu.be/_4eGqkkhIzs

Viele Grüße,

Neo

Share this post


Link to post
Share on other sites

Hallo zusammen,

obwohl der Thread schon älter ist, möchte ich mich hier noch einmal einbinden. Ich habe eine einfache rocrail Anlage (Oval mit Rückmeldern) über das Rocstudio plug-in mit MBS 5 und er entsprechenden Darstellung verbunden. Die Steuerung funktioniert so weit gut. Nun habe ich festgestellt, das die Züge nur dann auf oder an den in-Rückmeldern (Definition lt. rocrail) halten und warten, wenn das Oval im Uhrzeigersinn befahren wird. Wenn ich die Platzierungen ändere und die Loks anders herum fahren, werden die in-RM überfahren und die Lok hält ein, zwei Gleise weiter. In diesem Zusammenhang würde ich gerne wissen, wie die Ausgaben im Rocstudio Debug-Fenster, 3D MBS Ereignisse zu bewerten sind. Die Bedeutung der aufgelisteten Zahlen, Nummern ist mir schon klar, nur warum werden sie zweimal aufgelistet und was bedeutet die 0? Ich habe screenshots bzw. die Oval.mbp hinzugefügt.

Gruß Alfredo

Debug.JPG

Oval.JPG

Oval.mbp

Edited by V300

Share this post


Link to post
Share on other sites

Hallo an alle Rocrail Experten ich brauche mal Eure Hilfe:
Ich kann das Plug-in Rocstudio nicht in V5 aktivieren es kommt diese Fehlermeldung
         203924375_RocrailFehler.thumb.jpg.12e8e37352be703557ee666d53e05ed8.jpg
In V4 funktioniert es perfekt, kennt das jemand von Euch und weiß was zu tun ist.
Gruß Steffen

Share this post


Link to post
Share on other sites

Hallo Steffen,

bei mir funktioniert das plug-in in MBS-V5. Allerdings liegt die Verknüpfung bei mir im Ordner "Simulation". Sie wurde dort ohne mein zutun standardmäßig installiert. Bei älteren Versionen musste man das Tool nach meiner Erinnerung händisch starten. Wo es jetzt abgelegt ist, weiss ich nicht. Vielleicht ist dein Pfadverweis fehlerhaft.

Gruß Alfredo

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×