Jump to content

Gleise verbinden (wiedermal)


vikr
 Share

Recommended Posts

Hallo,

erstelle erstmals einen Gleisplan mit MBS und zwar auf der Basis einer existierenden Piccolotestanlage, bin also noch ziemlich unerfahren. Bin also nach wiki vorgegangen:

:Sie können Gleise nicht nur positionieren und drehen, sondern auch biegen und anstellen, um erweiterte Gleispläne umzusetzen. Markieren Sie über den Selektionsrahmen oder durch Drücken von Strg + linke Maustaste mehrere gerade und/oder gebogene Gleise und wählen Sie im Eigenschaftsfenster unter aktive Gleismodifikation "Biegen" aus. Die markierten Gleise färben sich nun gelb. Bewegen Sie die Maus an das Ende eines gelben Gleisstranges bis es sich grün färbt und drücken und halten Sie die linke Maustaste, um die selektierten Gleise zu biegen."

Das hat auch an einigen Stellen geholfen und es gibt auch bereits einen Thread mit diesem Betreff, der das Problem beschreibt, aber die dortigen Schritte habe ich erfolglos probiert.

Die Gleisstücke passen in echt zusammen und auch im Gleisplan sieht es optisch ganz gut aus.

Trotzdem gibt es zwei rot markierte Stellen, die ich einfach nicht grün bekomme. Welche Schritte könnte ich versuchen, um die Anlage auch in der Simulation fahrbar zu machen?

MfG

vik

 

piccolo-04.mbp

Link to comment
Share on other sites

Hallo vikr,

das Fatale an der Situation ist, dass Du 'Anstellen' verwendest hast, obwohl es keine Höhenunterschiede gibt. Solange alles plan ist, Finger weg von der Funktion!
Jetzt hast Du üble Winkel drin, und ich empfehle Dir, dass Du eines der vorderen Gleise nimmst, es auf die freie Seite der Anlage ziehst (notfalls machst Du die Bodenplatte größer), die Winkel einstellst, dass sie auf 0/0/90 stehen, und dann Gleis für Gleis von links nach rechts legst. Anders kriegst Du die Probleme hier nur extrem mühsam raus.
Dafür ist schon zu viel gebaut und das Problem zieht sich durch die ganze Anlage.

Gruß
  Andy

p.s.: Bevor Du mit dem flexiblen Biegen anfängst, lasse die Problemstellen mal offen und poste die Anlage nochmal. Da gibt's bestimmt noch einen guten Tipp.

Edited by Andy
Link to comment
Share on other sites

Hallo Andy,

Danke für Deine Hilfe.

Zitat
Zitat

das Fatale an der Situation ist, dass Du 'Anstellen' verwendest hast, obwohl es keine Höhenunterschiede gibt. Solange alles plan ist, Finger weg von der Funktion!

p.s.: Bevor Du mit dem flexiblen Biegen anfängst, lasse die Problemstellen mal offen und poste die Anlage nochmal. Da gibt's bestimmt noch einen guten Tipp.

 

Ich habe "Anstellen" zumindest nie beabsichtigt benutzt. Woran erkennt man denn, dass ein Gleis angestellt ist?

Habe eine Vorversion eingestellt, bei der ich noch keine Biegeversuche unternommen hatte.

MfG

vik

piccolo-02.mbp

Edited by vikr
Link to comment
Share on other sites

Hallo vikr,
das sieht man am x/y-Winkel in den Eigenschaften eines Gleises - und die z-Koordinate sollte 0 bleiben (da eben). Wenn Du's nicht mit 'Anstellen' gemacht hast, hast Du mal den Gizmo falsch gedreht - da rutscht man schnell mal rüber. Jedenfalls ist der Fehler auch in der Version schon drin. Ich hab's mal gerichtet, denn da hättest Du Dich ohne Erfahrung schwer getan. In der x-Datei sind in der Tat 4 Probleme.
Ich weiß nicht, ob da vielleicht ein falsches Gleis drin ist, oder aber ein Gleis eine falsche Dimension im MBS hat. Aber die Fehler lassen sich dann mit flexiblem Biegen abfangen. Beim Bauen unbedingt Höhenanpassung und Einrasten aktivieren (Menüleiste neben dem Lautsprechersymbol).

Gruß
  Andy

piccolo_x.mbp

piccolo_y.mbp

Link to comment
Share on other sites

Hallo vikr,

willkommen hier im Forum...

vor 41 Minuten schrieb vikr:

Habe eine Vorversion eingestellt, bei der ich noch keine Biegeversuche unternommen hatte.

... in der 3D-Ansicht ist deutlich zu sehen, wie einige Gleise eine Steigung machen...
Steigung.thumb.jpg.af3c3c7248a2089ca87f09d4528a40c0.jpg

Mit "Biegen" kann man dies nicht korrigieren, da es nur in einer Ebene funktioniert.

So etwas kann auch passieren, wenn man beim Verschieben von einem Gleis aus Versehen das Drehen mit dem Gizmo erwischt...
Steigung01.jpg.0587aa491678dbd7b3cb4546615399ac.jpg

... also nicht die drei Pfeile sondern einen der drei Kreise....

... in "piccolo-04.mbp" geht es zwar optisch in der 2D-Ansicht auf, aber die Steigungen sind nach wie vor vorhanden. Deshalb gibt es keine Verbindung...
Anstellen001.thumb.jpg.dd5ff381d0f44cca1673698e702a1751.jpg

... alles "eben" gemacht... geht es auf...
Anstellen006.thumb.jpg.4b7fe674473de13ffee913b46ddc2285.jpg

Gruß
EASY

Edited by EASY
Link to comment
Share on other sites

vor 26 Minuten schrieb Andy:

das sieht man am x/y-Winkel in den Eigenschaften eines Gleises - und die z-Koordinate sollte 0 bleiben (da eben).

 

Beim Bauen unbedingt Höhenanpassung und Einrasten aktivieren (Menüleiste neben dem Lautsprechersymbol).

Hallo Andy,

Danke. Es könnte wirklich über das Gizmo passiert sein...

Tatsächlich hatte ich die Höhenpassung deaktiviert in der Annahme, dass die nicht nötig ist, weil ich ja in der Grundplattenebene bleiben wollte.

Danke für die Y-Version. Wie hast Du die Gleise konkret platt bekommen?

MfG

vik

Link to comment
Share on other sites

vor 48 Minuten schrieb EASY:

willkommen hier im Forum...

Hallo EASY,

Danke an alle, wirklich superschnelle Hilfe!

Zitat

 

... in der 3D-Ansicht ist deutlich zu sehen, wie einige Gleise eine Steigung machen...
Steigung.thumb.jpg.af3c3c7248a2089ca87f09d4528a40c0.jpg

 

Danke, der Wald und die Bäume! Die Möglichkeit der vergrösserten 3D-Ansicht hatte ich einfach (noch) nicht auf dem Schirm!

Anstellen006.thumb.jpg.4b7fe674473de13ffee913b46ddc2285.jpg

Kann man durch geeignete Einstellungen als Anfänger verhindern, dass man versehentlich aus der Ebene der Grundplatte herausbaut?

Bist Du in die Eigenschaften der einzelnen Gleisstücke gegangen und hast dort jeweils einen Parameter der Z? Achse auf Null gesetzt, bevor Du einen neuen Biegeversuch unternommen hast?

MfG

vik

Edited by vikr
Link to comment
Share on other sites

vor 19 Minuten schrieb vikr:

Wie hast Du die Gleise konkret platt bekommen?

wie gesagt, alles nacheinander auf die rechte Seite gelegt, und die Eigenschaften-Ansicht gleich auf die x/y/z eingestellt. Und dann waren trotz Einrastungen immer noch einige Nullungen nötig. Deine Bodenplatte ist übrigens genauso verschiebbar wie jedes andere Objekt und Du kannst auch einfach über die Bodenplatte hinaus bauen. Habe gerade mal getestet, ob dann was ins Bodenlose fällt, aber nein - es kriegt z=0. Ich muß jetzt trotzdem mal sehen, wieso es bei EASY direkt aufgeht. Ich weiß jetzt nicht, ob er Dich üben lassen wollte, oder einfach nur vergessen hat, das Resultat anzuhängen. So läßt er mich üben :)

Gruß
  Andy

Link to comment
Share on other sites

Hallo Vik,

auch von meiner Seite willkommen im " Club ".

Ich habe jetzt auf die Schnelle die einzelnen mbp`s nicht angeschaut und sollte es darum gehen

alles wieder auf einen " Nenner " (Höhenniveau) zu bringen,

mach es einfach so: ziehe einen Rahmen um die gesamte Anlage (bitte nicht über die Grundplatte

hinweg, muß nicht sein) , es wird jedes Gleisstück angezeigt und in Eigenschaften unter Z(mm) die Null eingeben.

Danach müßtest du alle Gleise wieder plan auf der Grundplatte haben. Nun hast du die Basis zum weiterbauen.

Gruß

Karl

Link to comment
Share on other sites

vor 2 Minuten schrieb brk.schatz:

Hallo Vik,

auch von meiner Seite willkommen im " Club ".

Ich habe jetzt auf die Schnelle die einzelnen mbp`s nicht angeschaut und sollte es darum gehen

alles wieder auf einen " Nenner " (Höhenniveau) zu bringen,

mach es einfach so: ziehe einen Rahmen um die gesamte Anlage (bitte nicht über die Grundplatte

hinweg, muß nicht sein) , es wird jedes Gleisstück angezeigt und in Eigenschaften unter Z(mm) die Null eingeben.

Danach müßtest du alle Gleise wieder plan auf der Grundplatte haben. Nun hast du die Basis zum weiterbauen.

Gruß

Karl

P.S. hab ich noch vergessen: alle andere Maße selbstverständlich gegenfalls nachjustieren (Z in Winkelgrade)

Link to comment
Share on other sites

Hallo Karl,

bist Du Dir sicher, dass es so einfach funktionieren könnte, Ich habe da zumindest meine Zweifel, weil allein  von der Logik her, das MBs aus dem höchsten z-Wert eines Objektes und dem niedrigsten z-Wert eines Objektes eigentlich einen Durchschschnittswert der Höhenlage aller Objekte bilden sollte und somit nicht alle Gleise, wenn diese ein unterschiedliches Niveau haben sollten, gleichmäig wieder auf eine 0-Höhe setzen kann.

Gruß

streit_ross

Link to comment
Share on other sites

Hallo streit_ross,
ich war auch skeptisch und hab's mal probiert. Karl hat recht. Mit einem 'aber'!
Du mußt das Schloß öffnen, die Null in z eingeben (wenn eine da steht, nur den Cursor rein) und die Enter-Taste drücken. Nicht vergessen das Schloß wieder zu schließen, sonst bleibt's offen für später. Und bei Winkeln geht das nicht, sonst könnte man x- und y-Winkel auch schön nullen. Da werden alle drei Werte gemeinsam an alle gegeben - habe das gerade mal getestet. Außerdem müßte die Gleis-Geometrie wohl tatsächlich überprüft werden, denn ich denke, auch EASY hat ein klein wenig geflext (zumindest in der Wendeschleife das Kurvengleis rechts unten).

Gruß
  Andy

Link to comment
Share on other sites

hallo  streit_ross,

der " Nullpunkt "  ist das Maß aller Dinge im MBS. Beispiel: ziehst du eine Haus ,ein Gleis....etc.

auf die Grundplatte, wo landet es ? bei Null (Z in mm). Alles darüber oder darunter mußt du eingeben.

Ich hatte, wenn`s beim Bau einer Steigung positiv, wie negativ, mal nicht klappte, wieder von Null

als Basis neu angefangen.

Gruß

Karl

P.S. Ich hoffe, daß wir Vik damit nicht mehr verunsichert haben und er letztendlich zurecht kommt.

Link to comment
Share on other sites

Hallo EASY,
ach, Du hast den piccolo4 verwendet, deshalb. Da sind ja schon einige Dinge vorher flexibel gebogen worden. Ich hatte es jetzt insofern mißverstanden, dass ich dachte, der Original Gleisplan wäre dann sauber aufgegangen. Denn das tut er nämlich nicht. Wobei sich die Frage stellt, ob es ein Gleisplanfehler ist, vikr irgendwo einen kleinen Fehler drin hat, oder es ein Gleisdimensionsfehler im Gleisset ist. Dass im Wendekreis ein kleiner Abstand ist, der wäre drückbar. Aber auf der dritten Spur unten ist ein Gleis um einiges zu lang. (siehe oben piccolo_x.mbp). Jedenfalls schon mal Danke für die Arbeit, die Du Dir da noch gemacht hast.

@vikr

hast Du einen Link auf den Plan, bzw. kannst Du noch mal schauen, ob wirklich alle Gleise mit dem Plan übereinstimmen?

Gruß
  Andy

Link to comment
Share on other sites

vor 23 Stunden schrieb Andy:

hast Du einen Link auf den Plan, bzw. kannst Du noch mal schauen, ob wirklich alle Gleise mit dem Plan übereinstimmen?

Hallo Andy,

in der Version 2 war an einer Stelle die Kombination zweier Gleise etwas zu lang, hatte ich in Version 4 schon durch eine etwas zu kurze Kombination ersetzt.

MfG

vik

Link to comment
Share on other sites

vor 8 Stunden schrieb Andy:

.... Dann brauchen wir Henry nicht zu alarmieren....

stimmt, der hat freiwillig auch herumprobiert und ist zu folgender Lösung mit den grün dargestellten Gleisen gelangt:

zuerst wurden alle Gleise einzeln markiert und mit RESET in die Ausgangslage gebracht.
dann wurden diese Gleise wieder nach der Vorlage zusammengefügt.
Forum_2018_N00069.thumb.jpg.42e801c323ed854531c1d616aa9a106f.jpg
Der Versatz im Kehrschleifenbogen wurde durch BIEGEN bereinigt
In der Unteren Geraden taucht ein variables Gleis 9110 auf, welches notwendigerweise auch auf der gegenüberliegenden Geraden eingesetzt werden mußte.

Das ist insofern legitim, weil es das variable Gleis wirklich gibt. Es ist in der Länge von 83 bis 111 mm einstellbar und deckt den fraglichen Bereich ab.

Andere Gleiskombinationen wurden nicht ausprobiert.
Piccolo_03hk.mbp

Viele Grüße von

Henry

 

Link to comment
Share on other sites

Am 17.9.2018 um 20:01 schrieb vikr:

Hallo,

erstelle erstmals einen Gleisplan mit MBS und zwar auf der Basis einer existierenden Piccolotestanlage, bin also noch ziemlich unerfahren. Bin also nach wiki vorgegangen:

:Sie können Gleise nicht nur positionieren und drehen, sondern auch biegen und anstellen, um erweiterte Gleispläne umzusetzen. Markieren Sie über den Selektionsrahmen oder durch Drücken von Strg + linke Maustaste mehrere gerade und/oder gebogene Gleise und wählen Sie im Eigenschaftsfenster unter aktive Gleismodifikation "Biegen" aus. Die markierten Gleise färben sich nun gelb. Bewegen Sie die Maus an das Ende eines gelben Gleisstranges bis es sich grün färbt und drücken und halten Sie die linke Maustaste, um die selektierten Gleise zu biegen."

Das hat auch an einigen Stellen geholfen und es gibt auch bereits einen Thread mit diesem Betreff, der das Problem beschreibt, aber die dortigen Schritte habe ich erfolglos probiert.

Die Gleisstücke passen in echt zusammen und auch im Gleisplan sieht es optisch ganz gut aus.

Trotzdem gibt es zwei rot markierte Stellen, die ich einfach nicht grün bekomme. Welche Schritte könnte ich versuchen, um die Anlage auch in der Simulation fahrbar zu machen?

MfG

vik

 

piccolo-04.mbp

 

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...