Jump to content

Code-Tags


Andy
 Share

Recommended Posts

Hallo Neo,
hat das Forum neben emoji, link und quote eventuell auch den Code-Tag? Wäre der ideale Zeitpunkt den freizuschalten. Gibt optisch vermutlich eine schönere Trennung im Lua-Tutorial und man könnte bei einem größeren Stück Code auch mal was in die Zwischenablage holen für's Browser-Lua.

Gruß
  Andy

Link to comment
Share on other sites

Vielen, vielen Dank, Neo!

@fex

Neo hat dir in der Antwort an Andy schon ein Beispiel gezeigt. 

Man kann Programmcode wie z.B. ein Lua Skript dank des neuen <> Knopfes jetzt in einen speziellen Kasten setzen. Der hebt diesen Teil im Postimng deutlich erkennbar als Programmcode ab. Und der Kasten verhindert, dass die Forensoftware im Code-Block Dinge eigenmächtig ändert. Es hat nämlich fatale Folgen, wenn z.B. bei der Eingabe der erste Buchstabe einfach in einen Großbuchstaben geändert wird.

Alles, was die Formatierung des Postings beeinflusst, nennt man "tag" (täg ausgesprochen). Ein tag ist in der englischen Sprache eine Kennzeichnung. Zum Beispiel die kleinen Schildchen, die man im Laden an der Kleidung findet.

Link to comment
Share on other sites

Hallo,

vor 2 Stunden schrieb Goetz:

Und der Kasten verhindert, dass die Forensoftware im Code-Block Dinge eigenmächtig ändert.

Ist das dann eventuell auch eine Möglichkeit, Content-IDs wie z.B. diese hier

B76E6A80-5D49-4DC8-8908-098BE1CB435F

"sicher" zu übertragen (also beispielsweisezu verhindern, dass die Foren-Software irgendwelche "Schmierzeichen" in den Zeichenstring hinein schmuggelt, sodass das damit identifizierte Objekt (hier ist es meine Gotthard-Anlage) nicht mehr aufgerufen werden kann?

Viele Grüße
BahnLand

P.S.:
Warum wird der String (zumindest bei mir) mehrfarbig angezeigt (teilweise türkis statt schwarz)?

Edited by BahnLand
Link to comment
Share on other sites

Hallo BahnLand,

leider nicht. Diese "Schmierzeichen" entstehen, wenn man die Content-ID markiert und die Foren-Software daraufhin dynamisch Code für "Auswahl zitieren" hinzufügt. Die Zeichen sind HTML-Steuerzeichen.

Ich werde in V5 aber eine Zusatzfunktion einbauen, die solche Sonderzeichen aus Content-IDs entfernt, wenn man sie im Studio einfügt, dann lösen wir das Problem auf "Empfängerseite".

Viele Grüße,

Neo

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...