Jump to content

"Milchglas-Effekt" bei Ansicht aus flachen Winkeln


Eggu

Recommended Posts

Insbesondere bei flachen Ansichten sieht die untere Bild-Hälfte wie hinter Milchglas aus.
Siehe Bild im Anhang, offenbar sind hauptsächlich/nur Baumgruppen betroffen.
Auf zwei verschiedenen Rechnern mit verschiedenen Grafikkarten das gleiche Phänomen.

Die horizontale Grenze ist etwa in Bildmitte, verschiebt sich aber leicht, je nach Winkel.
Wie man im zweiten Bild sieht, verläuft die Grenze für den vorderen Baum sogar tiefer als für den Rest, nämlich durch den Stamm.

Kennt jemand eine Erklärung ?

Gruß
Eggu

mbs-Milchglaseffekt.jpg

mbs-Milchglaseffekt-2.jpg

Link to comment
Share on other sites

Hallo Eggu,

diesen Effekt hab ich bislang noch nicht wahrgernommen und offensichtlich sonst auch niemand. Dein Post hab ich aber sehr wohl bemerkt.

Beste Grüße, Ralf

Edited by ralf3
Rechtschreibkorrektur
Link to comment
Share on other sites

vor 4 Stunden schrieb maxwei:

bist du da in der Cockpit-Ansicht?

Nein, Normalansicht.

Anlage als Entwurf vorhanden:
5FF0E088-C420-4ED6-8CB0-06F7334B265E

Gruß

Eggu

Link to comment
Share on other sites

Hallo @Eggu,

... wenn ich die Ebene "Tramsteig Bäume" ausblende ist der Effekt (fast) weg.

Ich habe allerdings noch ein Objekt "Gruppe Laub 001" auf der Grundebene gefunden, bei der der Effekt deutlich zu sehen ist.
GruppeLaub01.jpg.7edfc16400b7a3a715b006c931d2ba7a.jpg

... es scheint sich um ein Darstellungsproblem zu handeln mit Bäumen die Transparenzen verwenden... ist aber nur eine Vermutung.

Gruß
EASY

Edited by EASY
Link to comment
Share on other sites

Hallo @Eggu,

ich habe festgestellt, dass der Effekt genau durch jene Bäume verursacht wird, die aus dem Archiv stammen. Ersetzt man die archivierten Bäume auf der Anlage durch "aktuelle" Bäume des Online-Katalogs, verschwindet der Grauschleier, der sich übrigens bei einer Höhen-Veränderung der Kamera-Position verändert (ja flacher die Kamera-Position gewählt wird, umso niedriger ist der Grauschleier.

Bumeoriginal.thumb.jpg.ded5533365299556590cf237011f5497.jpg

Ich habe zur Demonstration die Bäume aus dem ersten Bild durch "aktuelle" Bäume aus dem Online-Katalog ersetzt. Hierzu habe ich aus Aufwandsgründen die "Ersetzen"-Funktion für einige Exemplare "Laubbaum ... Frühling",  "Laubbaum ... Sommer"  und "Laubbaum ...Herbst" verwendet, um mit wenigen Aktionen möglichst viele Bäume auswechseln zu können.

Bumeausgetauscht.thumb.jpg.2b58a1912cdc3eb60cf1bf10663cc911.jpg

Das Ergebnis ist im zweiten Bild sichtbar: Der Schleier ist weg. Allerdings habe ich beim Ersetzen nicht dieselben Bäume bekommen, weil die archivierten Baum-Modelle nun in Form von Variationen in einer kleineren Anzahl von Baum-Modellen zusammengefasst sind. Und ich habe es nicht geschafft, bei der Auswahl des Ersatzmodells eine bestimmte Variation anzugeben.. Weil deshalb immer die erste Variation aus dem Ersatzmodell verwendet wurde, sieht der Wald im unteren Bild etwas anders aus als im oberen Bild.

In diesem Zusammenhang 2 Fragen an @Neo:

  1. Ist der Schleier bei den archivierten Modellen auf einer Anlage ein Fehler oder "gewollt"?
  2. Gibt es eine Möglichkeit, bei der "Ersetzen"-Funktion nicht nur das Ersatz-Modell aus dem Online-Katalog insgesamt,, sondern auch eine bestimmte Variation des Modells auszuwählen, oder gibt es diese Möglichkeit heute nicht?

Viele Grüße
BahnLand

 

Link to comment
Share on other sites

Hallo,

die problematischen Bäume verwenden einen Trick, um von allen Seiten gleichmäßig beleuchtet zu werden, obwohl die Geometrie nur aus wenigen Ebenen besteht. Das hat früher funktioniert, aber seit V6 eine realistische Lichtberechnung verwendet (PBR), führt dieser Trick zu Fehlern, weshalb die Bäume auch archiviert sind und nicht mehr eingesetzt werden sollten.

Eine Auswahl der Variation beim Ersetzen ist aktuell nicht möglicht.

Viele Grüße,

Neo

Link to comment
Share on other sites

vor 23 Minuten schrieb Neo:

hat früher funktioniert, aber seit V6 eine realistische Lichtberechnung

Danke für die Erklärung.

Ist mir gar nicht bewusst, die Bäume aus dem Archiv geholt zu haben.
Hatte vor einigen Monaten mit der Anlage "frisch" begonnen und möglichst Low-Poly-Bäume genommen,
kann nicht mehr nachvollziehen, woher die stammten.
Voran gegangen war die Diskussion  bezügl. Sichtbarkeit von Bäumen/Büschen in der 2d-Ansicht.

Gruß Eggu

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
×
×
  • Create New...