Jump to content
Neo

Neue Beta-Version 3.1.0.0

Recommended Posts

Hallo,

heute habe ich eine neue Beta-Version für euch, mit einigen interessanten Änderungen:

Warentransport

  • Angeregt durch Franz' Warentransport-Experimente unterstützt das Studio nun echte Kräne, die beliebige Waren aufnehmen und wieder absetzen können. Ein Kran ist ein animiertes 3D-Modell, welches entweder manuell per Maus oder automatisiert per Ereignisverwaltung/Steuerschnittstelle angesteuert werden kann.
  • Ein Kran kümmert sich automatisch um alle Verknüpfungen mit dem Transportgut, sodass die Steuerung lediglich aus einfachen Befehlen besteht, wie "Transportgut anheben" und "Transportgut absetzen". Der maximale Einflussbereich wird im Planungsmodus visuell dargestellt.
  • Im Katalog finden sich bereits ein paar Beispielkräne: Turmkran, Lager mit Kran, Umschlagbahnhof, Brückenkran, Containerkran und Kleinkran mit Sockel. Zusätzlich können die Modelle Abstellfläche und Abstellfläche (transparent) als Platzierungen auf Bodenplatten oder Wagons genutzt werden. Dafür einfach die Flächen auf die Anlage ziehen und z.B. mit dem Wagon verknüpfen. Wird die Fläche anschließend als Ziel eines Krantransports ausgewählt, transportiert der Kran ein gewähltes Transportgut automatisch zum Ziel und verknüpft es. Alternativ können auch Waren selbst als Ziele dienen, um z.B. Container übereinander zu stapeln.
  • In den experimentellen Anlagen findet sich eine Beispielanlage Zugunabhängiger Warentransport, die die neuen (automatisierten) Kranfunktionen demonstriert
  • Eine Dokumentation zum Bau eigener Kranmodelle folgt

Performance-Optimierungen

  • Unterstützung von Direct3D 11. Die 3D-Engine des 3D-Modellbahn Studios nutzt nun standardmäßig die deutlich modernere Direct3D 11-Schnittstelle, statt wie bisher Direct3D 9. Das führt zu einer verbesserten Performance, besonders wenn Anlagen viele Objekte enthalten. Unterstützt die Grafikkarte kein Direct3D 11, wird automatisch die alte Direct3D 9-Schnittstelle verwendet.
  • Animierte 3D-Modelle führen nicht mehr zu zusätzlichen Unterobjekten, werden also schneller verarbeitet. In diesem Zusammenhang gibt es den Begriff "Unterobjekt" offiziell im Studio nicht mehr, da allein die Anzahl der verwendeten Materialien (Texturen, Farben) über die Verarbeitungsgeschwindigkeit eines 3D-Modells entscheidet.

Weitere Änderungen

  • Das Gizmo kann im Planungsmodus optional im Menü "Ansicht" deaktiviert werden
  • Modellanimationen, die den Namen _Time besitzen, werden automatisch mit der Simulationszeit synchronisiert. Damit können 3D-Modelle erstellt werden, die in der Anlage die Simulationszeit anzeigen.
  • Erweiterung von _RandomX, sodass per _RandomX-Y auch ein Bereich zwischen X und Y angegeben werden kann
  • Die Katalog-Datenbank kann in den Einstellungen exportiert bzw. gesichert werden. Es werden dabei nur die eigenen Inhalte in einer Zip-Datei archiviert, die bei Bedarf auch wieder zurückgespielt werden können. Dies erleichtert das Sichern der eigenen Anlagen und 3D-Modelle, ohne das gesamte Katalogverzeichnis kopieren zu müssen.
  • Erhöhung der maximalen Katalog-Cache-Größe auf 2 GB
  • Neues Schnittstellenkommando 133, um die Katalog-ID eines Objekts auf der Anlage zu ermitteln
  • Gleismodelle ohne Bettung besaßen eine andere Höhe als Gleise mit Bettung

Viel Spaß beim Testen,

Neo

Share this post


Link to post
Share on other sites

Ich habe heute einen weiteren Kran hochgeladen mit dem ihr, nach Neo's Freigabe, alles mögliche verladen könnt.
bild1295.jpg

Wundert euch bitte nicht über den seltsamen Namen "Hebelkran". Der kommt daher, dass es mein erster Kran war bei dem sich der Kranarm wie ein Hebel auf und ab bewegt.

HG
Franz

 

Share this post


Link to post
Share on other sites

Hallo Leute,

ich habe mir die Musteranlage für Warentransport angesehen. UMWERFEND! :D:D:D(y)

Viele Grüße aus Transdanubien,

Vermanus

Share this post


Link to post
Share on other sites

Der Gleiseditor lahmt !

wenn ich ein Gleis ändern will (Gleis auswählen und bearbeiten) dauert es unendlich lange, bis die Parameter angezeigt werden. Die Zuordnug einer neuen Gleistextur mit dem Button darunter funktioniert aber wie gewohnt schnell, wenn ich die Textur aus dem Verlauf entnehme.

Nächste Frage: ist die Zeichen-Eingabe in ein Textfeld irgendwie begrenzt - will sagen - findet irgendwann nach einer bestimmten Anzahl von Zeichen ein harter Zeilenumbruch statt ?

Die Performance ist laut FPS bei mir in Dingskirchen allerdings gesunken ....

grüßt aus einer aktuellen Bauphase ohne Warentransport

Henry

Share this post


Link to post
Share on other sites

Hallo Henry,

dauert der Start des Gleiseditors bei jedem Gleis lange, oder nur beim ersten Aufruf?

Von welchen Textfeldern redest du? Wenn es Begrenzungen gibt, dann können keine weiteren Zeichen eingegeben werden. Ein Zeilenumbruch findet normalerweise nirgends statt.

In welchem Verhältnis sind deine FPS gesunken? Welche Grafikkarte besitzt du?

Viele Grüße,

Neo

Share this post


Link to post
Share on other sites

Hallo Neo,

der Gleiseditor bleibt stur --- es dauert unendlich lange, das Programm stürzt zwar nicht ab, aber wenn ich mal zu anderen Programmen umschalte, komme ich irgend wann wieder in den Ausgangszustand, ohne etwas erreicht zu haben.

Ich meine das Textfeld in Zusätzlich/Beschriftung. Es geht darum, durch Kopieren von Sonder-Zeichen und anschließendem Einfügen die Zeichenkette im Textfeld sehr viel weiter zu verlängern. (Windings) Im Moment habe ich als Ergebnis einen ungewollten Zeilensprung --- kommt das durch den Kopiervorgang hinzu ?

Meine Grafikkarte ist eine AMD Radeon HD 6470m mit 1 GB Ram auf dem Laptop ....

Viele Grüße von

Henry

Share this post


Link to post
Share on other sites

Hallo,

MBS-Version 3.0.8.1

Probleme mit dem Gleiseditor kann ich nicht bestätigen... bei mir geht es ohne Verzögerung....

Das Textfeld scheint in seiner dynamischen Größenanpassung beschränkt zu sein.
Ohne Änderung der Schrifteinstellung (Schrift Tahoma) ergibt sich bei mir eine maximale Zeilenlänge von 58 Zeichen, wobei (spätestens) das 58. Zeichen ein Zeilenumbruch in der Eingabe sein muß.
In der 1. Zeile ist das 58. Zeichen ein Zeilenumbruch in der 2. Zeile das 59. Zeichen. Nach der 2. Zeile kann ich zwar weitere Eingaben machen... sie werden allerdings nicht mehr angezeigt (... der Zeilenumbruch wird noch dargestellt).
(Bei Tahoma "Bold" sind es max. 50 Zeichen je Zeile)

Beschriftung1.jpg

Beschriftung2.jpg

Gruß
EASY

Share this post


Link to post
Share on other sites

Hallo EASY

Zitat

Probleme mit dem Gleiseditor kann ich nicht bestätigen... bei mir geht es ohne Verzögerung....

ja - solange Du nur einige Gleise und sonst nichts auf der Bodenplatte hast --- sind jedoch im Umfeld rechlich 3D-Modelle vorhanden --- dauert es. Das betrifft auch Anlagen der Community - jedenfalls bei mir. In Version 3.0.5.0 läuft es besser - oder liegt es daran, das mein anderer Rechener etwas schneller ist ?

für mich ist das Problem gravierend und besteht weiterhin.

Das Textfeld verhält sich so wie von Dir beschrieben - die Anzahl der einstellbaren Zeichen bleibt limitiert. Danke für Deine Hinweise.

Gruß,

Henry.

Share this post


Link to post
Share on other sites

Hallo Henry,

... habe diverse "Große Anlagen" ausprobiert... und keine Probleme festgestellt. Liegt vielleicht doch an Deinem Rechner...

... ich spreche mal ins Unreine (da ich nicht weiß ob es hilft)...
... vielleicht mal versuchen die "Cache Größe" für den Katalog in den "Allgemeinen"-Einstellungen zu vergrößern? (...falls es Dein Speicherplatz hergibt...)

Gruß
EASY

Share this post


Link to post
Share on other sites

Nachdem wir jetzt in der Lage sind verschiedene Ladegüter durch die Gegend zu transportieren stellt sich die Frage: Wohin mit all dem. Und da bietet sich eine Verladung auf Schiffe an. Für diesen Zweck habe ich heute 2 Hafenkräne hochgeladen.

Hafenkran-Groß: Seine Traverse passt sich sowohl an die 40'er Container als auch an die 20'er Container automatisch an und da die Schiffe meist tiefer liegen als der Kran selbst kann er auch Abstellflächen unterhalb seines eigenen Standpunktes ansteuern.
bild1299.jpg

Da der Hafenkran-Groß eher selten zum Einsatz kommt da er auf Grund seiner Bauform sehr viel Platz einnimmt gibt es noch den Hafenkran-Klein. Auch er kann, wie sein großer Bruder, Ladegüter unterhalb seiner Standfläche erreichen.
bild1300.jpg

Viel Spaß damit und die abschließende Bitte an die Beta-Teilnehmer. Lasst doch mal "hören" wie ihr mit der "Verladerei" zurecht kommt.

HG
Franz

 

Share this post


Link to post
Share on other sites

Hallo EASY,

ich habe den Cache auf 2000 MB angehoben. Nun klappt es wieder.

Neo, Kann es sein, daß mit der Installation vom Update der Cache auf 1000 MB voreingestellt war ? Wie groß darf der Cache sein ?

Danke sagt

Henry

Share this post


Link to post
Share on other sites

Hallo Franz,

danke für die neuen Kräne, sehen wieder super aus! Gleichzeitig habe ich die alten Kräne in der Kategorie Landschaft/Industrie/Kräne ausgeblendet, damit dort nur noch die Funktionsmodelle erscheinen.

@Henry
Das neue Update hat die Maximalgröße von 1500 auf 2000 MB angehoben, den eingestellten Ist-Wert aber nicht geändert.

vor 23 Minuten schrieb Henry:

ich habe den Cache auf 2000 MB angehoben. Nun klappt es wieder.

Bedeutet das, dass das Gleiseditor-Problem bei dir nicht mehr auftritt, nachdem du die Cache-Größe geändert hast? Kannst du auch den umgekehrten Fall testen, indem du die Cache-Größe wieder verkleinerst?

Viele Grüße,

Neo

Share this post


Link to post
Share on other sites

Hallo Neo,

kann es sein, dass in der MBS-Version 3.0.8.1 die Fenster bei den Modellen stärker blinzeln (also von einem Zustand in den anderen wechseln). Besonders stark fällt mir das bei den Triebwägen der Bahn AG auf.

VGaÖ

Vermanus

Share this post


Link to post
Share on other sites

Hallo Vermanus,

was meinst du mit "blinzeln". Welche Modelle konkret sind betroffen?

Viele Grüße,

Neo

Share this post


Link to post
Share on other sites

Hallo Neo,

dass die Fensterscheiben wechseln, und halt blitzen. Aus dem Katalog der Triebwagen der Bahn AG rot und die 4-achsigen Personenwagen der Serie Eurofima.

VGaÖ

Vermanus

Share this post


Link to post
Share on other sites

Hallo Vermanus,

ich kann bei mir auch ein Flackern ausmachen, allerdings kann ich keinen Zusammenhang zu der neuen Version erkennen, soll heißen, deine genannten Modelle flackern auch schon in der alten Version. Kannst du bei dir prüfen, ob das Problem auch mit der alten Version auftritt? Dafür einfach die alte Version über die neue installieren (deine Anlagen bleiben dabei erhalten).

Viele Grüße,

Neo

Share this post


Link to post
Share on other sites

Hallo Neo,

ich habe folgende Tests gemacht - immer mit anderen Gleisen -

----------------------------

cache 2000 MB : Layer Steuerung und Vegetation unsichbar, ca. 27 FPS gerades Gleis

Starten bis zur Eingabe : 12 sek
Abbruch  dauert 3 sek

cache 2000 MB : Layer Steuerung und Vegetation sichtbar, ca. 17 FPS gebogenes Gleis

Starten bis zur Eingabe :  7 min 10 sek
Abbruch dauert 60 sek

-------------------------------

cache 1000 MB : Layer Steuerung und Vegetation unsichbar, ca. 27 FPS gerades Gleis

Starten bis zur Eingabe : 10 sek
Abbruch 17 sek

cache 1000 MB : Layer Steuerung und Vegetation sichtbar, ca. 17 FPS gebogenes Gleis

Starten bis zur Eingabe :  4 min 16 sek
Abbruch dauert 3 min 45 sek

-------------------------------

ich hänge meine Dingskirchen-Anlage, die sich im Umbau auf MBS V3 befindet, zum Testen bei. Es werden noch viele nicht optimierte 3D-Modelle und Bordmittel verwendet.

viele Grüße,

Henry

Dingskirchen - Museumsbahn 2016 MBS_V3.mbp

Share this post


Link to post
Share on other sites

Hallo Henry,

Deine 3-Schienen-Gleis-Kreationen auf der Dingskirchen-Anlage sind schon bewundernswert. (y)

Ich kann auf meinem Rechner Deine Probleme mit dem Gleiseditor nicht nachvollziehen. Ich habe auf Deiner Anlage aus dem obigen Link den Bogenwinkel des abzweigenden Gleises einer Weiche in "nullkommanix" von 22,5° auf 45° geändert (MBS-Version 3.0.8.1, Cache-Größe 1000 MB, FPS-Zahl in der eingestellten 2D-Sicht mit eingeschalteter Vetikaler Synchronisation 60,0, wenn ausgeschaltet zwischen 75 und 81 pendelnd).

Viele Grüße
BahnLand

 

Share this post


Link to post
Share on other sites

Hallo Henry,

wie bei BahnLand treten bei mir keine Probleme auf. Ich vermute daher, dass es sich bei dir um ein treibertechnisches Problem handelt. Ich werde voraussichtlich morgen eine neue Beta-Version veröffentlichen, bei der optional in den Einstellungen der alte Direct3D 9-Renderpfad aus der alten Version ausgewählt werden kann. Damit kannst du das Verhalten erneut prüfen.

Viele Grüße,

Neo

Share this post


Link to post
Share on other sites

Hallo Bahnland,

danke für den Test, es ist ja nicht gerade tröstlich, aber dann muß die Ursache wohl in meinem Rechner liegen.

Auf diesem läuft Windows 10 als Migration von Windows 7. Auf dem Rechner meiner Frau läuft Windows 10 als Migration von Windows 8.1. Dort kann ich wie Du zügig arbeiten.(auch bei cache=500).

Frage: Gibt es bekannte Unterschiede in der Ausführung der Systemkomponenten unter Windows 10 je nach Migration ?

So langsam fällt mir nichts mehr ein - außer das DirektX 11 nicht bei mir paßt.

Danke sagt

Henry

 

Edited by Henry

Share this post


Link to post
Share on other sites

Hallo,

ich habe eine neue Beta-Version veröffentlicht, die in den Grafikeinstellungen optional wieder die alte Direct3D 9-Schnittstelle aktiviert. Diese kann bei älteren Grafikkarten, deren Treiber nicht für Direct3D 11 optimiert sind, zu etwas besseren Ergebnissen führen.

Viele Grüße,

Neo

Share this post


Link to post
Share on other sites
vor 15 Stunden schrieb Neo:

Hallo Vermanus,

ich kann bei mir auch ein Flackern ausmachen, allerdings kann ich keinen Zusammenhang zu der neuen Version erkennen, soll heißen, deine genannten Modelle flackern auch schon in der alten Version. Kannst du bei dir prüfen, ob das Problem auch mit der alten Version auftritt? Dafür einfach die alte Version über die neue installieren (deine Anlagen bleiben dabei erhalten).

Viele Grüße,

Neo

Hallo Neo,

anbei 2 Videos (1 vorher, 1 nachher).

VGaÖV

filmchen.zip

Share this post


Link to post
Share on other sites

Heute noch die versprochenen Baukräne. Anfangs hatte ich vor nur einen Baukran zu bauen und den per Zwischenstück in die gewünschte Höhe zu bringen. Diese Idee gefiel Neo nicht besonders da er der Meinung ist, dass das zusätzliche Zwischenstück sehr oft übersehen werden. Also habe ich den Großen ein wenig "geschrumpft". Nun also 2 Baukräne. Einer für's Einfamilienhäuschen und einer für die höheren Gebäude. Und sollten die Beiden mal garnicht passen können sie immer noch über die Skalierung angepasst werden.
bild1305.jpg

Noch auf Neo's Freigebe warten und dann viel Spaß damit
Franz

PS Beide mit Sound "Baukran" der auch noch von Neo freigegeben werden muss

 

Edited by Franz

Share this post


Link to post
Share on other sites

Hallo Neo,

 mit Umstellung auf den Kompati-biligu-dingsbumsModus Direct3D 9 lief mein rechner wieder stabil.

nun bin ich aus dem MBS raus gegangen und habe mich nach einiger Zeit wieder ins MBS geschlichen ---

wo ich nunmehr abgemeldet bin (mich also wieder anmelden muß) und in den Einstellungen wieder meine Grafikkarte mit

AMD Radeon HD 6310 Graphics - (Direct3D 11, Feature Level 11_0)

vorgeschlagen bekomme. Das Kästchen beim Kompatibilitätsmodus Direct3D 9 ist nicht markiert.

Frage: muß ich mich nun jedesmal neu anmelden und vorher den Kompatibilitätsmodus setzen ?

fragt

Henry

Share this post


Link to post
Share on other sites

Hallo Henry,

die Einstellungen zum Kompatibilitätsmodus sollten eigentlich dauerhaft gespeichert werden. Hast du dich selber abgemeldet oder ist das auch ein unerwarteter Zustand? Hast du das Studio zwischendurch deinstalliert oder eine andere Version installiert?

Viele Grüße,

Neo

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×