Jump to content

Timba

Members
  • Content Count

    1089
  • Joined

  • Last visited

Posts posted by Timba

  1. Gerade eben schrieb Andy:

    Irgendwie scheine ich einfach anders zu denken.

    Du denkst anders als das MBS, heißt aber nicht, dass du falsch denkst. ;)

    Dass eine Funktion "anheben" auch absenkt (und umgekehrt), das findet man nur per Zufall heraus. Mit Denken hat das nichts zu tun.

    Gruß Timba

  2. Moin @Goetz

     

    vor 13 Stunden schrieb Goetz:

    Und sehen, dass du jetzt direkt im Programm genau das machen kannst, was du bislang mit Paint Shop erledigt hast.
    Nämlich Landschaften mit dem Pinsel glätten (und noch einiges andere mehr.)

    Naja, leider kann man nicht alles mit den Landschaftstools vom MBS machen, was die gängigen Grafikprogramme so drauf haben. Weichzeichner und ähnliche Features, mit denen Übergänge abgemildert oder angeglichen werden, wurden gerade angesprochen und das macht die "Gelände glätten"-Funktion vom MBS auch ganz hervorragend. Grafikprogramme haben allerdings auch die gegenteilige Funktion, sei es Kontrast erhöhen, Schärfen, Rauschen hinzufügen, und solche Dinge. So etwas würde ich mir auch noch wünschen, zum Beispiel um den Unterschied zwischen Berg und Tal zu verstärken oder um ein etwas zerklüftetes Landschaftsbild zu generieren. Ich hoffe, du verstehst, was ich meine. Reales Gelände ist ja nicht immer geglättet. Da ist jedenfalls noch viel Luft für weitere Landschaftstools. Aber möglicherweise geht meine Phantasie über das Machbare hinaus.

    Gruß Timba

  3. Moin Andy,

    ich verstehe dein Problem nicht ganz. Du möchtest eine bestimmte Fläche komplett auf eine Ebene mit beispielsweise 100 mm planieren? Dann kannst du auf "Gelände absenken" stellen, da hast du einen Grenzwert, stellst 100 mm ein, und fährst über die Fläche. Obwohl der Befehl "Gelände absenken" heißt, wird alles unter 100 mm angehoben und alles über 100 mm abgesenkt, sodass du eine 100 mm hohe Fläche erhältst.

     

    Gruß Timba

  4. vor 41 Minuten schrieb Goetz:

    Und diesen Fall hast du beim Zentralblock.

    Wenn der zweite Zug in Block 1 einfährt, meldet er schon Bedarf für Block 2 an. Damit er im Idealfall ohne Halt durchfahren kann.

    Und auch im Bahnhof, nämlich dann, wenn ohne Halt durchfahrende Züge bei der Einfahrt bereits die Ausfahrt mitbeantragen. Das hatte ich bereits bei meinen Experimenten. Ich versuchte, die Steuerung analog zu meinen selbstgestrickten Steuerungen mit V5 resp. V6 aufzubauen. Mit der Ausfahrt funktionierte es leider nicht immer, was ich mir zu dem Zeitpunkt nicht erklären konnte. Nun dämmert es mir.

    Nochmals Dank für die Nachhilfe.

    Gruß Timba

     

  5. Hallo @Goetz

    vor 3 Stunden schrieb Goetz:

    Aber wenn das Studio erneut den Befehl bekäme, eine Fahrstraße ins Gleis 1 zu stellen, dann würde dieser Befehl ignoriert werden, weil diese Fahrstraße aktuell schon aktiv ist. Es sei denn, du aktivierst die Option "Anforderung vormerken". In dem Fall würde auf die aktive Fahrstraße noch ein "Blockiert, warte auf Freigabe" obendrauf gesetzt.

    Vielen Dank! Sehr gut erklärt. Ich hätte gar nicht erwartet, dass dieser Fall eintreten kann. Um dieselbe Fahrstraße anzufordern muss Herkunft und Ziel des zweiten Zugs absolut identisch mit dem ersten Zug sein, sonst wäre es ja eine andere Fahrstraße. Bei der Herkunft (=vorausgehender Abschnitt) kann ja erstmal nur ein einziger Zug betroffen sein, für alle anderen ist der Abschnitt gesperrt, bis der erste Zug in die Fahrstraße zu Gleis 1 einfährt und den vorausgehenden Abschnitt freigibt. Bis der nachfolgende Zug herannaht und seinerseits die Fahrstraße zu Gleis 1 anfordert, ist der erste bereits am Ziel und die Fahrstraße aufgelöst (aber noch nicht frei). Na gut, bei entsprechend unterschiedlichen Längen der Abschnitte kann es vielleicht auch anders sein. Das ist im Moment auch nicht wichtig.

    Gut zu wissen, dass bei aktiven Fahrstraßen eine neue Anforderung ignoriert wird. Das war mir bisher nicht bekannt und ich hätte es wohl in den nächsten Tagen zu spüren bekommen und mir einen Wolf nach dem Fehler gesucht. Ist es nicht besser, die Funktion "Anforderung vormerken" generell zu setzen? Gibt es eine Situation, wo das nachteilig wäre?

    Gruß Timba

     

  6. Am 13.9.2021 um 08:49 schrieb Neo:

    Erweiterung der EV-Aktion "Fahrstraße aktivieren/deaktivieren" um eine Option "Anforderung vormerken", um aktive Fahrstraßen anschließend erneut zu aktivieren (wichtig für Zentralblöcke)

    Diese Funktion wurde gerade kürzlich schon einmal erwähnt. Irgendwie habe ich Nutzen und Verwendungszweck noch nicht erkannt. Könnte mir vielleicht einer, der darüber besser Bescheid weiß als ich, etwas detaillierte Nachhilfe zukommen lassen? Also etwa Funktionsweise, Vor- und Nachteile, etc.

     

    Gruß Timba

  7. vor 2 Minuten schrieb Markus40:

    Auch wenn's dauert es wird sich sicherlich lohnen.

    Richtige Einstellung! Der Lohn ist die Freude am eigenen Tun und keiner von uns hier arbeitet im Akkord.

  8. vor 30 Minuten schrieb Markus40:

    ja sie sind verschwommen und man kann die Details nicht richtig sehen.

    Hatte ich mir gedacht. Ist natürlich klar, wenn du einen Screenshot von einer relativ großen Fläche deiner Stadt machst, ist die Auflösung nicht besonders. In solchen Fällen, wenn ich eine bessere Detailtiefe sprich: höhere Auflösung brauche mache ich mir Screenshots von kleineren Flächen (zoome die Ansicht weiter heran) und füge diese mit einem Grafikprogramm wieder zusammen. Aber ich muss dich warnen, das ist eine ziemlich zeitaufwendige Aufgabe. Ich weiß nicht, ob du dir das antun willst. Aber eine andere Möglichkeit sehe ich nicht, wenn es dir um Präzision geht. Die Alternative wäre eben, auf Präzision bei der Originaltreue zu verzichten und sich nur vage am Oriiginal zu orientieren.

    Gruß Timba

  9. vor 30 Minuten schrieb Markus40:

    ber die screenshot bei Google Maps sind auch nicht das ware.

    Inwiefern? Sind sie dir nicht scharf genug oder fehlen in den Karten Informationen, die du brauchst?

  10. Moin,

     

    vor 4 Stunden schrieb Hawkeye:

    Ist damit das Auswahlfeld  „Anforderung vormerken“ bei „Fahrstraße aktivieren/deaktivieren“ gemeint?

    Wo findet man dieses Auswahlfeld? Das habe ich gar nicht. Habe ich aus Versehen die V7 light gekauft? :D

     

     

    vor 2 Stunden schrieb Neo:

    wenn du mehrere Fahrstraßen aktivierst, hast du danach aktuell keine Möglichkeit zu bestimmen, welche dieser wartenden Fahrstraßen als nächstes an der Reihe ist.

    Das hast du an anderer Stelle schon mal erklärt. Wenn man's weiß, kann und muss man damit leben. Nur ist das meiner Meinung nach der einzige Kritikpunkt an der sonst ganz hervorragenden Fahrstraßenfunktion. Insbesondere bei miteinander konkurrierenden Fahrstraßen würde ich mir eine Abarbeitung nach FIFO wünschen, damit es berechenbarer ist, welcher Zug wann fährt. Dieses "Überraschungsei" gefällt mir überhaupt nicht.

     

    Gruß Timba

  11. vor einer Stunde schrieb Goetz:

    Sonst würden sich die Zungen beider Weichen berühren.

    Nach dieser Darstellung bei Wikipedia berühren sie sich nicht, aber keine Ahnung, ob die Grafik authentisch ist. Viel spannender finde ich eigentlich die Frage, wie das in der Realität gebaut wird. Ich hatte noch nie Gelegenheit, den Neubau einer Bahnstrecke live aus der Nähe anzusehen. Die werden wohl kaum wie im MBS fertige Schienen komplett mit Schwellen verlegen, sondern ich vermute mal, Schotter, Schwellen, Eisen und Schrauben werden einzeln angeliefert und vor Ort zusammengebaut. Vermutlich auch die Weiche, oder? Da kann man auch nicht gerade den Lehrling dranlassen, damit das auch nachher alles wunschgemäß funktioniert.

    Gruß Timba

  12. vor 14 Minuten schrieb HaNNoveraNer:

    Eine Abfrage in einer Schleife auf FREI würde also schon irgendwie Sinn machen.
    Das Problem ist nur, daß diese nur einmal ausgeführt werden kann,

    Naja, du kannst die Abfrage ja auch so programmieren, dass sie sich immer wieder selbst aufruft bis sich ein Erfolg einstellt. Kommt halt immer darauf an, in welcher Situation welche Herangehensweise die beste ist.

  13. vor 3 Minuten schrieb Neo:

    ja, sie würde dann aktiv bleiben und von einem anderen Zug genutzt werden.

    Möglicherweise in einer Situation, wo das überhaupt nicht gewollt ist. Wäre mir dann schon lieber, die Anforderung wieder aufzuheben. Das wiederum könnte sich als schwierig gestalten, falls es noch eine weitere gleichlautende Anforderung gibt.

    vor 5 Minuten schrieb Neo:

    Die Abfrage über die EV, ob eine Fahrstraße frei ist, bau ich aber auch gern mit in eines der nächsten Updates ein, intern gibt es ja bereits die vollständige Prüfung.

    Das wäre sehr hilfreich. Bis dahin behelfe ich mir lieber mit der Abfrage, ob das Gleis belegt ist. Ist ja im Grunde auch nicht viel anders.

    Danke erstmal

     

    Gruß Timba

     

  14. vor 2 Minuten schrieb Neo:

    Alternativ kannst du auch einfach beide Fahrstraßen aktivieren, das Studio wählt immer automatisch eine freie Straße.

    Eine Idee, die zu überlegen wäre. Allerdings muss für die dann nicht benötigte Fahrstraße die Anforderung dann explizit wieder zurückgenommen werden, da sie ja sonst in der Warteschlange bleibt, oder? Das könnte noch eine kleine Herausforderung werden.

    Gruß Timba

  15. Offenbar habe ich mich missverständlich ausgedrückt. Ich versuche mal eine bessere Erklärung.

    Zug 1 fährt auf Fahrstraße a in den Bahnhof auf Gleis 3 und bleibt dort stehen. Fahrstraße a wird aufgelöst und Status ist 0.

    Zug 2 kommt entweder auf demselben Weg oder aus entgegengesetzter Richtung und würde gerne vorzugsweise ebenfalls Gleis 3 nutzen, alternativ aber auch mit Gleis 2 zufrieden sein. Deshalb muss eine Prüfung erfolgen, ob Gleis 3 frei oder besetzt ist.

    Statusabfrage Fahrstraße a ergibt 0. Hilft in dem Fall nicht, weil Fahrstraße inaktiv ist zwar korrekt, aber frei ist die Fahrstraße ja trotzdem nicht. In dem Moment ist noch nichts blockiert.

    Erst wenn Zug 2 eine Fahrstraße zu Gleis 3 zugewiesen bekommt, tritt die Blockade ein. Ich wüsste es gerne vorher, um wie gesagt dem Zug eine Alternativroute anzubieten.

    Ist es so besser verständlich?

    Gruß Timba

  16. Moin,

    ich hätte auch noch eine Frage zum Thema Fahrstraßen.

    Wenn ein Zug das Ende der Fahrstraße erreicht hat, wird die Fahrstraße aufgelöst. Die Fahrstraße hat den Status 0 (inaktiv). Er steht aber noch auf dem Gleis, sprich: Wirklich frei ist die Fahrstraße ja nicht. Will nun ein anderer Zug dieselbe Fahrstraße nutzen oder eine andere Fahrstraße, die jedoch über dasselbe Gleis führt, dann bekommt er eine "Blockiert"-Meldung. So weit korrekt und verständlich. Kann man diesen Status irgendwie abfragen? Also, die normale Statusabfrage hilft in dem Fall ja nicht, sie gibt "0" zurück. Möglich wäre die Bedingung "Fahrzeug steht auf einem Gleis". Gibt es noch eine elegantere Möglichkeit?

     

    Gruß Timba

  17. vor 1 Minute schrieb HaNNoveraNer:

    Hier gibt es scheinbar ein Timingproblem in der Wiederholung.
    Verzögerungen und Laufzeiten von Animationen machen da Probleme.

    Daher schalten die Formsignale nicht richtig.
    Ergo wird auch der Wert an der falschen Stelle eingetragen.

    Hm ... ja, klingt wie eine schlüssige Erklärung. Wie soll man das umgehen? Auf Wiederholungen verzichten und für jedes Signal einen eigenen EV-Eintrag? Dann kann man es auch gleich selbst mit der Hand machen. Ein Befehl, der die Simulation anhält bis die Animation abgeschlossen ist, wäre hilfreich.

    By the way, wird die Animation überhaupt durchgeführt? Zu sehen ist nichts auf dem Monitor, wenn 16 Signale per Wdh zunächst auf 1 und dann wieder auf 0 geschaltet werden. Nur die Protokollierung zeigt an, dass da was war.

    Gruß Timba

  18. vor 7 Minuten schrieb Hawkeye:

    Zuerst das Signal auf Fahrt „1-Hp1“ stellen, dann erst über die EV den neuen Wert für „Beschleunigungen auf XX km/h“ z..B. vom Zs3 eintragen. 

    Moin Hawkeye. Genau so. Nur scheint es nicht immer zuverlässig zu funktionieren, warum auch immer.

    Gruß Timba

     

  19. vor 1 Minute schrieb Goetz:

    Der Wert wird immer für die Stellung eingetragen, die das Signal aktuell hat.
    Und wenn die Beschleunigung in dieser Stellung deaktiviert ist, dann siehst du den Wert hier nicht.

    Moin Goetz, ja, das hatte ich ja schon selbst rausgefunden, wie ich schrieb. Im Nachhinein erscheint es mir auch logisch. Aber ich schätze, ich bin nicht der einzige, der zunächst darauf reinfällt und diesen Umstand nicht beachtet. Deswegen wäre es ja hilfreich, wenn irgendwo ein Hinweis darauf stünde.

    Nur habe ich dann ja mein Experiment so konfiguriert, dass alle Signale auf "Fahrt" geschaltet werden, bevor der Beschleunigungswert übermittelt wird und analog dazu auf "Halt", um den Verzögerungswert einzutragen. Trotzdem funktioniert es bei einigen Signalen nicht.

    Gruß Timba

  20. Moin,

    mir ist ein seltsames Verhalten des MBS aufgefallen. Ausgangslage war, ich wollte den Wert der automatischen Beschleunigung in allen Signalen ändern. Um es einfacher zu haben machte ich das über die EV mit einer Wiederholung. Stutzig wurde ich, als die Änderung nicht an allen Signalen durchgeführt wurde. Um der Sache auf den Grund zu gehen habe ich auf einer neuen Platte 16 Signale aufgestellt und experimentiert.

    Zunächst mal scheint es so, dass der neue Wert nur dann übernommen wird, wenn das Signal in der "richtigen" Position steht, d.h. auf "Fahrt", um die autoAcceleration einzutragen und auf "Halt" für die autoDeceleration. Falls das so beabsichtigt war, ist es ja ok, müsste dann nur entsprechend kommuniziert werden, weil auf die Idee kommt man nicht sofort.

    Merkwürdig ist allerdings, dass ein Script namens "Prüfung", mit dem ich die Werte via Protokoll auslesen kann, anzeigt, die Werte seien korrekt übernommen, an einigen Signalen (nicht allen!!!) aber dennoch der alte Wert eingestellt ist. Das kapiere ich nicht. Ich habe mein Experiment erstmal abgebrochen, da ich nicht richtig schlau daraus werde. Vielleicht kann mal einer der Profis hier drüberschauen.

    Gruß Timba

     

    Protokoll:

    2021-10-11_095438.jpg.8f943917b1e13fbc0337bdaa5a98bfa1.jpg

     

     

    Eintrag am Signal:

    2021-10-11_095624.jpg.80d4f5e8200d97c977244f73c48a9eae.jpg

     

    Die Versuchsanlage:

    Signaltest.mbp

     

  21. vor 1 Stunde schrieb Neo:

    Das virtuelle Depot ist für die "Masse" gemacht, also unbegrenzt viele Züge, die nicht individuell gesteuert werden, sondern anhand von Vorschriften, z.B. in Form von Schlagwörtern oder Eigenschaften. Diese von einzelnen Zügen losgelöste Steuerung empfehle ich dir auch Abseits von Depots, denn dann kannst du einfach neue Züge auf die Anlage setzen oder davon entfernen, ohne die EV anpassen zu müssen.

    Ja, das wurde mir schon vermittelt und darum bemühe ich mich bereits. Auch in der Vorgängerversion schon. In diesem Testaufbau ging es mir darum, zu einem beliebigen Zeitpunkt einen beliebigen Zug ins Depot zu schicken und ebenso wieder herauszuholen. Das geht ja eigentlich nur manuell und dafür habe ich mir die Schalter aufs Brett gestellt, für jeden Zug einen, um den Befehl "ab ins Depot" auszugeben. Die Fahrt dahin geht dann wiederum anhand von Vorschriften vollautomatisch. Genauso wollte ich den Zug per Knopfdruck wieder aus dem Depot holen, also nicht den ersten, nicht den letzten, nicht irgendeinen zufälligen, sondern einen bestimmten. Das geht offenbar nicht per Knopfdruck. Aber nicht so wild, ich habe eine andere Lösung gefunden. Ist ja eh nur, wie gesagt, ein Testaufbau, um die Arbeitsweise der neuen Funktionen besser kennenzulernen. Besonders die Fahrstraßen finde ich sowas von geil, nachdem ich kapiert habe, wie man sie sinnvoll einsetzt. (y)

    Gruß Timba

×
×
  • Create New...