Jump to content

Timba

Members
  • Content Count

    1089
  • Joined

  • Last visited

Posts posted by Timba

  1. vor 2 Stunden schrieb Andy:

    Von einem Spline könnt ihr doch nicht erwarten, dass er da noch viel modifiziert. Die Tatsache, dass er überhaupt Wassertextur kann, ist doch schon toll!

    Wie du weißt habe ich von solchen Dingen keine Ahnung. Wenn es nicht geht, dann geht es halt nicht. Ich dachte eben, dass sei texturmäßig alles egal.

  2. vor einer Stunde schrieb Bobah:

    interessant wäre wie sich Übergange realisieren lassen...wahrscheinlich klassisches Fading^^

    Das wäre sicher eine Herausforderung. Spontan wäre meine Idee, einen Übergang mit einem Grafikprogramm herstellen, das JPG in eine Textur konvertieren und auf eine Ebene kleben, Transparenz des Wassers etwas erhöhen und dann die Ebene unters Wasser schieben. Hast du ne bessere Idee? ;)

  3. vor 44 Minuten schrieb Andy:

    in Richtung türkis, ja

    Seestraßensuppe:
    Ich bin mal im Februar auf dem Frankfurter Flughafen runtergekommen - von Schweden kommend. Dort voll reflektierendes Blau oder zugefrorenes Weiß und hier?
    Der Main k...braun (Schneeschmelzeeffekt?) und die Autobahnen randvoll. Da wollte man eigentlich gar nicht landen und gleich wieder umkehren.

    Gruß
      Andy

    Eigentlich hätte ich von dir jetzt goldgelb erwartet, um das Wasser darstellen zu können wie es aussieht, wenn die Modellbahnbrauerei überschüssige Ware in den Modellbahnfluss ableitet. :D

  4. vor 17 Stunden schrieb Neo:

    Was hättest denn gerne?

    Frei wählbar, wie bei den anderen beiden Wasser-Elementen. Oder ist das ein unverschämter Wunsch? ;)

    Könnte man nicht stattdessen die Flussbreite über Animation steuern, so wie es @BahnLandbei einigen Tunnelportalen realisiert hat?

    Gruß Timba

  5. Moin,

    das neue Element "Wasser (Fluss)" [Content-ID 502BC75D-D028-4114-8951-69ED5CFC797C] ist durch seine Ausgestaltung als Spline für Flüsse gegenüber "Wasser (rechteckig)" und "Wasser (kreisförmig)" im Vorteil, keine Frage. Was ich allerdings sehr vermisse ist die Möglichkeit der Farbänderung, wie sie bei den beiden letztgenannten vorhanden ist.

    2021-10-23_091949.jpg.a6aa053124d3528630d12f62e3fb49a2.jpg

    An die Stelle wurden Variationen der Flussbreite gelegt. Schade, nun sind Abweichungen vom chemisch sauberen Standardwasser nicht mehr möglich. Keine bräunliche Verfärbung durch Schlammeintrag, keine grünliche Verfärbung durch Algenbefall, leider nicht mehr möglich. Gibt es vielleicht eine Möglichkeit, die Farbänderung auch für "Wasser (Fluss)" einzurichten und die Flussbreitenvariationen irgendwie auf andere Weise anzubieten?

    Gruß Timba

  6. @Neo

    Moin,

    ein kleiner Schönheitsfehler: Wenn man in der Geländegestaltung den Schieberegler für Größe oder Stärke bewegt und den Wert verstellt und anschließend im Hauptfenster denselben Wert mittels Mausrad weiter verstellt ohne zuvor einen Klick auf die Landschaft auszuführen, dann wird nur die Prozentzahl verändert, aber der Schieberegler bleibt unverändert am Fleck. Erst nach einem Klick in die Landschaft wird es wieder "normal". Die Funktion ist aber nicht betroffen. Es liegt wahrscheinlich daran, dass das Steuerelement Schieberegler noch den Focus hat, solange kein anderes Steuerelement angewählt wurde, aber irgendwie sieht es trotzdem komisch aus, wenn die Prozentzahl auf 1% steht und der Schieberegler ganz rechts am Anschlag.

    Gruß Timba

  7. Moin,

    wenn Einrasten ganz sicher aktiviert ist,

    Bild1.jpg.473226079e850490a2ff3a0c72ed95ea.jpg

    dann müssen die Gleise andocken und das tun sie auch. Ab einer Nähe von ca. 20 mm (H0) rasten sie ein, wobei es keine Rolle spielt, ob das anzufügende Gleis etwas verdreht ist. Der einzige Grund, der mir einfällt, warum es bei dir nicht klappt, ist, wenn die Gleise auf unterschiedlicher Höhe sind. Beim Gleisverlegen bin ich selbst lieber im 2D-Modus, daher kommt mir der Verdacht, das könnte bei dir auch der Fall sein. Im 2D-Modus siehst du nicht, auf welcher Höhe sich das Gleis befindet. Am besten lässt du die automatische Höhenanpassung (Gelände) auch aktiviert.

    Bild2.jpg.e26299cd9489a0e74317d3486a71f51a.jpg

    Dann sollten die Gleise auch in der Höhe zueinander passen, falls du nicht zuvor "in der Luft" gebaut hast. Gegebenenfalls kannst du unten rechts im Eigenschaftsfenster überprüfen, ob beide Gleise auf derselben Höhe liegen. Unter Position z ist die Höhe eingetragen.

    Bild3.jpg.270165222c3cd1411e86899e41f9af58.jpg

    Gruß Timba

  8. vor 29 Minuten schrieb Andy:

    Das sollte so ja nicht passieren. F4 ist auch oft entschieden länger blockiert als optisch nötig. Merkwürdig.

    Dieses merkwürdige Phänomen habe ich auch gestern gehabt. Vielleicht hat es gar nichts mit dem hier vorliegenden Fehler zu tun, aber es ist ein Versuch, der nicht viel Arbeit macht. Das merkwürdige Verhalten bei meiner Anlage war durch nichts zu erklären, es waren definitiv keine anderen Fahrzeuge beteiligt, in der Fahrstraßenauflistung wurden keine Fehler angezeigt, die orangenen Linien der Fahrstraßen waren genau da, wo sie auch sein sollten, alles total chic und trotzdem war die Fahrstraße einen Moment lang blockiert ohne Grund. In meiner Hilflosigkeit habe ich dann einfach die Fahrstraße komplett gelöscht und anschließend neu eingerichtet. Oh Wunder, da war's ok. Das heißt, es kann auch mal ein winziger Fehler in der Fahrstraße sein, der mit bloßem Auge nicht erkennbar ist.

    Gruß Timba

  9. Am 17.10.2021 um 21:29 schrieb Goetz:

    die Geschwindigkeit, die du in Kontakten für die Beschleunigung einstellst, ist nur der Minimalwert.
    Ein langsamerer Zug wird hier beschleunigt, aber ein schnellerer wird nicht gebremst.

    Das ist zwar insofern sachlich richtig, da hier nur die Geschwindigkeit für die Beschleunigung erwähnt wird, gleichzeitig ist der zweite Satz aber irritierend für Anwender, die sich noch nicht so gut auskennen. Dieser könnte auf die Idee kommen, ein schnellerer Zug könnte nicht gebremst werden. Der Vollständigkeit halber sollte erwähnt werden, dass man auch beide Häkchen (Beschleunigen UND Abbremsen) setzen und beiden dieselbe Geschwindigkeit einrichten kann. Dann verlässt der Zug den Gleiskontakt immer mit derselben Geschwindigkeit, egal ob er schneller oder langsamer angekommen ist.

     

    2021-10-19_015823.jpg.1ca967a8d76e5bf453c97864b724a126.jpg

    Gruß Timba

  10. Nachtrag zum vorherigen Beitrag:

    Es ist ein Bug. Ich habe den Teil der EV nach Lua konvertiert und den Begriff 'contact' durch 'vehicle' ersetzt, klappt alles wunderbar. Es ist also seitens der Programmierung so wie überall im Programm vorgesehen, nur die grafische EV bietet die Auswahl nicht an. Bitte bei Gelegenheit korrigieren, @Neo.

    Gruß Timba

  11. @Goetz, das mit der Aufzeichnungsmöglichkeit in Win10 kannte ich noch gar nicht. Vielen Dank für den Tipp. Zuerst dachte ich, du willst mich auch den Arm nehmen und meinst die Aufzeichnungsmöglichkeit aus dem MBS. Da hätte ich ja eine Woche oder mehr gebraucht, so langsam wie die ist. :D Aber das mit Win10 ist eine geile Sache. Das kann ich sicher gut gebrauchen hier und da. Im konkreten Fall wäre mir aus gewissen Gründen ein Stopp dennoch lieber gewesen. Ein praktisches Werkzeug ist es aber trotzdem auf jeden Fall. Super!

    Gruß Timba

  12. vor einer Stunde schrieb Neo:

    die Existenz der Ereignis-Protokollierung wird ja gleichzeitig als "Debug-Modus" interpretiert, weshalb ich zusätzliche Stopp- oder Trace-Befehle zunächst sein lassen wollen würde. Mir erscheint es zunächst sinnvoller, die Protokollierung vieler Ereignisse dahingehend zu verbessern, dass sie keinen Einfluss auf die Performance der Anlage hat. Zwar gibt es hier schon eine bestimmte Asynchronität, aber diese ließe sich noch verbessern.

    Grundsätzlich gebe ich dir völlig recht. Leuchtet ein. Aber du kennst das MBS besser als ich und weißt, dass die Rekonstruktion einer bestimmten Situation via Protokollierung eine recht aufwendige Angelegenheit ist. Wer stand wo zu einem gegebenen Zeitpunkt, usw. Es gibt Situationen, die sich besser via Protokollierung aufklären lassen und es gibt Situationen, bei denen ein Blick auf die Anlage der bessere Weg ist, die Geistesblitze zucken zu lassen. Bei letzterem ist eben nur der exakte Zeitpunkt wichtig. Per Hand stoppt man die Sim die entscheidenden Sekunden zu spät, leider.

    Aber nicht so schlimm, wenn es derzeit keinen Stopp-Befehl in der EV geben kann, mit der Protokollierung geht es ja und die damit verbundenen Performance-Einbußen sind während des Testens zu verschmerzen.

    Danke für die Antwort.

     

    Gruß Timba

  13. Moin,

    die Idee war, in einem bestimmten Bereich manuell zu steuern und um nicht für jedes Fahrzeug einen Regler einzurichten, nur einen zu benutzen und diesen mit der jeweiligen Lok zu verbinden, sobald diese den Bereich betritt und den entsprechenden Gleiskontakt auslöst.

    Problem ist, bei Ziel (Auslöser) wird mir nur der Gleiskontakt angeboten. Der Begriff Fahrzeug fehlt, im Gegensatz zum sonst üblichen Erscheinungsbild. Ist das nun ein Bug oder ist das aus irgendeinem Grund so gewollt und was wäre dann wohl der Grund dafür?

     

    2021-10-18_203357.thumb.jpg.7a9bd89c003e391530facafd51ea4a39.jpg

     

    Gruß Timba

     

  14. Hast du es schon versucht? Funktioniert nicht. In der grafischen EV kannst du sowieso nur das einrichten, das es gibt. Also habe ich eine Lua-Abfrage eingerichtet.

    if $("24612").acceleration == 0 then
    end

    Das Objekt ist eine Weiche. Ist natürlich völliger Blödsinn, eine Weiche kann nicht beschleunigen. Und was macht MBS? Ignoriert es einfach.

    Nein, Neo hat das Ding einfach zu gut programmiert, so leicht lässt es sich nicht austricksen. :D

  15. Nenn mal ein Beispiel für eine ungültige Abfrage. Das, was ich gerade als ungültige Abfrage mir ausgedacht habe, wird einfach ignoriert. Da passiert nix, weil das ja gar nicht ausgeführt werden kann, logisch, da bleibt aber auch nix stehen. Nur wenn ich die Protokollierung dazuschalte, hält die Sim an. Das erreiche ich aber auch mit einem kleinen Lua-Einzeiler, wie oben schon geschrieben. Aber trotzdem danke, dass du versucht hast, mir eine Hilfe zu geben. (y)

  16. Hallo @Neo,

    wäre es vielleicht möglich und umsetzbar, der EV eine Aktion hinzuzufügen, welche die Simulation pausiert, so als würde ich oben in der Menüleiste die Pause-Taste drücken? Das wäre beim Austesten bestimmter Situationen oder bei der Fehlersuche hilfreich. Man könnte z.B. ein bestimmtes Ereignis und eine Bedingung festlegen, bei deren Eintreffen dann alles schlagartig einfriert und kann sich dann in Ruhe die Situation ansehen und analysieren. Zwar lässt sich das momentan auch über Lua erreichen mit 'error ("Message")', aber dann muss zwingend die Protokollierung mitlaufen, sonst bleibt das Ding nicht stehen. Ohne die Protokollierung ist die Grafik flüssiger, weshalb ich die Protokollierung nur mitlaufen lasse, wenn's unbedingt nötig ist.

    Gruß Timba

  17. Gerade eben schrieb Goetz:

    Stimmt das?

    Nein.

    vor 1 Minute schrieb Goetz:

    Denn in der Praxis erweist sich das Verhalten so, wie es jetzt ist, als ungemein nützlich.

    Nützlich ja, aber es macht keinen großen Unterschied, ob ich die Absenken-Funktion oder die Anheben-Funktion wähle. Darauf wollte ich hinaus. Es geht halt mal die eine Seite langsamer, mal die andere, genau wie du schriebst. Ok, wenn man das für einen Riesenunterschied hält, will ich nicht widersprechen. Für mich ist es das nicht. So wie ich es in meinem Vorschlag formulierte, wäre es ein echter Unterschied. Eben auch im Ergebnis!! Du musst zugeben, wenn ich die Funktionen Anheben und Absenken, so wie sie im Moment sind, nutze und die Maustaste lange genug gedrückt halte, dann ist das Ergebnis absolut identisch.

  18. Hallo @Andyund @Goetz,

     

    vor 2 Stunden schrieb Goetz:

    Was auf der einen Seite der Grenze liegt, ändert sich schlagartig, das andere langsam und kontinuierlich.

    Wenn du anhebst, steigt alles unterhalb der Grenze langsam an. Was schon darüber liegt, wird sofort abgesenkt.
    Beim Absenken passiert genau das Gegenteil.

    so ist es und daraus folgt, dass der Unterschied nur marginal ist. Je nachdem, wie Neo die dritte Funktion (Planieren) ausgestaltet könnte es dann noch einen dritten Weg geben, der ähnlich funktioniert, indem dort beide Seiten kontinuierlich geändert werden (oder beide schlagartig). Meiner bescheidenen Meinung nach wäre das unnötig. Wenn ich einen Vorschlag machen dürfte, sollten (jeweils bei eingeschalteter "Grenze"!!!) bei "Anheben" nur Punkte angesprochen werden, die unterhalt der Grenze liegen, aber keine Punkte abgesenkt werden; bei "Absenken" nur Punkte angesprochen werden, die oberhalb dieser Grenze liegen, aber keine angehoben werden; und schließlich bei "Planieren" sollten alle Punkte auf die gewünschte Grenze gebracht werden. Dann wären die Funktionen tatsächlich "echt" unterschiedlich, also auch vom Ergebnis her und nicht bloß von der Arbeitsweise, und jede Funktion wäre auf ihre Weise sehr nützlich. Was meint ihr dazu, und vor allem, was meint @Neo dazu?

    Gruß Timba

  19. Andy, ich kann mir nicht vorstellen, dass die "Planieren"-Funktion nach Einrichten einer Grenze anders funktioniert als die Funktionen "anheben" und "absenken" jetzt. Aber wir werden sehen. Um nicht unerwünschte Landschaftsteile beim Planieren/Glätten versehentlich zu beeinflusssen ist es vorteilhaft, den Radius der Werkzeugs möglichst klein zu halten. So meine Erfahrung. Dann fällt auch eine "unruhige Hand" nicht so ins Gewicht. Sehr hilfreich wäre hier allerdings die Möglichkeit einer "Maskierung", wie man sie auch bei Grafikprogrammen kennt. Also in der Form, dass man bestimmte Flächen temporär einfärbt und die sind dann für das jeweilige Bodentool tabu. Aber wie ich vorhin schon in einem anderen Faden schrieb, geht die Phatasie mit mir manchmal durch, d.h., wenn das alles umgesetzt würde, hätten wir am Ende keine Eisenbahnsimulation mehr, sondern ein 3D-Grafikprogramm. :D

    Gruß Timba

×
×
  • Create New...