Jump to content

Recommended Posts

@Andy

Am 22.9.2019 um 21:56 schrieb Andy:

Wenn da nicht noch Beta draufstehen würde,

meinst Du damit Blender 2.8?
Das gibt es inzwischen als stabile Version v2.80.75 (auch als Portable) und das stürzt nicht mehr ab, jedenfalls nicht bei mir.

Nur mal so zum Üben habe ich eine Euro-Palette gebaut ...

Palette_alt.thumb.jpg.52ccfada16515b10e915d5d2c0c0466e.jpg

(den grauen Hintergrund habe ich mir bei @Roter Brummer "geklaut" :P)

... nun ja, so richtig Freunde sind der Blender 2.8 und ich noch nicht geworden.
Die Oberfläche ist für mich noch sehr gewöhnungsbedürftig.
Flüssiges arbeiten, wie mit der "alten" Version, ist da noch nicht drin, dafür muss ich noch zu viel suchen, aber ich bleib dran und deshalb wird es von mir (vorläufig) keine neuen Modelle mehr geben.

Schöne Grüße
SputniKK

 

Share this post


Link to post
Share on other sites
vor 4 Minuten schrieb SputniKK:

stabile Version v2.80.75

Ja, die habe ich. Wollte auch schon einen Bug-Report machen. Aber da muß man sich als Developer anmelden. Habe ich jetzt keine Lust drauf.
Ein 2.81er ist auch schon in Bau.
Wahrscheinlich habe ich mit der Umstellung nicht so viele Probleme gehabt wie ihr, weil ich sowohl im Alten, als auch im Neuen suchen muß. ;)

Share this post


Link to post
Share on other sites

Hallo Zusammen,

nachdem ich mich nun ein wenig mit dem neuen Blender 2.8 beschäftigt habe, muss ich sagen (schreiben ;)), dass der gar nicht so schlimm ist, wie ich befürchtet hatte.

Im Web habe ich zudem ein (zwar noch rudimentäres) Handbuch gefunden, dass viele meiner Fragen beantwortet hat.

Ich denke, der Blender und ich werden doch noch Freunde B|.

Meine ersten (einfachen) Modelle findet ihr hier.

Schöne Grüße
SputniKK

 

Share this post


Link to post
Share on other sites

Guten Abend,

wie ich oben schon beschrieben habe, bin ich eig. ein Fan von Neuerungen. Und natürlich gefällt mir Blender 2.8! Mit den Erklärungen von @Neo (wie man texturierte Bilder sichtbar macht) und mit den Erfahrungen von vielen weiteren Usern hier gefällt mir Blender 2.8 immer besser.

Allerdings gibt es ein-zwei Probleme, weshalb ich Blender 2.8 (zumindest für Modelle für das 3D-MBS) noch immer nicht nutze. Vielleicht hat ja der eine oder die andere bereits soviele Erfahrungen mit Blender 2.8, dass meinen Problemen damit Abhilfe geschaffen werden kann, so dass auch ich gern uneingeschränkt die neue Version nutzen könnte?

Genau genommen gibt es 2 wesentliche Probleme, die ich hier gern beschreibe in der Hoffnung, dass jemand da schon weiter ist als ich:

Das 1. Problem: die Framerate für Animationen

bei meinen ersten Modellen, welche ich mit Blender 2.8 adaptieren wollte, haben die Animationen nicht funktioniert. Das hat mich nicht nur zur Verzweiflung gebracht, sondern auch dafür gesorgt, dass ich Blender 2.8 wieder geschlossen und mit 2.79 weiter gemacht habe.

Nun habe ich im Wiki unter Vorbereitungen (zum Modellbau) gelesen,

Blender 2.8 und neuer

  • Unterstützt den Export nach glTF ohne spezielle Addons.
  • Für animierte Modelle muss in Blender die Frame Rate im Output-Reiter auf 24 eingestellt werden.

dass die Framerate auf 24 eingestellt werden muss. Ja tatsächlich! Mit der Framerate 24 funktionieren die Animationen! Aber warum ist das so? Es gibt ja Gründe, warum ich in meinen Modellen Framerates von 50 oder sogar 100 verwende (an anderen Stellen beschrieben: das Flackern, wenn man die Innenbeleuchtung einschaltet)

Gibt es irgendeine Möglichkeit, auch mit Blender 2.8 höhere Framerates zu ermöglichen? Immerhin hat das ja bis Blender 2.79 und x-Export funktioniert. Diese Einschränkung leuchtet mir nicht ein und ich empfinde das als einen ziemlichen Rückschritt.

Mein zweites wesentliches Problem erläutere ich demnächst....

In der Hoffnung auf Erklärungen, Erfahrungen, Lösungen...

Gruß
Reinhard

Share this post


Link to post
Share on other sites

Hallo @Reinhard,

ich habe mal die FPS auf 60 umgestellt (und sonst nix!) und siehe da, meine Tür war schneller offen. Aber die Animationszeit war noch lange nicht um! Bis zum Ende ist dann natürlich nichts mehr passiert. Über den Effekt kann man sich nun Gedanken machen.
Blenderseitig muß dann zumindest das Time Remapping mit genutzt werden, was dann natürlich einen Einfluss auf die Framenummer hat und damit muß wohl auch die anim-Datei angepaßt werden.

Gruß
  Andy

Share this post


Link to post
Share on other sites

Ich muß vor einer Sache noch einmal warnen, die mir beim Hochhaus schon passiert ist. Heute auch wiederholt. Wenn ihr die Darstellung von WireFrame oder Solid auf Textur hochschaltet, besteht die Gefahr, dass der Blender abschmiert! Vorher sichern, das ist ein Zufallseffekt!

Gruß
  Andy

Share this post


Link to post
Share on other sites

Hallo,

die Thematik mit der Animationsgeschwindigkeit und der .anim Datei ist in diesem Thread schon angesprochen worden...

Am 22.9.2019 um 15:10 schrieb Neo:

du musst in Blender die FPS auf 24 setzen (Blender-Default) und dein Modell neu exportieren, dann funktioniert es:

FPS.jpg.851082d77be0a3999e46921376b570a8.jpg

Der Hintergrund ist der: Das glTF-Format speichert Animationen nicht in Keyframes ab, sondern in Zeiten, ohne eine FPS-Angabe (wird bei Zeitangaben auch nicht mehr benötigt). Damit aber die Anim-Dateien im Studio weiterhin funktionieren, muss das Studio die Zeiten wieder zurück in Keyframes umrechnen, wofür die Standard-FPS von 24 angenommen werden. Stimmen die FPS nicht, kommen natürlich alle Keyframe-Angaben durcheinander. 

 

Am 22.9.2019 um 19:47 schrieb EASY:

im .x Format konnte man ja bisher eine Animation mit wenig Frames [zeitlich] "strecken" indem man die FPS Angabe in Blender heruntergesetzt hat...
... bedeutet das nun, um den gleichen Effekt zu erhalten, muß man im .glTF Format die Animation "länger" machen (mehr Frames) ?

 

Am 22.9.2019 um 21:40 schrieb Neo:
Am 22.9.2019 um 19:47 schrieb EASY:

bedeutet das nun, um den gleichen Effekt zu erhalten, muß man im .glTF Format die Animation "länger" machen (mehr Frames) ?

nein, du kannst auch bei glTF in Blender die FPS herabsetzen und erhältst eine verlangsamte Animation, muss dann aber in der Anim-Datei diese Verlangsamung bei den Frame-Zahlen einrechnen. Wenn du also von 24 auf 12 FPS herunter gehst, musst die die Frames in den Anim-Dateien verdoppeln.

... wenn man also die Animationsgeschwindigkeit über Blender mit der FPS-Einstellung ändert, muß man den Eintrag in der .anim für die Frames selbst neu berechnen.
Für eine Verlangsamung der Animation über Blender (kleinere FPS als 24) die Anzahl Frames in der . anim erhöhen.
Für eine Bescheunigung der Animation über Blender (größere FPS als 24) die Anzahl Frames in der . anim verringern.
(Anzahl Frames in Blender x 24 / (FPS in Blender)
Hat eben nur den Nachteil, daß es sinnvoll ist, die FPS in Blender und/oder die Anzahl der Frames in Blender so zu wählen, daß bei der Umrechnung nur ganze Zahlen (ohne Nachkommastellen) herauskommen...

Gruß
EASY

Edited by EASY

Share this post


Link to post
Share on other sites

Guten Abend,

vielen Dank für die vielen Hilfen in der Frage Animationen und Framerates. Wieder bin ich ein Stück weiter mit Blender 2.8. insbesondere durch eure Beiträge hier und besonders durch @FeuerFighter!

Dabei ergaben sich weitere Fragen, von denen ich eine hier beantworten kann (ich hatte zwischendurch "den Mund ziemlich vollgenommen", indem ich sagte: ich glaube, in Blender kann man alles einstellen - aber es scheint zu stimmen)

Das Problem: die Maßangaben in Blender 2.8

Bild73a.thumb.jpg.20fe1b566bf6769a7dbc3a2d47463d46.jpg

Wenn man Blender 2.8 installiert und keine wesentlichen Änderungen bei den Einstellungen vornimmt, hat man bei den Maßangaben ungewohnt z.B. die Meter-Angabe "m". Das war bis Blender 2.79 nicht so. Um diese (unwichtige und ungewohnte) Angabe abzuschalten, geht man folgendermaßen vor:

Im Reiter "Scene" (der Pfeil) klappt man die "Units" auf und setzt das "Unit Sytem" von "metrisch" auf "none"

Bild73b.thumb.jpg.58d83638362a5f7f328f9c3231e058a8.jpg

Anschließend speichert man die (leere) Scene als Startup File (Start Datei)

Bild73c.jpg.9aabf21a1cbac0633ff0fb307480ddb5.jpg

und Blender wird zukünftig ohne die Maßangaben zur Verfügung stehen (ein Standard-Würfel von bisher 2m x 2m x 2m wird -wie gewohnt- mit 2.000 x 2.000 x 2.000 dargestellt).

Gruß
Reinhard

Share this post


Link to post
Share on other sites

Hallo Leute,
an alle, die sich mit meinem Blender 2.8-Problem beschäftigt haben:
Letztlich war es die vermutete Treibergeschichte, wobei es ein längerer Weg war, da Intel und Dell da kreuzweise aufeinander verwiesen haben. Am Ende war es eine maschinenspezifische Diagnosesoftware von Dell, die in einem BIOS-Update + deren Grafiktreiber endete. Bin froh, dass die Kiste noch läuft. Diese halbinstallierte Intel Support-Software, die sich nicht vollständig installieren ließ, weil der Rechnerhersteller sie nicht unterstützt, läßt sich nun auch nicht mehr einfach entfernen und meldet natürlich, dass es neuere Treiber gibt, die man über den Hersteller installieren sollte. :bangbangbang:  Bin gespannt, wie's nach dem November-Update von Win 10 aussieht 9_9

Gruß
  Andy
 

Share this post


Link to post
Share on other sites

Hallo alle zusammen,

habe mit Blender 2,8 zur Zeit folgendes Problem:

nach Aufruf UV-Editing bezüglich Texturierung einer markierten Fläche und anschließendem Klick auf Projektion aus Ansicht wird dann auf der linken Seite die Multitextur angezeigt sowie ein Rahmen, der auf der gewünschten Textur zu plazieren ist. So weit so gut. Leider lassen sich die einzelnen Punkte auf dem Rahmen nicht mehr selektieren und anschließend verschieben. Auch durch Klick auf Taste C können keine Punkte markiert werden.

Vielleicht weis einer von den erfahrenen Blenderleuten hier Rat.

1.thumb.jpg.610ad482a05c24a5e87c9c06e9ea881b.jpg

Viele Grüße

Toni

 

Share this post


Link to post
Share on other sites

Hallo Toni,
Du steht links noch auf Fläche (roter Kringel).
Bleibe im rechten Fenster auf Fläche und selektiere Dir das zusammen, was Du brauchst.
Dann links ggf. auch noch mal auf 'selektiere' 'alle' gehen. Das sind dann alle rechts ausgesuchten. ggf. am Anfang dann links 'Unwrap' (U-Taste).
Für die groben Positionierungen kann Du dann ruhig auch links auf Fläche bleiben und mit der Kombifunktion (grüner Kringel) schieben, rotieren, skalieren.
Dann auf Eckpunkte gehen, auf 'Auswählen' (Pfeil) und fein positionieren. Und 'Numpad Punkt' für sehr tiefes Einzoomen geht dann auch noch.

Gruß
  Andy

Anmerkung 2019-11-21 120941.jpg

Edited by Andy

Share this post


Link to post
Share on other sites

Hallo Andy,

vielen Dank für Deine Hilfe. Die Lösung war eigentlich ganz einfach. Ich musste nur im UV Editing-Fenster auf der linken Seite die Schaltfläche Punkte (nicht Fläche) anklicken und schon konnte ich die einzelnen Punkte wieder selektieren und verschieben. Ja, manchmal sieht man vor lauter Wald die Bäume nicht.

Viele Grüße

Toni

 

Share this post


Link to post
Share on other sites

Aber wenn's nur so ein kleiner Hinweis ist. Du glaubst gar nicht, wie gut das tut, wenn man da mal was zurückgeben kann. War eine dankbare Frage!

beste Grüße
  Andy

Share this post


Link to post
Share on other sites

Jetzt habe ich mal eine Frage.
Ich vermisse in den neuen Blendern die Anzeige der kleinen blauen Normalen. Ich habe mir insoweit geholfen, dass ich das Extrude-Tool angewählt habe, da wird die Normale ja mehr als deutlich angezeigt. Aber viele kleine blaue wären mir lieber. Nur wie?

Und SputniKK hat gerade geschrieben, dass 2.8.1 draussen ist!

Gruß
  Andy

p.s.: Übrigens habe ich mir gerade noch das Add-On 'UV: Magic UV' eingebunden. Endlich Copy&Paste in UVs. Was nutzt ihr für Add-ons?

Edited by Andy

Share this post


Link to post
Share on other sites

Hallo Andy,

die gibt es noch immer, sind aber nicht ganz so einfach zu finden:

Bild1.thumb.jpg.4f3967b25d105423be364b43e56fc5ec.jpg

Es gibt da aber noch eine neue Funktion "Face Orientation" und damit sind die "flaschen" Flächennormalen viel besser zu sehen: "rot" zeigt nach hinten und "blau" zeigt nach vorne. Funktioniert im Edit- und im Objekt-Modus.

Im Edit-Modus die Flächen umdrehen geht mit <Alt><n> Flip.

Schöne Grüße
SputniKK

Share this post


Link to post
Share on other sites

Hallo zusammen, ich habe mich mit einem Problem beschäftigt und möchte euch natürlich teilhaben lassen.

Folgende Voraussetzung: Unterschied im MBS zwischen SMOOTH, FLAT, und teilweise SMOOTH, Anlass war daß ich manche Meshes im Nachhinein "gesmoothed" habe bzw. "geflated" (dämliche Ausdrücke) , dann im MBS übers Ziel hinausschoß punkto Eckpunkte, daraufhin habe ich einige Tests angestellt deren Ergebnisse ich so eigentlich nicht erwartet hatte.

Als Beispiel eine Laufradachse (sämtliche Geometrien sind immer ident):
komplettes Mesh FLAT:
for.thumb.jpg.c1040af65d86ed2db9da91c732e3ac4c.jpg

komplettes Mesh SMOOTH:
for1.thumb.jpg.0e4e8d641b2956279b5e359d8fc11af2.jpg

teilweise Mesh SMOOTH: (nur ausgewählte Faces):
for2.thumb.jpg.5e6c97fc93c842e6ea711b6d36734685.jpg

und jetzt der umgekehrte Weg, komplettes Mesh SMOOTH, ausgewählte Faces FLAT:
for3.thumb.jpg.269b948c9ac74c3e5c6b987d3faa8a35.jpg
Erstens der Unterschied von 2 Vertices zw.3. und 4. Bild, wobei das Bildergebnis absolut identisch ist, und

zweitens dachte ich daß das Smoothen in der Grafikkarte erledigt wird, ergo kann man sagen je mehr gesmoothed wird um sehr wird an Vertices gespart (warum auch immer)

lg max

 

 

Share this post


Link to post
Share on other sites

Hallo @maxwei,

da hast du ja viel ausprobiert, wobei ich in erster Linie Smooth einsetze, wenn ich es für das Modell brauche. Was ich aber sagen wollte:

Am 12.12.2019 um 14:56 schrieb maxwei:

ergo kann man sagen je mehr gesmoothed wird um sehr wird an Vertices gespart (warum auch immer)

Das liegt daran, dass nicht wirklich die Verticies gezählt werden, sondern deren Normalen. Das heißt, dass ein Vertex, welches 2 "flache" Flächen verbindet, 2 Normalen (die der beiden Flächen) hat. Wenn du dieses Stelle "weichzeichnest" dann hat dieses Vertex nur noch 1 Normale, deshalb stellt sich ja der optische Effekt "smooth" ein.

Gruß
Reinhard

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×