Jump to content

Animieren mit Blender


Recommended Posts

Hallo Forum,

es gibt einen recht guten Video-Workshop von FeuerFighter, der die Animation von Türen/Toren beschreibt.

Hier wird beschrieben, das der Startpunkt der Animation unbedingt auf Frame 1 gesetzt werden muß. Das war zur Zeit der Erstellung des Videos auch völlig korrekt!

Wenn man heute aber Modelle mit dem Direct-X-Exporter von Neo ins Studio laden möchte, muss das erste Frame 0 sein!

Viele Grüße

fmkberlin

 

Link to comment
Share on other sites

Hallo fmkberlin,

eigentlich ist der Start bei Frame 0 nur eine Empfehlung, da der DirectX-Exporter bei 0 zu zählen anfängt. Hast du ein Problem entdeckt, dass auf dem Startframe einer Animation basiert?

Viele Grüße,

Neo

Link to comment
Share on other sites

vor 15 Stunden schrieb Neo:

Hallo fmkberlin,

eigentlich ist der Start bei Frame 0 nur eine Empfehlung, da der DirectX-Exporter bei 0 zu zählen anfängt. Hast du ein Problem entdeckt, dass auf dem Startframe einer Animation basiert?

Viele Grüße,

Neo

Ja, habe ich! Sonst hätte ich es nicht erwähnt. Keine Ahnung, ob es mit meinen doch manchmal etwas aufwändigen Animationen zu tun hat?

Hier ein Beispiel von einem gehenden Menschen -

Animationen.jpg

Der Start liegt bei Frame 2 -

Animationen2.jpg

Aber in der Anim-Datei musste ich Frame 1 als Start eintragen. Man habe ich damals nach einer Lösung gesucht! Viele meiner Modelle sind so animiert. Und ja, nachdem ich irgendwann von Frame 0 als Startframe gelesen und verwendet hatte, hat es nie wieder Probleme gegeben!

@FeuerFighter

Workshop.jpg

Was sollte ich da nun schreiben?

Viele Grüße

fmkberlin

Edited by fmkberlin
Link to comment
Share on other sites

Hallo fmkberlin,

ich bin jetzt nicht der Blender-Experte, aber laut deinem Bild startet der "graue Bereich" bei Frame 1, und dein erster Keyframe bei Frame 2. Ich weiß jetzt nicht, was dieser graue Bereich für Auswirkungen hat, aber alles, was mit Animationen zu tun hat, sollte im gleichen Frame starten. Daher die Empfehlung, alles bei 0 starten zu lassen, um eine einheitliche Basis zu schaffen.

Viele Grüße,

Neo

Link to comment
Share on other sites

Hallo fmkberlin,

es ist richtig, dass ich das vorgenannte Video-Tutorial damals erstellt habe. Ebenso Bau einer E-Lok-Halle Teil 1 und das V.-Tutorial Bodenplatten Gleisverlegung. Da ich seinerzeit noch keinen Account bei YouTube hatte, war FF so freundlich, die Tutorials für mich hochzuladen. Dafür nochmals Dank an FF.

Viele Grüße

Toni

Link to comment
Share on other sites

vor 13 Stunden schrieb Neo:

Hallo fmkberlin,

ich bin jetzt nicht der Blender-Experte, aber laut deinem Bild startet der "graue Bereich" bei Frame 1, und dein erster Keyframe bei Frame 2. Ich weiß jetzt nicht, was dieser graue Bereich für Auswirkungen hat, aber alles, was mit Animationen zu tun hat, sollte im gleichen Frame starten. Daher die Empfehlung, alles bei 0 starten zu lassen, um eine einheitliche Basis zu schaffen.

Viele Grüße,

Neo

Hallo Neo,

Ich hatte damals ganz erhebliche Probleme, meine Animationen ins Studio zu bekommen, weil ich, auf Grund des Videos, immer meinen Startframe auf 1 gesetzt habe. Leider kann ich sie auf die Schnelle nicht noch mal darstellen. Wegen dieser Probleme wollte ich einfach nur daraufhin weisen, das der Hinweis in diesem Video zu Problemen führen kann!

Wenn ich jetzt aber wieder erlebe, das gewisse Leute meinen, sie müssten gleich wieder auf mir rumhacken, bin ich es schon wieder leid. Besser wäre wahrscheinlich, ich hätte nichts gesagt, und ein neuer Modellbauer würde unter Umständen, an diesem Problem verzweifeln und aufgeben!

@FeuerFighter- Ich habe schon wieder den Fehler gemacht und mich von Dir anmachen lassen! Könnte mir in den ....... beißen!

@Toni - Diese beiden Videos sind Schuld daran, das ich mit dem 3D-Modeelbau angefangen habe. Danke!

Viele Grüße

fmkberlin

Link to comment
Share on other sites

Hallo fmkberlin

relax - es muß ja nicht jede Äußerung bierernst genommen werden - viele Meinungen - viele unterschiedliche Lösungen - wer am Problem nachdenkt, ist immer im Vorteil und kann neuere bzw. andere Erkenntnisse bei der Leserschaft auslösen. Entschuldigungen oder Rechtfertigungen sind nicht nötig, wenn es im Thema weiterführen kann. Alles ist gut.

Auch wenn nicht alle einer Meinung sind - weiter diskutieren ist immer erwünscht meint

Henry

Link to comment
Share on other sites

Hallo Henry,

Danke für Deinen Beitrag! Aber ich bin es leid, das ich jedesmal gleich von diesen Typen angemacht werde! Und den Chef interessiert das auch nicht!

Ich war so blöd und habe mit den Vorarbeiten für einen Video-Workshop über Animationen und  Multianimationen, mit Blender, begonnen. Die sind gerade im Papierkorb gelandet!

Viele Grüße

fmkberlin

 

Link to comment
Share on other sites

Hallo Frank,

warum Papierkorb?

Ich finde es immer gut, wenn man Tipps aus verschiedenen Blickwinkeln bekommt.

Man sollte die Video-Workshops verschiedener Autoren nicht als Konkurrenz-Produkte, sondern als sich gegenseitig ergänzend betrachten. Jeder hat seine speziellen Tricks und Kniffe, welche die anderen eventuell nicht kennen, jedoch möglicherweise ebenfalls sinnvoll und erfolgreich einsetzen können.

Das ist zumindest mein Standpunkt.

Viele Grüße
BahnLand

Link to comment
Share on other sites

Hallo fmkberlin @ alle zusammen

vor 9 Stunden schrieb fmkberlin:

@FeuerFighter- Ich habe schon wieder den Fehler gemacht und mich von Dir anmachen lassen! Könnte mir in den ....... beißen

es ist nicht meine Absicht jemanden anzumachen, sondern nur Richtig  zu stellen wen das Lob gebührt. Außerdem finde ich es Schade das Du die Video Workshops animieren mit Blender aus Trotz nicht mehr machen möchtest. Jede Anleitung kann den Usern hilfreich sein. Ich jedenfalls habe keine Probleme damit wenn auch von anderen Blender Anleitungen kommen, denn das kann nur Hilfreich sein. Also bestrafe nicht die Allgemeinheit wenn Du mit mir ein Problem hast.

 

Gruß

FeuerFighter

 

Link to comment
Share on other sites

Hallo,

... das mit dem Startframe 0 hat einen einfachen Hintergrund.

Sinnvoll ist in Blender den Startframe auf 0 zu setzen, wenn man mit einer .amim Datei arbeitet.
Bei der Definition der Animation z.B. "Door;0;15;AutoPlay;NoLoop" bezieht sich die "0" auf den ersten Frame in der Animation ! Es ist also egal ob ich in Blender den Startframe bei 1 oder 10 oder 100 setze... die "0" bezieht sich auf diesen Frame!!! .... und die "15" auf den Endframe (Animationslänge ist also 16 Frames).
Wenn ich nun in Blender bei 10 anfange (=Startframe !) und bei 25 aufhöre und in die .anim "Door;10;25;AutoPlay;NoLoop" schreibe werden die ersten 10 frames der Animation nicht abgespielt !!!
Bei Animationen ohne .anim Datei ist die Definition des Startframes in Blender egal.

oder einfach ausgedrückt:
Die Definition der Animation in einer . anim Datei beruht auf einer 0-basierte Zählweise.
... wenn ich also in Blender nicht mit 0 beginne muß ich anfangen umzurechnen für die Erstellung der . anim Datei.

@Neo:
... solltest Du in der wiki vielleicht noch einmal deutlicher darauf hinweisen...

Gruß
EASY

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...