Jump to content

Renovierungsarbeiten


Roter Brummer
 Share

Recommended Posts

  • 2 weeks later...

Hallo Brummi,

dass Du neben der Reduzierung der Materialien und Herstellung zusätzlicher LoD-Stufen für die Modelle auch noch die Textur "verbesserst", finde ich toll. Bei dem gezeugten Häuschen gefällt mir besonders die neue Holz-Maserung an den Türen und Fensterrahmen. (y)

Viele Grüße
BahnLand

Link to comment
Share on other sites

Hallo zusammen,

wo wir gerade bei Silos sind:

001.jpg

Verwendete Programme:

  1. MBS Exporter nach *.obj
  2. Blender (Export nach Collada)
  3. Sketchup 2016 (Import Collada)
  4. Seketchup 8 mit Exporter von BahnLand
  5. Paint.net
  6. Texturgenerator von BahnLand

P.S.: Es gibt auch noch eine LOD-Stufe mit 880 Polys.

HG

Brummi

Edited by Roter Brummer
Link to comment
Share on other sites

 

Hallo Brummi und alle SketchUp Experten

wenn Ihr wollt könnt Ihr Euch beim OBJ Import nach SketchUp den Umweg über Blender sparen.

Für SketchUp gibt es eine Erweiterung mit der können OBJ Dateien direkt in SketchUp Importiert

werden.

Hier der Link zur Videoanleitung, die beiden rbz Dateien sind in der Videobeschreibung:

https://www.youtube.com/watch?v=w2_-5CQH2eU

Ich habe SketchUp Pro 2016 da geht es.

Beim Umwandeln der rbz Dateien in rb Dateien und dann die rb Dateien und die Ordner

in den Plugin Ordner von SketchUp 8 kopieren da geht es bei mir in SketchUp 8 nicht.

Ich habe die Programme SketchUp 8 und SketchUp Pro 2016

und dann noch Blender 2.71 und 2.78

Könnt es ja mal ausprobieren

Viele Grüße Steffen

Link to comment
Share on other sites

Hallo zusammen,

zum Bahnhof Schönblick gehört ja eigentlich zwingend das Faller Stellwerk 121. Das vorhandene Modell war nicht unbedingt optimal:

001.JPG

Nach der (hier ziemlich aufwändigen) Renovierung sehen die Werte wesentlich besser aus:

002.JPG

Auf der Anlage ergibt sich folgendes Bild:

004.jpg

Und nachts dieses:

005.jpg

HG

Brummi

Link to comment
Share on other sites

Hallo zusammen,

der nächste Kandidat:

001.jpg

Es sei vielleicht noch angemerkt, dass durch meinen letztjährigen Festplattencrash die Dateien verloren waren. So war die Renovierung etwas pfrimelig. Das zweite Material ist der Halbtransparenz der Scheiben geschuldet, die in LOD1 aber wegfallen.

HG

Brummi

Link to comment
Share on other sites

Hallo Neo,

ich habe da mal mit angefangen - zunächst nur der Stundenzeiger. Es funktioniert aber nicht so richtig. Meine Fragen sind daher:

  1. Müssen die Meshes für die Zeiger bestimmte Namen haben?
  2. Müssen die Zeiger selber animiert sein?
  3. Wenn ja, ist es richtig, dass sich der Stundenzeiger um 720 Grad drehen muss?
  4. Wenn ja, ist eine bestimmte Anzahl von Frames vorzusehen?
  5. Braucht es eine Anim-Datei und wenn ja, was muss da genau drin stehen?

Ich habe da bestimmt noch mehr Fragen, auf die ich im Moment noch nicht komme.

HG

Brummi

Link to comment
Share on other sites

Hallo Brummi,

die Zeiger benötigen keinen bestimmten Namen, müssen aber animiert werden. Da auf einer 12-Stunden Uhr jede Uhrzeit zweimal angezeigt wird, muss der Stundenzeiger um 720 Grad gedreht werden. Die Anzahl der Frames spielt keine Rolle, es würden 2 Frames reichen, das Studio interpoliert selbstständig die Zwischenframes.

Eine Anim-Datei ist notwendig, um die Animation zu benennen. Hier genügt eine Zeile: "_AnimTime;1;10" (erste Zahl ist das Startframe in Blender, die zweite das letzte Frame der Animation).

Viele Grüße,

Neo

Link to comment
Share on other sites

Hallo Neo,

Zitat

Hier genügt eine Zeile: "_AnimTime;1;10" (erste Zahl ist das Startframe in Blender, die zweite das letzte Frame der Animation).

... ich kann es gerade nicht ausprobieren aber 2 Dinge:
... müßte da in der .anim nicht noch der Zusatz "... ;NoAutoPlay;NoLoop" in die Zeile (nach meiner Meinung mindest das erstere)

... nach meiner Erfahrung bezieht sich die erste und die letzte Zahl nicht auf den Start- bzw. der Endframe in Blender sondern erste Zahl ist 0 bezogen und die 2.Zahl ist quasi die Animationslänge (bei nur einer Animation).
Wenn ich in Blender Frame 10 bis 20 habe und schreibe in die . anim "Animation;10;20..." passiert nicht viel... ich muß in die .anim "Animation;0;10..." schreiben... also von allen Zahlen den Blenderstratframe abziehen (wenn dieser nicht 0 ist) (-> gilt besonders bei Multianimationen)
 

Gruß
EASY 

Link to comment
Share on other sites

Hallo,

@Roter Brummer
Dank deiner Dateien konnte ich den Fehler schnell finden. Das Wiki enthielt eine falsche Information, die Animation muss _Time heißen (also ohne "Anim"), dann funktioniert es korrekt. Habe das Wiki aktualisiert.

vor 47 Minuten schrieb EASY:

... müßte da in der .anim nicht noch der Zusatz "... ;NoAutoPlay;NoLoop" in die Zeile (nach meiner Meinung mindest das erstere)

Bei Automatikanimationen ist dieser Zusatz nicht notwendig, da das Studio die Animation komplett selber steuert.

vor 49 Minuten schrieb EASY:

Wenn ich in Blender Frame 10 bis 20 habe und schreibe in die . anim "Animation;10;20..." passiert nicht viel... ich muß in die .anim "Animation;0;10..." schreiben... also von allen Zahlen den Blenderstratframe abziehen (wenn dieser nicht 0 ist) (-> gilt besonders bei Multianimationen)

Die Angaben beziehen sich schon auf das Start- und Endframe, allerdings exportiert Blender Animationen selber so, dass sie in der DirectX-Datei bei 0 starten. Blender verschiebt den Start der Animation, das muss man immer berücksichtigen (fiel mir auch erst wieder auf, als ich die X-Datei von Brummi analysiert habe).

Viele Grüße,

Neo

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...