Jump to content

Start-Probleme Blender 2.91


Recommended Posts

vor 12 Stunden schrieb Reinhard:

Danke für die coole Idee, aber am Ende nützt sie mir nix, wenn Blender nicht mit allen Möglichkeiten wieder läuft.

Hallo Reinhard,
verabschiede Dich von dieser Vorstellung. Ich denke, die sind da auch ziemlich am Basteln. Ich glaube, ich hatte mit einem Renderer auch Probleme - dann nimmt man halt den anderen, es ist ja nur der Renderer, in MBS sieht es ja sowieso etwas anders aus. Natürlich nervt das ganz fürchterlich, wenn sich das Programm in so einem wackeligen Zustand befindet. Ihr werdet euch erinnern, bei mir waren da ja auch fürchterliche Effekte. Ich denke, damals war die Lösung alte Blenderversionen komplett zu entfernen, z.T. auch manuell in irgendwelchen Hintergrundordnern, wie Neo sie benannt hat. Momentan warnt er mich auch jedesmal, dass meine Treiber nicht aktuell sind, aber die sind nicht Neuer zu kriegen, weil sich da Intel und Dell gegenseitig aufrufen... Da braucht man eine unheimliche Portion Gelassenheit...
Ältere Blenderversionen nach zu installieren, wird nicht helfen, weil da eben immer common-Dinge geladen werden, die dann vom Neuesten kommen. Deswegen klemmt's ja. Aber mach bloß nix an Windows. Das kann da wohl ausnahmsweisenix für. Also - ruhig bleiben, sonst ruinierst du dir den ganzen Rechner.

Gruß
  Andy

p.s.: und bring unbedingt Deine ganzen Arbeiten erstmal auf einen Stick. Nicht auszudenken, wenn denen was passiert, in dem Chaos.

Edited by Andy
Link to post
Share on other sites
  • Replies 53
  • Created
  • Last Reply

Top Posters In This Topic

Top Posters In This Topic

Popular Posts

Ich nochmal, sich auf Kosten anderer (Kosten? wer holt die denn rein?) also sich auf Kosten anderer zu amysieren geht ja noch, aber die gesetzlichen Grundlagen sehen doch so aus: Wenn der

Guten Abend, heute kann ich verkünden, dass die Blender (Grafikkarten-) Probleme beseitigt sind und diese Odysse an dieser Stelle ein gutes Ende gefunden hat. Ich bedanke mich sehr herzlich

I, too, have been having Blender crash (disappear with no warning nor log file entry ...) over the last few weeks. I've tried setting up error log files from the '.cmd' files, but none have been gener

Posted Images

Hallo Reinhard

Am 30.12.2020 um 21:55 schrieb Neo:

im Blender-Verzeichnis gibt es einige *Debug*.cmd mit denen Logfiles erzeugt werden. Eventuell werden dort Fehler angezeigt, aus denen du schlauer wirst.

Hast du das eigentlich versucht? (hast nichts geschrieben)

verzeichnis sollte ungefähr so aussehen:

C:\Program Files\Blender Foundation\Blender 2.91\

Es gibt da 4 *.cmd ... welche durch  einen Doppelklick Blender im Debug mode starten und ein Log-file erzeugen, diese nennen sich dann xxx_debug_xxx.txt welche automatisch angezeigt werden sollten. (ansonsten sind sie im temp verzeichnis)

Wenn ja könntest du die Debug-Files hier hochladen, vielleicht sieht man da was?

lg max

Link to post
Share on other sites
Posted (edited)

Guten Abend zusammen,

vorweg:
 

Am 3.1.2021 um 12:43 schrieb maxwei:

Hast du das eigentlich versucht? (hast nichts geschrieben)

Nein, habe ich nicht probiert, weil mir die Handhabung - wie jetzt von dir - gefehlt hat und ich nichts mit den cmd-Dateien anzufangen wusste.

Folgendes muss ich hier nochmal loswerden: vielen lieben Dank für die tolle Hilfe und auch Hilfs-Angebote (hier entsprechende Dateien hochzuladen). Wie oben schon erwähnt, hatte ich auch persönliche Hilfe von @streit_ross. Insgesamt hat das alles leider nicht zu dem von mir gewünschten Ergebnis geführt. Dennoch mein ganz herzliches Danke dafür, dass man auch diese Probleme hier anbringen kann und viele viele Hilfsangebote bekommt.

Bei mir sieht das jetzt so aus: die Treiber sind auf dem neuesten Stand (ich glaube, dass ich das nicht mehr rückgängig machen kann oder will). Leider laufen keine Blender-Versionen mehr (weder 2.91, noch die wohl stabile 2.83.10 noch die Portable-Version) Bei allen friert das Programm ein, wenn ich den Tab "Shading" anklicken will. Nach derzeitigem Stand muss ich davon ausgehen, dass es ein Problem mit der AMD Radeon R7 oder deren Treibern gibt.

Es gäbe noch eine Option, die auszuprobieren ist mir aber zur Zeit zu aufwendig: Windows auf Werkseinstellung zurücksetzen und alle Programme neu installieren. Das will ich derzeit auch deshalb nicht, weil ich fürchte, dass das von mir angenommene Grafik-Problem (AMD Radeon R7 oder ihre Treiber) damit wohl nicht beseitigt werden würde.

Deshalb stellte sich für mich die Frage nach einem neuen Rechner, den ich sogar habe in Form eines Laptops. Der ist ein bisschen langsamer, aber ok. Der hat eine Nvidia Gforce Grafikkarte und zumindest die letzte als stabil angesehene Version Blender 2.83.10 läuft daruf und ich bin im Modellbau "wieder im Rennen". Der Laptop läüft jetzt parrallel ausnahmslos für Blender.

Eine große Bitte habe ich noch:

Einige von euch konnten mir hier antworten, dass dieses oder jenes Problem bereits in diversen Foren diskutiert wird. Leider fehlt mir für solch eine Problemverfolgung die Zeit und ich beneide diejenigen darum, die in der Lage sind, Problemlösungen auf diesem "internationalen" Weg zu besorgen. Ich habe dadurch u.a. gelernt, dass Blender 2.83.10 als letzte stabile Version angesehen wird, das ist auch die, welche Blender selbst als das anbietet. Deshalb habe ich die Version jetzt auf dem Zusatz-Laptop laufen.

Wenn in den "internationalen" Foren für Blender und diese Probleme neue Erkenntnisse kommen, könnt ihr das hier kundtun? Ich habe herausgehört, dass sowohl in den Foren auch diese Probleme viel diskutiert werden (also bestehen - nicht nur bei mir) und dass wohl bei Blender selbst ein reges Treiben dazu besteht, diese Probleme in den Griff zu bekommen.

Vielen lieben Dank bis hierher und euch allen ein hoffentlich tolles neues Jahr!

Gruß
Reinhrd

Edited by Reinhard
Link to post
Share on other sites

I, too, have been having Blender crash (disappear with no warning nor log file entry ...) over the last few weeks. I've tried setting up error log files from the '.cmd' files, but none have been generated by these crashes. I removed previous installation and tried 2.8.3.10, which also crashed, albeit slightly less. I then went to more extreme options, by uninstalling all Blender versions, removing all old program folders, and manually removing all mention of Blender from the Registry (I'm a retired IT bod, so could take the risk ...). Now, on a very clean PC, I knew that there was no contamination from previous versions.I've re-installed Blender to my 'C' drive (an SSD, which I normally reserve solely for System ...), and have copied the current Blender projects to this drive. The speed increase from the SSD is phenomenal, and I've had no crashes since (touches wood for Good Luck, just in case ...). Previously, my Blender program files were on a USB external drive, the project files on another. I believe that the external USB disks were going to sleep now and again (despite all attempts to prevent this ...), and was disturbing blender.
I'm now running 2.91 again, from this uber-fast SSD, with no issues for the last few days. The only downside is the size of the SSD system disk; I will have to be careful how much I can load it with without compromising the System. I may decide to invest in a larger-capacity SSD, if I can find something in my (low ...) budget.
The above ^^ won't apply to everyone, but may, I hope, help in some cases.

Edit: My PC is a desktop HP8200, with 12Gb memory and a NVidia GT720 low-profile graphics card, with 2Gb memory. Windows 10 Pro, 64bit. The 'C' drive is 128 Gb, and now has only 20Gb free. I use this same PC for everything: music composition, video editing, the web, 3D modeling ...).

Auch ich hatte in den letzten Wochen einen Blender-Absturz (ohne Warnung oder Eintrag in der Protokolldatei verschwinden ...). Ich habe versucht, Fehlerprotokolldateien aus den '.cmd'-Dateien einzurichten, aber durch diese Abstürze wurden keine generiert. Ich habe die vorherige Installation entfernt und 2.8.3.10 ausprobiert, das ebenfalls abgestürzt ist, wenn auch etwas weniger. Ich ging dann zu extremeren Optionen über, indem ich alle Blender-Versionen deinstallierte, alle alten Programmordner entfernte und alle Erwähnungen von Blender manuell aus der Registrierung entfernte (ich bin ein pensionierter IT-Mitarbeiter, könnte also das Risiko eingehen ...). Jetzt wusste ich auf einem sehr sauberen PC, dass es keine Verunreinigungen durch frühere Versionen gab. Ich habe Blender auf meinem C-Laufwerk (einer SSD, die ich normalerweise nur für das System reserviere ...) neu installiert und habe kopierte die aktuellen Blender-Projekte auf dieses Laufwerk. Die Geschwindigkeitssteigerung von der SSD ist phänomenal und ich hatte seitdem keine Abstürze mehr (berührt Holz für viel Glück, nur für den Fall ...). Zuvor befanden sich meine Blender-Programmdateien auf einem externen USB-Laufwerk, die Projektdateien auf einem anderen. Ich glaube, dass die externen USB-Festplatten ab und zu in den Ruhezustand gingen (trotz aller Versuche, dies zu verhindern ...) und den Mixer störten.
Ich verwende jetzt wieder 2.91 von dieser überschnellen SSD, ohne Probleme in den letzten Tagen. Der einzige Nachteil ist die Größe der SSD-Systemfestplatte. Ich muss vorsichtig sein, mit wie viel ich es laden kann, ohne das System zu beeinträchtigen. Ich kann mich entscheiden, in eine SSD mit größerer Kapazität zu investieren, wenn ich etwas in meinem (niedrigen ...) Budget finde.
Das obige ^^ gilt nicht für alle, kann aber hoffentlich in einigen Fällen helfen.

Bearbeiten: Mein PC ist ein Desktop-HP8200 mit 12 GB Speicher und eine NVidia GT720-Grafikkarte mit niedrigem Profil und 2 GB Speicher. Windows 10 Pro, 64 Bit. Das Laufwerk 'C' ist 128 GB groß und hat jetzt nur noch 20 GB frei. Ich benutze denselben PC für alles: Musikkomposition, Videobearbeitung, Web, 3D-Modellierung ...).

Edited by Dad3353
Link to post
Share on other sites

@Dad3353, you still got SKP installed aswell ?

Try to delete that one. For some reason i got a feeling that it might be the problem.

Why i think that and it may be absurd, but i got SKP 8 and 2017 installed on my laptop.

Now SKP 8 keeps crashing....

Could it be the same for Blender and SKP ?

who knows...

Link to post
Share on other sites
10 minutes ago, BahnLand said:

Hello Hubert,

I have installed Sketchup V8, Sketchup Make 2016 and Setchup Make 2017 on my computer and can use them all without any problems.

Many greetings
BahnLand

I think Hubert was suggesting that there might be a conflict between SKU and Blender. Yes I have SKU 8, 2017 and Blender 2.91 all installed. Now that I'm working from the SSD 'C' drive, I don't seem to have crashes, but I'll need to spend more time to really know for certain. I'd like to keep SKU if possible, as it can be handy sometimes.

Ich denke, Hubert hat vorgeschlagen, dass es einen Konflikt zwischen SKU und Blender geben könnte. Ja, ich habe SKU 8, 2017 und Blender 2.91 installiert. Jetzt, wo ich vom SSD-Laufwerk 'C' aus arbeite, scheint es keine Abstürze zu geben, aber ich muss mehr Zeit aufwenden, um es wirklich sicher zu wissen. Ich möchte die SKU wenn möglich behalten, da dies manchmal nützlich sein kann.

Link to post
Share on other sites

Hallo @maxwei,

scheint ein guter Hinweis zu sein, den ich auf dem "richtigen" Rechner probieren werde. Bei Blender auf dem Laptop scheint es etwas leichter zu laufen, wenn ich Cycles anstatt Eevee nutze.

Danke für den Tipp!

Gruß
Reinhard

Link to post
Share on other sites

Hallo Reinhard,
Eevee geht viel stärker direkt auf die Grafikhardware. Wenn da ein Treiber nur leichte Probleme hat, wird's kritisch.
Nochmal die Frage: Hast Du irgendwann in dieser Zeit mal alle Blenderversionen gelöscht und dann nur die Neueste frisch installiert? Ich denke immer noch, das hilft!

Gruß
  Andy

Link to post
Share on other sites

Hallo @Andy,

vor 31 Minuten schrieb Andy:

Hast Du irgendwann in dieser Zeit mal alle Blenderversionen gelöscht und dann nur die Neueste frisch installiert?

Habe ich gemacht, mehrmals. Mit Unterstützung von @streit_ross bis in die Tiefen der Registry, immer wieder, aber keine Version wollte sich mehr starten lassen.

In diesem Beitrag habe ich das angedeutet. Ausführlicher wollte ich das hier nicht darstellen. Der Vorschlag von @maxwei, in Blender gleich von Eevee auf Cycles umzustellen, könnte funktionieren, da Blender ja immer wieder startete (bis auf die Portable-Version, die ging gar nicht erst an) erst wenn ich auf den "Shader"-Tab geklickt habe, stand alles still. Also sollte das vielleicht funktionieren. Ich habe nur erstmal keine Lust mehr, das auszuprobieren, da Blender ja nun auf dem Laptop läuft. Wenn man das so einen Tag lang geschätzte 15 mal erfolglos gemacht hat, vergeht eben die Lust für ein paar Tage ;)

Allerdings habe ich auf dem Laptop bereits auf Cycles umgeschaltet, da der nicht der stärkste ist.

Vielen Dank für dein/für euer Mitdenken.

Gruß
Reinhard

Link to post
Share on other sites

Hallo Reinhard,
das ist frustrierend, in der Tat. Ich kann da gut mitfühlen. Hab damals ja auch lange genug damit rumgemacht, trotz aller eurer gut gemeinten Hilfen.
Tröste Dich damit, dass wir's am Ende schon noch packen werden.
Meine Maschine, die damals diesen Riesenärger gemacht hat, frißt den neuen Blender anstandslos! Irgendwie wird's gehen.

Gruß
  Andy

Edited by Andy
Link to post
Share on other sites

Hallo Reinard,

irgendwann wirst Du wieder die Lust bekommen, weiter mit deinem alten Rechner der Fehlerursache auf den Grund zu gehen. Er ist ja nicht kaputt, wenn er alle Anwendungen außer Blender 2.91 nicht fehlerfrei ausführt. Das ist neben dem aktuellen Frust auch eine Frage der Dringlichkeit. Ich  will Dich auch zu nichts drängeln, aber wenn Du einfach Lust und Laune hast, dann könntest Du folgendes probieren:

Gehe über  Systemeinstellungen-Gerätemanager auf Deine Radeon-Grafikkarte und entferne diese. Dann den Rechner neu starten und sich den Grafikkartentreiber selber neu suchen und installieren lassen. Das dürfte eigentlich ein von Windows bereitgestellter sein (oder einer von AMD, was nur im Hinblick auf das Ergebnis interessant ist) . Anschließend Blender installieren und testen. Diesen, meinen Vorschlag, kannst Du in zwei Varianten machen. Einmal, indem Blender noch nicht installiert wurde und zum zweiten, indem Du erst Blender installierst, aber noch nicht gestartet hast. Versuch macht kluch. 

Gruß

streit_ross

Link to post
Share on other sites
Posted (edited)

Hallo @streit_ross, hallo @alle,

bevor ich den Vorschlag von Streit_Ross probiere, habe ich das mit der Render-Engine probiert.

Bild97.thumb.jpg.00860a6aeac3c76555614f99a219e15e.jpg

MIt dem (für mich nicht wirklich überraschenden) Ergebnis. Blender starten ging, Render-Engine umschalten auf Cycles ging, alle Tabs anklicken ging, nur nicht den "Shader"-Tab, hier steht Blender wieder, alles vorbei.

Habe nun auch die cmd-Dateien probiert, es gibt auch debug-Dateien, aber mit deren Inhalt kann ich nicht wirklich was anfangen, auch wenn ich die eine oder andere Zeile lesen kann.

Also Blender wieder entfernen, registry säubern und dann versuche ich das, was @streit_rosshier gerade vorschlägt. Ich hoffe, dass der Rechner dann überhaupt angeht, wenn ich die Grafikkarte in der Sxstemsteuerung entferne??? Aber ich vertraue dir da...

Gruß
Reinhard

Edited by Reinhard
Link to post
Share on other sites

Hallo Reinhard,
mir ist noch folgendes aufgefallen:
wenn du Shading klickst, baut er auf der linken Seite ein Thumbnail-Directory auf. Der Filepath ist C:\Users\Admin\Documents. Er besitzt da auch ein Filefilter, was z.B. Image Files beinhaltet. Und wenn da ein Grafikfile liegt, was gar keins ist, oder umgekehrt, oder vielleicht eine 0-Size-Datei, wo er versucht einen Header zu finden, dann sind das Gründe, wo er sich aufhängen könnte, weil da noch ein Fall in Blender nicht berücksichtigt wurde. Liegt da irgendein Müll rum, den du wegräumen könntest?

Gruß
  Andy

Link to post
Share on other sites

Hallo,

vor 9 Minuten schrieb streit_ross:

keine Sorge, der Rechner geht an

ja, hat er gemacht, als wenn ich die Grafikkarte (inkl. Treiber) gar nicht entfernt hätte (zumindest die Treiberversion ist dieselbe, wie vorher - von 11 2020). Dass da irgendwas passiert ist, war zu bemerken, weil der Bildschirm an der einen oder anderen Stelle kurz schwarz wurde, wo das sonst nicht hingehörte.

vor 7 Minuten schrieb Andy:

baut er auf der linken Seite ein Thumbnail-Directory auf. Der Filepath ist C:\Users\Admin\Documents

So eine Thumbnail-Directory kann ich zwar gerade nicht nachvollziehen, weil es diese Directorys nur gibt, wenn ich Dateien speichere oder öffne, aber auch der von dir beschriebene Ordner enthält keine Fehl- oder Leer-Dateien, dennoch auch vielen Dank für diesen Tipp.

Als nächstes noch ein Versuch, Blender zu installieren,

aber für heute erstmal euch allen eine gute Nacht

Gruß
Reinhard

Link to post
Share on other sites

Hier ein Photo wie es aussieht, nachdem ich auf Shading geklickt habe. Links oben ist dieses Directory. Und er braucht auch einen Moment, bis er das darstellt.

 

Screenshot 2021-01-07 020536.jpg

Link to post
Share on other sites

Hallo @Andy,

ja, das müsste das File-Open-Menü sein. Danke für die Klarstellung. Das ist eines der ersten Schritte, dies auszublenden, wenn ich Blender einrichte, deshalb sehe ich das auf meinem funktrionierenden Blender (Laptop) nicht mehr. Aber laden sollte Blender daraus "von allein" nichts. Wie gesagt, in diesem (für Blender zunächst Start-) Ordner sind keine fehlerhaften Dateien.

Ich versuche es heute erneut, zuvor werde ich aber nochmal die Grafik-Treiber entfernen und das inzwischen installierte AMD-Aktualisierungsprogramm, damit nicht AMD die Grafikkarte neu erkennt, sondern Windows.

Ich melde mich...

Gruß
Reinhard

Link to post
Share on other sites
Posted (edited)

Hallo @alle,

Blender läuft wieder auf meinem Hauptrechner. Dazu musste ich tatsächlich erst die AMD-Treiber-Aktualisierungssoftware entfernen. Erst jetzt hat Windows zwar AMD-Treiber gefunden und installiert, aber eine ältere Version aus 2019 (nicht die aktuellste von 2020). Vielen Dank nochmal an euch alle, aber besonders an @streit_ross, der mir den Hinweis gab, die Grafikkarte zunächst aus Windows zu entfernen.

369639568_Bild98Grafiktreiber.thumb.jpg.99a53f207342b8c0848fc5adcec852a2.jpg

Allerdings habe ich nun wieder ein Grafik-Problem beim Start des Rechners (etwa jedes 2. Mal startet der Rechner nicht mit der Benutzeroberfläche sondern mit einem bunten Wirrwarr an Linien welche sich nur mit einem kalten Neustart beenden lassen). Aber das ist nicht so wild, als wenn Blender nicht laufen würde.

Und Blender belasse ich zunächst bei der (stabilen) Version 2.83.10 (mit Cycles anstelle Eevee als Render-Engine). Bleibt meine Bitte von weiter oben, hier zu veröffentlichen, wenn sich bei Blender selbst diese Grafik-Probleme behoben haben (möglicherweise nur mit AMD Radeon, nicht mit Nvidia Gforce?)

Dann habe ich noch eine Frage: kann man die AMD Radeon-Grafikkarte ohne weiteres gegen eine Nvidia Gforce austauschen? Vielleicht nicht so teuer, wie ein neuer Rechner auf Gforce-Basis??

Gruß
Reinhard

Edited by Reinhard
Link to post
Share on other sites

Hallo Reinhard,
erstmal Glückwunsch, dass 'es' wieder lebt. Schon heftig, wie es letztlich zu bewältigen war.
Und zum Austausch von Grafikkarten: Ich habe noch nie davon gehört, dass das nicht möglich wäre.

Gruß
  Andy

Link to post
Share on other sites

Hallo Reinhard
 

vor 41 Minuten schrieb Reinhard:

kann man die AMD Radeon-Grafikkarte ohne weiteres gegen eine Nvidia Gforce austauschen?

Selbstverständlich, dazu aber ein paar Tips:

1. Ist dein Gehäuse groß genug für jede Grafikkarte? (es kann sein bei Slim-Gehäuse daß nur bestimmte Grafikkarten von den Abmessungen her passen, vorher aufschrauben und eventuell abmessen)

2. Daten sicherheitshalber auf ein externes Medium sichern

3. derzeitige Grafikkarten-Software und Treiber deinstallieren und Windows abschalten, dann erst neue Grafikkarte rein und Treiber installieren.

lg max

PS: Über Updates werde ich informieren, bin des öfteren in Foren und auf der Blender HP unterwegs.

Edited by maxwei
Link to post
Share on other sites

Hallo Reinhard,

informiere Dich mal bei Google über die Gigabyte GeForce GTX 1050 Ti OC Low Profile 4G  . Für ca.175 € bei Amazone erhältlich. Vorteil: 4 GB Speicher, 3 x HDMI. Vergleichssieger bei Warenvergleich.de 

Eine Nummer kleiner, nur 2 GB Grafikspeicher, dafür aber mitt passiver Kühlung und 100 € billiger, die MSI GeForce GT 1030. Preis-Leistungssieger bei Verbraucher.Org

Für einen technischen Vergleich der folgende Link:

Nvidia-Grafikkarte Test / Vergleich 2021 » Alle Modelle im Test & Vergleich (warenvergleich.de)

Gruß

streit_ross

Link to post
Share on other sites

Hallo Leute,
mein Bruder hat mir gerade sein etwas älteres Equipment vermacht. Was für ihn veraltet ist, ist für mich 'de luxe'. Meine Anlage läuft total ruckelfrei und die stellt schon Ansprüche. Er wartet sogar noch auf eine Grafikkarte und will mir dann auch seine geben (derzeit nutze ich eine Onboard-Karte, mit der ich eben schon wunschlos glücklich bin). Aber, ich habe mit dem Rechner doch ein Problem, was für mich durchaus relevant ist: die Stromkosten! Unterschätzt das mal nicht!!! Er hat dann auch mal gezuckt.<
Das ist was anderes, als so ein Schlepptop.

Gruß
  Andy

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
×
×
  • Create New...