Jump to content
JimKnopf

Hilfe zu den LOD Stufen und Materialien

Recommended Posts

Hallo Moin,

ich habe da eine Frage wie bringe ich 4 Materialien in meinem Modell Bhf Assuan unter ????

Material 1 ist die Multitextur

Material 2 ist die Transparente Textur für die Fensterscheiben

Material 3 ist für die _LS Objekte

Material 4 ist für die _LC Objekte

Das Modell hat die LOD Stufen 0 und 2, alle 4 Materialien sollen in der LOD Stufe 0 sichtbar sein. Geht das überhaupt und wenn ja wie muss ich die Materialien den LOD Stufen zuordnen ? In dem Modell habe ich der LOD Stufe 2 das Material 2 für die Fenster zugewiesen, aber es ist nur zu sehen wenn die LOD Stufe 2 aktiv ist.

Bhf. Assuan ID 6259204C-9AF0-452D-B460-BF8584ED9437

Vielleicht kann mir da jemand weiter helfen :/

Gruß Axel

Share this post


Link to post
Share on other sites

Hallo Axel,
LOD-Stufen sind doch nichts anderes als separate Objekte. In der Stufe 0 gehen ja 4 Materialien (oder?!?) und Transparenz brauchst Du in der Stufe 2 nicht mehr. Davon sieht man nicht mehr viel. Da kannst Du ganz durchlässig machen oder ganz dicht. Außerdem sieht er doch jetzt schon gut aus. Ist halt mächtig viel Sand auf den Scheiben ;).
Kannst die Transparenz in der 0 aktivieren, dann reicht's doch.

Gruß
  Andy

Share this post


Link to post
Share on other sites

Hallo Andy,

es dürfen leider nur 3 Materialien pro LOD Stufe sein. Wenn ich das Modell ohne LOD Stufen speichere habe 4 Materialien und gut 9000 Polys. Im Modelleditor kommt die Meldung ich möchte doch eine LOD Stufe einfügen mit drei weiteren Materialien… also erstelle ich die LOD Stufe 2 mit nur einer Textur und nur noch 4000 Polys, aber der Haken im Modelleditor wird nicht grün. Er wird nur grün wenn ich in Stufe 0 drei Materialien habe, das Material was ich aus Stufe 0 gelöscht habe und in Stufe 2 eingefügt habe ist auch nur in der LOD2 sichtbar.

Gruß Axel

Share this post


Link to post
Share on other sites

Hm, ich dachte, wenn's noch eine LOD-Stufe gibt, sind auch mehr Materialien im Hauptobjekt möglich. Schlimm genug, dass da in der Wiki keine genauen Angaben stehen.
Ich weiß jetzt nicht, inwieweit Du _LC auch für die Innenraumbeleuchtung verwendest. Ich denke mal, das tust Du. Ansonsten bliebe die Möglichkeit auf _LC zu verzichten und da 'vorbeleuchtete' Fassadenteile zu erstellen, zu den _LS zu legen und im Beleuchtungsfall auszutauschen. Mit den Strahlern außen würde es wohl gehen, aber mit Innenraum wird's heftig. Ich frage mich auch, wie man dann unter den Umständen noch _ENV und was weiß ich unterbringen soll. Es bleibt dann eben nur ein entweder-oder.
Mal sehen, vielleicht kommt ja noch ein besserer Tip rein. Wäre ich auch neugierig drauf.

Gruß
  Andy

Share this post


Link to post
Share on other sites

Ja Andy, das habe ich auch schon probiert, nur die LS Fassadenteile erscheinen mir viel zu hell. Ich werde mal versuchen vor den LS Fassadenteilen eine dunkle Glasscheibe setzen – mal sehen wie das wohl aussieht.

Gruß Axel

Share this post


Link to post
Share on other sites

Hallo Axel,

vor einer Stunde schrieb JimKnopf:

es dürfen leider nur 3 Materialien pro LOD Stufe sein

das stimmt so nicht!
In der LOD0, also der obersten Stufe, sind 5 Materialien möglich, wo bei Material NICHT GlEICH Textur bedutet!
Denn wenn Du aus der Multitextur einem ModellTeil ein "_LS" zu ordnest, dann gibt das ein zusätzliches Material, aber keine zusätzliche Textur!

Bei _LOD2 sind dann nur noch 3 Materialien (NICHT Texturen) erlaubt, wobei transparente Texturen (wie Andy auch schon schreibt) einfach weggelassen werden können: sind nicht mehr sichtbar.

Alle Klarheiten beseitigt?

Schöne Grüße
SputniKK

 

 

 

Share this post


Link to post
Share on other sites

Hallo SputniKK,

ich habe nur die Multitextur = also Material 1, aus der Multitextur sind auch die _LS Gruppen = Material 2 und auch die _LC Gruppen = Material 3 zu geordnet. Material 4 ist die transparente Textur. Soweit LOD0, also 4 Materialien. In LOD2 ist es genau wie in LOD0, nur ohne die transparente Textur. LOD2 hat also nur 3 Materialien, sollte so im Modelleditor passen – tut es aber leider nicht (keinen grünen Haken). Ich kapier einfach nicht warum das so ist…

Gruß Axel

Share this post


Link to post
Share on other sites

Hallo Axel,

dann hatte ich Dich falsch verstanden, denn Du machst offensichtlich alles richtig mit den LOD-Stufen (y).

Was wird Dir angezeigt, wenn Du auf das gelbe Dreieck im 3D-Modelleditor klickst?

Bild1.thumb.jpg.7a2770ead0e78640e58c9150f29c5293.jpg

Schöne Grüße
SputniKK

Share this post


Link to post
Share on other sites

Hallo Axel,

vor 3 Stunden schrieb JimKnopf:

Material 2 ist die Transparente Textur für die Fensterscheiben

... ich kann nur Transparenz im Oberlicht erkennen... wenn das so ist, und die Scheiben dort eine Tranransparents von 100% haben (sieht für mich so aus), dann ist es nach der Aussage von Neo zulässig, z.B. in der Multitextur eine Ecke zu machen, die zu 100% transparent ist.
Dies wird vom MBS dann nur als ein Materal gewertet... (habe es eben ausprobiert).

Die Regel:
>>Texturen mit Halbtransparenzen (Alpha-Werte) sollten nicht mit Texturen ohne Transparenzen vermischt werden. Genauer gesagt ignoriert das Studio alle Transparenzen von Texturen, wenn diese nicht mindestens zu 75% aus transparenten Pixeln bestehen.<<

... gilt nur für für Texturen, die zu kleiner 100% transparent sind.

... damit wäre "Material 2" hinfällig:)

Gruß
EASY

Edited by EASY

Share this post


Link to post
Share on other sites

Hallo Axel, hallo an alle,

entschuldigt, dass ich da reinplatze. stellt euch mal die Frage: was ist noch sichtbar(erkennbar) wenn ich als Betrachter das Modell aus der Nähe (LOD0) und dann aus einer großen Entfernung (LOD2) betrachte? Bei der LOD2-Stufe kann ich eigentlich nur noch,bei einem Gebäude, den Umriss mit Farbgebung, sowie die Dachfarbe erkennen. Diese 2 Materialien/Texturen stammen aus der LOD0-Stufe und die beiden sind dann auch in der LOD2-Stufe noch zu sehen. Damit ist die Bedingung der LOD-Stufe erfüllt und wenn die Datei der LOD-Stufe im gleichen Verzeichnis sich befindet wie LOD0, wird das grüne Häkchen gesetzt. Mit Multitexturen müsste es ebenso funktionieren.

Gruß Karl 

Share this post


Link to post
Share on other sites

Karl, Du kannst in LOD0 eine Lok, in LOD1 ein Haus und in LOD2 einen Quader in ein Modell rein tun und dabei völlig unabhängige Texturen verwenden.
Er fordert halt nur bei einer aufwändigen LOD0 nur noch etwas, was in der Entfernung entlastet. Mich wundern halt nur die Daten, die Axel in seinem zweiten Post gezeigt hat.
Ich hätte jetzt gedacht, das reicht nun. Es muß also so sein, wie SputniKK es gesagt hat. Er darf keine Transparenz-Dinge in LOD2 mehr drin haben, wenn er _LC dort noch verwendet. Es zählen die 'Typen', nicht die Texturen.

Gruß
  Andy

Share this post


Link to post
Share on other sites

Hallo Axel, wenn du willst kann ich mir das mal anschauen wenn du mir eine PN schickst, zwecks E-Mail-Austausch, vorausgesetzt du baust in Blender.

lg max

Edited by maxwei

Share this post


Link to post
Share on other sites

Moin, Moin,

danke euch für die Hilfe ich werde noch ein bisschen rumwerkeln bis es passt - oder ich lasse die Transparenten Flächen am Dach weg.

@maxwei auch dir Danke, ich erstelle die Modelle mit Sketchup.

 Gruß Axel 

Share this post


Link to post
Share on other sites

Hallo,

eigentlich ist es völlig egal, mit welchem Modellierungsprogramm man seine Modelle baut. _LS-Objekte, _LC-Objekte und Transparenz-Objekte benötigen halt immer ein eigenes Material, womit man zusammen mit den "Standard"-Material innerhalb eines Models immer bei 4 landet, wenn man in LOD2 nicht auf einen Objekttyp verzichtet. Bei meinen Fahrzeug-Modellen habe ich immer "normal", _LS und Transparenz eingesetzt (auch in LOD2), womit ich durchgehend 3 Materialien benötige. _LC habe ich bei meinen Modellen nicht im Einsatz.

Und warum benötige ich in LOD2 immer noch Transparenz?
Dies ergibt sich aus der Nachtbeleuchtung. Habe ich beleuchtete Innenräume (_LS), die bei Nacht durch die halbtransparenten Fenster nach außen scheinen, so wird das Licht durch die "Fensterscheiben" etwas gedämpft. Lasse ich nun in LOD2 die Fensterscheiben (sprich Transparenz) weg, wird das Licht aus den Innenräumen beim Übergang nach LOD2 plötzlich heller. Diesen Effekt habe ich als "störend" empfunden, weshalb es bei meinen Modellen auch in LOD2 (halb)transparente Flächen gibt.

Viele Grüße
BahnLand

Share this post


Link to post
Share on other sites

Hallo @JimKnopf ,

entschuldigt, wenn ich mich auch noch rein hänge.

Zitat

es dürfen leider nur 3 Materialien pro LOD Stufe sein.

Nein, wie oben Sputnick bereits geschrieben hat, können es bis zu 5 Materialien (Texturen und andere Objekte, also _LS usw.) sein .

Zitat

Wenn ich das Modell ohne LOD Stufen speichere habe 4 Materialien und gut 9000 Polys. Im Modelleditor kommt die Meldung ich möchte doch eine LOD Stufe einfügen mit drei weiteren Materialien…

Ja, diese Meldung ist Logisch. Bei jedem Modell mit über 5000 Polys, kommt diese Meldung. Es sollen halt nach Möglichkeit immer 5000 Polys sein. Da dies nicht geht, sollst Du eine weitere LOD-Stufe hinzu fügen. Wobei hier durchaus auch erst LOD1 kommen könnte. Nur sollte dann Die Anzahl der Polys um 30 % verringert werden. Wenn Du nur 3 oder 4 Materialien hast, können Die bleiben. Nur ab 5 Materialien, sollte es Eins weniger sein. Genauso verhält es sich dann bei Jeder weiteren LOD-Stufe. Im übrigen, Du sollst nicht weitere 3 Materialien zur nächsten LOD-Stufe hinzu fügen. Es steht dort sicher, daß es nur 3 sein sollen. Eben 3 aus der vorherigen Stufe.

Zitat

also erstelle ich die LOD Stufe 2 mit nur einer Textur und nur noch 4000 Polys, aber der Haken im Modelleditor wird nicht grün. Er wird nur grün wenn ich in Stufe 0 drei Materialien habe, das Material was ich aus Stufe 0 gelöscht habe und in Stufe 2 eingefügt habe ist auch nur in der LOD2 sichtbar.

Dies hört sich, meiner bescheidenen Meinung nach so an, als ob Deine Lod Stufen nicht im selben Ordner liegen, oder, was mir auch schon mehrmals passiert ist, es gibt irgendwo ein Teil, welches ein anderes Material/Texture hat, die Du nur in einem Modell verwendest. Also entweder LOD0  oder LOD 2.

Wobei ich mir den Text eben nochmal auf der Zunge zergehen lies und festgestellt habe, der letze Satz ist wieder Logisch vom Modelleditor. In Stufe eins hast Du 3 Materialien, in Stufe 2  nur noch eins. Ergo, hast Du 60 % an Materialien eingespart.

Was sagt der Editor denn, wenn Du nur LOD 2 hochlädst.

Schönen Abend wünscht

Andreas (astt)

P.S. Ein Nachtrag, der mir gerade noch eingefallen ist. Gehe bitte in den Ordner, in dem Du beide Lod Stufen gespeichert hast. Kopiere nun den Namen und nur den Namen der ersten Lod Stufe und füge diesen in in die zweite LOD Stufe ein. Mir ist es auch schon mal passiert, daß ich irgendwo ein Leerzeichen oder einen anderen Buchstaben hatte und das Programm deshalb die LOD Stufen nicht alle erkannt hat. Ich sass Tage davor ohne darauf zu kommen, wo der Fehler ist. Hat aber dann geholfen.

Edited by astt

Share this post


Link to post
Share on other sites

Moin, Moin,

habe den Fehler gefunden, ich hatte in der LOD2 Stufe bei einem Scheinwerfer die _LS und _LC Gruppen nicht gelöscht. Jetzt passt es mit der Anzahl der Materialien.

Das Entwurfsmodell 6259204C-9AF0-452D-B460-BF8584ED9437 habe ich aktualisiert und werde das Modell in den Katalog stellen, aber erst steht noch die Bauabnahme von Neo an.

Danke an allen die mir auf die Sprünge geholfen haben.

Kommt gut ins neue Jahr Gruß Axel

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×