Jump to content
Neo

Neue Beta-Version 4.0.9.0

Recommended Posts

vor 9 Minuten schrieb Neo:

Hallo,

der Menü-Punkt wird im Moment nur angezeigt, wenn lokale Dateien fehlen. Du kannst entweder deine Pakete bei dir unter "Meine 3D-Modelle" löschen und danach die Option wählen, oder auf das nächste Update warten, dann werde ich die Option dauerhaft aktivieren.

Viele Grüße,

Neo

Hallo Neo,

ich werde dann mal auf das Update warten.

Danke

fmkberlin

Share this post


Link to post
Share on other sites

Hallo Frank ( fmkberlin )

Ich bin kein Experte von Programmierung , am Anfang hat es bei mir auch nicht geklappt . Ich habe beim zweiten mal Neustart alles gehabt ( bei Standard ) . Heute bin ich auf Professional umgestellt worden , auch da musste ich Neustart ausführen .

Es kann sein das die Aktuellisierung nicht sofort funktioniert . 

Habe jetzt noch mal aus- und angemeldet , geht super !

Viele Grüße

H:xnS

Share this post


Link to post
Share on other sites

Hallo MBS-v4 Modellbau Experten,

ich brauche mal wieder eure Hilfe.

1.  Gibt es den Begriff _CCP noch?

2.  Das Programm richtet immer nur eine LOD Stufe ein.

Keine_LOD0-2.thumb.JPG.6a0acd469dddcf613dce4a7d465b6875.JPG

Wer kann mir Helfen.

Gruß fex

Share this post


Link to post
Share on other sites

Hallo Hans,

ich werde mal abwarten wie sich das entwickelt.

@Alle  - Ich habe ein neues Problem entdeckt! Gibt es in V4 nur noch 6 Animationen pro Modell?

59fccbb1ba7ed_Animationen1.jpg.e8e9ce4522f13f5809e59ea8f88a18d3.jpg

Die *:amin Datei sieht aber so aus -

59fccc07ac70c_Animationen2.jpg.2308fb4d0e563ddb2654047ca5611cac.jpg

Ein nächstes Problem, warum kommen alle Animationen mit Endlosschleife im Studio an?

VG

fmkberlin

Share this post


Link to post
Share on other sites

Halo fex,

Für die LOD-Stufen hat BahnLand weiter Vorne folgendes erklärt:

Detailstufe 1 = Dateiname.x

Detailstufe 2 = Dateiname_LOD1.x

Detailstufe 3 = Dateiname_LOD2.x

Damit hat es bei mir auch geklappt.

Zu _CCP kann ich leider nichst sagen.

VG

fmkberlin

Share this post


Link to post
Share on other sites

Hallo fmkberlin,

zu Punkt 2 habe ich schon eine Lösung gefunden: der Dateinamen darf keine Bindestriche im Namen haben.

Zu Punkt 1 muss ich noch warten.

Gruß fex

Share this post


Link to post
Share on other sites

hallo fex,

die lod stufen werden automatisch vom program erkannt - wenn sie im selben verzeichnis wie das haupt modell und den namen des hauptmodells mit der namenserweiterung _LOD1 oder _LOD2 haben und als .x datei vorliegen.

hauptmodell = haus.x
lod stufe       = haus_LOD1.x ... usw

vg quackster

Share this post


Link to post
Share on other sites

Hallo an alle lösungssuchenden Spezialdiskurierer,

bei allem Verständnis für Eure Diskussion über ganz spezielle nur mit den von Euch genutzten Eingeweihte zu verstehende und dann wohl auch zugegebenermaßen not- wendigen gegenseitigen Hinweisen, nutzt doch bitte dafür den persönlichen Nachrichtenaustausch. Es dürfte doch von Euch zu verstehen sein, dass eine derart detailierte Problemdiskussion nun wircklich nicht von der großen Allgemeinheit mit Interesse verfolgt werden dürfte. Wenn Ihr denn ein praxisreifes Produkt im Ergebnis Euer Dialoge geschafft habt, dann holt Euch hier im Forum unseren (garantierten) Dank ab. Bis dahin lasst uns "Laien" aber auch noch Platz zum Fragen vergrößert nicht unbewusst die Unübersichtlichkeit des Forums.

Viele Grüße

Streitross 

Share this post


Link to post
Share on other sites

Hallo Streitross,

wenn Du vorgeschlagen hättest, dass man für solch "spezielle" Themen bitte einen neuen Thread aufmachen oder den schon vorhandenen Forenzweig "Modellbau" im Abschnitt "Modelle" hierfür vewenden möge, wäre ich mit Deiner Bitte möglicherweise einverstanden gewesen. Den Vorschlag, man möge für solche Diskussionen doch bitte den "privaten Nachfrichtenaustausch" verwenden, kann ich dagegen überhaupt nicht unterschreiben. Denn

  1. bei einer privaten Nachricht lege ich explizit fest, wen ich damit adressieren möchte. Damit habe ich den Kreis der Diskutierenden von vornherein festgelegt.
  2. jemand aus dem Forenkreis bekommt dann überhaupt nicht mit, dass ihn dieses Thema eeventuell interessieren könnte, und nimmt damit gezwungenermaßen an diesem Erfahrungsaustausch überhaupt nicht teil.
  3. das Forum erfüllt auch den Zweck, Informationen, die hier ausgetauscht und erarbeitet werden, auch für mögliche später zum Forum stoßenden Interessenten "aufzubewahren" und verfügbar zu halten.

Private Nachrichten sind daher in meinen Augen kein geeignetes Mittel, Erfahrungen und Hilfestellungen auszutauschen, die auch nicht adressierte Forums-Teilnehmer interessieren könnten. Auch ich interessiere mich nicht für alle Themen, die hier im Forum angesprochen werden, dann ignoriere ich diese Themen eben, fordere aber nicht, dass diese dann bitteschön nicht im Forum zu diskutieren seien. 

Gerade in dem hier vorliegenden speziellen Fall (Validierung der Beta-Version zur Stabilisierung und Justierung der neuen Programm-Funktonalität) halte ich es besonders wichtig, dass alle betroffenen Themen (auch jene speziell zum Modellbau) hier im Forum für alle zugänglich besprochen werden. Nur so ist es möglich, jeden, der sich für das Thema interessiert, in die Diskussion einzubinden und dessen konstruktive Ideen in die Validierung mit einfließen zu lassen. Die anderen mögen diese für sie möglicherweise zu spezilellen Diskussionsabschnitte bitte einfach ignorieren.

Viele Grüße
BahnLand

Share this post


Link to post
Share on other sites

Hallo Streitross,
so sehr ich Dich hinsichtlich der Unübersichtlichkeit des Threads verstehe, - ich suche auch schon mal verzweifelt (da hatte ich doch mal was gelesen)-, halte ich gerade am Anfang nur einen Thread für die Umstellung für sinnvoll. Eine private Diskusion ist m.E. kontraproduktiv. Auch wenn ich manchmal nur die Hälfte davon verstehe worum es in den Diskusionen geht, kann ich daraus doch immer wieder Brosamen herausklauben, die mir bei meinen Problemchen, die ich mit der neuen Version habe, weiterhelfen.
Dies würde mir entgehen, wenn sich die Diskusionen auf einen privaten Kreis beschränken würde.
Insoweit kann ich Bahnland nur zustimmen.

Viele Grüße

Jochen

Edited by Jochen

Share this post


Link to post
Share on other sites
Am ‎03‎.‎11‎.‎2017 um 14:20 schrieb Neo:

Das ist Absicht. Früher hat man die virtuelle Kamera per Maus und Tastatur bewegt, heute bewegt man standardmäßig die Anlage. Damit gleicht sich das Studio anderen 3D-Programmen an, wodurch die Umstellung leichter fällt (wenn man sich erst mal an die neue Steuerung gewöhnt hat).

Das dies aber nur bei gedrückter Maustaste passiert ist unglücklich. Bei anderen Programmen erfolgt die Verschiebung ebenfalls wenn man einfach mit dem Cursor an den Bildschirmrand stößt.

Abgesehen davon finde ich die Voreingestellte Richtungswahl eher kontraproduktiv, aber das ist eine persönliche Sache und kein generelles Problem.

Share this post


Link to post
Share on other sites

Zuerst ein herzliches "Hallo" in die Runde ...

seit etwa zwei Wochen bin auch ich vom "MBS-Virus" (V3)  infiziert und habe mit viel Interesse die Neuerungen der V4 studiert.

@Neo : da ist Dir aber ein Meisterstück gelungen ! Tolle Leistung - absolut !

Da es ja in V4 einige neue, animierte Objekte (Drehscheibe und Schiebebühne) gibt, würde mich folgendes interessieren :

Wird es für diese auch eine "Steuerschnittstelle" (wie "Rollmaterial-Kommands" oder "Kran-Kommandos") geben ? 

Hintergrund :

meine kleine, reale Spur N-Anlage steuere ich komplett mit mehreren Arduinos.

Als Bedienoberfläche dient mir die HMI-Software "zenon". Da diese Software eine VSTA-Schnittstelle (C#) bietet,

habe ich einen asynchronen TCP-Client entwickelt, der sich zur MBS-Steuerschnittstelle verbindet.

Alle Befehle, die ich jetzt zum Beispiel an meine realen Loks über den Arduino sende, werden gleichzeitig über

die TCP-Verbindung an das MBS gesendet - und voila : sie bewegen sich absolut synchron.

Mein "Faller Containerterminal" kann ich auf die gleiche Weise steuern bzw. animieren ...

Toll wäre es, wenn ich das auch für meine Drehscheibe und Schiebebühne realisieren könnte ...

@Neo : ich hoffe, es Dir einen Gedanken wert und das Wiki wird ergänzt ?

Vielen Dank für Eure Aufmerksamkeit und liebe Grüße aus dem Schwabenland,

Reinhardt

Share this post


Link to post
Share on other sites

Also als erstes mal was zum Thema der beiden neuen Bit Versionen. Ich hab mir beide Versionen runter geladen die 64 Bit und auch die 32 Bit Version. Habe jetzt mal die Frames auf der Bahnbärs- Anlage getestet  ( ich denke diese ist durch seine Grösse und den vielen Animationen mit den farbahren Autos und den gehenden Fussgängern mit am Frame intensivsten die momentan in der Community drin sind ) komischerweise habe ich bei der 32 Bit Version mehr Frames als bei der 64 Bit Version. Bei der 64 Bit war der niedrigste Wert 13,9 und auf der 32 Bit 16,3 Frames obwohl da steht die 64 Bit version ist besser für grösserer Anlagen . Aber ich kenne mich mit den Bit Versionen auch nicht so aus es ist mir nur an meinem PC aufgefallen. Ich Selber habe  ein ziemlich schwaches System ein Asus ZenBook UX 305 mit einer I7 U 5500 Prozessoreinheit , gehört zur Kategorie der Ultrabooks daher kann ich auch nicht jede Anlage komplett Ruckelfrei wiedergeben ( selbst die Bahnbärs Anlage je nach Zoomstufe ruckelt bei mir mit locker über 20 Frames noch  ( das ist immer so ein leichtes gestocke der Zug fährt nicht flüssig durch genauso wie die Autos trotz akzeptabler Framerate) dagegen ist die Anlage Kleinstadt mit einer ähnlichen Framerate ( tendenziell sogar weniger im vergleich als die Bahnbärsanlage ) trotzdem irgendwie viel Ruckelfreier ( aber auch ohne Bewegungsanimationen von Autos und Fußgängern ) Falls das ganze etwas komisch klingt kann ich das durchaus verstehen aber das sind  Performentzbeobachtungen die ich bei mir gemacht habe. Die Vierländereck Anlage dagegen funktioniert auf meinem Sytstem natürlich sowieso gar nicht. Ich versteh es manchmal selber nicht aber es ist so . Dies sollte keine Kritik an die sehr schön gemachten Anlagen ( Kleinstadt und Bahnbärs ) sein aber wie gesagt das sind Faktoren die ich bei mir beobachten konnte und diese beiden anlagen habe ich halt getestet. Aufgrund dieser Tatsachen sind mir Anlagen ohne  Bewegungsanimationen von Autos und Fussgänger daher doch viel lieber . Die Anlagen schauen auch gut aus wenn man die Autos und Fußgänger einfach nur hinstellt und es ist Performentzfreundlicher gerade für Schwache Systheme wie meins. Habe auch gehört das viel an Beleuchtungen momentan gebaut wird . Ich hoffe eine aufwendige Nachtbeluchtung frisst nicht mehr als am tag da hab ich schon wieder etwas angst mit meinem ZeenBook . Neija schönen abend euch noch

Share this post


Link to post
Share on other sites

Hallo Neo,

vielleicht hast Du es überlesen.

Deshalb noch mal die Frage: "Ist in V4 die Anzahl der Animationen, pro Modell, auf 6 Animationen beschränkt?"

VG

fmkberlin

Share this post


Link to post
Share on other sites

Hallo Frank,

in der V4-Version des Steuerwagens meines RAe TEE II habe ich 11 Animationen eingebaut.

Viele Grüße
BahnLand

Share this post


Link to post
Share on other sites

hallo Neo,

für den gleiseditor würde ich mir schon die möglichkeit wünschen, weichen als rückfallweichen zu markieren.

bei mehrspurigen strassen mit möglichen spurwechseln ist das schon von nöten.

vg quackster

Share this post


Link to post
Share on other sites
vor 18 Minuten schrieb BahnLand:

Hallo Frank,

in der V4-Version des Steuerwagens meines RAe TEE II habe ich 11 Animationen eingebaut.

Viele Grüße
BahnLand

Hallo BahnLand,

ich hatte die Bilder schon mal eingestellt.

hier die *.anim Datei -

5a0030352603c_Animationen2.jpg.61d27972be6c0fd123a162d369a27163.jpg

und hier das Eigenschaftsfenster -

5a0030649eec5_Animationen1.jpg.869b8a1c1f5653967aebfaa84eef1e6d.jpg

In der EV sieht es genauso aus!

Wenn ich meine Fahrzeuge mit Licht ausstatte, brauche ich nur dafür -

1. Ablendlicht

2. Fernlicht

3. Blinker Rechts

4. Blinker Links

5. Bremslicht

6. Rückfahrlicht

schon diese 6 Funktionen. Dann sind aber keine weiteren Animationen, wie Türen öffnen oder Ähnliches, möglich.

VG

fmkberlin

 

Share this post


Link to post
Share on other sites

Hallo Frank,

prüfe bitte mal Deine AnimationSet-Definition in der x-Datei, ob wirklich in allen AnimationKey-Definitionen die Zustände 0-122 spezifiziert wurden und auch überall als Anzahl "123" angegeben ist. Wenn nämlich diese Zahl beispielsweise auf "111" stehen würde, wäre dies eine Erklärung dafür, dass die Animationen 7 und 8 nicht übernommen wurden und daher auch im Eigenschaftsfenster des Modells nicht angezeigt werden.

Viele Grüße
BahnLand

Share this post


Link to post
Share on other sites

Hallo BahnLand,

Danke für Deine schnelle Antwort!

5a003cef46768_Animationen3.thumb.jpg.3d785073969e8f564693a2708a6ed158.jpg

Das fehlende Rueckfahrlicht ist bei 117-122 definiert. Ich habe es jetzt aber noch bei meinem Trecker probiert -

5a003d9871f97_Animationen4.thumb.jpg.14105b8c570c4eb3d1adb4ebce38a68b.jpg

Und da fehlt mittendrin die Position 8-.  ???

Muss jetzt aber erstmal zum Zahnarzt!

VG

fmkberlin

Share this post


Link to post
Share on other sites

Heureka, ich habe es gefunden :D

Nachdem BahnLand (Noch mal vielen Dank für Deine Hilfe!) auch keinen Grund finden konnte warum V4 die Animationen nicht übernimmt, V3 aber sehr wohl, habe ich doch noch weiter probiert! Ich konnte dann feststellen, das V4 genau die Animationen Brems- und Rückfahrlicht nicht akzeptiert. Auch wenn man sie im Model in der Reihenfolge veschiebt. Habe dann die Animation für das Bremslicht gelöscht und neu angelegt. Vorher war nur über Positionsänderung, und das nur um ein kleines Stück, animiert. Diese Positionsänderung habe ich vergrößert und gleichzeitig noch eine leichte Skalierung hinzugefügt. Und jetzt klappt es :)

5a00d96692bf1_Animationen6.jpg.65073828e708ec0afff9a55f4b5707f9.jpg

Ich bin schon gespannt, was da noch alles kommt!

VG

fmkberlin

Edited by fmkberlin

Share this post


Link to post
Share on other sites

Hallo Frank

Freue mich auf die Erweiterungen deiner vorhandenen Rollmaterial ( Busse ,  LKW usw. ) .

Es ist ja nicht alles an einen Tag geschaffen worden , also laßt dir genug Zeit Du brauchst .

Ich kann dann ja später die Fahrzeuge auswechseln .

Danke für die Mitteilung der Änderungen !

Viele Grüße

H:xnS

Share this post


Link to post
Share on other sites

Hallo,

dank eurer Tests habe ich soeben ein neues Update veröffentlicht, was die ersten größeren Fehler der neuen Version V4 beseitigt. Eine Auflistung der Änderungen könnt ihr am Ende meines ersten Beitrags hier einsehen.

Am 6.11.2017 um 03:15 schrieb fmkberlin:

Ist in V4 die Anzahl der Animationen, pro Modell, auf 6 Animationen beschränkt?

Nein, wie du schon selber herausgefunden hast, wurden deine Animationen teilweise wegoptimiert, da sie nur minimale Transformationsänderungen besaßen. Diese Optimierungen sind allerdings wichtig, weil der Blender-Exporter teilweise für nicht-animierte Objekte Animationen exportiert, und diese wieder herausgefiltert werden müssen, um die Komplexität von Modellen nicht zu beeinträchtigen.

Am 6.11.2017 um 10:36 schrieb quackster:

bei mehrspurigen strassen mit möglichen spurwechseln ist das schon von nöten.

Inwieweit kann dafür die vorhandene Funktion des Rollmaterials "Weichen freischalten" genutzt werden?

Am 5.11.2017 um 13:23 schrieb Fairchild57:

Wird es für diese auch eine "Steuerschnittstelle" (wie "Rollmaterial-Kommands" oder "Kran-Kommandos") geben ?

Im Moment gibt es für V4 zwar keine Steuerschnittstelle, aber nur, weil sie einer zukünftigen Schnittstelle weichen muss. Es wird zwar nicht sofort, aber in Zukunft wieder die Möglichkeit geben, externe Programme an das Studio anzubinden, dann aber ohne den Problemen der alten Schnittstelle.

Am 5.11.2017 um 20:52 schrieb Markus Meier:

komischerweise habe ich bei der 32 Bit Version mehr Frames als bei der 64 Bit Version.

Die "Bittigkeit" hat keinen Einfluss auf die Geschwindigkeit des Studios, da die meiste Arbeit die Grafikkarte erledigt, und diese nicht zwischen 32- und 64-Bit trennt. Die neue 64-Bit-Version ermöglicht lediglich das Laden von Anlagen, die mehr als 4 GB Arbeitsspeicher benötigen.

Viele Grüße,

Neo

Share this post


Link to post
Share on other sites

Hallo Neo (Zitat aus Ergänzung von heute im Beitrag vom 31.10.),

Am 31.10.2017 um 10:46 schrieb Neo:

Eine Tauschtextur wird standardmäßig auf alle Variationen angewendet, da Variationen für gewöhnlich die gleichen Tauschtextur-Layouts verwenden

wie ist diese Aussage zu verstehen?
Meinst Du damit, dass dann, wenn ein Benutzer einer Variante des Modells auf der Anlage eine Tauschtextur zugewiesen hat, diese auch dann wirksam bleibt, wenn der Nutzer für diese Ausprägung des Modells nach der Tauschtextur-Zuordnung eine andere Variante auswählt?

Ich vermute, dass der Modellbauer trotzdem für alle Varianten, für die er Tauschtextiuren zulassen möchte, die betroffene Original-Textur weiterhin mit "_Custom.xxx" bezeichnen muss ("xxx" stellvertretend für passende Datei-Endung), da sie ja nur so als auszutauschende Textur erkannt werden kann.

Viele GRüße
BahnLand

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×