Jump to content

V7 - keine Verbindung zur Online-Datenbank


AndreasWB

Recommended Posts

Hallo,

nachdem sich die registrierte V7 automatisch aktualisiert hat, bekommt sie keine Verbindung mehr zur online-Datenbank.

Beim Start sucht sie "ewig", bevor sie mir meine zuletzt geöffneten Projekte anzeigt.
Anlagen oder Objekte mittels ID werden nicht gefunden. Ebenso der online-Katalog.

Gruß

Andreas

Datenbank suchen V7.jpg

online-DB na.jpg

Edited by AndreasWB
Link to comment
Share on other sites

Hallo Andreas,

es liegt sehr wahrscheinlich an Deinem Rechner, bzw. an Deiner Internetverbindung, denn auch bei mir funktioniert alles ohne Probleme.

Woran es aber bei Dir liegen könnte, wäre von weitem reine Spekulation.

Schöne Grüße SputniKK

Edited by SputniKK
Link to comment
Share on other sites

Hallo Andreas,

Netzwerkprobleme können sehr zahlreiche Ursachen haben, wir selber kennen jedoch dein System nicht und müssten blind losraten.

Verbindungsprobleme mit den MBS-Servern sind mir darüber hinaus nicht bekannt. Wie weitreichend sind deine Computerkentnisse?

Viele Grüße, 

Neo

Link to comment
Share on other sites

Hallo Neo,

klar, kann man nicht blind losraten.
Daher nochmals (teileise wiederholt aus dem Eingangs-Post):

Am 26.9. habe ich die V7 erworben. Danach die neue Lizenz bezahlt und nach Installation auch erfolgreich freischalten können.
Sodann hat vermutlich zunächst auch die Kommunikation mit Eurem Server erfolgreich funktioniert.

Erst als wenige Tage später die Meldung über ein Update für V7 erschien, welches ich dann auch installiert habe, fing der Ärger an.
Beim Starten der Anwendung bekam ich ab dann immer diesen "Trieselkries" für einige Minuten, bis sich dann die Startseite mit meinen zuletzt geöffneten Anlagen erscheint.
@alle
Die fehlende Verbindung merkt man zunächst nicht! Solange man Bauteile verwendet, die auch schon in früheren Anlagen vorhanden sind, funktioniert das Auswählen und Einfügen einwandfrei. Nur - !! - wenn man Bauteile auswählt, die man noch niemals bisher verwendet hat, erst dann kommt die Meldung über den Verbindungsfehler.
Da ich die neuen Fähigkeiten von V7 bei meinen bestehenden V6-Anlagen ausprobiert habe, trat das Problem die ersten Tage auch noch nicht auf.

So, nun wieder @Neo: Meine Computer-Kenntnisse sind hinreichend gut. Nur mit Widows-Interner hapert es etwas.

Eine meiner Vermutungen war, daß die Windows-Firewall (Win 7 - 64 bit pro) das Programm irgendwie blockiert, scheint jedoch nicht der Fall zu sein (siehe Anhang).
Wie findet MBS den Zugang zu Eurem Server? Ist ggf. die entsprechende Info im Programm beschädigt? Fehlende/beschädigte Config irgendwo?
Was kann ich im Installations-/ Datenverzeichnis überprüfen?

Der Speicherort meiner Anlagen / Datenbank ist nicht im default %appdata% des Systemlaufwerks, sondern auf meiner Daten-HDD (siehe Anhang).

Zunächst dachte ich, daß ggf. eine Neu-Installation das Problem beheben könnte. Jedoch kann ich nun die nochmals installierte V7 nicht mehr Freischalten (mangels weiterhin bestehender Verbindungs-Fähigkeit). Auch die alte V6, die parallel weiterhin installiert ist, hat nun dieses Verbindungsproblem.

Welche Informationen benötigt Ihr noch?

Gruß

Andreas

MBS in Firewall.jpg

MBS Speicherort.jpg

Link to comment
Share on other sites

@ AndreasWB...

How did that Database path get there ..? Was it the System that wrote it, or have you written it yourself ..? My installations, for v6 and for v7, are on external USB drives, but I let the system write the paths. Both paths point to the Studio folder, not the catalog. Here's a screenshot of my v7 settings ...

How did this database path get there? Was it the system that wrote it or did you write it yourself? My installs for v6 and v7 are on external USB drives, but I let the system write the paths. Both paths point to the Studio folder, not the catalog. Here is a screenshot of my v7 settings ...

1582772828_2021-10-0411_59_07-3DTrainStudioV7.thumb.jpg.e5902a72ae2effde0d738f1722f87f29.jpg

Try removing the '\ Catalog' from the path; I think that's confusing MBS.
Hope this helps. B |

Douglas

Try removing '\ Catalog' from the path; I think MBS is confusing.
Hope that helps. B |

Edited by Dad3353
Link to comment
Share on other sites

Hallo an Alle

 

Wenn jetzt aber die Verbindung bei anderen funktioniert. Nur bei einem einzelnen User nicht, kann das Problem doch deutlich eingegrenzt werden.

Zumindest, bei wem das Problem liegt.

Bei mir gibt es keinerlei Verbindungsprobleme und daher habe ich auch mal Modelle heruntergeldaen, die ich noch nie benutzt hatte.

Am einfachsten geht dies mit dem Herunterladen einer Anlage. Da muss man sich nicht erst einzelne Modelle durchsuchen, die man noch nciht benutzt hatte.

 

Gruß in die Runde

Link to comment
Share on other sites

Ich würde beim Datenbank-Speicherort mal auf die drei Pünktchen gehen. Wenn es da zu Verzögerungen kommt, ist der eingetragene Pfad falsch, bzw. nicht mehr zugänglich, denn den würde er in der Auswahl als erstes zeigen. Ferner sollte er im dargestellten Baum dann in 'Catalog' noch den Ordner 'Data' zeigen. Wenn das alles schnell und problemlos geht, weiß ich's auch nicht. Auch bei einer HDD stellt sich nicht die Frage, ob sie kaputt geht, sondern nur wann.

Gruß
  Andy

p.s.: im Originalpfadnamen heißt es übrigens \3D-Modellbahn Studio V7\

Edited by Andy
Link to comment
Share on other sites

Wenn ich lese, dass noch Windows 7 auf dem Rechner ist, schrillen bei mir die Alarmglocken. Das wird schon lange nicht mehr mit Updates versorgt und ist ein offenes Scheunentor für potentielle Angreifer. Auch wenn alles gestern noch problemlos funktionierte, kann das heute schon anders aussehen. Ich will nicht behaupten, dass das alte Windows 7 das Problem ursächlich verschuldet, aber generell würde ich dazu raten, auf Windows 10 zu upgraden. Geht ja zum Glück immer noch mit der Windows 7-Lizenz.

Gruß

streit_ross

Link to comment
Share on other sites

46 minutes ago, Andy said:

... ps: by the way, the original path name says \ 3D-Modellbahn Studio V7 \

This is true if installing the data in the same place as the program; this is not 'best practice'. The program goes into the Windows 'Program Files' folder, but it's better if the data goes into the Windows 'Program Data' folder. I have such folders on all my external disks that contain programs, and keeps the place tidy. A backup of data is so much easier, faster and more convenient if it's only the 'Program Data' folders that get backed up.
It's not important, if one is not 'IT savvy', but for those handling many programs over many disks, good house-keeping becomes a higher priority. My 'C' drive is a relatively small (120Gb ...) SSD, so I keep that only for system use. It's far too small for the terabytes I have of data on USB drives and a couple of NAS devices.

Dies gilt, wenn die Daten an derselben Stelle wie das Programm installiert werden; dies ist keine „beste Praxis“. Das Programm wird in den Windows-Ordner "Programme" verschoben, aber es ist besser, wenn die Daten in den Windows-Ordner "Programmdaten" verschoben werden. Ich habe solche Ordner auf allen meinen externen Festplatten, die Programme enthalten, und hält den Ort aufgeräumt. Eine Datensicherung ist so viel einfacher, schneller und bequemer, wenn nur die Ordner „Programmdaten“ gesichert werden.
Es ist nicht wichtig, wenn man nicht 'IT-versiert' ist, aber für diejenigen, die viele Programme auf vielen Platten handhaben, wird eine gute Haushaltsführung eine höhere Priorität. Mein 'C'-Laufwerk ist eine relativ kleine (120 GB ...) SSD, also behalte ich das nur für den Systemgebrauch. Es ist viel zu klein für die Terabyte, die ich an Daten auf USB-Laufwerken und ein paar NAS-Geräten habe.

Edited by Dad3353
Link to comment
Share on other sites

4 minutes ago, streit_ross said:

When I read that Windows 7 is still on my computer, the alarm bells ring for me. It has not been provided with updates for a long time and is an open barn door for potential attackers. Even if everything worked fine yesterday, things may look different today. I don't want to claim that the old Windows 7 was the cause of the problem, but in general I would recommend upgrading to Windows 10. Fortunately, you can still use the Windows 7 license.

greeting

arguing_ross

I am now wary of Windows Updates, as too often they crush working programmes and drivers. I have had Windows 10 since it came out, but have now stopped all updates except the anti-virus definitions, and my System remains in a stable 2019 configuration. Too often I've had to completely re-install after a µsoft update, with no means of rolling back. Windows 10 is fine, once it's stable, but one has to keep it stable to be useful. No more updates for me; I don't want nor need the 'extras' that they bring (Yes, I'm old...).

Ich bin jetzt vorsichtig mit Windows-Updates, da sie zu oft funktionierende Programme und Treiber zerstören. Ich habe Windows 10 seit dem Erscheinen, habe aber jetzt alle Updates mit Ausnahme der Antivirendefinitionen gestoppt, und mein System bleibt in einer stabilen 2019-Konfiguration. Zu oft musste ich nach einem µsoft-Update eine komplette Neuinstallation durchführen, ohne dass ein Rollback möglich war. Windows 10 ist in Ordnung, sobald es stabil ist, aber man muss es stabil halten, um nützlich zu sein. Keine Updates mehr für mich; Ich will und brauche die "Extras", die sie mitbringen, nicht (Ja, ich bin alt...).

Link to comment
Share on other sites

Hi Doug,
basically you are right, so that datas are separated from programs. Best on another disk/partition. But then: if you buy a computer today, there is windows preinstalled and there is only one disc/partition. And after all: Datas are now simply in the folder 'Users', (as MBS-Datas are too), and this folder is prepared for multiuserhandling, networks and so on. After all Windows works best, if you let it alone...

greets
  Andy

p.s.: I pointed to the folder name because of the letters in bold, which are missing in Andreas' folder name. If he copied all, those are missing.

Edited by Andy
Link to comment
Share on other sites

1 hour ago, Andy said:

...if you buy a computer today, there is windows preinstalled and there is only one disc / partition. And after all: Datas are now simply in the folder 'Users', (as MBS-Datas are too), and this folder is prepared for multiuserhandling, networks and so on. After all Windows works best, if you let it alone ...

Indeed, such is Modern Life, 9_9but I am old, so I do things correctly. B|

Tatsächlich ist das moderne Leben so 9_9, aber ich bin alt, also mache ich die Dinge richtig. B|

:D :P

Link to comment
Share on other sites

Hallo Andreas,

einen Zusammenhang mit dem lokalen Datenbankverzeichnis kann ich nicht sehen. Gibt es Probleme beim Zugriff auf die Datenbank, wird eine entsprechende Fehlermeldung ausgegeben.

Es gab allerdings am 30. September ein Ereignis, was dazu führte, dass alte Geräte nicht mehr auf verschlüsselte Webseiten zugreifen können, weil diese alten Geräte ein bestimmtes Zertifikat nicht mehr unterstützen. Weitere Informationen siehe hier.

Womöglich ist dein veraltetes Windows 7-System ebenfalls betroffen. Hast du alle Updates installiert? Gerade die Tatsache, dass bei dir plötzlich mehrere Programme nicht mehr funktionieren, deutet auf ein zentrales Problem in deiner Software/Hardware hin.

Mit dem Studio selbst ist alles in Ordnung, dieses verwendet die Internetfunktionalität des darunterliegenden Betriebssystems.

Viele Grüße,

Neo

Link to comment
Share on other sites

Hallo Neo,

es sind nicht "mehrere" Programme, sondern ausschließlich nur Euer 3D Modellbahnstudio. Alle anderen Programme, auch von internationalen kommerziellen Anbietern, die sich auch selbsttätig gesichert mit den Sites verbinden, funktionieren weiterhin einwandfrei.
Hier muß also eine Lösung von Eurer Seite gefunden werden. (Einbinden der Verschlüsselung in das Executable statt externer inkompatibler API)

Gruß

Andreas

Edited by AndreasWB
Link to comment
Share on other sites

Hallo Andreas,

wir können dir von unserer Seite aus nicht weiter helfen, da kein anderer Nutzer Probleme mit der Internetverbindung unter V6 oder V7 hat. Der wichtigste Tipp im Moment ist, auf Windows 10 oder 11 zu aktualisieren, da dein Windows 7 von Microsoft nicht mehr unterstützt wird und wir daher nicht sicherstellen können, ob dein System überhaupt auf dem aktuellsten Stand ist.

Viele Grüße,

Neo

Link to comment
Share on other sites

Hallo Neo,

es kann doch nicht sein, daß ich, trotz bisheriger auf Eurer Webseite garantierter Kopatibilität, jetzt nur für die weitere Nutzung von MBS zusätzlich Geld ausgeben soll.
Schließlich habe ich vor Eurer Änderung meinen Obulus ordnugsgemäß für die Lizenzen von V6 und V7 entrichtet.
Mein System ist aus dem aktuellen Stand, der letztens von Microsoft noch geliefert wurde.

vor 1 Stunde schrieb Neo:

Der wichtigste Tipp im Moment ist, auf Windows 10 oder 11 zu aktualisieren,

Ist das wirklich Dein Ernst?

Link to comment
Share on other sites

Hallo Andreas,

vor 31 Minuten schrieb AndreasWB:

Ist das wirklich Dein Ernst?

ja, denn Windows 10 gibt es auch weiterhin für Windows 7-Nutzer gratis. Und sobald Microsoft ein Betriebssystem nicht mehr unterstützt, sollte ein Wechsel schon aus Sicherheitsgründen vollzogen werden.

Zwingend erforderlich ist das Update nicht, denn es gibt noch andere Nutzer, die Windows 7 ohne Probleme einsetzen. Nur kann ich dir aktuell ohne weitere Hinweise nicht helfen, wenn andere Nutzer keine Verbindungsprobleme haben. Auch eine frische Installation von Windows 7 in einer virtuellen Maschine (VM) zeigt keine Probleme in V6 oder V7.

Es handelt sich daher nicht um ein grundsätzliches Problem (weshalb ein Wechsel der API keine Lösung wäre), sondern um ein sehr spezielles Problem, dessen Ursache wir nicht kennen und wir aus der Ferne auch nicht diagnostizieren können. Daher bleibt mir leider nichts anderes übrig als dir ein Update auf ein aktuelles Betriebssystem zu empfehlen.

Viele Grüße,

Neo

PS: Kannst du mit dem Internet Explorer folgende Webseite öffnen: https://valid-isrgrootx1.letsencrypt.org/

Link to comment
Share on other sites

vor 2 Stunden schrieb AndreasWB:

Hallo Neo,

es sind nicht "mehrere" Programme, sondern ausschließlich nur Euer 3D Modellbahnstudio. Alle anderen Programme, auch von internationalen kommerziellen Anbietern, die sich auch selbsttätig gesichert mit den Sites verbinden, funktionieren weiterhin einwandfrei.
Hier muß also eine Lösung von Eurer Seite gefunden werden. (Einbinden der Verschlüsselung in das Executable statt externer inkompatibler API)

Gruß

Andreas

So ein Tonfall gehört sich nicht !

Wenn Du der Einzige mit diesem Problem bist und sich bisher noch kein anderer mit gleichem Problem gemeldet hat, ist auch für mich klar, das die Ursache nur bei Dir liegen kann.

Kein Grund, sich so im Ton zu vergreifen !

Vielleicht hast Du ja mal die Möglichkeit, das 3D MBS auf einem anderen Rechner auszuprobieren. Da würde ja auch die Demo-Version genügen.

Link to comment
Share on other sites

Tonfall:

es ist leicht von einemn Wechsel zu sprechen. Es hängt aber noch viel mehr dahinter.
Es sind zahlreiche weitere Programme und Entwicklungsumgebungen installiert.

Und dann das alles riskieren nur wegen eines Spielzeugs? ...

meint

Andreas

Link to comment
Share on other sites

  • 1 year later...

Hallo zusammen,

ich bin neu hier. Ich habe vor ein paar Tagen MBS V7 Professional installiert und wollte mir nun den Offline-Katalog für meinen Urlaub herunterladen.

Leider bis ich genau auf das hier beschriebene Problem gestoßen. Mehrere Versuche wurden letztlich immer mit der Fehlermeldung (s. o.) quittiert. Ich benutze Windows 10 22H2 mit allen Updates. Ich habe bisher mit keinem Programm Verbindungsprobleme gehabt, nur jetzt mit MBS. Gibt es evt. noch Lösungen an anderer Stelle?

Viele Grüße

AK

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
×
×
  • Create New...