Jump to content

Angeheftete Kameras


Recommended Posts

vor 2 Stunden schrieb Bahnkater:

Warum verrutschen an Fahrzeugen angeheftete Kameras immer?

Eventuell liegt es daran, dass du während der Mitfahrt die Pfeiltasten drückst und so die Kameraposition (unbeabsichtigt) verschiebst?

Von alleine verschieben sich die angehefteten Kameras meines Wissens nicht.

Link to comment
Share on other sites

Posted (edited)

Hallo Goetz.

Nein, daran kann es nicht liegen. Es basiert immer wieder, und so viele Male wie das schon vorgekommen ist, habe ich bestimmt nicht immer auch die Pfeiltasten gedrückt. Insbesondere weil ich die sowieso nicht häufig benutze. Es MUSS also einen anderen Grund geben.

Edited by Bahnkater
Kleine Korrektur eines Wortes
Link to comment
Share on other sites

Zusätzlich:

Während der Mitfahrt ist es mir auch noch nie aufgefallen. Es passiert also gewissermassen im verborgenen. Wenn ich die jeweiligen Kamera auswähle,

ist die dann nicht mehr dort wo sie sein sollte.

Link to comment
Share on other sites

Hallo Little

Okay, Ich werde gleich mal meine Anlage "Die Tunnel bei Hartdingen" veröffentlichen. Ich habe da selber mal einfach die Ansicht "Kamera auf VT 11 hinten" 

laufen lassen und gesehen wie die Kamera ihre Position verliert. 

 Gruss Bahnkater

Link to comment
Share on other sites

Hallo,

vor 3 Stunden schrieb Bahnkater:

Wenn ich die jeweiligen Kamera auswähle, ist die dann nicht mehr dort wo sie sein sollte.

Ausgangssituation...
001.jpg.6ff935815ea42982d8aa730e6d6cd393.jpg

... wenn ich nun die Kamera markiere und dabei nur leicht (sehr leicht!) die Maus bewege, dann rastet die Kamera auf die Bodenplatte ein...
002.jpg.8f1f54d4e3df1d8417b4ca0f855cb290.jpg

... und hat nun eine zur Lok verschobene Position.
003.jpg.119f4cc8605257d996b1303ade670fd6.jpg

Ist das ungefähr das was bei Dir passiert?

Gruß
EASY

Link to comment
Share on other sites

Vor einiger Zeit hatte ich das gleiche/ähnliche Thema angesprochen, dass manchmal nämlich   "angeheftete" Objekte während der Fahrt sich nach und nach ein klein wenig verschieben und langsam wegwandern, z.B. Fahrgäste in einem Wagon. Es gab einige Erklärungsversuche, aber ganz schlüssig war es nicht (so meine Erinnerung), habe es dann aber weiter nicht mehr erforscht. Scheint ja aber weiterhin zu existieren, dieses Phänomen. 
Gruß Eggu

Link to comment
Share on other sites

Hallo @Bahnkater 

deine Kamera ist auf einem Wagen mitfahrend verknüpft, und folgt fixiert gleichzeitig der Position dem VT11 (Triebkopf).Screenshot2023-03-10212100.thumb.jpg.d9da1e8e8c0c65421969976063a6f8af.jpg

Deshalb erfolgt bei Kurven natürlich eine relative Bewegung des VT11(Triebkopf) zum Standort der Kamera in x,y-Richtung und somit bewegt bzw. dreht sich die Kamera, um weiterhin den Triebkopf VT11 im Visier zu haben. Ist das die Bewegung der Kamera die du meinst? Das hast du doch selbst so eingestellt. 

Da aber der Drehpunkt der Kamera nicht das Zentrum der Kamera ist, nimmt man eine seitliche Verschiebung war.Screenshot2023-03-10213716.thumb.jpg.a472225906301b01e7100338b38291aa.jpg

Auf gerader Strecke dürfte aber alles wieder in der "normalen" Position sein.

Screenshot2023-03-10213838.thumb.jpg.44e45bad99c6d617f54818ca008d905f.jpg

Ist bei mir zumindest so.

VG, Hawkeye

Link to comment
Share on other sites

vor 2 Stunden schrieb Bahnkater:

Ich habe da selber mal einfach die Ansicht "Kamera auf VT 11 hinten" 

laufen lassen und gesehen wie die Kamera ihre Position verliert. 

Wie lange muss das laufen, bevor der Effekt eintritt?
Passiert das plötzlich? Oder allmählich?
Ich kann deine Anlage hier im vierfachen Tempo laufen lassen und fröhlich zwischen allen Kameras hin und zurück schalten. Da verschiebt sich bei mir nichts.

War ich zu ungeduldig?

Link to comment
Share on other sites

Posted (edited)

Die Verschiebung ereignet sich nur allmählich. Ich schätze mal nach so 10 bis 15 Minuten sollte es deutlich sein. Da ich die Kamera genau mittig über dem Wagen positioniert hab, müsste sie auf gerader Strecke auch genau von dort aus auf den führenden VT11 blicken. Das tut sie aber im verlauf der Fahrt immer deutlicher nicht genau nanu von der Mitte des hinteren VT 11 aus. Das ist auch schon mit anderen Kameras auf anderen Anlagen basiert. Daher dachte ich halt dass das ein ernst zu nehmendes Problem ist.

An Goetz: Ja ein wenig Geduld braucht es schon und das hin und her schalten hat meine Meinung nach keinen Einfluss.

Gruss Bahnkater

Edited by Bahnkater
Link to comment
Share on other sites

vor 33 Minuten schrieb Bahnkater:

Die Verschiebung ereignet sich nur allmählich. Ich schätze mal nach so 10 bis 15 Minuten sollte es deutlich sein.

Das stimmt. Es lässt sich auch leicht nachweisen. 

An einer beliebigen, möglichst geraden Strecke die Kameraposition mit der Position des verknüpften Wagens abgleichen. Hier die Y-Position der Kamera auf die 57,67 des Wagens setzen. 

Screenshot2023-03-11101011.thumb.jpg.b15f2ac247e8f4dfdc68864216676135.jpg

Screenshot2023-03-11101103.thumb.jpg.d6c0fe267bcc9bc45585b9175868c77e.jpg

Nach ein paar Umläufen die Position der Kamera zum Wagen an etwa derselben Stelle wieder vergleichen. 

Screenshot2023-03-11101906.thumb.jpg.c3e88d32fe4ebb4828ff4e0a3315272d.jpg

Screenshot2023-03-11101655.thumb.jpg.e987b4f513d9df6c546d15fe2939ce23.jpg 

Ich denke, das wegen der Größe der Anlage Rundungsfehler bei der Positionsberechnung der Grund sind, die sich nach einer gewissen Zeit dann auch in der Verschiebung bemerkbar machen.  

VG, Hawkeye

Link to comment
Share on other sites

vor einer Stunde schrieb Bahnkater:

ein wenig Geduld braucht es schon und das hin und her schalten hat meine Meinung nach keinen Einfluss.

prima,
jetzt weiß ich, worauf ich achten muss (und wie ich es überprüfen kann).
Und ich kann deine Beobachtung bestätigen.

Kameraverschiebung.thumb.jpg.8b6ebe6222e197e568636bdef3970622.jpg

Link to comment
Share on other sites

vor 47 Minuten schrieb Bahnkater:

Gibt es da jetzt eine Lösung ?

Hallo Bahnkater,

der erste Schritt war doch, erstmal aus deinen dünnen Informationen die Beobachtung zu bestätigen und zu reproduzieren. Das haben Götz und ich ja auch endlich geschafft.

Sicherlich wird sich @Neo das auch ansehen. 

VG, Hawkeye

Link to comment
Share on other sites

Hallo,

ich habe jetzt auch einen Test mit einer Gotthard-Nordrampe gemacht. Der Zug überwindet in Spur Z zwischen den beiden Abstellbahnhöfen am bergseitigen und talseitigen Ende der Strecke eine Distanz von etwa 40 Metern (= 40000 mm). Der Zug benötigt hierfür etwa 17 Minuten in jede Richtung. Die Messung für die Bergfahrt und die Talfahrt fand getrennt mit verschiedenen Zügen statt, weil einin einem der Endbahnhöfe ankommender Zug nicht gleich weiter fährt, sondern immer andere Züge vor lässt.

Die Benutzerkamera war hierbei immer mit dem letzten Wagen des Zuges verknüpft und auf die Lok an der Zugspitze ausgerichtet. Die Kamera war beim Start sowohl im bergseitigen als auch im talseitigen Abstellbahnhof auf die x-y-Koordinaten des Wagens, mit dem sie verknüpft war, eingestellt. Bei der Talfahrt hatte ich nach der Ankunft eine seitliche Abweichung von 0,01 mm und längs keine Abweichung. Nach der Bergfahrt war keine Abweichung zwischen den x-y-Koordinaten des Wagens und jenen der verknüpften Kamera vorhanden. Den vertikalen Abstand zwischen Wagen und Kamera habe ich nicht ausgemessen.

Ich vermute, dass das "Abrutschen" der Kamera aus der ursprünglich festgelegten Position auch etwas mit dem "Fahrverhalten" des Zuges zu tun hat.  Meine beiden "Messzüge" fuhren jeweils im Wesentlichen mit gleichmäßiger Geschwindigkeit durch (nur bei der Talfahrt - wo es auch die kleine Abweichung gab - musste der Zug an einem Blocksignal anhalten), und die Kurven auf meiner Gotthard-Anlage sind sehr "moderat".

Möglicherweise sieht das bei vielen Stopps und engen Kurven anders aus.

Viele Grüße
BahnLand

Link to comment
Share on other sites

Meine (unbestätigte) Vermutung war:

Wenn sich die (neue) Kamera-Pos. immer nach folgendem Schema berechnen würde, dürfte es keine Verschiebung geben:
Kamera-Pos-neu = Zug-Pos-neu + Verschiebungsvektor,
wobei der Verschiebungsvektor einmalig beim Verknüpfen berechnet und beibehalten wird (Kamera-Pos  -  Zug-Pos)

Aber Rundungsfehler könnten sich einschleichen bei:
Kamera-Pos-neu = Kamera-Pos-alt + Delta,
wobei: Delta = Zug-Pos-neu  -  Zug-Pos-alt 
 

Gruß Eggu

 

Link to comment
Share on other sites

I placed a Contact Point just in front of the loco, linked to the loco, then set a Camera, also linked to the loco, to 'Track' the Contact Point, which it does. It doesn't matter if the Contact Point slips (rotates...), the Camera will always remain fixed pointing towards that object. Obviously the Contact point, and the Camera, can be hidden. Worth considering..?

Ich habe einen Kontaktpunkt direkt vor der Lok platziert, der mit der Lok verknüpft ist, und dann eine Kamera, die ebenfalls mit der Lok verknüpft ist, so eingestellt, dass sie den Kontaktpunkt "verfolgt", was sie auch tut. Es spielt keine Rolle, ob der Kontaktpunkt verrutscht (sich dreht...), die Kamera bleibt immer fest auf das Objekt gerichtet. Offensichtlich können der Kontaktpunkt und die Kamera ausgeblendet werden. Eine Überlegung wert...?

Douglas

2023-03-1114_44_04-Simp_Oval_BR75_00_-3DTrainStudioV8.thumb.jpg.c51ee95e1aafa14d8a7efa638c365ae3.jpg

Edited by Dad3353
Link to comment
Share on other sites

vor 27 Minuten schrieb Eggu:

Aber Rundungsfehler könnten sich einschleichen

Hallo Eggu, 

das sehe ich auch so. 

Ich hab mal zum Testen eine ähnliche Anlage, in einer "normalen" Größe erstellt.  (X-Werte ca. +/- 10.000mm). Die Geraden liegen auf +/- 50mm. 

 Screenshot2023-03-11145342.thumb.jpg.17b5c58ed5f8ca03726c5788c5b1a163.jpg 

Hier bleibt die Kameraposition am letzten Wagen mit dem y-Wert auf der Geraden immer gleich bei 50 mit einer max. Abweichung +/- 0,01

Die Anlage von Bahnkater ist aber gigantisch!  x-Werte bim Bereich von +/-83.000mm!

Screenshot2023-03-11140237.thumb.jpg.f0b99e32e862cf7c1b5c132ec35bf421.jpg

Ich vermute, je größer die Zahlen mit denen die Position errechnet wird, umso weniger Nachkommastellen werden berücksichtigt. Dadurch können solche Rundungsfehler entstehen. Die sich nach einer Weile auch aufsummieren und zu solchen Effekten führen.  

Kameratest.mbp

VG, Hawkeye

Link to comment
Share on other sites

Falls das Rundungsfehler sind, da die Position der Kamera im Raum immer wieder neu berechnet wird, finde ich das merkwürdig.
Eigentlich müßte, unabhängig von der Anlage, die Position der Kamera relativ zum Ursprung des verknüpften Objekts gespeichert werden.
Und daraus sollte sich dann immer die Position der Kamera reproduzierbar berechnen lassen.
Bin mal auf @Neo s Erklärung gespannt.

Gruß Thomas
 

Link to comment
Share on other sites

vor 1 Stunde schrieb HaNNoveraNer:

Bin mal auf @Neo s Erklärung gespannt.
 

Ja genau, darauf bin ich auch gespannt .

vor 3 Stunden schrieb Hawkeye:

Die Anlage von Bahnkater ist aber gigantisch!  

Ich kann eigentlich nur gross. Ich möchte meinen Zügen halt etwas Auslauf geben. Und die sind zum Teil auch etwas länger. :D

Link to comment
Share on other sites

Moin, 

um die Beobachtung von Bahnkater weiter einzugrenzen, habe ich die Testanlage erweitert. Die Gerade sind auf exakt +/-50mm verlegt und die Gesamtlänge ist auf ca. 90.000mm vergrößert. 

Kameratest_V2.mbp 

1. Umlauf: Die Kamera ist am letzten Wagen verknüpft und folgt der Lok nicht.

 Screenshot2023-03-12073225.thumb.jpg.cf06c2f22b9e3adf24456525b5beed80.jpg  

Hier bleibt der Y-Wert nach einem Umlauf erhalten.

2. Umlauf: Die Kamera ist am letzten Wagen verknüpft und folgt der Lok in den Kurven.

Screenshot2023-03-12073509.thumb.jpg.b43d3233de3827d85415116ab7654b38.jpg

Hier stellt sich nach einem Umlauf schon eine Verschiebung von 0,2mm ein.

Es muss also einen Zusammenhang mit der Koordinatentransformation durch die Relativbewegung der Kamera geben.

VG, Hawkeye

PS: @Bahnkater: Die schnellste Lösung für dein Problem ist, das Verfolgen der Lok abzuschalten und ggf. den Blickwinkel zu erhöhen.   

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
×
×
  • Create New...