Jump to content

Neue Beta-Version V6


Recommended Posts

Neo was ist mit meinem Problemm Starseite ok von da doppel klick auf Onleinkatalog ok aber eine anlage öfnen im Program ist ein unerwarteter Fehler aufgetreten

sory wen ich wider Frage bin ferzweifelt:$:$ wen ich von 3D ansicht auf 2D schalte kan ich hinter dem schwartz das Gitter sehen kan es sein das der Donlod

Link nich richtig geht

Al.jpg

Link to post
Share on other sites
  • Replies 260
  • Created
  • Last Reply

Top Posters In This Topic

Top Posters In This Topic

Popular Posts

Hallo, heute habe ich wieder ein kleines Schmankerl für euch. Ein Update auf 6.0.5.0 steht zur Verfügung, bei dem ich nicht nur viel von eurem Feedback eingearbeitet habe, sondern auch eine neue

Hallo, ich habe soeben noch eine neue Version zur Verfügung gestellt, die nur kleinere Fehler behebt. Diese Version stellt jedoch den offiziellen Start von 3D-Modellbahn Studio V6 dar, d.h. ab je

V6 ist einfach Genial und wird immer Genialer! Danke an Neo und alle Beteiligten! Hallo Gemeinde, ich habe da auch noch was - https://youtu.be/sZWYkThl3x4 Ein Traum geht en

Posted Images

Hallo @aloys63,

ich konnte jetzt auf einem älteren Laptop mit Windows 7 deinen Fehler reproduzieren. Es gibt noch ein Problem in Zusammenhang mit der Kantenglättung unter Windows 7. Bitte geh in die Grafikeinstellungen vom Studio und deaktiviere die Kantenglättung, dann kannst du z.B. wieder Anlagen laden. Mit dem nächsten Update kannst du die Kantenglättung dann wieder aktivieren.

Viele Grüße,

Neo

Link to post
Share on other sites
15 minutes ago, Neo said:

 

Tatsächlich weiß ich auch nicht, was du darunter verstehst. Virtuelle Spuren gibt es doch seit V4.

 

Wie BahnLand sagte, "Virtuelles Gleissystem".
Wir haben gerade und kurve aber keine abzweigungen. Dafuer muss ich gleisweichen benutzen oder habe ich da etwas nicht verstanden ? 

virtuelle_weiche.thumb.jpg.173a154e8f0a078ac65b4ef89a9e8a2b.jpg

Das beispiel hier: Einsatzfahrzeuge fahren aus und kehren zurueck und werden rueckwaerts eingeparkt. Mein steuerung soll das koennen. Natuerlich kann ich das mit einem realen gleissystem bauen und unsichtbar machen, dachte aber da wir virtuelle spuren haben waere es logisch auch weichen zu haben. Wie Andy sagt, kann ich mir auch bauen, habe aber derzeit noch viele andere dinge auf der todo liste. 
Habe ich da etwas noch nicht verstanden ? 

gruss

gmd

 

Link to post
Share on other sites

Hallo @Neo,

seit gestern steht mir dank meinen Tata ( @Wüstenfuchs ) auch die  V6 Profiversion zu Verfügung. Ich habe darauf mal eine ältere Anlage von mir geöffnet mit der ich bisher nicht so richtig weiter kam. Durch die neue Gleisverwindung konnte ich mein größtes Problem beheben, leider ist durch die neue Rollfunktion der Wagons ein neues Problem entstanden. Auf meiner Anlage stehen einige Waggons in einer Schräge, wo sie auch stehen bleiben sollen, könntest Du evtl. den Wagons noch eine Bremse verpassen? 

@gmd, Die Weiche lässt sich doch ganz einfach über den Gleiseditor selbst erstellen, daß schafft selbst meine 10jährige Cousine schon. :PB|

HG

C.Fuchs

Link to post
Share on other sites
1 minute ago, C.Fuchs said:

Hallo Neo,

seit gestern steht mir dank meinen Tata ( Wüstenfuchs ) auch die  V6 Profiversion zu Verfügung. Ich habe darauf mal eine ältere Anlage von mir geöffnet mit der ich bisher nicht so richtig weiter kam. Durch die neue Gleisverwindung konnte ich mein größtes Problem beheben, leider ist durch die neue Rollfunktion der Wagons ein neues Problem entstanden. Auf meiner Anlage stehen einige Waggons in einer Schräge, wo sie auch stehen bleiben sollen, könntest Du evtl. den Wagons noch eine Bremse verpassen? 

gmd, Die Weiche lässt sich doch ganz einfach über den Gleiseditor selbst erstellen, daß schafft selbst meine 10jährige Cousine schon. :PB|

HG

C.Fuchs

Ok, muss ich mir wohl anschauen :) .. dann nehme ich mal an dass dies problem geloest ist. Werde es versuchen.

gruss

Gmd

 

Link to post
Share on other sites
vor 1 Stunde schrieb Neo:

deaktiviere die Kantenglättung,

Startseite Einstellung Grafigkarte Kantenglättung deaktiviert

Habe ich keine Änderung (Fehler beim Instaliren?) Treiber Gafigkarte aktuel

Edited by aloys63
Link to post
Share on other sites

Hallo Neo,

hier ist eine beobachtung, wahrscheinlich hast du auch darauf eine antwort :) ..

Bei sehr vielen weichenanschluessen habe ich ein flimmern (ueberlagerte ebenen).

http://teutanic.com/flimmern.mp4

selection des angeschlossenen gleises, selektion anheben und z achse nach oben ziehen ohne bewegung (sichtbar) und es
rastet unmerkbar ein wie das bild unten zeigt aber die resultierende optik ist nicht die gleiche wie in V5.

Ist wohl eine rundungsdifferenz irgendwo. 

gruss

Gmd

 

 

nach_flimmern.thumb.jpg.cb7d6fda5d1e858203e529b7d304e2fa.jpg

Link to post
Share on other sites

Hallo,

vor 6 Minuten schrieb gmd:

hier ist eine beobachtung, wahrscheinlich hast du auch darauf eine antwort

was du dort siehst nennt sich Z-Fighting. Beide Gleise besitzen die exakt gleiche Höhe, wobei es zu Überlappungseffekten kommt.

Das gibt es aber eigentlich schon immer, nicht erst seit V6. Hast du diese Gleiskombination in V5 getestet? Wenn es mit den exakten Gleisen dort nicht auftritt, dann bitte einmal eine Testanlage mir zukommen lassen.

Viele Grüße,

Neo

Link to post
Share on other sites
vor 18 Stunden schrieb hubert.visschedijk:

Hallo alle, @Neo
Ich habe auch die V6 heruntergeladen.
Mein erster Test war also die Spiralbiegung.
Was mir auffällt ist, dass es im Gegensatz zum Plugin keine automatische Rundung des ersten und letzten Teils gibt.
(also immer noch eine "Beule", wenn der Zug die Spirale auf und ab fährt)
@NeoHabe ich etwas falsch verstanden oder ist es das?

@NeoKönnen Sie den maximalen Gradienten oder die endgültige Höhe bestimmen, indem Sie irgendwo eine Zahl eingeben?

Mit vielen Grüßen

danke 

Link to post
Share on other sites
2 hours ago, Neo said:

Hallo,

was du dort siehst nennt sich Z-Fighting. Beide Gleise besitzen die exakt gleiche Höhe, wobei es zu Überlappungseffekten kommt.

Das gibt es aber eigentlich schon immer, nicht erst seit V6. Hast du diese Gleiskombination in V5 getestet? Wenn es mit den exakten Gleisen dort nicht auftritt, dann bitte einmal eine Testanlage mir zukommen lassen.

Viele Grüße,

Neo

Habe von V5 nach V6 konvertiert. War in V5 nicht vorhanden. Habe in der V6 schon einige gefixt. Werde beide als entwurf hochladen.
Konvertiere die V5 version und der effekt is mehrfach vorhanden. Leicht zu finden wenn du genau hinschaust. Ist halt ziemlich gross :), sorry.

Gruss

Gmd

V6: Monster3 B20DF39C-8189-4077-8744-23FD65F98D27

V5: Monster3V5  321B5E8D-CEC3-4D2E-8C1F-897D69F3FE5C

Link to post
Share on other sites

@Neo, ich habe ein Problem mit den neuen Flexgleis Funktionen.
Das Gleis (Gebogen) rastet immer automatisch neben dem Zielgleis (Gerade) ein.
So kann ich die Gleise nicht verbinden. Es springt immer zur falschen Stelle.
Ich greife das gebogene Gleis an der x oder y Achse.
Das kommt durch das automatische Einrasten bei 90 Grad.
Aber so kann man nicht feinjustieren!
Die eine Achse müßte den Radius ändern und die andere den Winkel, das wäre besser.
So kriegt man die Gleise nicht zusammen :-(

Noch besser:
Das automatisch Einrasten am WInkel müßte deaktiviert werden, wenn das Gleis an einem anderen Gleis andocken könnte.

test.thumb.jpg.bc51348c5e557022020a7041531b5e35.jpg

 

 

Edited by HaNNoveraNer
Link to post
Share on other sites
vor 2 Stunden schrieb C.Fuchs:

Hallo Neo,

ich habe mein hier beschriebenes Problem mit den rollenden Wagons erstmal durch Peilloks bzw. Dummiantriebe gelöst. Falls Du oder ein anderer da noch eine bessere Lösung hat wäre ich dafür Dankbar.

HG

C.Fuchs

Hallo Mullemaus,

warum willst Du Wagons ausgerechnet in einer Schräge abstellen? Ich kann mir zwar denken um was es in der Anlage geht, aber mir erschließt es sich nicht genau warum der / die Wagon(s) ausgerechnet in auf einen schrägen Gleis stehen müssen.

HG Dein

Tata

Link to post
Share on other sites
vor 44 Minuten schrieb MX1954LL:

Hi Hannoverander,

geh mal mit der Maus auf das weiße Feld bis es gelb wird und dann ziehe dahin wo es andocken soll.

Gruß

Lothar

Und dann?
Dann verformt sich das Gleis wieder falsch.

Momentan kann man nur Shift drücken, um das Einrasten auszuschalten und das Gleis in eine bestmögliche Position bringen mit
gleichförmigem Radius.
Besser wäre es, wenn Neo das so programmieren könnte, daß das Gleis dann am Zielgleis einrastet, ohne sich wieder zu verformen.

test.thumb.jpg.8876eb563722d84a35998619306be6ad.jpg

test.thumb.jpg.c3c7a98dfa9814556041a2cd4dd494e4.jpg

Edited by HaNNoveraNer
Link to post
Share on other sites

Hallo,

vor 2 Stunden schrieb gmd:

Leicht zu finden wenn du genau hinschaust. Ist halt ziemlich gross :), sorry.

kannst du die problematischen Stellen bitte in eine kleine Anlage extrahieren? Das macht es mir leichter, vielen Dank.

vor 46 Minuten schrieb HaNNoveraNer:

Momentan kann man nur Shift drücken, um das Einrasten auszuschalten und das Gleis in eine bestmögliche Position bringen mit
gleichförmigem Radius.

Stimmt, das Einrasten auf feste Winkel besitzt eine höhere Priorität als das Einrasten an einem anderen Kontakt, das werde ich umdrehen, vielen Dank für den Hinweis.

Viele Grüße,

Neo

Link to post
Share on other sites
13 hours ago, Neo said:

Hallo,

kannst du die problematischen Stellen bitte in eine kleine Anlage extrahieren? Das macht es mir leichter, vielen Dank.

 

Werde es versuchen, muss check ob dann der effekt auch bleibt

gruss

gmd

Edit:  321B5E8D-CEC3-4D2E-8C1F-897D69F3FE5C

hoffe das hilft, convertiert von V5 nach V6 und alles andere entfernt.

Edit 2:  Ich habe nochmals in V5 nachgeschaut um sicher zu sein dass ich dich nicht auf eine falsche faehrte fuehre. 
In V5 ist das flickern auch vorhanden, allerdings nur waehrend man ein oder aus zoomed. Mir war aufgefallen dass auch bei gelaendeteilen mit flickern diese in V6 permannt flickern und in V5 nur bei zoom oder pan. Das neue konzept reagiert anders, allerdings ist es wohl kein rundungs oder versionsproblem in der definition selbst sondern nur in der darstellung. Da wirst du nicht viel machen koennen und ich werde diese stellen fixen. 

Ich denke das ist jetzt die richtige info die ich zu der sache geben kann.

 

Edited by gmd
Link to post
Share on other sites

Hallo,

vor 15 Stunden schrieb gmd:

Das neue konzept reagiert anders, allerdings ist es wohl kein rundungs oder versionsproblem in der definition selbst sondern nur in der darstellung.

ich konnte das Verhalten jetzt nachstellen. Ursache ist die erweiterte 3D-Engine in V6, die die Szene mit Hilfe mehrerer CPU-Kerne rendert. Dadurch entstehen Laufzeitunterschiede, die zufällig verteilt sind, und dazu führen, dass in Frame A das eine Gleis zuerst gezeichnet wird und in Frame B das andere Gleis. Hier kann man tatsächlich nicht viel ausrichten und die Lösung besteht im Endeffekt darin, sich überlappende Geometrie zu vermeiden.

vor 59 Minuten schrieb aloys63:

Habe V5 entfernd und neu instalirt keine Probleme also könnte der Donlod für V6 defegt sein

Der Download ist korrekt, da du sonst V6 nicht hättest installieren können. Hast du deine Grafikkartentreiber auf dem aktuellsten Stand? Ist es dir möglich, deinen PC/Laptop auf Windows 10 zu aktualisieren?

Viele Grüße,

Neo

Link to post
Share on other sites
10 hours ago, Neo said:

Hallo,

ich konnte das Verhalten jetzt nachstellen. Ursache ist die erweiterte 3D-Engine in V6, die die Szene mit Hilfe mehrerer CPU-Kerne rendert. Dadurch entstehen Laufzeitunterschiede, die zufällig verteilt sind, und dazu führen, dass in Frame A das eine Gleis zuerst gezeichnet wird und in Frame B das andere Gleis. Hier kann man tatsächlich nicht viel ausrichten und die Lösung besteht im Endeffekt darin, sich überlappende Geometrie zu vermeiden.

 

Danke fuer die klarstellung. Die neue verlegefunktion macht es einfacher so etwas zu verhindern. 

Welchen anteil hat die perfomance der grafikkarte an der bildrate ? Hat das ueberhaupt einen wesentlichen einfluss ? So ganz habe ich die beobachtungen der bildrate noch nicht einordnen koennen. Was ist der engpass bei der bildrate ? 

gruss

Gmd

 

Link to post
Share on other sites

Hallo,

vor einer Stunde schrieb gmd:

Was ist der engpass bei der bildrate ?

oh mit einer Antwort darauf könnte man Bücher füllen. Bei der Verarbeitung von komplexen Szenen sind so viele Komponenten involviert, dass man jede Anlage einzeln auf jeder entsprechenden Hardware untersuchen müsste, um konkrete Analysen zu erstellen. Was ich bisher auf meinem Entwickler-Rechner (Standard Durchschnitts-PC) beobachten konnte ist, dass die Grafikkarte bei großen Anlagen eher nur rund 30% Anteil an der Bildrate besitzt, und der Rest an die CPU geht, die die Anlage simulieren und an die Grafikkarte schicken muss.

Die Grafikkarte übt daher schon einen Einfluss auf die Performance aus, benötigt aber auch eine starke CPU, wenn sehr große Anlagen verarbeitet werden müssen.

Viele Grüße,

Neo

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
×
×
  • Create New...