Jump to content

Neue Beta-Version V6


Recommended Posts

  • Replies 260
  • Created
  • Last Reply

Top Posters In This Topic

Top Posters In This Topic

Popular Posts

Hallo, heute habe ich wieder ein kleines Schmankerl für euch. Ein Update auf 6.0.5.0 steht zur Verfügung, bei dem ich nicht nur viel von eurem Feedback eingearbeitet habe, sondern auch eine neue

Hallo, ich habe soeben noch eine neue Version zur Verfügung gestellt, die nur kleinere Fehler behebt. Diese Version stellt jedoch den offiziellen Start von 3D-Modellbahn Studio V6 dar, d.h. ab je

V6 ist einfach Genial und wird immer Genialer! Danke an Neo und alle Beteiligten! Hallo Gemeinde, ich habe da auch noch was - https://youtu.be/sZWYkThl3x4 Ein Traum geht en

Posted Images

2 hours ago, Neo said:

Hallo,

oh mit einer Antwort darauf könnte man Bücher füllen. Bei der Verarbeitung von komplexen Szenen sind so viele Komponenten involviert, dass man jede Anlage einzeln auf jeder entsprechenden Hardware untersuchen müsste, um konkrete Analysen zu erstellen. Was ich bisher auf meinem Entwickler-Rechner (Standard Durchschnitts-PC) beobachten konnte ist, dass die Grafikkarte bei großen Anlagen eher nur rund 30% Anteil an der Bildrate besitzt, und der Rest an die CPU geht, die die Anlage simulieren und an die Grafikkarte schicken muss.

Die Grafikkarte übt daher schon einen Einfluss auf die Performance aus, benötigt aber auch eine starke CPU, wenn sehr große Anlagen verarbeitet werden müssen.

Viele Grüße,

Neo

Ja ist sicher ein umfangreiches thema. 

Warum ich frage ist bedingt durch folgende beobachtung:

Komplette anlage in full screen stehend 10.2FPS  cpu 15% GPU  50% 
Komplette anlage in full screen animiert 6.1FPS  cpu 13% GPU  36% 

Display 1/6 auf full screen stehend  38FPS cpu 17% GPU 64%
Display 1/6 auf full screen animiert 12FPS cpu 13% GPU 34%

Mein bildschirm hat 5120x2160 aufloesung wenn full screen, native resolution.

Das macht fuer mich nicht so richtig sinn, dass im stand mehr leistung verbraucht werden soll als bei laufender animation. 
Ausserdem muss ja die position insgesamt fuer jedes animierte fahrzeug berechnet werden unabhaengig von der anzeige und das scheint nicht der engpass zu sein. 
Ich wuerde erwarten dass bei laufender animation die CPU leistung steigt und auch die GPU und nicht sinkt gegenueber dem still stand. 
Das macht fuer mich nicht wirklich sinn, da scheine ich etwas nicht ganz zu verstehen. 

Mein PC I9 3.6 GHz 32Gb Ram Gforce GTX 1060
Die grafik ist low end aber wenn ich auslastung von 30% sehe dann glaube ich den engpass woanders. 

Entschuldige wenn ich auf diesem thema herumreite aber ich moechte verstehen was da vorgeht und ob es sinn macht die grafik karte zu aendern, was ich aber derzeit nicht als notwenig sehe, oder irre ich mich da ? 

gruss

Gmd

 

 

Link to post
Share on other sites

Hallo gmd,

ohne deine Anlage durchgetestet zu haben, kann ich mir die Werte folgendermaßen erklären: Wenn die Anlage stillsteht und nichts animiert wird, besteht die Aufgabe der CPU praktisch nur aus der Übermittlung der 3D-Objekte an die Grafikkarte. Diese Übermittlung wurde in V6 auf Multithreading umgestellt, nimmt sich also mehr zur Verfügung stehende CPU-Ressourcen, um schneller zu arbeiten.

Wird eine Anlage animiert, muss die CPU viel Zeit in die Animationen investieren, die bisher noch nicht auf Multithreading umgestellt sind (weil das deutlich komplexer ist). Die CPU lastet also nur einen Kern aus, und die Übermittlung der 3D-Objekte an die Grafikkarte am Ende eines Frames ändert daran nicht viel.

Bei deiner Anlage ist daher anscheinend die Animation der Szene der Engpass, weil es vermutlich sehr viel zu animieren gibt und das Studio in diesen Bereichen noch nicht alle Kerne deiner CPU auslastet.

Viele Grüße,

Neo

Link to post
Share on other sites
vor 17 Stunden schrieb Neo:

Hallo,

Am 4.10.2020 um 04:20 schrieb gmd:

Das neue konzept reagiert anders, allerdings ist es wohl kein rundungs oder versionsproblem in der definition selbst sondern nur in der darstellung.

ich konnte das Verhalten jetzt nachstellen. Ursache ist die erweiterte 3D-Engine in V6, die die Szene mit Hilfe mehrerer CPU-Kerne rendert. Dadurch entstehen Laufzeitunterschiede, die zufällig verteilt sind, und dazu führen, dass in Frame A das eine Gleis zuerst gezeichnet wird und in Frame B das andere Gleis. Hier kann man tatsächlich nicht viel ausrichten und die Lösung besteht im Endeffekt darin, sich überlappende Geometrie zu vermeiden.

Hallo @Neo und @gmd

ich löse diese "Flimmereffekte" einfach im Eigenschaftsfenster mit der Änderung der Z - Position.

In diesen Fall von    -102,41  auf  -102,409  Enter drücken und der Wert springt zurück auf  -102,41 

Aber Dein Flimmern ist weg. Dies geht mit + 0,001  oder mit -0,001.

Internette Grüße Maik

595814553_danach1.thumb.jpg.73cf8cfa6b120ae36d8871453d4fb4f2.jpg

Link to post
Share on other sites

Hallo Markus,

V6 befindet sich aktuell in der öffentlichen Test-Phase, d.h., jeder ist eingeladen, die neue Version zu testen, aber beworben wird V6 erst in wenigen Wochen, wenn die Test-Phase vorbei ist.

Viele Grüße,

Neo

Link to post
Share on other sites
vor 3 Stunden schrieb Neo:

Hallo Markus,

V6 befindet sich aktuell in der öffentlichen Test-Phase, d.h., jeder ist eingeladen, die neue Version zu testen, aber beworben wird V6 erst in wenigen Wochen, wenn die Test-Phase vorbei ist.

Viele Grüße,

Neo

Ok weil ich habe heute schon 39.99 für die V6 ausgeheben ( mit dem 25% rabatt ) muss ich dann für die finalversion nochmal zahlen oder bekomm ich dann ein kostenloses upgrade auf die entgültige V 6 ? 

Link to post
Share on other sites

Hallo,

Gerade eben schrieb Markus Meier:

muss ich dann für die finalversion nochmal zahlen

nein keine Sorge, es gibt nur eine V6, die durch zukünftige Updates weiter verbessert wird. Irgendwann ändere ich einfach den Status von "Beta" auf "Final". Zukünftige Updates zu V6 sind selbstverständlich kostenlos.

Viele Grüße,

Neo

Link to post
Share on other sites

Hallo,

vor 4 Minuten schrieb Easydiver:

ist es möglich die blauen Dreiecke etwas kleiner darzustellen  ?

zu Beginn von V6 waren die Dreiecke kleiner, in den internen Tests hat sich jedoch herausgestellt, dass sie zu klein und schlecht zu bedienen waren, weshalb ich sie vergrößert habe.

Wenn du die Schienenstöße prüfen möchtest, einfach die Selektion entfernen oder auf einer zweiten Ansicht die technische Darstellung dazu schalten, dann werden dir verbundene Gleise auch farblich hervorgehoben.

Viele Grüße,

Neo

Link to post
Share on other sites

Hallo @Neo ,

vor 13 Minuten schrieb Neo:

zu Beginn von V6 waren die Dreiecke kleiner, in den internen Tests hat sich jedoch herausgestellt, dass sie zu klein und schlecht zu bedienen waren, weshalb ich sie vergrößert habe.

Wäre es trotzdem möglich die Dreiecke seitlich zu verändern, so das sie nicht in die "Schnittstelle" geraten  ?5.thumb.jpg.20ab023aef86e4e06dfe2b5b5afaeea3.jpg

Grüße Maik

Link to post
Share on other sites

Hallo Maik,

vor 15 Minuten schrieb Easydiver:

Wäre es trotzdem möglich die Dreiecke seitlich zu verändern, so das sie nicht in die "Schnittstelle" geraten  ?

ich wüsste jetzt nichts, was dagegen sprechen würde, weil es sich nur um eine Anzeige handelt und das tatsächliche Bearbeitungs-Gizmo weiterhin direkt am Kontakt angezeigt wird. Wenn sonst keiner Einwände hat, kann ich die Dreiecke gern ein wenig verschieben.

Viele Grüße,

Neo

Link to post
Share on other sites

Löcher schneiden und verschließen

Hallo Neo,

ich habe gerade festgestellt, dass man nicht in einem Rutsch von "Löcher erzeugen" auf "Löcher entfernen" gehen kann. Man muss dazu zunächst diesen Bearbeitungsmodus verlassen und kann dann wieder auswählen, ob man Löcher erzeugen oder entfernen will. Ich meine, in Version 5 hätte man auch während der Bearbeitung direkt wechseln können.

HG
Brummi

Link to post
Share on other sites

Hallo Brummi,

vor 20 Stunden schrieb Roter Brummer:

ich habe gerade festgestellt, dass man nicht in einem Rutsch von "Löcher erzeugen" auf "Löcher entfernen" gehen kann.

danke für den Hinweis, wird korrigiert.

Viele Grüße,

Neo

Link to post
Share on other sites

Hallo @Neo,

wenn ich ein Fahrzeug selektiere und dann z.B. durch einen Gleiskontakt die Automatische Beschleunigung oder Verzögerung ein- oder ausschalte, wird dies im Eigenschaftenfenster nicht aktualisiert (erst nach erneutem Anklicken des Fahrzeugs). Bei Änderungen des Kupplungsstatus oder der Beschleunigungs-/Verzögerungswerte werden diese Änderungen dagegen sofort angezeigt.

Nicht vorgesehen oder nur noch nicht implementiert?

Viele Grüße,

Walter

Link to post
Share on other sites

Hallo Walter,

vor 9 Minuten schrieb walterKY:

Nicht vorgesehen oder nur noch nicht implementiert?

das war bisher nicht implementiert, macht aber natürlich im Vergleich zu den anderen automatischen Aktualisierungen auch Sinn. Wird nachgeholt, vielen Dank für den Hinweis.

Viele Grüße,

Neo

Link to post
Share on other sites

Hallo @Neo

nun dampfen die Dampfloks auch im Stand bei eingeschalteten Motor. Sie dampfen aber sehr kräftig. In den vorherigen Version (V4, V5) habe ich mir dabei immer mit dem Partikeleffekt "Dampf hell" geholfen indem ich ihn mit der Lok verknüpft habe. Im Video unten zu sehen wenn die Lok anhält und Dampf von der Fahrt verflogen ist.

 

Folgende Einstellungen habe ich für den Partikeleffekt genommen:

Rauchpartikel.thumb.JPG.40c46ed6369cda91213bba962a2d535b.JPG

 

Kannst du bei den Dampfloks in V6 es in etwa auch so einstellen. Zur Zeit sieht es ja so aus, als wäre eine Dampflok im Stand unter Voll-Last und der Dampf sehr unnatürlich mit einer Glühbirnenform.

Viele Grüße
Stephan

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
×
×
  • Create New...